Having problems with your Vacuums ?

I bought a Kenmore canister vacuum, model 116, in April 2007. This morning, the sound of the motor suddenly began to deepen, and I began to lose suction. Normally, if something is clogging the hose, the motor will wind up to a higher pitch, not a lower one. The filters are clean, the bag is empty, and I can't detect anything lodged in the hose. If this were a car's engine, I would say it's "lugging down". Any pointers?


Answers :

Okay, bear with me. Is it possible you have a suction adjustment, dial somewhere on vac. Check and see and if it does, be sure it's all the way up. Also, try removing hose and run a broom handle fr. one end to the other...BUT be careful not to stretch or break hose, they cost BIG BUCKS.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I bought a Kenmore canister vacuum, model 116, in April 2007. This morning, the sound of the motor suddenly began to deepen, and I began to lose suction. Normally, if something is clogging the hose, the motor will wind up to a higher pitch, not a lower one. The filters are clean, the bag is empty, and I can't detect anything lodged in the hose. If this were a car's engine, I would say it's "lugging down". Any pointers?


Okay, bear with me. Is it possible you have a suction adjustment, dial somewhere on vac. Check and see and if it does, be sure it's all the way up. Also, try removing hose and run a broom handle fr. one end to the other...BUT be careful not to stretc ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Hello, I have the same model. And though it is three years old, starting from the last month, it does not clean anything anymore. Cannot even pick up one single thing from the floor. Every dirt gets stuck in the hose. I cleaned the hose and cleaned the filters but it still does not pick anything up. Is three years its normal lifetime or do I have the change the filters, instead of cleaning them? Thanks.


I know bissell vacuums are very cheap but they should last more than 3 years. there should be two parts to the dirt cup. remove the dirt cup and above it there should be a round plastic part. unscrew it and check that filter. ... Bissell 6594 PowerForce Bagless Upright Vacuum

I have a Z345 Electrolux cylinder vacuum cleaner, from the 1970s probably, but not used much. I have lost the guide. I forgot to change the bag before it was full. Smoke started to come out - smelling of burnt paper, not rubber. So switched off. It did not blow the fuse, and may be OK. I wish to inspect it. How do I open it up? Alos I have an air filter and a motor filter for it. I have often changed the air filter on the top. How do I get at the motor filter, if there is one? Than


Good day! OK you have to is replaced the bag and that's it.And don't forget to change the bag again to avoid that problem.Thank you ... Electrolux Guardian Bagged Canister Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Not sucking from bottom into bag, but blows out the side filter,..yet it DOES **** FROM HOSE ATTACHMENT. How can this be?...the.belt is fine recently replace, the rollers clean..I can feel anything i


Here is a diagram ,it's probably the hose behind the brush bar thats blocked.http://www.vacsite.com/en/bissell-parts-1/bissell-parts/3522-powerf ... Bissell 3522 PowerForce Bagged Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I was given a model 6591, plugged it in and it worked but didnt "****" and didnt sound right. I turned it off and removed the hose from the back found a badly plugged hose. Removed the hair plug cleaned filters and when I tried to turn it on again. Now the motor will not turn on or even make a noise. I hear there is a fuse that can be blown? How can I find the fuse if there is one? Thank You Ron


The User Guide for the bissell Clearview Power Trak\012\012http://canada.bissell.com/images/UserGuides/3590C.pdf\012 ... Bissell 6591 Power Trak Revolution Bagless Upright Vacuum

My filter queen just had the motor rebuilt last year and was basically a brand new unit when I got it back. It is not picking anything up now when I vacuum. The beater bar on the carpet attachment is turning fine and when I take all the attachments off the hose I can feel the suction being created like it should be picking up debris just fine. I have emptied the canister even when it did not have much in it; however, it still will not pick anything up off the carpet. It picks up debris tempo


It sounds as if you have a clog inside the "Power Nozzel". They mention that there are "no user serviceable parts within the Majestic® Power Nozzle" My advice would be to see if you can see a clog with in reachable distance and try to remove the ... Filter Queen Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu


Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

My shop vac is plugged. The hose is clear. The filter is removed. The filter bag is not installed. It still won't draw a suction. It sounds like it is plugged. The motor whines at a higher-than-usual pitch. What can I do?


Turn off the vac, take the head off of it and remove the filter paper. Inside, there's a white ball (bigger than golf ball, smaller than baseball) that's inside a cage. This is designed to keep water out of the blower when the vac tips over, and sh ... Vacuums

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.


Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I just bought this vacuum at a second hand store. My girlfriend told me to grab it as it such a quailty product. How ever I can't find a model number or anything else. I need a manual please. Does it take bags? Do I need to replace the filter or just wash the one I have? It is black and silver, cannister. It also says big gary's vacuum system warehouse in surry British Columbia, Canada. It also says to use filter pow-r-nozzle 96. I have no idea of the year.


I suggest you google what you know. I dont think anyone here can suggest where you can get a manual for a machine you dont even know the name of.\015\012\015\012You ask about a bag ... I dont know ... is there one in it now? You ask abo ... Vacuums

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?


Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

My filter queen majestic quit working. I opened up the unit to see what was wrong and I did not immediately notice anything wrong. Upon furter examination I noticed one of the traces on the printed circuit card was burnt. I used a soldering iron to "bridge the trace and it appeared to fix the problem for a while. Now it has stopped working again, and when I jumper the trace to run the motor it seems to work. Should I just replace the card? Or is there a more serious problem with too much current


I recommend replacing the card. Soldering involves the risk of further damaging the card, so it would be useless anyway. Why waste valuable time?\015\012There is a possibility of the motor overheating, generally due to a blockage in the airfl ... Filter Queen Majestic Canister Vacuum

Motor will not come on when hose is plugged in wall outlet. Green light is on, circuit breaker is on, changed bags even though 1/2 full, cleaned sec. filter. What is the problem?


... Broan-NuTone VX475 Bagged Central System Vacuum

I cant find a motor filter for Eureka The Boss UMC-18 anywhere!


... Vacuums

Eureka 4467AV overheats and shuts down after about 3 or 4 minutes of operation. I pulled all the filters to assure no blocked air flow. I assume the motor is not getting enough cooling air but i can't figure out why. checked bag for blockages as well as hoses. could the thermal protection have gone bad?


... Eureka 4467AV Upright Vacuum

One day I was vacuuming and it sounded like something went up inside somewhere and the motor, I assume,..... is frozen ..all it does is hum when I turn it on! I have changed the belt, filter and checked and cleaned all hoses... what could this be? THANK YOU, Gail


It's likely something got into the fan, is stuck there, is preventing the fan from turning, and so prevents the motor running. There's a good possibility the motor burned out because of this. If there's a strong smell of burning metal, this is prob ... Hoover Elite Rewind Bagless Upright VacuumVacuum

I'm trying to change the filter....One person told me to open the hose end and take the bag out and go from there, but that isn't the right way!!! It's the other end where a couple brushes are able to be stored on top of the canister, but I can't figure out how to get that section off..it's as tight as a drum HELP PLEASE and thanks. Betty


There's a tab at the middle of the lower back of the tool holder (air diffuser). Pressing in on that tab should enable you to lift the back of the holder first, then lift off the whole thing. It will come off, just make sure the tab is in far enoug ... Electrolux Epic 6500 Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Wondering if the head is plugged up because it makes a sound like air is escaping somewhere. I've replaced the original cloth bag with a comparable "O" paper bag from Sears. I tried to see if there was a clog in the hose by placing a broom handle in the hose to see if something would loosen. I also cleaned the filter and the air filter. If the head is plugged, how can I fix it? We can't get the vacuum apart. Thanks.


I had this problem, but suction improved when the attachments were properly secured in their holders. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?


Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.


Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0845 seconds