Having problems with your Vacuums ?

No suction. filter and hose clear. motor high pitch. don't know how to remove cover to check motor.

\015 No suction...hose clear....filters are clean....motor sounds like it is straining-high pitch....how do you get into the motor-romove cover. model no. 116.22812\015

Answers :

Something is clogged somewhere start from bottom and foolow suction path all the way through. wht kind of vacuum?
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No suction. filter and hose clear. motor high pitch. don't know how to remove cover to check motor.

Something is clogged somewhere start from bottom and foolow suction path all the way through. wht kind of vacuum? ... Vacuums

OUR DYSON 07 SWEEPER HAS VERY LITTLE Vacuum, have cleaned all filters and hoses, on line troubleshooting has said to check soleplate being on correctly, we have done this, still does not have good vacuum, belts are covered by a housing, the video that shows the changing of the belt is not the same, I need to know how to remove the cover to check both belts and any help in gaining the vacuum

This video shows you everything you need to know ... Vacuums

Eureka 4470 The suction works from the hose, but not from the base. I do not know how to remove the cover to check the inside.

Take apart botem 1st cheak the hoses for sumthign in there ok stick a hanger in it poke it out from bottem side under ... Eureka Smartvac 7975 Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Hoover SteamVac Model F6056-900 SteamVac/SpinScrub. Indicator light and high pitch suction noise indicates that dirty water tank is full. However, water level indicator (yellow bobbing plastic thing) is at the bottom of the tank and there is no water in the tank. Have check all the hoses for clogs, none found. Checked water port from motor area to receptacle tank for clogs, none found. Fixed broken hose to upholstery wand with duck tape, (wire not broken, just cracked plastic hose). The onl

There are 2 filters, make sure they are clean, one is on the tank lid, the other is from the bottom, it is red, pull it out and clean it. If yours has a foam filter on the tank lid covering the yellow ball, make sure there is at least a 1/4 in. gap ... Hoover Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i

At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

How do I gain access to the motor of an Electrolux 2000 canister vacuum. The air intake on the motor must be partially blocked as there is a loss of suction and the motor makes that high pitched whine like it does when you cover the hose with your hand

Dismantling the vacuum probably won't help much, and reassembling can be a bear. \015\012To check the intake, remove bag and look into bottom of bag well. It there's a filter there, remove it and check intake at bottom of bag well. Clear if t ... Electrolux UltraLux 2000 Bagged Canister Vacuum

How do I access the motor to my eureka capture? It has no suction at all but turns on just fine..filters are cleaned and there are no clogs or leaks on the hose....im thinking there must be something stuck in the motor possibly but there are soo many screws that im having trouble removing them all....whats the best way to access the motor to check it??

... Eureka Capture Upright Vacuum Vacuum

I have a Hoover SteamVac spot cleaner, model F5505. This is an older cleaner. It has no suction and I believe the hose may be clogged, but don't know how to remove the hose and check it.

... Hoover F5505 SteamVac Spot Vacuum

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.

Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My Bissell 3920 motor is making a high pitched noise. I have cleared out pet hair from top to bottom. Cleaned the lower filter and replaced the upper filter. I Checked for blockage in the hoses and found none. The filter indicator goes green when I turn it on, but the straining motor noise persists.

Click on the link below to view the replacement motor and fan for your Bissell 3920 vacuum\015\012\015\012http://www.vacuums24x7.com/motorfan.html ... Bissell 3920 Bagless Upright Vacuum

The brush wouldn't work when the selector switch was in carpet mode. Took the power head apart and removed the motor. Everything o.k. in the power head. Checked and found that the neutural wire had pulled out of the connector, the connector was never crimped at the factory. What a day! Took 2 hours and a large pizza to get it done. Neutral wire was in the hose just below the handle. Reconnected the wire and crimped it, put everything back together. It works!!!!

Great. ... Kenmore Vacuums

Vacum I need to check the brushes in the motor smells have removed four screws but the cover is not coming off. I dont want to damage this by forcing it but cannot find any other screws Thanks fairweather

Hi there!\015\012\015\012It would certainly help if you said which model it was.\015\012\015\012I can only give generic help now, and do the best I can for you.\015\012\015\012Most plastic products rely heavily on ... Vacuums

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(

... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

The vaccum has been cleaned and checked but the brush is not rotating and no suction at the bottom, but through the hose. In reading the instructions to remove the brush cover it says to lift tab one and release 2-4. Where is the tab for tab 1 can not find anything for tab one to be able to lift, nothing there any ideas for help would be greatlly appreciated/

3 on the front and one on the back. where the belt runs ... Bissell 6594 PowerForce Bagless Upright Vacuum

Kenmore Model 116 Cannister Vacuum.Trying to get into motor area. Think belt is worn out. I have removed the front two screws under the hinged cover, but can not remove cover over motor.. Still attached at rear. No evidence of any more screws to remove.

Under the cordwinder actuator button, are your other two screws. To remove this cover, take a flat tipped screwdriver and , very carefully, find the "tabs" (there are two) both on the front section under the button. Then, Carefully, press them in a ... Vacuums

I have a Sears Upright vacuum cleaner, model 116.35922500. The vacuum wasn't picking up. I discovered a clog in the nozzle hose. I attempted to remove the cover of the brush unit to clear the clog. I was unable to remove the cover completely, but was able to clear the clog. My problem now is that I cannot replace the cover correctly. Is there a way to remove this cover? Thanks, Elizabeth

When you tried to remove the cover did you have to put a little force on it to get to the clog ... Vacuums

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom

Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?

... Vacuums

Removing kenmore vacuum Canister motor cover model 116-27312790

What you need to do is take it apart and look for any carpet peices dug up in there preventing the motor to spin. Also go look for another filter for it and if you google it you can probably get instructions or if you still have the book. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

I have a Necchi LYdia 3 machine type 544 The motor was overheating and I removed the bottom cover and examined the motor .It looked fine and ran well. It worked OK for a time and then got hot.I was able to partially remove the motor for inspection.I found that the cooling impeller was not secured to the shaft,I tightened the set screws and reinstalled the motor. In process of getting the drive belt back on I turned the wheel that extends out of the case to index the screw that attaches the bobb

Good day!Please try to re align the motor position.You have to do is repeat the procedure that you take to remove the motor and double check the alignment because all motor in misalignment is very hard to turn.And ... Vacuums

Old Sanyo 1500 watt "Power Control" vacuum cleaner. I need to remove the plastic covers that are attached to the on/off switch and the power cord recoil. This will allow me to remove the retaining screws for the upper motor cowling. The motor and wiring is clogged with wood dust and I want to blow the dust out using compressed air.

... Sanyo Vacuums

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony

... Kenmore Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.3655 seconds