Having problems with your Vacuums ?

Nothing inn the canister after using,suctione working,bottom roller working,no air leaks from hoses.Also when running awhile it shuts off by itself,have to wait awhile to use again

\015 Nothing in the canister afer using suction working bottom roller working no air leaks from hoses. Also when running awhile it shuts of by itself.have to wait awhile to use again\015

Answers :

I'm not sure what vacuum you have, but that sounds like a blockage to me. Thermal shut off kicks in, shutting the motor down, to prevent damage from overheating. After waiting like 1 hour it probably comes back on. Make sure hose, filters, bag (if any) is clean. All "airways" of vacuums need to be clear of any blockages, since airflow is what makes vacuums work.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Nothing inn the canister after using,suctione working,bottom roller working,no air leaks from hoses.Also when running awhile it shuts off by itself,have to wait awhile to use again

I'm not sure what vacuum you have, but that sounds like a blockage to me. Thermal shut off kicks in, shutting the motor down, to prevent damage from overheating. After waiting like 1 hour it probably comes back on. Make sure hose, filters, bag (if an ... Vacuums

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?

I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.

Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Currently my dyson does not work when in the upright position. When I pull the handle back, it will run, but the suction is not very good at all. I tried washing the filter, but that didn't work. Sometimes it works for awhile, but then the problem occurs after the machine has been used for awhile. What do you think the problem is?

Hi its Darran at Dyson.It sounds as though the brush bar may not be turning properly when you put the machine into the upright position. To test, lie the machine on its side in the vacuuming position (head released) then switch it on and ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.

Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

We have a Eureka built in vacuum system model cv800B. The unit is about 15 years old. It runs for about 5 minutes then shuts down. If you wait atleast 10 minutes you get another 5 of run time. Any help would be appreciated. Steven

... Vacuums

When trying to use my Hayden Model 3600 central vac when trying to turn on the unit runs for 1 or 2 seconds and shuts off and continues to do so while switched on. I have thoroughly cleaned the filter and dirk canister but the intermittent running still occurs. Any suggestions?

... Hayden Industries SuperVac 3600 Central System Vacuum

I have the same problem as steve967 The dyson dc16 is fully charged, runs well for 5-10 seconds and shuts down. I wait for a second or 2 and it runs again for 5-10 seconds. This will continue for numerous cycles, until I am finished cleaning. I have cleaned all the filters, and the power is good, The system will just not stay on. It is just over 2 years old. A friend of mine had the same problem with his Dyson DC16 after just a couple of months and has replaced his Dyson with a Black N De

Dear Michael_Stad,I am going to sound like a broken record but here is my same answer to another person with the same problem.I have I had the same problem with my Dyson DC16, where it only runs for a few\015\012seconds at a t ... Dyson DC16 Root 6 Bagless Handheld Cyclonic Vacuum

No suction for use of crevice tools, running hot, then shut off

Obviously no suction in hose would indicate a blockage, over heating is a breaker that shuts off the machine when it over heats. There is no way to clean hose the on this model because the hose does not detach at either end, therefore I had to emplo ... GE 106766 Bagged Canister Vacuum

Vacuum runs for awhile and then shuts off

This sounds like an overheat issue. I suspect that something has restricted the air flow. Air flow is required for function and to cool the motor. if the air flow is restricted a thermal limiter opens the circuit, rather than have a fire. ... Proteam ProForce® 1500XP Bagged Vacuum

I have a ten year old M+S central vac. it shuts off after about 5 min of use. They came out and took the unit to their shop. I dont have the model #.repair shop says I need a new motor but it runs. what can I tell them?

... M&S Systems FX-3000 Bagged Central System Vacuum

Once the unit runs it sometimes does not want to shut off. This happens regardless of the port used. If I unplug the unit it will usually seem to reset after a while and then may or may not work properly.

Most likely you have a bad relay board. It is the part that controls the on/off and power supply. ... Broan-NuTone CV450 Central Bagged Central System Vacuum

My lux 7000 has a new bag but when i start to use it with the power unit or without the unit shut's it self off i can reset the lites or the motor if you will by clicking the on off switch 4or 5 times and i'm ready to go again untill you start to work and off it goes you can repeat the switch thing as long as u want, it just won't let u vacuum ,it turn's it self off .I blew it all out but found nothing in it. if u don't try to vacuum it will run as long as u want to listen to it. Can you

Have you replace the afterfilter? It may also cause this if rather dirty. It's located under the tool caddy/air diffuser on the back half of the machine.\015\012Try this: Disconnect hose, turn on vacuum. Does it continue running? If so, pl ... Electrolux Lux 7000 Bagged Canister Vacuum

I have a Hoover Mach 2.7 Windtunnel that shut off during use and wouldn't turn back on. Was doing kitchen floor and running fine. Though a breaker tripped but didn't...what could it be?

Hello, \015\012\015\012It sounds like your thermal reset switch inside of your Hoover may have gone bad. When a vacuum cleaner doesn't turn on it, it's either caused by one of four things. \015\012\015\012Ele ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My vacuum keeps shutting off while I'm using it...

... Broan-NuTone VX475 Bagged Central System Vacuum

Can this be left charging all the time when it is not being used or do we need to wait until it is fully run down before we charge it?

It is always best to run the battery down and then recharge it. Over a certain amount of charges (different circumstances for different brands) you will find that you have longer battery life. ... Vacuums

I was using my Heritage 11 vacumn with the hose attachment and the motor shut down like the power went off .When you push the switch on the housing the light comes on but the motor does not run.

Hi, the motor could be overheating. Most vacuums have a heat sensor that shuts the vac. off if there is a clog. Let it sit, feel if it's hot. If so you may have a blockage of dirt etc. Try to clear it, let it cool and tart it up. I hope this helps, i ... Kirby Heritage II Vacuum

Vacuum stops My Wind Tunnel stops working in a very short time when using. It takes awhile for it turn back on. It still shuts off quick. I have cleaned the hoses and inside of the power brush. This doesn't correct problem. Delbert Briggs

Your thermal cutout is tripping. This only happens when the motor heat gets very high, and the reason it takes a while to turn back on is that the motor has to cool down before it will reset. Ensure that absolutely every air pathway is clear, because ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Water leak I just bought this steamer a few days ago, and already I am having problems, when I fill the water tank that your suppost to fill the water runs out before I even turn the machine on. I have tried using plugs to keep it from doing this just so I can shampoo my carpet, this seems to work to a point, considering the fact that there are two holes underneath close to the brushes and one just a little ways back from that location. Do you know if this is something that should have plugs or

If you just pruchased this, then it is under warranty, take it along with proof of purchase to a warranty repair shop and have them fix it. If water just runs out, then there may be a seal missing or a water line off. ... Eureka Atlantis 2595A Upright Wet/Dry Vacuum

I was cleaning my carpet using my hoover steamvac ls. I had already changed the water 3 times. The last time, the water ran out and I kept running it for a couple of minutes trying to **** up some of the water off the carpet when it just shut down. I check the breaker and the outlet and they were OK. Checked my manual for troubleshooting; couldn't find an answer there. Do you think I burned the motor up (I didn't smell anything) or will I have to send it in for repair? When I clicked on your web

(1) take the tank off and reassemble to assure you sealed to the lower handle.\015\012(2) the water feed has nothing to do with the motor or electrical, purely mechanical.\015\012Hoover web site is free, no cost. ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

Have a new vacuum that only used for about a month. It runs and shuts off without picking up very good. Need to find out how to get it fixed as it has five year warranty.

Well if it's only a month old and has a 5 year warranty return to where you bought it to have it fixed... ... Euro-Pro NV31 Infinity Vacuum

It's making a very loud noise when running. I have a Bissell Quicksteamer series 2080. When I was using it yesterday it was making a light squealing noise then it turned into a loud racket. I shut it off and and cleaned the brush (lots of dog hair on it) But the racket continued.

... Bissell 1770 Quicksteamer II Upright Vacuum

My eureka optima vacuum shuts off after 5 minutes of use, the brush still spins, but no suction. If I wait 30 minutes, it will work again, for 5 minutes.

... Eureka 431A Optima Bagless Upright Vacuum

Over heating Light Comes on as soon as I try to turn the unit on. I have a Miele S558 Silver Moon vacuum that has only been used once and it shut off and will not come back on. The overheating light comes on as soon as I try to switch speeds on the handle or turn the unit on at the canister, and the vacuum will not run. Do you have any idea what the problem is?

... Miele s558 Silver Moon Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0742 seconds