Having problems with your Vacuums ?

Overheating while vacuuming - 15 mins near new machine. Have checked filters. No change


Answers :

When we run vacuum cleaner continuously, it gets hot.
\015\012So after each 3-4 minutes cleaning, stop it and remove the dust. This will cool the motor and in this way we can use it for a long time. So use vacuum cleaner with breaks.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Overheating while vacuuming - 15 mins near new machine. Have checked filters. No change


When we run vacuum cleaner continuously, it gets hot.\015\012So after each 3-4 minutes cleaning, stop it and remove the dust. This will cool the motor and in this way we can use it for a long time. So use vacuum cleaner with ... Vacuums

Hover Elite Rewind I've only had this vacuum a few months and I really liked it until now. There is almost no suction from anywhere in the vacuum, and I've cleaned all the filters and rollers with my shop vac and made sure that everything was assembled correctly. It used to be really quiet now it is quite loud and it keeps over heating, and shutting off. At this point I have no idea what could cause this problem, the machine is nearly brand new and I can't afford a new one at this point.


You have to clean out the hose under the bottom of the vacuum cleaner. To do this you have to remove the bottom plate the covers the brush it has about 6 screws. Also remove the brush and belt in order to thourhly clean it. I had the same issue you h ... Vacuums

Vacuum My vacuum is loosing it's suction power. I've checked the belt and it's in perfect shape...I've bought a new filter cup...I've checked for clogs and there aren't any...I've cleaned the entire machine...and I still can't find the source of the problem.


You checked the belt, but I bet it has stretched and won't drive the brush roll under load like it should. Belts only last a few months the stretch and should be replaced. Iff you have suction at the hose, then it has to be down below, either belt/ ... Eureka Whirlwind 4480 Upright Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Hello, I have a Eureka 71b handheld vacuum. There is literally no suction. I checked the hose and it is NOT clogged. I thought it might be the filter so I bought a new filter. Still no filter. The rot


... Eureka Vacuums

OUR DYSON 07 SWEEPER HAS VERY LITTLE Vacuum, have cleaned all filters and hoses, on line troubleshooting has said to check soleplate being on correctly, we have done this, still does not have good vacuum, belts are covered by a housing, the video that shows the changing of the belt is not the same, I need to know how to remove the cover to check both belts and any help in gaining the vacuum


This video shows you everything you need to know ... Vacuums

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Ive changed the filter and checked the hoses but vacuum doesnt pick up ...when its on the dust is being blown out the bottom of the vacuum....i took the canister off to test the suction its fine...also cleaned the filter ...help!


Have you check the roller brush and drive belt? It may be your belt has broke or is slipping and therefore not turning the brush.\015\012Turn on machine and power head see if brush is turning if it is put a small amount of pressure on the rol ... Kenmore Vacuums

Our problem with our Rainbow E Series is that it has sucked water up and blown it out through the lower part of the hepa filter, making the filter wet and dirty. This had happened before and the repair shop did not see any problems with the machine, so we replaced the filter and were very carful not to overfill the tank and to change the water often. Now it has happened again and ruined another filter. Do you know what could be causing this issue? Can the filter be cleaned or will a new one be


Thank you for allowing\012us to help, please respond with further questions and concerns\012\012Spanish speaking\012available for all problems\012\012 ... Rainbow E series Canister Wet/Dry Vacuum

Does the philips active carbon filter FC 8033 fit the model of vacuum cleaner I own (HR 8903/A)? My catalog says I should replace with HR 6969 but was sold the FC 8033 filter. My machine seems to be overheating and I wonder if it has anything to do with the new filter.


... Philips Vacuums

While vacuuming the red light for the bag of the vacuum came on and the vacuum stopped. The bag was no where near full so I replaced it with a new bag - same problem. It vaccumes for a minute or then stops with bag light on. It is the correct bag for the machine - so what's the problem?


I'm assuming this is the Epic 6500 or similar model.\015\012Detach the hose, turn vacuum on. If it runs, place palm of hand against inport hole. If it shuts off the problem is with either the control valve setting or the control valve assembl ... Electrolux Vacuums

I got a used filter queen majestic vacuum at a yard sale and want to fix it up and start with new filters where do i get the filters and how do i change them


Hello,\015\012 \015\012Well you bought a really great vacuum cleaner. The Filter Queen's are extremely durable and very well made vacuums. They sell brand new for over $2500, so picking one up at a yard ... Filter Queen Majestic Canister Vacuum

Belts breaking/melting The original belt broke at almost 1 year so I replaced it. I changed the carpet setting to shag even though my carpet is very low pile to make it easier on the vacuum. I didn't get to use it but just a couple minutes and could already start smelling the new belt getting hot. I checked the roller and it is easy to spin. Not clogged with hair or dirt. Now the inside of the new belt has small pieces of rolled rubber instead of being smooth. The metal shaft that goes into the


... Dirt Devil M088905 Vision Bagless Upright Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

Have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.


... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)


Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Kenmore progressive upright filter is being bypassed, clogging screen at outlet. Tried new filter, no change. 7 or 8 passes with the vacuum and the screen at outlet gets clogged.


Take the filter out and hold your hand over the filter connection. Turn it on and see where the air is being bypassed. What you see should suggest the fix. ... Kenmore 35622 Upright Vacuum

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u


Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?


This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

Vacuum cleaner hi.this is 10 yrs old and not overly worked.bags are changed regularly and the micro filter has been changed at least three times over ten years.it goes well for about 2o minutes then loses power with not much "suck"after that.sometimes shutting down completely,because of overheating i presume,or just carries on at a much lower'"suck".have tied shaking bag inside but no luck.any suggestions out there or can you tell me the agents support office for new zealand[auckland].many thank


What brand vacuum is it? ... Vacuums

Vacuum Model 116.24614400 Unplugged working machine to move to a new area. Plugged it in and NO POWER TO MACHINE. Checked plug and it is working fine. Is there a reset button? thanks You, Barb [email protected]


... Kenmore Vacuums

Vorwerk ET 340 - been great but now noticing strong burning smell after vacuuming some hair from the bathroom. Bag is nearly empty. Gave it a rest then unscrewed the cover housing the motor and all looks clean (dust is sucked up the pipe and doesn't appear to get near the motor). When I restarted it, burning smell still there. Are there any filters that might need changing? What could be causing the smell? Could the hair have gotten caught somewhere? Thanks.


Jessica,\015\012\015\012Try changing the dirt bag.\015\012Check if the motor gets hot after operation. You can come to check it by touching outside the motor housing. If it is hot or just warm.\015\012Is the smell of burning hair or something e ... Vacuums

92L3-W this unit was fine when new, did a good job, after a few months it got very loud. it is so loud you need ear plugs to use it. i have checked and cleaned it. there is'nt any visible problem with it. after cleaning and changing all filters it still is very loud a lot more than when it was new.


... Bissell Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1563 seconds