Having problems with your Vacuums ?

Hi we have a central vacum system (canister). Sometimes when you plug in the hose it works fine othertimes it doesn't work?


Answers :

There are two types of coupling that plug in. One has a solid metal ring. There are two metal electrical **** inside of the inlet. When you press the coupling into the inlet the metal ring completes the circuit. If the ring or the **** are badly tarnished, they may have to be scrubbed before they complete the circuit.
\015\012The other type of coupling has a double split. There is a switch on the wand that completes the circuit from one side of the split to the other. If when inserted, this split lines up on one of the **** and the *** doesn't touch either part of the ring, then it is not going to operate either.
\015\012Give me some feed back if that doesn't fix it.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hi we have a central vacum system (canister). Sometimes when you plug in the hose it works fine othertimes it doesn't work?


There are two types of coupling that plug in. One has a solid metal ring. There are two metal electrical **** inside of the inlet. When you press the coupling into the inlet the metal ring completes the circuit. If the ring or the **** are badly ... Vacuums

My dyson 07 doesnt **** up when im doing the carpet but the hose works fine? when im vacuming it sucks up very little and the hose part seems to be sucking up air when im doing the carpet? would this mean something is plug??? thanks randy


There is a block in the hose take lower hose of and clean ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Central vac our central vac will not work unless the main vac in the garage is switched on manualy.... its sucking fine but i have to switch it off at the main switch in the garage after i have used it normaly i just plug in the hose and vac away and it switches itself off we have just had cable installed with a fisher guy in the walls do you think that would be the problem thanks a lot


It is possible that the low voltage wiring that controls your central vacuum has been damaged during the cable work. You can check to see if the low voltage relay is working by shorting the two terminals together at the unit. Just disconnect the two ... M&S Systems AirVac AVP1200 Platinum Series Central Vac - 12,000 sq ft Bagged Central System Vacuum

My BROAN CV-110 hose with the rug beater only works if I turn it on from the base unit. Shouldn't it turn on when I plug the hose into the wall recepticle? Do I need to replace the hardware at the end of this hose and if so, where would I purchase that? This central vac came in a house I just purchased. Thanks for any help. Sherry


... Broan-NuTone CV450 Central Bagged Central System Vacuum

My Dyson vacuum works fine for cleaning the rug but the hose doesnt get any suction at all. I removed the hose and all the parts around it that I could and dont see any clogs or broken pieces. I lost my manual so I dont know if this is addressed, or if there is a switch Im not flipping. Gave it a thorough look but found nothing.


Hi there,Sorry to hear you're having a problem with your DC07. If you have suction through the cleaner head but not through the wand, it sounds as though you have a blockage. Although you say you've already checked for these, you may find ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a eureka cv2301b central vac system that turns on and works when the system is plugged in but when operating the hose and head inside the house you cannot shut off the system even if you unplug the hose from the wall... Whats going on


... Eureka CV2301 Bagged Central System Vacuum

It will not suck up materials on the vacuum part. the hose works just fine when it remains plugged in to the upright part


Hi pop into bissel web page faq page type you querry see if there an answer http://bissell.com/Search/FAQ.aspriz. ... Bissell 6594 PowerForce Bagless Upright Vacuum

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a broan central vac 24 yrs old ,vac works if you turn sw on cannister,not by plugging hose att,is this a major problem,thanks


Broan 450 air-watt and 8.5 amp power unit. Covers 3,000 sq. one 30-ft. crush-proof hose with on/off switch, one 10-in. wide hard floor brush features swivel neck for easy maneuverability around furniture. My new home is just ... Broan-NuTone CV350 Central Vacuum

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


Open this manual to page 18 and clean all the filters listed to restore air flow.http://www.managemylife.com/mmh/lis_pdf/OWNM/L0908343.pdf ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Screeching noise The vacum works fine on the bare floor setting but doesnt on the caprte setting i;ve cleared the enitre roller brush and its still making that awful noise?


Hello,When a Dyson DC07 makes this horrible grinding noise, it can only mean one of two things. The Dyson DC07 uprights use a clutch mechanism to control the brush spinning when you change the floor / carpet switch. When y ... Dyson DC07 Bagless Upright Cyclonic Vacuum

All the suction has been lost at the bottom end, the hose still works and sucks fine. what can be the problem? there doesnt appear to be any blockages either


It sounds like you must have a blockage behind the beater brush on the bottom of the v ac ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a Nutone central vacuum model number CV450W that was working great until I recently removed the hose and it now runs continuously until I pull the plug....any suggestions please


Disconnect the thin low voltage wiring between the vac and the rest of the house. If the vac continues to run you have a defective relay in the vac motor housing. If the vac stops you have a short in the wiring in the house, likely behind an in ... Broan-NuTone CV450 Central Bagged Central System Vacuum

My hose suction works fine but the vacum itself will not **** anything up


On the underside of the machine you will see a short length of clear plastic tubing with spiral reinforcing. Often this gets split, allowing an air leak. If the split is bad, there will be almost no effective suction at the brushbar. If that's the pr ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have no suction for vacumming the floor. the wand is totally still working and sucking it heart out. clear hosing doesnt looked cracked. dont know where else to look.


Hi, if the wand is doing its job very well, you have to have a blockage some where, either in the hose where it attaches to the bottom of the unit near the roller section. It may be hard to see, but this is what is causing the bottom from not picking ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

We have an Epic6500. when we plug it in the machine works without the hose. We even purchased a new hose thinking there was a problem with the hose. However as soon as we put the hose on the machine the machine does not work. What do you think the problem may be?


Wow, this is a good one. I wonder if anyone has wrked on this machine before. Do you remember what happened when it stopped working / Obviously there is a foul up in the wiring. I need more info. When the machine is on does it shut off as soon as the ... Electrolux Epic 6500 Vacuum

Spotbot will not light up in handsfree mode, but works fine in manual (hose) mode


You may want to contact one of our Authorized Service Centers to have a quality technician inspect your machine.Here's a quick link to locating one. \015\012 ... Bissell SpotBot Robotic Wet/Dry Vacuum

I was given a model 6591, plugged it in and it worked but didnt "****" and didnt sound right. I turned it off and removed the hose from the back found a badly plugged hose. Removed the hair plug cleaned filters and when I tried to turn it on again. Now the motor will not turn on or even make a noise. I hear there is a fuse that can be blown? How can I find the fuse if there is one? Thank You Ron


The User Guide for the bissell Clearview Power Trak\012\012http://canada.bissell.com/images/UserGuides/3590C.pdf\012 ... Bissell 6591 Power Trak Revolution Bagless Upright Vacuum

Suction stopped. Roller and belt working-in fine order. Checked hoses have not found any blockage. Blowing out air or sucking so little can't feel it with hand on hose end. Help!


Either a blockage or the main air filter is blocked , some it can be washed and others it must be replaced I would check the owner manual and look at the filter, foam ones can and usually have instructions where they install to wash them. ... Hoover Tempo Widepath Upright Vacuum - Blue

I have a central vacuum system. When I disconnect the hose from a wall outlet the central canister does not shut down dispite my turning off the vacuum at the handle of the hose. The only way I can get the system to shut down is to pull the plug at the canister. What gives? Rob


What I'm hearing is the canister(Not the Powerhead) portion of the unit is running all the time unless you unplug it. this problem could be caused by a short in one of your low voltage lines running through the house. To determine that just unplug on ... Vacuums

Hooked everything up per directions. I plugged it in to the closest electrical outlet and nothing happened. The lights did not light up, the connected wall control and sensors leds do not light up. It appears the unit doesn't have power. The electrical outlet socket is fine as everything else I plug into it works fine. I have tried every other electrical outlet available. The unit won't power on from any outlet, and all of those outlets run other things, like power tools an refrigerators


Dear Davehibshman,Firstly; dismantle the plug and replace the fuse with the same rating as the one you have just taken out. Replace the plug cover, put the plug into the socket and try again. If this doesnt work, there may be a problem wi ... Vacuums

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden


Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

Vacuum Model 116.24614400 Unplugged working machine to move to a new area. Plugged it in and NO POWER TO MACHINE. Checked plug and it is working fine. Is there a reset button? thanks You, Barb [email protected]


... Kenmore Vacuums

Suction hose I can't get the suction hose to work...and I have cleaned it out to make sure it isn't plugged. There is a small amount of suction just not enought to pick anything up.....the floor part works great...what could be the problem


I would first double check the hose, remove it and drop a marble through it to be sure. make sure the bag is new and also check the filter underneath the bag if it is clogged it could cut the suction. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Vacume cleaner The vacume has no suction. the belt is fine i checked it. It turns fine no air is comming from the hose.


Check the hose and see if it has a clog, also the hose at the bottom. The filters may be clogged, make sure they are clean and that air flows thru them, if not then replace them. ... Eureka 5892AVZ Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0886 seconds