Having problems with your Vacuums ?

No suction - motor runs, belt running. - Vacuums


Answers :

Clogs, som,e times on the bottom there is a pan and a hose opening secured, if its clogged, it won't work, open the bottom where there should be a small latch, also I have used shop vacs to **** clogs out threw hoses?
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

No suction - motor runs, belt running. - Vacuums


Clogs, som,e times on the bottom there is a pan and a hose opening secured, if its clogged, it won't work, open the bottom where there should be a small latch, also I have used shop vacs to **** clogs out threw hoses? ... Vacuums

When I sart to run my bagless vacuum, it runs for a second and then shuts off. I replaced the belt and the filter. The repairman told me that on bagless vaccuums, the motor and bearings get clogged w


Take the brush roller off and on the ends are the bearing caps.try to take those off and clean the bearings ,carpet strands and hair will cause that.after you do that make sure the roller turns freely if not then the bearings might be bad and if that ... Vacuums

Hoover WindTunnel S3765. The motor spins and the belt turns when I turn the brushes on, and the brushes will spin. The problem is that when I do this on carpet, the brushes stop spinning. As soon as I pull the "head" off the carpet, the brushes spin again. It's almost as if the vacuum suction is too great. I took the head apart and watched the motor turn the metal spindle that the belt rests on, and the belt turns as well.


The belt is stretched and needs replacement.(Belt # 38528036) . The brush is not turning against resistance. ... Hoover Vacuums

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Brand new LG LUV200r used 10 minutes now after removing dust tank & reinstalling the vacuum motor does not run only the beater bar??? I have located wo circuit breakers both seam to be set. This suction motor should run when the switch is pressed & the beater bar should operate when the handle is moved down??? Not A happy customer will return unit to Best Buy only 100 mile round trip!!!! RDH


... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?


There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

On an old upright prolux plus, I just replaced the belt and cleaned out the brush motor, ran the vacuum for a bit, then the vacuum motor died...it's always run great. any suggestions of what to check?


... Electrolux Vacuums

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

Replacement parts... I've got a 3594 Bissell and the belt has come completely off. In the process of breaking, it bent the metal guide inside the motor housing and melted the plastic that holds the guide and keeps the belt inline with the roller. I've got it running again by using a screw I filed all the threads off of, but it only works for 10 minutes at a time before breaking another belt. This process is getting expensive, as it usually takes 30 minutes to completely vacuum the house. Is ther


Most likely it is the top cover that needs to be replaced, part #2031238 and is around $30. It would have that guide on it. ... Bissell 3594 CleanView PowerTrak Bagless Upright Vacuum

Series 6500 motor shuts off, vacuum continues to run, not suction


It's tripping the temperature overload in the motor. The most common cause for this is a clogged hose. Take the hose loose and attach it to the exhaust port under the back cover. You should be able to see if it's clogged and unclog it. I might also s ... Electrolux Epic 6500 Vacuum

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?


... Kenmore Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.


Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I have looked online for this vacuum but could not find it. The closest one is the Eureka 8803 but the p/n on mine says 79307. I have totally disassemble this vacuum. There are no clogs anywhere. Motor spins by turning shaft. Belt is new and turns brush. It still has absolutely no suction.


... Eureka Boss Capture 8803AVZ Bagless Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Powerhead woes Drive belt for power head beater brush on Hoover S3755 keeps jumping off drive motor shaft when vacuuming low pile carpets like oriental rugs unless minimal suction is used. Any tricks to keeping the belt in place other than this?


I've had my Hoover S3755 for about 2 years and loved it, at least until the last couple of months when the "belt slipping off" problem started. I changed the belt and the vacuum would work for a little while then the belt would come off again. I pu ... Hoover S3755 WindTunnel Bagless Canister Vacuum

The suction still works but the primary floor vacuum doesn't. I checked the belt and its not broken. The engine that runs the floor vacuum doesn't engage like it used to


The belt doesn't have to be broken to affect the the way the vacuum picks up on carpet. If the belt is stretched then it will slip and not turn the roller brush properly. Here is the manual and belts you need: ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I replaced the powerhead drive belt. Now (2 times) while vacuuming the powerhead motor appears to run backwards. Because the metal pully which has left hand threads on it will backout / unscrew it self. Prior to this belt rerplacement it functioned properly. Thank You Bob


Look at your power head motor. If you see a fiberglass looking sleeve on the shaft where the belt attaches to it, you need to remove that. You can slip it off, chip it off, or break it off piece by piece. You can usually use pliers and break it into ... Rainbow 75th Anniversary Canister Vacuum

My suction motor won't run on my electrolux Prolux vacuum


... Electrolux Vacuums

Oreck XL Commercial vacuum cleaner ---- has high pitch squeal or whining sound when turned on. The belt is ok and the suction is ok. Is the motor about to go out?


... Vacuums

Motor runs,brushes turn,no suction - Vacuums


Either the fan on motor is broken or off shaft or the unit is plugged,if its plugged the motor will sound like its running faster than usual ... Vacuums

WE HAVE A DIRT DEVIL ULTRA VISION TURBO VACUUM MOD 87800 AND ITS BREAKING BELTS AND THE MOTOR SMELLS WHEN WE RUN IT


... Dirt Devil Vision Turbo W/Bonus Upright Vacuum Vacuum

My machine ran over some string,made a funny noise and emitted some smoke,the hand suction pipe at the rear works perfectly, the motor runs fine,but the front of the vacuum will not work.thankyou very much, Thomas.


The string bound up the beater bar (brush), keeps the belt stationary, and the motor spindle is just rubbing against the belt and melting it. remove the belt guard, remove the brush, and the belt. clean off the brush bearings (at the ends of the br ... Panasonic Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0892 seconds