Having problems with your Vacuums ?

Motor runs,brushes turn,no suction - Vacuums

Answers :

Either the fan on motor is broken or off shaft or the unit is plugged,if its plugged the motor will sound like its running faster than usual
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I purchased a Eureka C4910 last year and have a question that I am hoping you can answer. There are two motor actions with this vacuum, 1) the vacuum suction, and 2) the beater bar. The action of the beater bar is that motor is supposed to automatically shut off when the handle is in the complete vertical position assuming the vacuum is stationary, but then turn on when the handle is tilted toward the floor, assuming the vacuum is moving back and forth. The beater bar motor turn-on mechan

Good day!Normally when the motor is easily moved back and forth means that it have a proper lubrication,proper alignment and no clogs.When the motor and the belt is OK the problem could be on electrical wiring and switch ... Eureka C4910 Bagged Upright Vacuum

My A 2045 Karcher vacuum's suction is really weak and the motor seems to be working VERY hard. The motor sounds like it used to when the vacuum fell over and went into overdrive! Now it's in overdrive all the time and the suction is minimal. Nothing is blocked and the filter is clean and dry. What do I need to do?

... Karcher K DS 5500 Vacuum

I have any easy-flo built-in vacuum. I recently had the bearings on the motor, top and bottom replaced. I put the vacuum back together and it mow has low suction power. There is plenty of suction on the side of the canister where the rigid tubing meets the canister body but little suction at the wall plates. Any ideas? Roger

There is either a blockage or a pipe is open somewhere. You should check the system at the wall valve without the hose to determine if the pipes are blocked or if perhaps the hose is plugged. If one of the wall valves is damaged or open, this will af ... Vacuums

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

Suction problem I have a Hoover Widepath Fold Away, 12 amp motor vacuum cleaner and the problem I am having is every time I vacuum, the vacuum gets clogged up with carpet. I am probably only able to do one stroke then it gets clogged and I have to stop and unclog it or it spits it out on the carpet. This is very frustrating and I don't get much vacuuming done. Please can you help me. Thank you. Gwen email is [email protected]

Get rid of the carpet its shredding and falling apart.no sence in vacuuming old rotten carpet.or try using a vacuum without a brush roller and just suction ... Hoover U8145-900 Savvy Bagless Upright Cyclonic Vacuum

How do I gain access to the motor of an Electrolux 2000 canister vacuum. The air intake on the motor must be partially blocked as there is a loss of suction and the motor makes that high pitched whine like it does when you cover the hose with your hand

Dismantling the vacuum probably won't help much, and reassembling can be a bear. \015\012To check the intake, remove bag and look into bottom of bag well. It there's a filter there, remove it and check intake at bottom of bag well. Clear if t ... Electrolux UltraLux 2000 Bagged Canister Vacuum

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.

Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I was vacuuming the vent in the bottom of the fridge. I must have picked something because the motor got wildly noisey. I cleaned out hoses, etc. There is no suction. I can see the blades of the motor and they are not turning around. Model U4269-930 Series B.72. Can I get at the motor to see if something is keeping the blades from turning? What would be your suggestion. Many thanks. Pat Sauerman

Hi Pat, my name is John I will do my best to assist you.\015\012\015\012You certainly can get at the motor, with simple hand tools. \015\012\015\012Referring to this ... Hoover Vacuums

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.

You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

Will the broken pre-motor filter housing catch affect the overall suction of the vacuum?

... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.

I would start with washing out the ilter really good and letting dry. then try the system. ... Electrolux Central Vacuum

Remove suction motor on rainbow vacuum

How I can open Rainboe E-series Vacuum to change new Air Filter? ... Vacuums

Series 6500 motor shuts off, vacuum continues to run, not suction

It's tripping the temperature overload in the motor. The most common cause for this is a clogged hose. Take the hose loose and attach it to the exhaust port under the back cover. You should be able to see if it's clogged and unclog it. I might also s ... Electrolux Epic 6500 Vacuum

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.

Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?

... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Hoover WindTunnel S3765. The motor spins and the belt turns when I turn the brushes on, and the brushes will spin. The problem is that when I do this on carpet, the brushes stop spinning. As soon as I pull the "head" off the carpet, the brushes spin again. It's almost as if the vacuum suction is too great. I took the head apart and watched the motor turn the metal spindle that the belt rests on, and the belt turns as well.

The belt is stretched and needs replacement.(Belt # 38528036) . The brush is not turning against resistance. ... Hoover Vacuums

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced

There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

Brand new LG LUV200r used 10 minutes now after removing dust tank & reinstalling the vacuum motor does not run only the beater bar??? I have located wo circuit breakers both seam to be set. This suction motor should run when the switch is pressed & the beater bar should operate when the handle is moved down??? Not A happy customer will return unit to Best Buy only 100 mile round trip!!!! RDH

... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative

Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I bought a Kenmore canister vacuum, model 116, in April 2007. This morning, the sound of the motor suddenly began to deepen, and I began to lose suction. Normally, if something is clogging the hose, the motor will wind up to a higher pitch, not a lower one. The filters are clean, the bag is empty, and I can't detect anything lodged in the hose. If this were a car's engine, I would say it's "lugging down". Any pointers?

Okay, bear with me. Is it possible you have a suction adjustment, dial somewhere on vac. Check and see and if it does, be sure it's all the way up. Also, try removing hose and run a broom handle fr. one end to the other...BUT be careful not to stretc ... Vacuums

My dyson vacuum motor is sounding very high pitched... The tubes are all clear and there is suction with the tubes not not real good suction on the beater brush area....

If you have tried cleaning other parts and cannot find an obstruction, and still have no suction, you could try this:\015\012\015\012 ... Vacuums

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?

... Kenmore Vacuums

I have looked online for this vacuum but could not find it. The closest one is the Eureka 8803 but the p/n on mine says 79307. I have totally disassemble this vacuum. There are no clogs anywhere. Motor spins by turning shaft. Belt is new and turns brush. It still has absolutely no suction.

... Eureka Boss Capture 8803AVZ Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1030 seconds