Having problems with your Vacuums ?

Motor runs but no suction on a kenmore upright


Answers :

It could be stopped up or the belt has broken. check the hose by removing it and drop a coin in one end and see if it comes out the other end , if not your hose is plugged. Try pushing a broom stick from the end of the hose that plugs into the vac.
\015\012If the hose is ok, check the little hose at the bottom of the vac that goes into the part that has the brush.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor runs but no suction on a kenmore upright


It could be stopped up or the belt has broken. check the hose by removing it and drop a coin in one end and see if it comes out the other end , if not your hose is plugged. Try pushing a broom stick from the end of the hose that plugs into the vac. ... Vacuums

Hoover upright bagless vacum.motor runs, brush turns, no suction through hole behind brush roller. however there is suction going out of dust cannister filter flap to motor. what could possible problems be?


Sorry to read about your problem, I hope this helps you out.you have a clog between the brush and bagI tried to help you. Please help me and Rate/Vote on my response, thanks and good luck ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Have an old upright that does not pickup dirt. The beater bar runs but the suction motor doesn't. Do not know how to disasemble upright.


I don't recommend taking it apart yourself. The problem could be a switch, wiring, or connection. The motor could also be bad. I strongly recommend taking it to an authorized Aerus Electrolux store for a free diagnosis. Let a trained service tech ... Electrolux EL5010A Bagged Upright Vacuum

I have a Kenmore Elegance model 116 that has lost suction. There is no blockage and both the filter and bags have been changed. The powerhead turns on but the vacuum itself is fairly quiet, not sure if that motor is running. How can I regain the suction?


... Kenmore Vacuums

Bissell upright has weak suction and motor running hot but can't find a blockage


... Bissell 8975 CleanView Bagless Upright Vacuum

My Electrolux Upright vacuum cleaner will not suction. Motor will run to turn roller, though.


The air passage form the brush area to the bag is plugged somewhere. Remove the lower plate and the bag above so that you have access to the air passage from both ends. A hooked, stiff wire will help pull the debris out. This problem is usually cause ... Vacuums

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter about 5 min. of use. We then need to let it sit for awhile and then we can run it again for another 5 min. The bag has been change. Any one have any ideas how to fix this?


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.\012You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessa ... Kenmore 34612 Bagged Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Upright model not suctioning, but motor running


Hi,Often the hose can pug and it can be very hard to get it out... some thing can push sideways when you run something through the hose but then close it up when the suction is applied...Make sure to stretch out the hose and run som ... Dirt Devil Vacuums

Kenmore progressive canister vacuum model 116 52612205, I have power and suction but the powerhead motor doesn't come on to run the brushesdo you have a solution


... Vacuums

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?


... Vacuums

No suction After taking the vacuum apart, I noticed there is no suction at all. The motor runs, belt runs, but no suction coming through.


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.Does the brush turn? If not, then the belt that drives the brush is broken. Replace the beltJim ... Hoover Tempo Widepath Upright Vacuum - Blue

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

No suction My Hoover Wind Tunnel vacuum runs but there is no suction. The last two or three times I used it, it shut itself off after having a burning smell. When I unplug it for the suggested 30 minutes, the motor will run again but no suction. What is wrong?? Should I just buy a nve one? This one is 8 years old.


Sounds like your motor bearings are going bad. This is generally indicated by the motor overheating, and the heat transferring out through the motor pulley, which is where the belt attaches. So, your machine is overheating, melting the belt, and then ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

Motor is running and the brush is also running but i have no suction and the suction tube is clear


A clogged filter or if it has a bag hole in bag or bag isn't in correct. ... Hoover Vacuums

Brand new LG LUV200r used 10 minutes now after removing dust tank & reinstalling the vacuum motor does not run only the beater bar??? I have located wo circuit breakers both seam to be set. This suction motor should run when the switch is pressed & the beater bar should operate when the handle is moved down??? Not A happy customer will return unit to Best Buy only 100 mile round trip!!!! RDH


... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

Does not pick up, no vaccum, motor runs, no blockage, should feel suction on hose outlet without hose hook up. Paper filter missing over cloth filter. float overload ball free, seal on section good no leakage. Maybe bad motor but runs.


Here\015\012 is a Link to one of my Tips:www.fixya.com/support/r6311178-vacuum_brush_bar_not_spinningThis\015\012 should solve the problem. ... Minuteman C82906-01 HEPA Vacuum Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Kenmore progressive bagless no suction however brush runs well .


Remove all the filters and clean themon the bottom you have what is called an intake hose.you will see it as it comes up from the bottom and up on the backside.it connects to a fitting take the screw out and pull the hose away from the back.take a co ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Kenmore whispertone 116 canister motor won't run


... Kenmore 23313 Whispertone Bagged Canister Vacuum

BURNING SMELL My DC 07 has suffered from poor suction in the upright position for some time now but this morning it ground to a halt. It was if the motor had burned out. I turned it upside down and some small stones etc tumbled out. I tried switching on again and the motor kicked in but the smell was horrendous so i switched off immediately. If it's likely to be **** inside the motor area i don't no how to access it. I've removed for fixing screws but still unable to prise apart. Is it just the


Hi.\015\012\015\012Try this site http://dysonmanuals.llc.nu/ has service manuals covering removing the Dc07 motor. ... Dyson DC07 All Floors Bagless Upright Cyclonic Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0588 seconds