Having problems with your Vacuums ?

Motor smells hot after 5 minutes. Brand new exhaust filter turns black


Answers :

First - stop using the machine! The black material in the exhaust filter is carbon dust from the carbon brushes in the motor. The fact that the motor quickly smells hot and is shedding so much carbon indicates that the carbon brushes are worn to their limit (or damaged). They need replacing. Don't use the machine again until the new carbon brushes are in place or you risk causing irreparable damage and will be in line for a costly new motor. Carbon brushes are usually not expensive but, depending on your expertise, you may need someone to fit them for you.\015\012
\015\012You don't tell us the make or model of your vacuum so that's about all I can say. Good luck.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Motor smells hot after 5 minutes. Brand new exhaust filter turns black


First - stop using the machine! The black material in the exhaust filter is carbon dust from the carbon brushes in the motor. The fact that the motor quickly smells hot and is shedding so much carbon indicates that the carbon brushes are worn to thei ... Vacuums

Brand new 3HP shop vac smells like motor burning when turned on!


... Shop Vac ShopVac 3 HP 2 Stage 10 Gallon--Automotive Wet/Dry Vacuum Vacuum

When I turn on my Kenmore Premier 4.5 Peak HP 10.0 Amp after about a minute of running I get a burning smell. When I opened up the compartment that holds the dust collection bag, and remove the bag I found a filter. The filter was minimally dusty and has been cleaned. After sniffing around, I could not identify the source of the smell.


Dose it smell like rubber check your belt ... Vacuums

My new Hoover 2100 Model number PU 2110-001 stops for 20 minutes every 4-5 minutes of use. It seems to get too hot. It has done this since new, I have changed the dust bag & all filters, but it makes no difference. Help


AS new return to shop, Not fit for purpose, they should replace it. sounds as if thermal fuse is tripping in the motor, resets itself when cooled down. ... Hoover Vacuums

My new Hoover 2100 Model number PU 2110-001 stops for 20 minutes every 4-5 minutes of use. It seems to get too hot. It has done this since new, I have changed the dust bag & all filters, but it makes no difference. Help


... Hoover Vacuums

Went to turn it on after not using for several weeks and it states not ready to brew like usual but after about four minutes it just turns off. Wont let us brew a cup or access the menu even to choose size of cup or anything. It sounds like it's sucking up water to make cup and pokes hole in the coffee but nothing more than that. It is almost brand new


You have posted the fault in the wrong column with no instruction of the make/model.\012Assuming it to be new , Is it passed the warranty period before we take a look ,?\012Just lave it on for sometime and see if there is any change. per ... Vacuums

My brand new bissel little green proheat pet series is spraying solution however it's not hot when it comes out. I put hot water in the tank & turned the heater on. Isn't this the whole point?


Have you checked the user manual? Can be found at http://www.bissell.com/searchresults.aspx?searchtext=little green&mode=userguides\015\012\015\012If there is no element then the water will cool down naturally. ... Bissell 1425 Little Green ProHeat Handheld Steam Vacuum

Vacuum turned off started smelling and got hot but only for 2 to 3 minutes then turned off


Hi There, 2 to 3 minutes is too short for a blockage in my opinion. I would suggest you have a burnt out motor. Did it make any kind of uneven sound or popping sound? If yes then you will need to ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Lost suction I've only used this vacuum a few times, it's practically brand new. Now, one I turn it on, it sounds fine, and the hose feels as if it's getting some suction, but it's not strong enough to actually **** things up from the carpet into the canister. I have completely emptied the canister and bought a new filter. Nothing seems to help.


TOSS IT and forget it! I have never used a hand vac that worked that was worth the effort of turning it on .... I suggest they are all junk ... I found very few vacuum cleaners ... actually **** especially anything made by dirt devil ... I do have a ... Dirt Devil Vibe AllPurpose Hand Vacuum Bagless Vacuum

I have a hoover hurricane and it will not pick up no blockage, brushes are new and new belt. The exhaust filter is just blowing out hot air.


... Hoover Vacuums

Model DC-31 Animal. Brand new out of the box. Brush turns intermittently at initial start-up then stops completely after 30 sec. to 1 minute of using. Belt is in-tact and functioning. Belt motor hand-turns with some resistance felt.


... Dyson DC31 Animal Bagless Handheld Cyclonic Vacuum

I have the same problem as discussed above. My Hoover Pet Cyclonic upright stops working while using it. The bottom feels hot when this happens. When it first occurred, I emptied the canister and even tried a different plug. It did not turn back on for over an hour. When it did turn back on, it would die again after about 3-5 minutes of use. I don't know what else to try. I have washed the secondary filters, let them air dry and replaced them and this did not help the problem. My friend,


... Dirt Devil Hoover Uh70085 Pet Cyclonic? Upright Vacuum

Belts breaking/melting The original belt broke at almost 1 year so I replaced it. I changed the carpet setting to shag even though my carpet is very low pile to make it easier on the vacuum. I didn't get to use it but just a couple minutes and could already start smelling the new belt getting hot. I checked the roller and it is easy to spin. Not clogged with hair or dirt. Now the inside of the new belt has small pieces of rolled rubber instead of being smooth. The metal shaft that goes into the


... Dirt Devil M088905 Vision Bagless Upright Vacuum

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

Brand new Hoover Max Extract Deep Cleaner brushes won't turn. Read manual. Checked filters - all clear. Set Spin Scrub Mode Selector to a scrub setting. Brushes still won,t turn. However the brushes on the Spin Scrub hand tool rotate.


... Vacuums

My brand-new Hoover Windtunnel T-Series Pet Rewind Bagless vac simply shut off while I was using it and now I can't get it to turn back on. I've emptied the dirt collection bin and let the unit sit unplugged for 30 minutes to reset the Thermal Protector as per the manual. I've even tried a few different outlets just in case a fuse got tripped, but the vac still won't turn on. What happened? Do I need to return this vac to the store? I just bought it 5 hours ago.


... Hoover Vacuums

My brand new Hoover S3865 will not come on. Only the light turns on. Turned off for 30 minutes and tried again and got nothing. Help.


... Hoover S3865 Bagless Canister Cyclonic Vacuum

Yesterday i put naan to hot black and decker toaster just 1 minute led turn on after its off and naan just half cooked and led not turn as red please give me solution!


... Vacuums

My Kirby is brand new(Sentria). Everytime I turn it on to vacuum, it smells like burnt rubber. I've checked the belt twice, it's on fine. What am I doing wrong?


Please check out my step by step instructions.....http://reviews.ebay.com/CHANGING-THE-BELT ... Kirby G6 Bagged Upright Vacuum

I forgot to replace the vacuum cleaning bag in my Hoover Wind Tunnel Supreme Mach 3.3! It overheated and turned off. I spent all afternoon cleaning the dirt out of the inside, filters, etc. It still overheats when used over 1 minute. Do I need to buy a new vacuum?


... Vacuums

Suction fine whe first switched on but soon (2 minutes) starts to die as a burning smell gets stronger. Filter cleaned. no parts feel hot to touch. What could be the problem. Machine used daily, approx. 6 years old.


Check belt for beater bar ,also check where motor pulls in cooling air ... Vacuums

I recently purchased a Hoover SteamVac to replace an old one because the brushes would not turn. I used it last week and then tried to use it last night and the same thing happened w/ the brand new model - the brushes won't. I've cleaned the brushed, the filter and everything else I can see. Can you help?


Those things are a waste of money you better off renting one. but the only thing i could think of is that something is stuck or your belt came off track ... Hoover Steam Vac Dual V w/ SpinScrub Vacuum

Over heating? My 10 gallon 4HP shop vac has started shutting off after about 30 sec. after I turn it on to use. It smells real hot after I shut it off. I have changed the filter and the bag, which did not solve the problem. Any suggestions on what the problem could be? It's only about 31/2 years old and I really don't use it all that much, mainly for getting up dust and cob-webs from my garage.


It sounds like you need to replace the motor in it . thank you for using fixya ... Shop Vac ShopVac 3 HP 2 Stage 10 Gallon--Automotive Wet/Dry Vacuum Vacuum

Dirt devil blows hot air brand new - Dirt Devil 12 Amp HEPA Filter Vacuum Vacuum


... Dirt Devil 12 Amp HEPA Filter Vacuum Vacuum

My eureka vacuum won't suction and starts to smoke when I try to use it. It sounds like it is suctioning when I first turn it on, but after about 20 seconds it begins to smell like burning and does not suction at all. I have tried cleaning and unclogging the filter and everything. It's bagless so I don't need a new bag.


The problem is that your belt is stretched and worn. This causes that burning smell and it also causes the vacuum to not pick up well. You need to replace the belt. Here is the belt you need and the manual with instructions: ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0748 seconds