Having problems with your Vacuums ?

Vacuum was running unusually hot recently and then

\015 Fein vacuum turbo II Vacuum was running unusually hot recently and then when I turned it off it wouldn't come back on\015

Answers :

If it was running hot somethinghas melted together and now wont start must be torn apart to see what has failed most likely the vac motor impellar.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vacuum was running unusually hot recently and then

If it was running hot somethinghas melted together and now wont start must be torn apart to see what has failed most likely the vac motor impellar. ... Vacuums

I have bought a HOOvER freespace 2000W cyclonic vacuum cleaner but it runs VERY HOT and I am wondering if this is the usual running temperature. I have cleaned the air intake filter and removeed the e

... Vacuums

The handle for my Eureka 5993 AVZ was getting very hot when used. Finally, the wires around the switch melted and now the vacuum will not work. What is wrong? Is the switch bad? The wires only melted in the immediate vicinity of the three-prong switch. Nothing else appears to be wrong; the vacuum worked fine when it was running - except for the handle getting hot. Thank you!

Try cleaning all...\015\012if have sam paoblem need replaced main motor.... ... Eureka 5893AVZ Bagless Upright Cyclonic Vacuum

We have had a Dyson DC14 for 5 years. Recently, when I run the vacuum, it whines a high pitch sound. It still maintains a suction and does not seem to have lost any power. I am unaware of anything that was done to change the condition of the vacuum. Concerned what the noise is and if it is damaging the vacuum.

... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

I was given a Kenmore progressive hepa filter 22313 Bagged Canister Vacuum recently, but don't have the manual. We used it once to vacuum the house and it worked beautifully. Then we used it 5-6 days later and it started whining and getting hot. What year was this vacuum manufactured? Where can I download an owners manual?? Help!

Http://www.managemylife.com/mmh/owner_manuals/5461/KENMORE-Vacuum-Canister-L0809572 ... Kenmore 22313 Bagged Canister Vacuum

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?

Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

I have a iRobot 4150 and have recently experiencing performance issues with the vacuum. Recently, it started stopping about a minute after you turn it on. I thought maybe the battery was the issue, but I bought a replacement. It has worked well for the past 6 months. While it's running it sounds like it is going to die, even though it is fully charged. Any ideas?

Yes, a common issue with the cleaning head module, chm. You will need to diassemble the Roomba and remove all debris from the CHM. Also take a look in its gear box. ... iRobot 4150 Roomba Vacuum

Really LOUD Just recently this vacuum went from the normal everyday vacuum to now sounding louder than my power saws in my workshop. Checked for clogs.. everything is clear.... cleaned it all over and then turned it back on and.... The neighbors thought I was running a saw mill out of my house. HELP!

Its the belt if it is a savvy.Have the same problem ... Hoover U8145-900 Savvy Bagless Upright Cyclonic Vacuum

Our miele red star(s314i) vacuum was running great and quit suddenly. It had not been running for a very long time and just quit. Newish bag, no clogs in hose and doesn't seem overly hot. the over heated warning light did not come on. I've waited 30 plus minutes to try to restart and no luck. Any ideas

Ok, so if the cord test didn't fix the problem, then it sounds like either the plug has gone bad, or the switch. The plug is a very common problem to go bad, and can be caused by just simply yanking the plug out of the wall, or putting too much tens ... Miele Red Star Bagged Canister Vacuum

Burning smell There is a burning smell when I run my Kirby Ultimate G.  The smell seems to be coming from the belt.  I looked at the brushes and they are spinning so the belt is working.  the Post on the vacuum is getting very hot not sure if that is normal.  What is causing this?

Unlock the sweeper brushes and take them out. on each end is a cup bearing and should be free of debris.then check around and under the belt and likely there is debris wrapped around it.the post is getting hot as your pulling too much of ... Kirby Ultimate G Bagged Upright Vacuum

Motor dying? recently my herritage has been sounding sick, i tried to use it the other morning and it barely could blow up the bag, there is also a hot smell to it when it is running, the motor doesnt sound as powerful as it use to. Any suggestions?

Replace the carbon brushes in the motor. ... Kirby Heritage II Vacuum

I have two older Filter Queen (brown vacuum cleaners). Besides unclogging the hose area and making sure it is not filled with dirt, what else would cause the machine to run hot and have a high pitched sound? Is there another area where I might have clogs?

There is a secondary filter under the paper cone that gets filled with fine dust. It can choke off the airflow. The noise motor sounds like a bearing going dry. That should be replaced ... Filter Queen Majestic Canister Vacuum

I just bought a good Sears Kenmore Progressive 300 upright vacuum (116.38812891) today at a garage sale for five bucks. I left my relic Electrolux with the new owners of my former home during a recent relocation. In the interim I bought a Bissel 3750H which I do not care for, and borrowed a Eureka 7685 AU which performs somewhat better. I cleaned up the Kenmore, and though it seems to run well, noticed the drive belt is showing signs of degeneration. I would like to replace it, but was unable t

... Vacuums

My riccar vacuum runs for about 2 minutes then shuts off and when it is on it does not pick up anything it gets very hot quickly

You have a clogg and there is a reset button in rear near left wheel. ... Riccar R100 Vacuum

We have a EZT vacuum model 6508C. It started running hot yesterday. Today it will not turn on at all. Is there a reset button?

... Vacuums

I have a Nutone central vacuum model number CV450W that was working great until I recently removed the hose and it now runs continuously until I pull the plug....any suggestions please

Disconnect the thin low voltage wiring between the vac and the rest of the house. If the vac continues to run you have a defective relay in the vac motor housing. If the vac stops you have a short in the wiring in the house, likely behind an in ... Broan-NuTone CV450 Central Bagged Central System Vacuum

Lux legacy vacuum runs fine and was recently serviced - yesterday the tone of the motor on the vac started a higher sounding pitch - is this a potential problem and is there anything i can do with it - thank you

You don't mention whether it was the canister or upright model, but if it sounds differnet than what it usually does, then there is a potential problem. It could be anything from a full/clogged bag to a dirty filter to a clogged hose. You can check ... Electrolux Vacuums

Motor running extremely hot

You might want to check the brushroll. It may need to be replaced. The brushroll end caps on your model should come off easily and if there is a collection of hair, etc under them and you can clean it out, do so. If it is impossible to clean out, you ... Eureka 1934 Bagged Upright Vacuum


It sounds like a problem with you motor. The hepa filter has nothing to do with the motor, and should not have been removed. It sounds like the repair man doesn't know much about rainbows. It could be a short in the motor housing or faulty/imprope ... Rainbow E series Canister Wet/Dry Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

My vacuum will not run continuously

It should still be under warranty so take it back to the suppler, distributor or Dyson if you are near. ... Dyson DC44 Animal Handheld Vacuum Cleaner

DT 1300 As I am vacuuming the motor seems to fade in and out and sometimes stops running for a few seconds and then resumes. If I move the hose a bit near the vacuum end, it runs smoothly again. Does this sounds as if there might be a short in the motor? Would this be something I can fix myself or does the vacuum need to go in for repairs.

... Oreck DutchTech DTX1300C with Motorized Carpet Brush Bagged Canister Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Fantom vacuum vacuum starts running fine at first,but after about 15 mins the suction stops but the vacuum continues to run

Sounds like a partly clogged filter ... Fantom Vacums FM741 Twister Bagless Upright Vacuum

My filter queen will not run and feels hot

You have got to be kidding me. you want me to pay for your advice after I paid over $2,000 for this vaccum. Not only that, the sales rep that sold the filter queen to me, stole my Oreck vac right out my livingroom. I did not realize until after he le ... Filter Queen Majestic Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 2.0785 seconds