Having problems with your Vacuums ?

Rule 1800 Pool Cover Pump With Leaf Protector 110v not running. Pump had a partially severed electrical cord which I repaired. I have cleaned out the pump for debris (took off outer parts). I still get nothing when I plug it in. Impeller is somewhat hard to turn but I can find nothing impeding it. Thoughts?


Answers :

Most likely the shaft bearing is seized up and not allowing the impeller to turn. Pull the bottom odd till you can spin the impeller by hand and use some penetrating oil around the shaft turn it by hand a few times and then with it still apart plugg it in and spin the impeller by hand to see if it will sart.
Try connecting the unit in another power outlet and check it. if still the same problem then
\015\012You are probably just getting an air lock and can fix this by taking the hose off till it's under water or hold it upside down in water till it starts. If you hold the cord while it's in the water an just make sure it's tight you should be able to feel the vibration through the cord to tell if the pump is indeed running while under water.
\015\012You can also test the pump as follows:--
\015\012A way to test the pumps correct operation is to:
1. Unplug the pump.
2. Remove the pump from the water and disconnect the hose.
3. Plug the pump back in.
a. It should cycle on for about five seconds.
4. Place the pump in about 3 to 4 inches of water.
5. Wait for 2-5 minutes for the pump to cycle on.
a. If the pump cycles on and continues to pump water
1. Remove the pump and it should shut off. Place the pump back in the water and wait for a few minutes. It should kick on and continue to pump the water. Remove the pump and it should shut off. You can try it as many times as you like. Normal operation occurs when the pump activates and deactivates on its own.
b. If the pump cycles on but does not run continuously, the pump may have an internal malfunction.
c. If the pump does not work at all, please make sure there is power going to the unit. If it is plugged in, the pump may be defective.
If the pump works when you are testing the unit, try straightening the hose and make sure the hose goes up once and down once continuously (no camel backs).

\015\012This will help. Thanks please keep updated.please do rate the solution positively .thank you for using fixya
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Rule 1800 Pool Cover Pump With Leaf Protector 110v not running. Pump had a partially severed electrical cord which I repaired. I have cleaned out the pump for debris (took off outer parts). I still get nothing when I plug it in. Impeller is somewhat hard to turn but I can find nothing impeding it. Thoughts?


Most likely the shaft bearing is seized up and not allowing the impeller to turn. Pull the bottom odd till you can spin the impeller by hand and use some penetrating oil around the shaft turn it by hand a few times and then with it still apart plugg ... Vacuums

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden


Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Pump part number is 2107181, the diverter valve # 2136988. You can Bissell and they can tell you who may have parts near you, or you maybe able to order thru Bissell.com. Before you took it apart, were you getting water to spray out of the hose. I ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Search for bissell pro heat pump. bissell.com will not have it ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat


It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

We have bissell pro heat and I have put new belts on and took off the top plastic cover I blew out the lines and I still can't get it to pump water or solution. The red little spinner flow indicater does'nt get water, if I pour water into it it runs out the front. I guess I don't know what else to do. The machine worked fine the last time we used it about 6 months ago. Any suggesttions?


Did you check and make sure the belt is still on right? They do come off from time to time.There are like 6 long screws holding the top cover to the bottom. The are real pain in the behind to put back together once you take them off. T ... Bissell Vacuums

The pump motor in my Bissel Proheat 2x Plus seems to have failed. It was seized so I sprayed WD-40 in it and let it sit for 3 days. Now I can turn it by hand, but when plugged into the unit it still doesn't spin. Here's a picture: http://bbay.dreamhost.com/bissel_proheat_2x_plus/P1070021.JPG I wanted to take the motor out and hook it into another power source to see if I can get it going but it has 3 wires. I'm used to only 2 (+ and -). How can I hook the motor up to another power source,


... Bissell Vacuums

My steam mop gets hot but steam is not coming out when i pump it. However when I release the bottom attachment steam comes out of bottom of the base (purple part). I took the attachment off to see if it was plugged but dont see anything. Any suggestions?


Hi,Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head...Euro-Pro Shark Steam Mop Problem ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

When I plug in my vaccum the power light turns on, but i get no power to the machine??? I changed bags and filters and still nothing??? Can you help?


That light wire is attached to part of the wiring that is just a piece attached to the main wire coming from the switch. Your bags and filters have nothing to do with powering the machine. You may have a bad switch or there may be a ground wire off ... Vacuums

Again, I have a Bissel Model 3760-4. The same problem as everyone else. The beater bar will not turn. Took apart, nothing. Took to vacuum repair shop and they said it is not getting power to the motor to the beater bar. Seems like a fair number of folks are having this same issue. You would think Bissell would come up with a fix, if nothing else to save their reputation. Thanks Diane


... Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

My DC 17 is plugged. I can see through the small hole in the top blue "flower shaped" that the holes at the top of the canister are plugged with hair & dirt. I cannot see anyway to get to these small round holes. Is there a way to remove the top blue "flower shaped" piece? I have removed the inner cone from the clear canister but still cannot get up underneath.


Please kindly follow the steps below to clean your vaccum cleaner,1.) Remove the clear plastic handle. You\015\012will have to take out two screws and then unclip from the from the\015\012front. It's stiff, I gently used a flat head screw drive ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Bissel proheat carpet cleaner wont spray out of the bottom or the spray handle. I took of the scrub brushes and off and cleaned out the bottom of the machine including popping out the two spray heads to make sure they were not clogged. Put it back together. Still no spray! I also did the turn off, remove fluid containers, replace, turn on for one minute to prime the pump, and still so spray...does this mean my pump is not working?


... Bissell Carpet Cleaner Powerbrush Deep Cleaner Vacuum

The belt wont turn...i cant get in to the inside to check to see if the belt isnt on the roller...how do i get up in there..i took the bottom plate off and you still cant get inside... thx Peggy


The following site has some great info on your machine:\015\012\015\012www.dysonmedic.com ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Dyson animal We bought a Dyson Animal from Sears a few years ago along with a service contract. We took it each year to be serviced. One year I took it because it lost it's suction. They sent it to the factory, but it came back still not working right. We did the same procedure over ands over many times than I can remember. I now have the cleaner in my garage and am using my old vacuum because I just can't seem to get anywhere with Sears. Please help me. We paid almost $600.00 and now it can't b


As someone who works for Sears, let me just say right now.. The service contract you bought sucks.. and does not really do anything for you. it was just a wast of money ( they have a new one now.. thats so much better because you get your money back ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Eureka Altima vacuum the brush is not spinning. I took it apart and the belt is Not broke, but when I turn the vacuum on I can smell the motor overheating. I turned the machine off and unplugged it and then took it apart so I could see the underneath and plugged it back in and the belt still won't turn..can you help?


Hi, since you have detected the the smell of the overheating motor, then the motor is faulty which is why the belt is not turning. You should change th motor ASAP........... ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Hi there, I have an electrolux mondo (375W suction) vac cleaner.I hoovered 1 room switched it off then when I tried to turn it on again nothing happened.I have changed the bag and the fuse in the plug but still nothing... fiona


... Vacuums

My shark steamer has stopped working after a year of having it (I have already replaced one, I'm a idiot!). My problem; however, is that it will steam, but the steam stops traveling through the actual "mop" part. I plugged it in, wait seconds and start pumping, but the steam builds up until it's hard to pump. I had to press the button really hard for the bottom to come off and it shot off like a rocket! I tried to stick something through the tubing, but it did nothing. What am I doing wrong? I


\012\012\012Hi,Here\012is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it\012may not be getting steam to the head... ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

I cannot charge my two year old electrolux pronto. I purchased a brand new hand held vacuum for it, but even the new one does not charge. When I plug in the cord nothing happens. If I turn on either the long handle or the portable unit within the long unit, the blue charging light comes on for a few seconds, then out. This tells me that the circuit is intact without a broken wire somewhere. I took it all apart carefully and could see nothing broken or out of place. On re-constructing it, it


It must be the charging transformer. We have already ruled out the vacuum unit. Unfortunately the transformer is not a serviceable part, and will need to be replaced. ... Electrolux Pronto 2-In-1 Stick/Hand Vacuum - Cayenne

I plug my Polti in and absolutely nothing happens, no lights come on nothing, I've changed the fuse but still noting


There maybe a broken switch or the motor may be burnt out. Take it to a used vacuum store and they will give you sound advice. ... Polti Eco Pro 3000 Canister Steam Vacuum

How do I clean out the suction side of a Hoover steam-vac Model#f6020-900. I took all the screws out and still cant get it apart.I vacuum before using it, but it still seems to find more hair.


These don't come apart. Hoover makes a thin long tool that will allow you to stick up into this suction side to clean it or use a long piece of galvanized metal strip to slide up into it and clear away the hair. ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

Altrev, I have an ODC325 Black&Decker spacemaker coffeemaker on my boat and it stopped working this weekend although the hot plate still gets hot. I suspect it is the thermal switch as you described (I hear a click when I switch the machine on but nothing happens and the heating element does not kick in). I would be very happy to receive one or two of these 14 spare switches you mention so I can repair the unit. If still available I would appreciate hearing from you how we can do the transact


We don't sell parts individually on the site here.... was it some other solution for another person you saw about the switch? I don't believe there really is a part called a thermal switch... there is a thermal fuse but if the hotplate gets hot I wo ... Vacuums

There is no power...seems like a motor problem. The bag is clean...the mouth is clean the plug us in...NOTHING! I took mouth off and manipulated/pushed in that power press area that engages the motor on the front (not the switch on the back) and NOTHING! Not sure if motor died and/or what to do now. Help. I have had this baby for 15 years.


The front safety switch must be pushed in by either the hose or head (or manually), before the on/off switch will operate. The most common reason for no power is a bad cord. Second most common is worn carbons in the motor, and third is a bad switch. ... Kirby G4 Bagged Upright Vacuum

I took the hose off to wash it then after letting it dry overnight I put it back on but Im guessing it there was still a little bit of water in between the grooves which ran to bottom of vacuum and now my dyson gets stuck, sort of like a tight hinge. It vacuums fine but I have to keep pushing it down to the carpet with my foot. How can I fix this problem?


Lubrication at the pivot points ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1054 seconds