Having problems with your Vacuums ?

My honda gx390 pressure washer is not starting. It is backfireing through the carb. Will run if I pull enough sputters them might kick in and run then will die. I have cleaned the carb & float bowl and changed the oit so it is up to leavel and seem to have spark but could be better spark. It was running (allthough not well ran out of gas and then I filled it up and this is what I have. Thanks for any help.

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My honda gx390 pressure washer is not starting. It is backfireing through the carb. Will run if I pull enough sputters them might kick in and run then will die. I have cleaned the carb & float bowl and changed the oit so it is up to leavel and seem to have spark but could be better spark. It was running (allthough not well ran out of gas and then I filled it up and this is what I have. Thanks for any help.

... Vacuums

Ryobi RPBV2500 My blower only seems to ant to run when the choke lever is at the first position. It did run with the choke completely off but seemed to suffer from what I thought was fuel starvation when it ran for awhile. When I took the fuel cap off it would start up again, making me think it had a fuel lock. I had a garden centre with engineers look at it.They said that they had checked the carb and could find no blockages. Can you please help?

... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

My vacuum has not been running right..the beater bar is not picking up and the rollers aren't spinning...the belt doesn't need replaced so what else could it be...everything else seems to be running fine???

The motor shaft that spins the belt may have hair wrapped arount it, causin the belt to slip. You can't miss the burnt odor.\015\012Remove the belt and clean the motor shaft. ... Vacuums

IRobot rumba 4000 seems to run ok and then starts making a kinda hi pitched growling noise and slows way down. it is very clean(blown clean with air compressor)sensors are clear ,newly installed well lubricated on ends of brush and beater bar, new battery. it seems like the wheel tracks may be dragging . i have cleaned and lubricated where i could on them but can't find a way to totally remove and inspect wheel tracks.

It sounds like your Roomba's brush gears are not working. Run the robot without the dust bin to see if the brushes are turning. If they are not, the robot will need to be replaced. Contact iRobot CS for support at (877) 855-8593. ... iRobot Roomba 4000 Bagless Robotic Vacuum

HI i have a electrolux vitesse pet lover 1600w modl ece09113.When used it runs for 10 to 15 min then turns of has been like this from new.I know it says it could be blocked but have cheaked and seems to be fine. As this hase done this from new could it be a thermo cut out switch faulty. Thankyou. Dave.

... Electrolux Vacuums

The motor runs slow (so does not pick up properly) and does not run at all if the hose is pulled out. There doesn't seem to be a blockage and the roller is clean. Could it be as simple as changing the filters?

... Sebo Felix Ice Blue Bagged Upright Vacuum

Recently my central vac system started making a louder than usual and laboured sound when in uise, enough so that I took note and inspected the canister and motor while running. The motor was trowing off blue sparks and looked like it could 'POP' at any moment. I will not risk using it until I know what the problem is and how to repair it. My assumption is the motor needs to be replaced. The system came with the resale house I bought 3 yrs ago but I do not know the age of the system itself.

... Vacuums

Have Fresh Aire 2.1 about 4 years was running great then went dead. I cant find where the fuse is and have unit apart. I plug in no fan dim display shows to errors. Unit was pretty dirty at the time. I need schematic and suggestions. Also need to knpw how to remove the honeycomb from the light unit to check for blown bulb. Seems brittle and I could break it with trying to pry with augur or sharp screwdiver object.

I'm sorry this may only be a partial help. But fuses are usually very close to the motor, OR where the switch is located. Pretty easy to find by testing but you have to be or so careful you dont electricute yourself. Now if your testing shows v ... Vacuums

Our dryer has been running longer than normal on cycles. It seems to dry just fine but at times it seems like the timer is not working. The dryer will just keep running for hours. Ideas on what I should do?

Have you checked to see that the knob for the signal to ring is still set to "on"? I know I have accidentally pushed my own off & wondered the same thing as you are. You may also have an excessive problem somewhere. Check your removable lint fi ... Vacuums

Noise My Dyson DC08 is making a loud, rough, vibration/noise that seems to be coming from the from the rotating brush housing. I replaced the old belt which was several years old and slipping. When I run the motor with the new belt removed the machine sounds normal. The bearings on the rotating brush seem to be running smoothly when turned by hand both when out of the brush holder and when installed in the machine. I can't find anything rubbing on the belt or rotating brush. I applied a bit o

Hi there, it's Jack at Dyson.\012I'm sorry to hear you're having difficulty with your Dyson vacuum. From your \012description, it sounds like the model number you've supplied may not be correct, \012as DC08 is a cylinder vacuum which doesn't use ... Dyson DC08 Cylinder Bagless Canister Cyclonic Vacuum

I have a panasonic mc-ul975 vacuum that works great when working properly. the airflow through the canister seems to stops once the aero blast technology is done running which causes the vacuum to not function as it should (does not have as much suction and the hose/tool accessories do not work at all). if air is continually running through the canister everything seems fine. please help!

Hi there. In Panasonic vacuums, there is a thermostat protection on the motor. It will auto ... Panasonic MC-UL975 Upright Vacuum

The Oreck vacuum motor sparks the stop running. Plugged to another outlet, the motor did the same things, run for few seconds with sparks and stopped again.

... Oreck XL2200 Bagged Upright Vacuum

Green sparks at back of motor when running

Hello, pedrsenI was trying to help you out here. Maybe this will help some? I was going backto some customers that asked questions in the recent past and even fartherback. It appeared that no one answeredsome of them, So, I thought I would ... Kirby G4 Bagged Upright Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.

Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou

Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

Hoover Wind Tunnel 7500 Brush not Turning. I have replaced the Brush and the belt. The problem does not seem to be either to me. I believe might be a missing part. The place were the belt hooks on is a metal pole which never seems to grip the belt well. In fact it seems loose most of the time and slips on the brush, causing the belt to eventually burn up. Could there be a missing plastic or rubber piece meant to hold the belt taught  on the metal pole?

Check the Idler Pulley part Number 43241004 (Item 13 in the IPB) ... Vacuums

My Discovery 4210 Roomba will run normally for about 20 minutes on a smooth, wooden floor. It then begins the following sequence: run forward a few inches, turn in a tight counter-clockwise circle a few revolutions, stop, power off a few seconds, power up, repeat cycle from forward run. The sequence can be repeated seemingly endlessly if I don't turn off the power manually. I've replaced the motor, and led revolution sensor system on the left drive wheel. I've blown the dust out of everywhere. A

This robot vacuum has a electronic micro processor that controls the unit and tells it how to operate and where to go based on programmed parameters. It's quite a technical marvel. I have dropped a link here for contacting the company tech support li ... iRobot Roomba 560 Robotic Vacuum

My kenmore progressive canister vacuum's power head has stopped working. When I check for suction from the hose, it seems strong. Could it be a belt has broken? Is this a repair that I could do myself? Thank you!

... Kenmore Vacuums

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti

You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

My Bissell doesn't seem to be vaccumming as well as it was before. Not sure what the issue is. Could the belts be loose? They are on there, but not extremely tight. Should they be tight? The brush on the bottom seems to have a lot of play/bounce to it as well. Thanks for the help.

You have a partial or complete clog of the hose that carriesthe drit from the floor to the bag or other storage device.\015\012\015\012Clean it and you will regain the power you originally purchased. You may have to remove some parts to ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Passat 2000 W Reg Had the rear brakes and disks changed then a month later had a front tyre replaced and as I drove off something went tinkle tinkle on the road (like someone had left a spanner). Week later the ABS light and the brake light come on with the usual STOP Brake Fail Service Manual message. Had brakes checked but they could find no fault. I've tried the ABS under controlled conditions and it works. What could the problem be?? I've been running the car under these conditions and no pr

The ABS module has a history of wearing out on VWs. Nothing wrong with the brakes themselves, but the ABS module would need to be replaced to stop the lights coming on... but the problem is a new ABS module can be very expensive for a new one (~$900 ... Vacuums

Cleaning solution does not come out of the rotating cleaning head or the hand-held nozzle the solution pump seems ok but does not run (electrical continuity check between the two leads on the pump show very low resistance so they seem to be intact) - no dirt or blockage is apparent (it is a very simple device with 1 moving part wires to the pump also pass a continuity check THERE IS NO VOLTAGE on the pump leads from the control circuit board when I turn on the "manual" cleaning mode - a

You can contact Bissell directly at the following\015\012\015\012For UK inquiries:\015\012Monday - Thursday 9 am — 5 pm\015\012Friday 9 am — 4 pm\015\012\015\012BISSELL Homecare (Overseas) Inc ... Bissell SpotBot Robotic Wet/Dry Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0698 seconds