Having problems with your Vacuums ?

My vaccuum cleaner is an EVERSTAR 1200. I turned it on - everything appears OK until I realize that it is not suctionning. I cleaned out the canister - made sure the vacuum was not obstructed. Still no suction. What could it be?

Answers :

First clean the filter on top of the canister, do not wet it, blow it and get all the accumulated dust out. Then check the hoses for obstruction. There should be an emergency valve on the rear part, if it is open, you better ck the hoses.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No suction i have a bissell lift off revolution vacuum. I have cleaned all the filters and emptied out the canister made sure that the hoses are not plugged but it will not pick up unless you use the hose. the floor brush is clean and still no suction coming from under the vacuum... could you help me please

Is there a blockage in the small hose in the bottom of the machine \015\012take of the pod and you will see the small hose, \015\012Is the main hose pushed into the bottom housing ... Bissell 37603 Upright Vacuum

My vaccuum cleaner is an EVERSTAR 1200. I turned it on - everything appears OK until I realize that it is not suctionning. I cleaned out the canister - made sure the vacuum was not obstructed. Still no suction. What could it be?

First clean the filter on top of the canister, do not wet it, blow it and get all the accumulated dust out. Then check the hoses for obstruction. There should be an emergency valve on the rear part, if it is open, you better ck the hoses. ... Vacuums

My Bissell cleanview is NOT suctioning well, all filters, nozzles, attachements, canisters and belts are clean and in good repair. We've pretty much made sure everything that I can get to without completely dismantling the vacuum is super clean and/or new... still poor suction

Did u check the filter above the dirt cup?\015\012\015\012twist the yellow piece and wash the filter ... Bissell 3594 CleanView PowerTrak Bagless Upright Vacuum

Hover Elite Rewind I've only had this vacuum a few months and I really liked it until now. There is almost no suction from anywhere in the vacuum, and I've cleaned all the filters and rollers with my shop vac and made sure that everything was assembled correctly. It used to be really quiet now it is quite loud and it keeps over heating, and shutting off. At this point I have no idea what could cause this problem, the machine is nearly brand new and I can't afford a new one at this point.

You have to clean out the hose under the bottom of the vacuum cleaner. To do this you have to remove the bottom plate the covers the brush it has about 6 screws. Also remove the brush and belt in order to thourhly clean it. I had the same issue you h ... Vacuums

Noisy vacuum I have a eureka capture that I bought in april it's making a horrible high pitched squeal type noise, I have made sure my roller is clean, my filters are clean, i replaced my hepa filter and there are not any blockages I don't know what else the problem might be. Could you please offer other suggestions to fix this?

... Vacuums

I have Hoover Widepath Bagless 12 Amp Windtunnel vacuum. Yesterday I was vacuuming and smelled smoke and it shut itself off. Today I cleaned out the filters (they weren't bad) made sure nothing was obstructing the hoses or the spinning brush part. It turned on for 1 second, smells like smoke somewhere from the bottom and now won't turn back on so I don't know if anything is spinning or not. What can I do to fix this myself?

Hi There,\015\012\015\012When a vacuum cleaner smokes, it is usually only one of two possible problems.\015\012\015\012It could either be that your motor burned up, or that your belts burned. The belts on this particular mod ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

I took the cover off the brush so I could cut off all the hair that was wrapped around it (vacuum was working fine, I just noticed the hair). I pulled the brush/spinner thing off one side, cleaned everything, popped it back in where it belonged, and tried to make sure the belt was in the proper alignment. However, when I turned the vacuum on, it makes a horrible noise like I'm sucking up rocks. What have I done wrong in putting it back together? It seemed simple...

The ends of the brush roller have to go in in a certain position.each end has a different look.make sure the match up to the seats on the roller guides and make sure the belt is centered.the belt will center itself by turning the roller by hand in on ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

I replaced the belt on my Dirt Devil Featherlite Bagless Vacuum and the brush roller rubs and makes a very loud noise when turned on. I have gone exactly by the manual instructions and made sure the belt and end caps were on correctly, but the bristles still rub the back and it makes a very loud noise. Without the brush roller in the vacuum, it sounds and runs normal. What could the problem be?

Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=561283\015\012Generic problem for all Vacuums\015\012I replaced the belt on\015\012Posted by piggyt ... Vacuums

Carpet steamer will wash but not vacuum up waste water , cleaned out reserve tank and made sure underneath was clean

It sounds like a seal is not right. You are loosing suction somewhere. ... Hoover F7220900 SteamVac V2 Upright Vacuum

I have a Kenmore 116.36932 (upright-bagless vacuum) that the motor protector by-pass valve has opened. I've clean out the area between the agitator brush where the flexible extension hose starts. There was some blockage there. I checked the rest of the system (extenstion hose, back filter area, pipe area to canister and area to side filter. I took the 2 filters out and the by-pass valve is still open. Where else could there be a blockage that I can take apart to clean and put back together

... Vacuums

I have a Kenmore DuraPower Dual Cyclone Action 12 Amp that just randomly stopped right in the middle of vacuuming. I assumed the plug had come out of the wall so I went to check and this wasn't the issue. I tried multiple outlets and that wasn't the issue. I made sure nothing was stuck and there is nothing stuck. Nothing happens when I press the red "ON" button. What could this be? Thanks!

... Kenmore Vacuums

My kenmore progressive canister vacuum won't start,any ideas, is there a fuse? it was on then just quit. I've checked all connections and made sure they are snug, and that it's still plugged in (!) model 116.

Wire broken in several place along suction tubing. Replaced tubing and works fine ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

Kenmore upright vacuum belt keeps breaking as soon as I put a new one on. I have made sure the brush roller is clean. How can I fix this or troubleshoot this?

... Kenmore 31723 Vacuum

Have dirt sensor light on continuously on Kenmore Progressive canister vacuum cleaner...lost manual, do not know where sensors are so can clean them. Could not find answer on the site or from Kenmore. Thanks.

... Kenmore 25812 / 25813 Progressive Bagged Canister Vacuum

Arrgh! I have an upright Bissell vacuum. Everytime I use it, it smells like a cloud of dust. I have made sure countless times that all the filters are clean and the hoses are intact, so I don't know what the problem is. Is this problem normal? Or am I somehow blowing dust everywhere? Any insight it much appreciated, thanks!!

I believe you have a clogg in the suction pipe. ... Bissell 3590 CleanView Bagless Upright Vacuum

My vacuum is making a loud noise like I sucked up somehting I shouldn't have I have cleaned all the hair and made sure there was nothing else stuck in there but it continues to make that loud noise is there something else that will cause it to make this ugly noise, and how can I fix it

... Dyson DCO7 Upright Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.

Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

When we turn on the vacuum, the canister falls open. The clips holding the canister in place do not seem to hold the canister tightly which I'm sure that it did in the past. The clips do not look bent, but every time we turn on the vacuum the intense pressure blows the canister open only remaining attached the the rest of the vacuum by one clip

Check filter and make sure it is kept clean at regular intervals. Possibly worn out clip retainers on cannister side due to excessive pressure build up. Do not force closure unless pressure is back to normal. May crack cannister or damage unit beyond ... Hayden Industries SuperVac 6000 Central System Vacuum

I have a Kenmore canister vacuum - model 25614506. Some time ago, I was not able to turn the vacuum off with the on/off switch, but could still use the vacuum. Turned if off/on by pulling the plug. The other day when I went to plug it in, I heard a pop. Now the sweeper runs but the vacuum cleaner does not **** - no air flow. What could be the problem. The cleaner is only 4 years old.

The motor has an inline fuse ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

My dyson vacuum cleaner doesn't seem to have the same suction power it used to. I have cleaned out the canister and have taken apart the vacuum head (for cleaning carpets) and it doesn't seem to be blocked but it seems to lose suction by the time it reaches the head. The suction is strong at the end of the hose (where you attach the telescopic attachment with vacuum head) Any ideas? Thanks, Irene

... Vacuums

My Hoover s5620 central vacuum is not sucking. I cleaned out the canister and vacuumed the inside bag in the canister. The hose is clear as is the central vacuums tubing. Any suggestions ?

Try getting some compressed air source and blow back whatever is stuck in the hose. ... Vacuums

Which Kenmore vacuum cleaners are made by Panasonic? Are all of their direct drive machines made by Panasonic? We have a blue Hoover Windtunnel with the dirt sensor. It cleans well, but it is unbelievably noisy. I wondered if something was out of place and the brushes were hitting, but everything looks normal. We bought Kenmore models 36722 and 36724 and love them. I believe they were made by Panasonic. Our Kirby sits in the basement. Much heavier. These are quiet and clean well. I would like an

Some Kenmore vacuums are made by Panasonic, some are made by Hoover or Eureka or even Sebo. I would go to a Panasonic dealer for that kind of machine instead of trying to go by the Kenmore brand. Sears has a hard time with service. A good Vacuum C ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My lovely IRobot vacuum Roomba560 teases at the moment. When it has vacuumed in approx. 15 minutes it stops and when I try to turn the lights, it shows red light vith text clean. I have cleaned everything that can be cleaned. When it is fully charged again it all repeats. Could it be the battery that need replacement? Sincerely, Tom and Annette Haspang

Yes, sounds like you need a new battery, they cost about$70 for an IRobot one or you can get them cheaper - do a Google search\012 ... iRobot Roomba 560 Robotic Vacuum

My Kenmore canister vacuum cleaner model 116.27514700 has unacceptably low suction.It is much less than my older GE Walmart canister vacuum. the 2 filters are very clean and there is no blockage in the hose and the dust collection bag is empty. Is poor suction a characteristic of this model or if not is there a way to fix this problem?

... Panasonic Kenmore Canister Vacuum Vacuum

Hello, I have a Kenmore Progressive Canister Vacuum 116.20912006. It won't turn on. On the hose assembly, the end where the hose swivel is, there are 4 metal pins that plug into the canister. One of the pins looks like it broke off. There are only three pins remaining. I assume there should be four pins as there are four holes. Is this the problem and is it fixable? The vacuum is from 2002 so I am not sure a replacement part is even available and at what price. Thank you. Susan susan.eng@

Hi Susan, if the pin has broken off you can do one of two things, first, would be to find a local vacuum repair shop and take it there for them to look at. they may be able to look at the hose and fix it for you pretty cheaply. what ... Kenmore Progressive 20912 Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1419 seconds