Having problems with your Vacuums ?

The problem is that the cleaner is heavy to use and does not pull itself forward as it should. It has been back to the supplier 3 times but they have not fixed the problem. The LED's on the front flicker and I think it may be a problem with the sensor. If you have any info. on how the sensor works and where it is located it would be useful as well as any other suggestions to fix the problem please.


Answers :

If it heavy then do some muscle work and body building
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The problem is that the cleaner is heavy to use and does not pull itself forward as it should. It has been back to the supplier 3 times but they have not fixed the problem. The LED's on the front flicker and I think it may be a problem with the sensor. If you have any info. on how the sensor works and where it is located it would be useful as well as any other suggestions to fix the problem please.


If it heavy then do some muscle work and body building ... Vacuums

We have an Epic6500. when we plug it in the machine works without the hose. We even purchased a new hose thinking there was a problem with the hose. However as soon as we put the hose on the machine the machine does not work. What do you think the problem may be?


Wow, this is a good one. I wonder if anyone has wrked on this machine before. Do you remember what happened when it stopped working / Obviously there is a foul up in the wiring. I need more info. When the machine is on does it shut off as soon as the ... Electrolux Epic 6500 Vacuum

Hello, I just bought a Bissell Powergroom (model 92L3-W) vacuum and a Bissell Proheat Pet (model 8910-3) deep cleaner and I love them both. My problem is, when we unpacked them we somehow lost the manuals; I think I had too many helpers that night – they may have gone out to the trash with the boxes. I need replacement manuals if you would be so kind as to help me out. Could you email me a manual for each of these two machines, or tell me exactly where to find them online? I’ve been looking, but


Follow the link below and enter the model numbers to access the User's Guides.\015\012http://www.bissell.com/customer-support/ ... Bissell 8910 ProHeat Clear View Upright Vacuum

I am having problems with the roller on my Oreck DTX-1300. It turns on and off intermittantly while I'm vacuuming. I have completly taken it apart and cleaned and inspected the roller unit.(I am very much mechanically inclined) This has stumped me, I have checked the electrical from the vacuum to the floor unit, and everything else that I could think of. Question: what does the metal sensore plate on the bottom of the roller unit do?? Anything anybody can tell me, I would greatly appreciate. Cap


... Oreck DutchTech DTX1300A Bagged Canister Vacuum

I have a Broan Nutone central vacuum. The power head seems to stall unless you lift up on the handle. I think I may need to change the belt but cannot find a place to purchase one to see if this is the problem Model number BN180 type 1


You are correct, you need a new belt. You can find belts for the Broan BN180 at www.vacbelts.com. ... Vacuums

We understand that your problem is: I currently own and use on a regular basis the Kenmore Progressive upright bagged vacuum. Model number 116.35923500. The headlight flickers and the intelliclean light stays red. Ive tried cleaning the intelliclean sensors, changed the bag, and cleaned off the agitator. Is this a power issue? Should I take it to the store? Any suggestions would be greatly appreciated


Welcome to fixya\012\012Hello\012\012 \012\012I have a solution for this ... Kenmore Progressive 35922 Bagged Upright Vacuum

I have an Electrolux Oxygen 3 vacuum I purchased rebuilt. After 1 month the power stopped working. I took it into Electrolux Authorized repair dealer, which was a horrible experience. When we received it back it was clearly not as powerful as before. Does anyone have any suggestions on what the problem may be? I would rather fix it myself than take it back to them. The next repair center is too far away. I am pretty good with fixing things, just needs some guidance. I think the repair center rep


Never have liked Electrolux doing any repair because it has been my experience that they don't do what they say they did....if you can read between the lines.....give me a picture of the unit and more details and I'll try and help you. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Our Miele vacuum is only 2/3 years old and seems to have given up the gost, our previous one lasted 15 yrs. The machine starts ok and within 4/5 minutes the power drops down and the hoover comes to a stop and it may re-power itself again within minutes, as of today their is no power when the on button is pressed. What do you think the problem is Thank you.


There is a circut board that is going bad and not providing the power to run the motor. You will need to contact a Miele dealer for that part. It is the only board that is in this machine so they should just need a model number in order to get it ... Oreck XL Ultra Bagged Upright Vacuum

I was trying to repair my wife's kitchenaid mixer and took part of it apart, including the back part, where the electrical connections are. The original problem was the plastic gear was damaged -- I finally had the good sense to find the solution for that problem on the internet and replaced the damaged part. But now the mixer just won't turn on. I don't think I damaged anything in the electrical section, but I suspect I either blew a fuse or somehow disconnected something.


Do you have a model number? Is the voltage getting to the motor from the switch? ... Vacuums

Hi, I have a Kenmore vacuum cleaner model number 20712008. There seems to be a problem with power getting to the suction base. There may be an electrical problem with the connector between the metal tube and the base.


... Kenmore Vacuums

We have a GE Advantium 120 microwave. all sounds like the unit is working all controls work. it does not heat at all. I have the shelds off and do not see any problems. what do you think is the problem and how do I test for it? thank you for your help.


If the unit works but it doesn't heat then the magnetron isn't working. The only way t test it is to measure the 2 voltages that power it: the heating coil - 5 volts AC and the high tension - 5000 volts DC. While you can measure the heating voltage ... GE Vacuums

Lately, my Kirby Ultimate G has been acting funny. When I push it forward, it's fine, but when I pull it backward on the carpet, the light on the front flickers and the power flutters off an on. I thought it might be the rollers, so tonight I turned the machine over and pulled out the hair that was wrapped around the roller. However, that did not fix the problem. I should probably backtrack a little bit. In the past, I have had problems with the vacuum running over its own power cord.


The cord will need to be replaced with a cord made for the machine, as it has a non-standard plug. The cord cover is held in place with a # 20 Torx screw. Remove the screw and push the cover gently from behind to unlatch it. The handle must also be r ... Kirby Ultimate G Bagged Upright Vacuum

Currently my dyson does not work when in the upright position. When I pull the handle back, it will run, but the suction is not very good at all. I tried washing the filter, but that didn't work. Sometimes it works for awhile, but then the problem occurs after the machine has been used for awhile. What do you think the problem is?


Hi its Darran at Dyson.It sounds as though the brush bar may not be turning properly when you put the machine into the upright position. To test, lie the machine on its side in the vacuuming position (head released) then switch it on and ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I recently purchased a bissell proheat 2x and have used it several times with great results, the problem I am now having is no water being released from the bottom of the machine and the gauge is not spinning. What could be the problem. I have taken the machine apart thinking maybe something is clogging it.


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Kenmore YM-40-35 R Sewing Machine Manual (or copy) wanted. If a manual is not available, I'd be OK with instructions for threading the needle and bobbin and any additional details that an expert may have. I think the machine may be a Canadian model number, it looks old, made of metal with screwed in presser foot. Thanks v. much. Elizabeth, [email protected]


Hello,please kindly visit the site below to see the comprehensive instruction with video on how to thread and bobbin your sewing machine.http://www.wonderhowto.com/how-to-thread-mechanical-singer-sewing-machine-224245/wish you ... Vacuums

Hi folks, my beam vacuum makes a very loud roaring noise quite often. the problem started when i was vacuuming up a quantity of vermiculite from my chimney. i think i overloaded the vacuum i think and it made this loud roaring noise. the vacuum tends to make thos noise when i am hoovering after 5 minutes or so. any ideas?. thanks in advance Tom....


If the filter bag is bad and didn't trap all of the dust, then it got into your motor, so you may have a problem with your motor now. ... Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Stuck Roller Same problem here. I think in our case, the accumulation of hair and the increasing resistance the hair created over time caused the hair to start melting, and eventually the end cap was stuck to the roller, which prevented the roller from turning. I cleaned out the melted hair(?) as best I could, but I think I need to order a new roller and end caps.


Befrore you plunk your $ down ...\015\012\015\012I dont now that you melted the hair so much as you may have an accululation of gunk and hair. If there is a good (not 'fast food' type) auto parts store near you, go there and ask the cou ... Electrolux 1910 Bagless Upright Vacuum

Kenmore 23613 The vacuum when turned on has a burnt smell. My husband has taken the vacuum apart, still can't seem to get to the belt. The belt in the rug part is not the problem, it is something in the canister part. Can you tell me what you think might be our problem? Thanks!


If it smells like burnt plastic it is something wrong with the motor part, but if it is a wet dog,burnt hair gross kinda smell it cool change the bag and buy deoderizer tablet to put under bag kinda like a airfreshener. if it dont work like it used ... Kenmore 22085 Bagged Canister Vacuum

Hi I’ve got a Panasonic vacuum cleaner MC E468 1600W a few years old now but works well up to recent problem. Not picking up I checked the obvious things and found excessive air being sucked in around the hose housing at the back of the vacuum (as it enters the waste bag) On inspection it appears to me as if there should be some sort of gasket that may have perished and been sucked in, however I can’t identify any such part. Any thoughts on what the problem/solution may be will be appreciate


The hose on the back might be loose - check to see that the hose is not obstructing anything where it screws in at the back - or indeed the screws may be loose themselves; some of the MCE 468 models had an additional ring washer that sits between the ... Panasonic Vacuums

Leaking problem I have a leak in my water tank. It only leaks when it is upright. And sometimes it doesn't let the water out when I go to clean. What do you think could be the problem


I had the same problem and it was a crack in the plastic near the small rubber valves that let the water out. After having two tanks crack like this I complained to Hoover about the poor design and they sent me a new tank with a new design fee of cha ... Hoover F7425-900 SteamVac V2 Widepath Upright Vacuum

My Eureka Maxima 4704 pink vacuum is really squalling .. its so loud you need ear plugs .. we just got the thing Christmas .. and has been used under normal conditions..we keep the filter clean and even recently washed it and let it dry for 12 hrs to see if that was the problem but it wasn't what else could be the problem ... I do not think that the belt is slipping because I can't smell rubber burning ...IM STUMPED


... Vacuums

Hi all---I have a Dirt Devil 091020V. there was a problem with the wand where it was the only thing sucking even when it was stuck in the tube it would ****--but nothing from the vacuum end--the diverter was stuck closed I took it apart and found something stuck but in the meantime the torsion spring [I think} fell out and I don't know where it goes--so now only the vacuum works --not the overhead cleaner part.. is there a digram somewhere that can tell me where it goes--I think it might b


... Vacuums

Windtunnel Hello: I was reading thru another readers problem of power to vacuum but won't turn on. Same problem for me. All hoses are free of clogs and I have the vacuum basically taken apart as far as I can. You state a THERMO by the motor may be open. What does this part look like? Thank you. Craig


The thermo is a small square piece with two wires coming out of it. Did you check the switch? The switch has a high failure rate. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Hi i hae a star product whipper sniper and i cant get it to go i hae spark i hae fuel but it seems as if there is no fuel getting to cylinder i think it is a problem with my carby the serial no is fcb12071 please help rectify my problem cheers


One thing that you can try is to remove the carb from the unit and spray it down with carb cleaner -- maybe it is blocked (?),,, one more thing to try would be to see if it will fire using ether. there could also be something wrong with the fuel dia ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0650 seconds