Having problems with your Vacuums ?

My mobile is samsung gt 5233s. Marathi font in my mobile is not looking smoothly. it look like type writer characters . How to solve this problem?

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My mobile is samsung gt 5233s. Marathi font in my mobile is not looking smoothly. it look like type writer characters . How to solve this problem?

... Vacuums

My Bernina 807 set on min. speed takes off fast, doesn't go slow at all, although there is a difference in the slow speed setting and high speed setting if I switch from one to the other while stitching. The machine is well oiled and goes well apart from this. I would like min. speed to start smoothly and slowly. I have read it could be capacitor in foot, but DH says it does not look burnt out. Would it help my problem to remove it? thank you, Barbara

... Vacuums

I recently lost power to the power head. Thinking the hose was not sending current to the head, I bought a new hose. It did not solve my problem. I have since noticed that a warning symbel is appearing that indicates what looks like a key with TA inside. The vacumn has good suction. Please advise John.

Hi\015\012\015\012Please check the link bellow to diagnose your problem…..\015\012\015\012http://home.howstuffw ... Electrolux Epic 6500 Vacuum

Aquamate basin pump does not work. Used it 3 times, stored it for a year and pump does not work. Looks like a reliability issue. Is this product defective for everybody? I saw an ebay listing for the basin that states "the pump works." Looks like I am not the only one with this problem if he has to mention that the pump worksl How do I get a basin with a working pump? gap920

Hmmm............ looks like the impeller is already stuck from a year w/o using it!\012\012\012I suggest if u could open it and spray some penetrating oil on the bushing of the pump motror and the impeller, force the motor to turn m ... Rainbow E series Canister Wet/Dry Vacuum

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.

... Miele S251 Flamenco II Bagged Canister Vacuum

Have Electrolux 1590 whole house vac, and can't see how to get brushes out. Leads so short, and don't want to break them trying to free brushes. Do they slide out of plastic housing? My eyes not real good, but it looks like the leads are part of a brass sleeve that slides into the plastic housing. It also looks like the plastic housing may be a snap lock type, but I don't see how to open it.

... Electrolux Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?

... Kenmore 34722 Grab-N-Go Upright Vacuum

Windtunnel Hello: I was reading thru another readers problem of power to vacuum but won't turn on. Same problem for me. All hoses are free of clogs and I have the vacuum basically taken apart as far as I can. You state a THERMO by the motor may be open. What does this part look like? Thank you. Craig

The thermo is a small square piece with two wires coming out of it. Did you check the switch? The switch has a high failure rate. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

How to take apart the Hoover U6437-900 to change the belt and clean it. I have the belts and I have removed several screws. It looks like the knobs for the wheel carpet height and carpet to floor selection are the problems but I can not figure out how to remove the knobs. Besides, I am not certain if this is the problem. Do you have the instructions? Thanks

HERE IS THE MANUAL > http://hoover.com/file/500/ ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My Kenmore 7520 canister vacuum has a problem with the retractable cord. It has jammed and does not come out or retract. It jammed half way through the retracting action. Cannot pull it out or retract. Would like to know how to open the canister to take a look for the problem. Thank you

... Vacuums

Belt type Ok, thank you for the help! I did have the top off, but did not know the taking the motor loose trick, thank you for that! Now I have a couple of more questions, and thank you so much for all of the help! I got a belt from sears, & the sales guy sold me an off brand belt. It looks just like the belt that broke, although do you have to force the motor back down into place? I think it may be the wrong belt? I have looked on the Hoover website & they do not even have parts listed fo

The belt number is 91001028. The belt will be snug but not real tight, so the belt you got may not be the right one. Most repair shops for vacuums should have this belt in stock. ... Hoover U8145-900 Savvy Bagless Upright Cyclonic Vacuum

Dear sir, i needs a solution for chinese nokia 6300 mobile's white screen problems so help me how i can solve this problems please.......... fast help me sir. thank you

Remove the memory card and battery replace batterry after 30 minutes to hard reset. If the phone boots up then check card for errors, virus, delete, format as required and reset.\012If this wont solve , you will need help fromNokia care to rein ... Vacuums

Our housekeeper has twice pulled the cord out past the yellow marker and we've had it repaired both times at a cost of $75 ea. The housekeeper is now gone but I would like to try and fix the problem myself but cannot find disasembly instructions. Looking for some assistance as I really don't feel like spending another $75 if I can take care of it. Thoughts ?

Try this. Set vacuum on it's back end. Gently pull out cord and release. It may take a few tries, but should work\015\012Repair/service manuals are only available to authorized service tech at authorized Aerus Electrolux stores. These are i ... Electrolux Lux 5500 Canister Vacuum

A cap on one end of the roller brush is centered and turns freely. The one on the other end is not centered and does not turn but does not look broken. It looks like it's supposed to be that way but it doesn't allow the roller brush to turn. How to I solve this?

It's hard to say definitively what the problem is here. Rollers usually have bearings at each end and they can wear or freeze up especially if they are exposed to water. When you say that the cap is not centered, I assume that you mean that you hav ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti

You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

Cleaning problem When i clean after is dry looks ashy, what i need to do to solve this problem

Hi,This type of problem usually is not he fault of the Shark Steam Mop.The problem is the old residue left on the floors by other cleaners.Here is a tip that I wrote that will help you out with that problem... ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

I purchased a used Minuteman 2400 series buffer/burnisher over the weekend from a store that is closing. The unit is about 7-8 years old. I did not get a manual with this item, can you help me out with this. I would like to read up on it so if I have problems I can look back on it. Even as far as the operation of it would help to have a book for it. Linda

I have this manual available via email. chris321 at gmail. ... Vacuums

My euro steam mop is not getting steam to the head, it gets hot but no steam comes out. looks like an ongoing problem with these mops/ can you help?

Hi,Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head...Euro-Pro Shark Steam Mop Problem ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

I have an old Progressive vacuum cleaner that says "Hepa Filter" and "Whisper Belt". Not sure what the model # is. The problem is that the vacuum part itself (the part that touches the floor and rolls over) has ejected its filter that we can see through the little window- it just came out under the rollers under the device... we cannot see how to re-insert this piece of filter which looks like a kind of round, flat grey foam/fabric and clearly goes inside- (top of the part that touches the flo

Check this procedure:\015\012\015\012Unplug the appliance that you will be \015\012changing the filter in.\015\012\011\011\011\011\011\011\011\015\012\015\012\011\011\011\011\011\011\011\011\015\ ... Kenmore 23313 Whispertone Bagged Canister Vacuum

Hello, I have a Kenmore Progressive Canister Vacuum 116.20912006. It won't turn on. On the hose assembly, the end where the hose swivel is, there are 4 metal pins that plug into the canister. One of the pins looks like it broke off. There are only three pins remaining. I assume there should be four pins as there are four holes. Is this the problem and is it fixable? The vacuum is from 2002 so I am not sure a replacement part is even available and at what price. Thank you. Susan susan.eng@

Hi Susan, if the pin has broken off you can do one of two things, first, would be to find a local vacuum repair shop and take it there for them to look at. they may be able to look at the hose and fix it for you pretty cheaply. what ... Kenmore Progressive 20912 Bagged Canister Vacuum

My bissellpowersteamer clearview #3105403 strays no solution when on. the hand attachment does, I have also lost my directions and problem solving booklet to which I would like to recieve another one,

When it doesn't spray solution then that usually means that the pump belt is broken or stretched. You can get replacement belts and also view the manual here: ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Miele vacuum Sometimes when I hit the auto roll up cord button or even move the cord, the power vacuum goes off. I move the cord again and it comes back on. I took it apart and looked at the connection from the cord to the auto roller. These are the electrical slip on type connections and are still in good shape. There are no bends in the cord. I air dusted everthing inside, put it together (with no extra parts!). Good news..it powered up so I did not break it, but it still has the same problem.

... Vacuums

No suction i have been using mine for like a year or so. today i went to use it and then no suction. the water comes out but it wont **** it up. I haven't had any problems till now. I cleaned the little red filter but still nothing. I dont wanna take it apart with out knowing what im looking for.

I had exactly the same problem with my five-year old my Bissell 7920, and it's probably a broken pump belt.  See page 19 of your instruction manual for how to replace.  The Bissel ProHeat belt accessory pack costs $3.99 and you get a pump b ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

I have Optima, 12amp Eureka vacuum, Model 431, AXZ type and the extension hose for cleaning corners and edges --the plastic part that the attachments fit into has a piece broken off and tools don;t fit anymore. It looks like the hose attachment can be replaced--can it be and if so--where can I get a new hose attachment. It seems it is cheaply made of plastic and really shouldn't have broken a piece off.

... Eureka 431A Optima Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2523 seconds