Having problems with your Vacuums ?

My vacuum makes a wierd sucking and blocking sound when turned on and when you put the extension tube on the suction decreases...but when just the wand handloe is on the suction is excellent...we replaced the barrel thinking it was broken but that hasnt fixed the problem


Answers :

You did not list the make and model of your unit, so it is difficult to hunt for problems.\015\012
\015\012Check to see if any of the tube vents might be open. They should be closed when in use.\015\012Also check to see there are no holes in the hose and that all attachments are free of obstructions.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My vacuum makes a wierd sucking and blocking sound when turned on and when you put the extension tube on the suction decreases...but when just the wand handloe is on the suction is excellent...we replaced the barrel thinking it was broken but that hasnt fixed the problem


You did not list the make and model of your unit, so it is difficult to hunt for problems.\015\012\015\012Check to see if any of the tube vents might be open. They should be closed when in use.\015\012Also check to see there are no holes in th ... Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

No suction I have a similar problem - volta vortex bagless vacuum will not ****. Worked for 1 job then quit sucking, I have had the heads replaced, then the barrel - 2 months later same problem. I push the power lever to max - 10 seconds later it turns itself down and doesn't work properly. I am over it, now looking for refund


Hi there SmartAlec from NelsonVacuums.com.au here. The problem is going to be the filter. THis kind of vacuum basically replaces the bag with a simple filter and the vacuum ... Vacuums

Dog hair gets caught all the time in the belt drive spool, is there a fix for this other than having to pull it out all the time by hand? I have replaced the belt and the brush but this hasnt solved the problem and the belt moves so slowly and I get the loud whining/grinding noise too.


It could be either the clutch, the beater bar or the brush housing. I have included links to each parthttp://platinumvacuum.com/dyson-dc07-dc14-clutch-assembly-900252-04.htmlhttp://platinumvacuum.com/dyson-dc07-dc14-brushbar-assembly-9041 ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.


First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

Low suction Replacing filters....need help replacing the belt - anyone know how? But before doing these things, have had a problem with suction....I'll let you know if the problem clears up.


Hi, You can take care of both things at once. Here's how:\015\012Unplug and flip your vacuum over, beater bar side up. Remove the cover base plate that surrounds your beater bar. It's held on with either clips or screws, and usually "hinges ... Eureka 2961AVZ Bagless Upright Vacuum

The problem is that the cleaner is heavy to use and does not pull itself forward as it should. It has been back to the supplier 3 times but they have not fixed the problem. The LED's on the front flicker and I think it may be a problem with the sensor. If you have any info. on how the sensor works and where it is located it would be useful as well as any other suggestions to fix the problem please.


If it heavy then do some muscle work and body building ... Vacuums

Suction problem my proheat wont suction water out of carpet,,, it made a mess of my carpets now, any one no how to fix the suction problem?


The valve on the bottom of the water bucket is not being pushed up enough to allow the vaccuum to go through. Perhaps a part is missing but I used a small ball bearing and a car vaccuum cap to build it up and now our works but it is still a piece of ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

My Bissell ProHeat 2x is pouring water out of the bottom anytime it's turned on. I had it in the shop for no water, took it back again for the same problem, took it back again because it had no suction, finally took it apart and found the problem with the suction and fixed it myself. Worked fine for a day and now it is constantly leaking water, if it's turned on, and is useless for anything except for making a mess.


Took the unit apart and discovered my heater had small pinholes in the metal and they had put in silicone, instead of a gasket, which didn't seal. So much for the place I took it to "saving" my heater for me. I repaired it myself by getting a few o ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have a Filter Queen Majestic canister vacuum cleaner. At the end of the wand, a button to release the attachement not only broke, but also one eyehole on the wand where one nipple on the button falls into. So therefore a new button isn't going to fix the wand because there isn't a hole on one side of the area where the button falls in place for a nipple to secure the button in place. IS THERE A REPLACEMENT PART FOR A NEW SECTION OF THE WAND WHERE THE RELEASE BUTTON IS SECURED IN PLACE THAT I C


... Filter Queen Majestic Canister Vacuum

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated


1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

When connecting the wand into the brush component. sporatic power (sometimes runs sometime nothing) the power is on again off again. when hold pressure down on the wand the power stays on. do you think the coupling connection is bad on the wand? would the wand replacement likely be the culprit?


There is is switch or sensor in the connection. Likely that piece is worn or shorted out. You may be better off getting a new wand piece ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

Hoover Wind Tunnel U6458-900 Self Propel doesn't work - via other expert advice here for other models of Hoover - I'm thinking it is the actuator that needs to be replaced as I can see the cable does not connect to anything on the bottom. My problem is - I can't get the cover off. Been trying for a couple of hours. I removed every screw I can seem to find but something is hold it down. I also am wondering if/when I do eventually get the cover off, would I need to replace the cable when I replac


On some models there are hook/springs that hold the cover of the base snug. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Power nozzle of my S3670 does not work (vacuum itself does work), the headlight bulb in the nozzle is broken. This happened in the past several times - we would bring the vacuum to service center - I don't know what they did other than replacing the bulb. I decided to go to ACE and buy replacement bulb myself, replaced the one in the nozzle - this did not fix the problem. I don't see any fuzes or anything in the nozzle. However, the manuals says to "Use only HOOVER part no. 27317307, which is a


... Hoover S3670 Bagged Canister Vacuum

No suction vacuum working fine and suddenly, no suction at all....what could be the problem? no suction through the machine from either the wand or the floor/brush side


Sucked up a sock?? No seriously.. it may be as simple as that or that an on board filter is clogged. Check your manual for all filters and Hepa/screens and others. Also, is the unit making any odd noises since the non -suction scenario? Whining or s ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

I bought a used Miele vacuum with the SET210 wand, but the push button to release and clamp the telescoping wand was missing. I can get the wand to slide by pushing with my finger, but it's a little difficult. The main problem is that nothing holds it in place at the desired position. I bought a replacement push button online, but it came with no instructions. How do I install it?


Your best bet would be to put on your friendly face, and take the unit into a Vacuum Repair Shop, and have them assist you, or at least give you tips on the procedure. Chances are you will have to disassemble the unit a lot more than you might want ... Vacuums

HI, I have a Kenmore 25813 and it seems like there is an intermittent short. When I have the extension wand on and the power floor attachment on, when it rotate the wand the light cuts out and so does the power floor attachment, when I twist it back it comes on again. I don't have this problem if I remove the wand and just use the crevice tool with the hose. Any idea where the short might be and can I fix it myself? Thanks. Gary


This is common you may have a short in the contacts from the handle to the wand or a break in the cord that goes into the powerhead ... Kenmore 25812 / 25813 Progressive Bagged Canister Vacuum

Suction only coming through the wand when its replaced its not switching back to the upright. I have a dyson DC28 animal


Hi there, it's Jack at Dyson.I'm sorry to hear your DC28 doesn't seem to be working correctly. It sounds as though the change-over valve may be jammed - this diverts the suction to the hose when you remove the wand, and back to the cleaner he ... Dyson DC28 Animal Bagless Upright Vacuum

My dyson slim vacuum doesn't have suction on the bottom. The wand has suction, how can I fix this?


... Dyson Slim DC18 All Floors HEPA Bagless Upright Vacuum - Iron/Titanium/Yellow

NO SUCTION My Electrolux Z2274 upright vacuum cleaner has lost it's suction and is very noisy. Have checked and rechecked there is no blockage. Have cleaned the filters. In fact done everything I can think of. Any one know why and how to fix this??


If you have no suction, there are only a couple of things that could cause it. As you have checked for blockage, and changed your filters, you may have a vacuum motor with bad bearings, or broken fan blades (inside/on the vacuum motor). Either sympto ... Electrolux Central Vacuum

No suction hello, there was a rubber smell then no suction. i'm thinking it needs a new belt but don't know how to remove the cover to replace. is it a complicated procedure. is there a diagram available? don't have any info here. thanks, leslie


Flip the machine upside down and remove the four screws from the baseplate. Replacement should be fairly self-explanatory from there. If it's a self-propel model, note that the v-belt in the front WILL look loose normally, so it does not usually requ ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Currently my dyson does not work when in the upright position. When I pull the handle back, it will run, but the suction is not very good at all. I tried washing the filter, but that didn't work. Sometimes it works for awhile, but then the problem occurs after the machine has been used for awhile. What do you think the problem is?


Hi its Darran at Dyson.It sounds as though the brush bar may not be turning properly when you put the machine into the upright position. To test, lie the machine on its side in the vacuuming position (head released) then switch it on and ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

The power wand electrical connection on the power unit itself seems to be corroded. I think I need a new two wire plug to plug into the wand. the model is a Eureka 6984 A. I am able to disassemble the power unit if necessary and replace the wire and plug if one is available


Try hesco inc they have a on line store with all the vacs parts diagrams and fast shipping. ... Eureka Vacuums

Hi. I have Dyson dc08 hepq+. Thet problem is its not having suction .I checked inside the pipe and foot , ery thing is fine. And if i take the whole dirtbin out ...machine workes fine. when i put ery thing back ....as soon as i start it , after 2 second machine change its voice...and loos suction. I think its just happen because ...the saftey yellow valve inside the machine turns up because the dirt drum is blocked inside some where. Any suggstion ...what can i do with it. I m tahnkful in avance


Hi its Darran at Dyson.From your description of the problem, it sounds as though the bin inner is missing. To confirm this, if you remove the cyclone and bin from the machine, then separate the 2 pieces as if you were going to empty it, w ... Dyson DC08 Hepa Allergy Bagless Canister Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1053 seconds