Having problems with your Vacuums ?

We have a Russell hobbs power cyclonic pets 2000w vacum cleaner that seems to have lost quite a bit of suction, we have cleaned the filter and made sure there are no obstructions in the hose. We have only had the item for 2 months so would like some help with the problem. Regards Mrs D.Cook


Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

We have a Russell hobbs power cyclonic pets 2000w vacum cleaner that seems to have lost quite a bit of suction, we have cleaned the filter and made sure there are no obstructions in the hose. We have only had the item for 2 months so would like some help with the problem. Regards Mrs D.Cook


... Vacuums

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.


Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

My Dyson DC 14 is making the horrible "ratcheting"sound only when the brush is engaged on the carpet setting. I have cleaned the brush, so there are no obstructions, the canister is empty and properly on the unit. I checked to make sure all of the "traps" and hoses are clear of obstructions, the belt is on the brush securely and moves freely, the brush itself spins freely, but there is still the "ratcheting" noise. Any other suggestions?


Our DC33 was making the same ratcheting sound immediately upon placing the cleaner/brush head on the carpet. We carefully pulled the beater/brush bar out of the vacuum. Once removed, we pulled the black plastic end off of the center rod. We discovere ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My dyson DC17 will not turn on unless the handle is pulled back.(into the vacuuming position) The attachment hose will not work at all (0 suction thru it). I've checked the hose and made sure there is no obstruction. Any ideas?


Not sure if I can help, but I'll try. The DC17 has two motors: the vacuum motor and a separate motor for the brush bar. It is normal that the brush motor works only when the handle is pulled back in the vacuuming position - that's the way it's made. ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Dc07 problem I have a dc07 cyclonic vaccum and like this model,however, for some reason,it has been very dificult to push and pull for the past month or so. i have completely cleaned the brush assembly,cleared any obstructions in the hoses,and, cleaned the filter.I also checked the belt tension,wich i thought was fine but to no avail.Be advised that the brush assembly is spinning and suction is excellent. It just feels like the brush drags along the carpeting. this is a great vacuum cleaner and


The dyson uses two belts, one from the motor to a clutch and then from the clutch to the brush roller, the belts that they use are not much better then any other belt ( those you should change yearly ) but you cant just change the belts you have to c ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have Hoover Widepath Bagless 12 Amp Windtunnel vacuum. Yesterday I was vacuuming and smelled smoke and it shut itself off. Today I cleaned out the filters (they weren't bad) made sure nothing was obstructing the hoses or the spinning brush part. It turned on for 1 second, smells like smoke somewhere from the bottom and now won't turn back on so I don't know if anything is spinning or not. What can I do to fix this myself?


Hi There,\015\012\015\012When a vacuum cleaner smokes, it is usually only one of two possible problems.\015\012\015\012It could either be that your motor burned up, or that your belts burned. The belts on this particular mod ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

No suction I've only had my vacuum for a couple of months and it seem I have a similar problem but there is no clear blockage. It seems like I don't have adequate suction that reaches the accessory hoses nor the main one. I'm not sure where to start. I've taken the darn thing apart but I can't see any obvious malfunction. Any suggestions?


If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.


I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

Torn Hose The hose on my Dyson is torn right at the top where the the accessories connect. I was able to take the connection apart and shorten the hose, but I don't know what to use to reattach the hose to the black fitting. It looks like it was glued...not sure what kind. Any ideas?


Duct tape ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

My Bissell Proheat Turbo puts out too much water and cleaner and won't **** it back up like it should. Also when I use the attachments dirty water runs out the the hose when I am done. It's used a lot, I shampoo all the carpets about 2 times a month and I shampoo the funiture 1 time a month. I bought it about 3 months ago.


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell ProHeat Turbo Deep Cleaner Upright Steam Vacuum

Clogged Hose 8 Year old Electrolux Centralux Vacume Cleaner has a clogged hose. Seems something is lodged in the middle of the hose - about half way down. I have tried a "plumbers snake" with no luck, except to clean out some "lint Balls" bot not the obstruction that seems to be like a "nail or stick".


Hi, this sounds like you have something stuck quite firmly in the hose!! If you use a good sturdy stick then you should be able to move the object without any damage to the hose. Check along the outside of the hose first just incase something has pus ... Electrolux Centralux Vacuum

Hi, my Dyson slim does not have any suction in the wand/hose. The vacuum itself works, just not the hose. I have unattached the hose, by unclipping it at the base, to make sure there are no rips or


Your changeover valve arm is more then likely broken or cracked. If so you will have to change out your under carriage assy. it's a pretty big job. I would recommend having an authorized Dyson service center change this for you as pretty much the who ... Dyson Slim DC18 All Floors HEPA Bagless Upright Vacuum - Iron/Titanium/Yellow

No suction I have new belts. Everything is clean. No clogs. When I turn it on it smells like rubber , the brush doesnt spin. Everything seems to be free flowing.. Roller brush isnt stuck on the ends. Took off hose to make sure no clogs anywhere. There is not even suction thru the hose with the handle in upright position.


Generally, the problem is that the belt is not running the brushes.  This is caused by one of the following:\015\012\015\012\015\012beater brush is jammed.  This is either an object stuck in the brush or im ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Suction hose I can't get the suction hose to work...and I have cleaned it out to make sure it isn't plugged. There is a small amount of suction just not enought to pick anything up.....the floor part works great...what could be the problem


I would first double check the hose, remove it and drop a marble through it to be sure. make sure the bag is new and also check the filter underneath the bag if it is clogged it could cut the suction. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I ordered an item from L.Cameron on 23rd Sept. Order acknowledged. paypal also acknowledged payment made . Item ordered has not been received, no cash has been taken from my paypal account. Perhaps I have misundertood the procedure. Can you advise? Email number; [email protected] I am not sure what I have to do. Thankyou


... Vacuums

Hello, I have a Kenmore Progressive Canister Vacuum 116.20912006. It won't turn on. On the hose assembly, the end where the hose swivel is, there are 4 metal pins that plug into the canister. One of the pins looks like it broke off. There are only three pins remaining. I assume there should be four pins as there are four holes. Is this the problem and is it fixable? The vacuum is from 2002 so I am not sure a replacement part is even available and at what price. Thank you. Susan susan.eng@


Hi Susan, if the pin has broken off you can do one of two things, first, would be to find a local vacuum repair shop and take it there for them to look at. they may be able to look at the hose and fix it for you pretty cheaply. what ... Kenmore Progressive 20912 Bagged Canister Vacuum

Our Dyson sucked something up last week (not sure WHAT) and now the telescoping hose won't ****. Well, it sucks but just BARELY . I took the hose apart and can't see anything, but it makes a weird noise now when you stand the unit up and are not actually vacuuming with it. Help!


Well if the hose is completly clear the blockage is either before that or after that the brush roller should come out to clean the tube as you know also comes out make sure all are clear right up to the collector ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

The hose on my vaccuum is not picking up. I am pretty sure something is blocking the hose up but not all the way. Is there a way that it detaches from the vaccum and if there is what next?


The hose should be attacthed by two screws or two clips, depending on the model BISSELL vacuum you have. \012Remove the hose and push a broom handle through the hose to clear the clog. ... Bissell Vacuums

Rainbow shampooer The soap dispenser on my Rainbow is not dispensing soap when I flip the switch to 'soap' mode. All connections are intact. All plastic hoses are intact. What do you think is going on? The soap bottle connects to a little straw that appears to be free of obstruction, however, it connects into a sealed casing on the hose.


The little "wash/rinse" switch on some of the Aquamate units shuts off the soap flow by kinking the tube inside the housing. If you leave the switch in the rinse position (therefore, kinked) when you're done using it, it may dry in the kinked positi ... Rainbow E series Canister Wet/Dry Vacuum

DIRT DEVIL VACUUM 4 MONTH OLD AND HOSE SPLIT TOOK BACK TO ARGOS TRIED TO INFER IT WAS MY FAULT ENYONE HAD THIS PROBLEM ? THE STRETCH HOSE SPLIT AND I HAVE NOT HAD THIS HAPPEN WITH ENY OTHER CLEANER THE SALES GIRL IN ARGOS SAYS THIS WAS MY FAULT . DIRT DEVIL VACUUM DDCYLBG5 BAGGED CYLINDER G TABERN.


From the Argos website... they must repair or replace or refund, up to 1 year. The squeaky wheel gets the grease, go over her head.\015\012 \015\012If there's a fault with the product...\015\012We've made it easier!\015\012 ... Vacuums

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged


Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch ... Electrolux Epic 6500 Vacuum

Hi I have an Electrolux Envirosteamer and it has stopped steaming. I have made sure the water cap is on tight and also taken the head apart (where the hose finishes up and the attachments fit on) and the hose is intact there. I have no steam and wonder if I have a valve problem? if so can anyone tell me if it's worth trying to order the part and fix myself. I'm fairly handy! Thanks Sue


If the water is boiling and element is ok then it could be the outlet valve it is poss to diy but is a 2 person job as very fiddley ... Eureka Deluxe Enviro Steamer Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom


Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0398 seconds