Having problems with your Vacuums ?

I have a Kenmore Model 116 26312603 sweeper. The vacuum motor does not run, the power head does run. What is the most likely solution?


Answers :

If the switch is a simple on/off switch,it could be that.Make sure it is unplugged.If you take the switch apart,twist the two wires together,and cover with electrical tape.If you do not have electric tape,make sure the connection is off of the ground,somewhat sticking up in the air at least a few inches and preferably not on a carpeted surface,or near any cloth.Then,plug it in and unplug it quick.If the motor starts,the switch is bad.If it does not,the motor is likely bad.There may be some spark when you plug it in,but you should not be electrocuted.That will normally happen if something is turned on before it is plugged in.I have done it many times.If you ever do have an electric-related fire.DO NOT USE WATER.You need carbon dioxide.Greg
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Kenmore Model 116 26312603 sweeper. The vacuum motor does not run, the power head does run. What is the most likely solution?


If the switch is a simple on/off switch,it could be that.Make sure it is unplugged.If you take the switch apart,twist the two wires together,and cover with electrical tape.If you do not have electric tape,make sure the connection is off of the ground ... Vacuums

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

Power Head keeps cutting in and out while vacuuming???Canister motor keeps running but the power head starts and stops like there is a short or some loss of connection somewhere. Any ideas?


My kenmore progressive vacuum had the same problem. The electrical terminal at the bottom of the wand was corroded. I used a flat head screw driver to scrape the female portion of the connector as best as I could. I then took off the plastic cover on ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Power head motor is good,runs great from test cord switch seems to work. brush roll cleaned but power head motor will not run


If you have checked the power delivery down to the powerhead and you have current running to the powerhead, then you likely have a burned fuse. There is a fuse built into the powerhead motor and is usually located on the field winding. This is not ea ... Eureka 6831A Bagged Canister Vacuum

Kenmore progressive canister vacuum model 116 52612205, I have power and suction but the powerhead motor doesn't come on to run the brushesdo you have a solution


... Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see


... Oreck XL Ultra Bagged Upright Vacuum

Motor/Fan does not run. I have removed and taken the top of the canister plastic motor housing apart and tested for power. I have power through the cord to the switch and power from the switch to the two wire terminals. I have not removed the motor. Looks like I will need special tools to take out the motor. The Vac looks almost new. It has been setting for several years. What do you think?


Sorry to read about your problem, I hope this helps you out.Well you can order a new motor at shop vac, check out this link.you dont have to remove to check the motor, just connect power to the motor leads ... Shop Vac QPMH450 Canister WetDry Vacuum

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?


... Vacuums

Power head has power but motor won't run


Circuit brealer switch may be bad, but the fact that Rainbow nozzle made this strange sound makes me think that it may have ha ... Rainbow E series Canister Wet/Dry Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have had my Fantom Lightning vacuum for about 12 years and the power head motor has burnt out. I would like to know how to purchase a new power head as I just love my Fantom. How much are they and can I still buy one?


There are no parts \015\012you can try and find used one\015\012if your in my area i have a used one in stock ... Fantom Vacums Lighting Canister Vacuum

My Miele Solution HEPA 5000 vacuum cleanr gives off a burning smell but will continue to run with a varying motor tone. I have not run it for more than a minute like this. I have reviewed responses to similar problems but cannot figure out how to access the motor. Can anyone advise?


... Miele S318 Bagged Canister Vacuum

Have an e-series rainbow. Belt and brush bar have been replaced in power head. But the red reset button can still be pushed and it is not staying going like it should. May it be the motor?


... Rainbow E series Canister Wet/Dry Vacuum

The beater bar motor doenst work when i push the bar button the bar button doesnt light up like power button how can i test bar motor or bar switch or what is the common problem wiyh this model I have 2 that dont work the same way


If it do not work ...and you already are on the second one that behaved in the same way it may be a problem with the power in your place and the cause it may be the main fuse...Im not sure where is located in this model but it has to be near the powe ... Vacuums

Carbon brushes on ME-48 power head motor worn out. Where can I get replacement brushes? Motor is O 90197X7, Lamb, Model 118173-73 - 240V 50/60Hz


Hi Les,Most sites sell only the motor.Here's a website that includes motor brushes: http://www.kleen-ritecorp.com/search.aspx?IsSubmit=true&searchTerm=lamb+motor&gclid=CIbZ59zwiKgCFQprKgod8W2itQHope you can find the righ ... Filter Queen Vacuums

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?


... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have a Series G Kirby Model G7D. The other day when I was vacuuming all of a sudden the TechDrive (Power Drive Assist N/D) pedal fell off. I see the hole that it goes into but when I put it in it's loose and falls out and doesn't control the power drive anymore. When I shook the vacuum I heard something rattling around inside the vacuum head. So I unscrewed the bottom and looked inside and found a small metal part labeled K3 on one side and T on the other side. It looks like it would fit


Hi, I have a Kirby G4 and i'v replaced the carbon brushes myself using a step by step guide however since its been back together it worked for about five minutes it then started sparking from the inside!!(a lot!!) I'v obviously touched something i sh ... Kirby Ultimate G Bagged Upright Vacuum

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony


... Kenmore Vacuums

I was using my Heritage 11 vacumn with the hose attachment and the motor shut down like the power went off .When you push the switch on the housing the light comes on but the motor does not run.


Hi, the motor could be overheating. Most vacuums have a heat sensor that shuts the vac. off if there is a clog. Let it sit, feel if it's hot. If so you may have a blockage of dirt etc. Try to clear it, let it cool and tart it up. I hope this helps, i ... Kirby Heritage II Vacuum

Rainbow vaccum power nozzle model number r-2800c is getting power but the motor does not run


Check circuit breaker inside of power nozzle shell. Bypass it temporarily to see if motor will run without circuit breaker wired in.If motor runs without it, it's a faulty circuit breaker (expensive to replace) ..... if motor still does n ... Vacuums

I had the vacuum cleaner question about the canister and the wand/powerhead... the Kenmore Progressive Vacuum canister model 116.25812 and the canister not powering off without unplugging the vacuum. The solution I received that they both run on their own switch so it is normal makes sense. However, is there a power switch on the canister anywhere? The only way for the canister to be turned off is by unplugging it. Any ideas? One would think there would be a switch. I am new to fixya and hope


Hi. On some models, one switch controls all of the power. Your issue, which is no working switch is almost certainly a blown triac on the circuit boar ... Vacuums

Model 533 sounds like motor is running but wheels don't spin


... iRobot 530 Roomba Vacuuming Robot, White Vacuum

Miele Blue moon vacuum motor surging on and off and power light flashing. After many surges of the motor (on->off->on-> off etc), the motor no longer attempting to start as ferquently ie. now off for many seconds and may turn on for 1 second.. sometimes stops turming on and just power light flashes. There is also no voltage at the plug for the hose for the power head. I noticed that the vacuum first started having probs when hair was caught in the power head and the ovetrheating light went on


... Miele Blue Moon Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1053 seconds