Having problems with your Vacuums ?

SubBrand name 'Exmork', 5 Kw Sine wave inverter Intermittently, breaks into a spurious mode which causes it to draw excessive current while the output waveform becomes seriously corrupted with severe transient spikes close to the crossover point. We have available oscilloscope images showing the problem graphically. We have four of these inverters out in the field, and they all exhibit the problem from time to time. The fault has precipitated failures in the Power-board module in two units


Answers :

Had similar problems with my inverters a while back tried to sort it out myself all to no avail. Eventually found out it was a problem from the manufacturers and all that were produced had the same fault. Had to change my brand to Su-Kam inverters. If all four of your units have the same problems then the problem is from the manufacturers if your warranty is still valid return them otherwise you are stuck with them. Sorry for any inconvenience.
Hope this solution has been helpful?
Hi.

I dont have schematics for this particular inverter.

The problem is in the oscillators section of the inverter, likely one of the oscillators. Since the problem goes out disconnecting power, the components located before the oscillators in the final stage of the inverter must also be tested. A faulty capacitor may also result in this problem.

As said, the problem is more likely one of the oscillator. The oscillator is defective and goes slowly out of phase. After a while this will result in a corrupted wave form. When you disconnect and re-apply power the problem re-occurs only after a while, when the oscillator starts going out of phase again.

As said a faulty component may also cause the problem.

Regards.

Ginko.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

SubBrand name 'Exmork', 5 Kw Sine wave inverter Intermittently, breaks into a spurious mode which causes it to draw excessive current while the output waveform becomes seriously corrupted with severe transient spikes close to the crossover point. We have available oscilloscope images showing the problem graphically. We have four of these inverters out in the field, and they all exhibit the problem from time to time. The fault has precipitated failures in the Power-board module in two units


Had similar problems with my inverters a while back tried to sort it out myself all to no avail. Eventually found out it was a problem from the manufacturers and all that were produced had the same fault. Had to change my brand to Su-Kam inverters. I ... Vacuums

Hello, I have a Kenmore Progressive Canister Vacuum 116.20912006. It won't turn on. On the hose assembly, the end where the hose swivel is, there are 4 metal pins that plug into the canister. One of the pins looks like it broke off. There are only three pins remaining. I assume there should be four pins as there are four holes. Is this the problem and is it fixable? The vacuum is from 2002 so I am not sure a replacement part is even available and at what price. Thank you. Susan susan.eng@


Hi Susan, if the pin has broken off you can do one of two things, first, would be to find a local vacuum repair shop and take it there for them to look at. they may be able to look at the hose and fix it for you pretty cheaply. what ... Kenmore Progressive 20912 Bagged Canister Vacuum

I have a miele S4210 vacuum. It has a SAB100 accu nova battery brush which will not work. After charging the battery, light comes on saying not charged and now the power head brush won't turn. I had problems with my first powerhead so I purchased another and it worked for a short time and now I have the same problem again. I have four batteries I use interchangeably but nothing seems to work. I spent a fortune on this vacuum and to tell you the truth I hate it! Contacted Miele after 1st year of


... Miele S300 Bagged Canister Vacuum

My Ken-Tech atomic clock shows the time exactly four hours earlier. It has four, not five buttons in the back. How can I reset it?


We dont have excalty the model, so its possible that this Atomic Clock with Day & Date Instrcutional Guide can helpful.Go ... Vacuums

Hello! I have a problem with my Tefal Sensio scales. They are now probably around four years' old and have been in perfect working order up to now. Well, I had some problems before - the moment I'd step on them, instead of going into "calculating mode" as they usually do, they would show the number 92 straight away and then the display would change into some strange symbols (please don't laugh here :-) - my weight in kg is 55, my husband's around 80 and each of us gets 92 reading). Previo


... Vacuums

Blue Moon S658 Miele vacuum problem where suction cuts off. The power light stays on. Sometimes I lose full suction, and other times I just lose partial suction. This shows on the handle by going from 1000 to 400, or nothing. Any thoughts on what this could be?


This is a problem with the circuit board in the SES-125 hose. If you replace the hose, this problem will stop. Unfortunately this is the only solution to this problem. \015\012\015\012-R ... Miele Blue Moon Bagged Canister Vacuum

My first proheat lasted four years so I bought a new one. After I used my Pro Heat for only the fourth time my first issue occured, the gear on the pump that runs the brushes came off, so I had the one from my old proheat, I just changed the gear spindle that is screwed to the pump and fixed that problem but now it will not pump water. That is why I bought a new proheat, I could not get the old one to pump even after a new pump and made sure all lines were not cloged.


Is your new machine a 2X or like the old style proheat? ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

My Riccar 1700 will intermittently lose power while vacuuming. I have had the vacuum for 4 years and this is the second time that I have had this problem. The first time the authorized repairperson said the problem was a dirty hepa filter. The second time, the repairperson put on a "pig-tail"(?) and said that he did not have a shut-down problem when he tested the vacuum in the store. I just picked it up from the store today, brought it home and the same problem occurred within minutes.


... Riccar RC1100 Compact Vacuum

Hi, I have a Xenon 600 VA sinewave inverter. My inverter starts working even when the main power is ON.So the battery gets dried up even when power is there.Can I know why this is happening? Is this due to main power line problem or a inverter problem.


... Vacuums

My Eureka central vacuum of almost 10 years, has a reoccurring problem, of a defective relay on the pc board. The problems is usuallly the motor will not turn off. The pc board has been replace 8 times, of which 3 times were with in the last 4 months.


Are you taking the machine in to someone? or is this a self diagnosis?? \012\012What I mean with those questions is, sometimes it isn't the PC board that is causing the problem. Sometimes it is something else. Even the people that you are ... Eureka CV1804B Bagless Central System Vacuum

I have an euro-pro steam cleaner model # sc505 that is about 2 years old. It has only been used a limited number of times, about 3 or 4 times. It now has a tightly sealed safety cap on it and it will not release allowing me to add water to the steamer to use it now. Any tips on fixing it? I'd love to have a products guide to items that are available for compatiability with our sharkie. We constantly see new items available and wonder will that product work with ours?? Thanks!


... Euro-Pro Shark SC-505 Handheld Steam Vacuum

O.k. this is the 3rd time I'm writing this...not even sure how many times I'm being charged.... Already aggravated and exhausted so Please, Please help me. I bought 2 Westek 1 outlet timers for our Bearded Dragons. They have to have 12 hours each of specific lighting (day and night). I get the "up" are off times and the "down" pins are on times. The problem is the Clock Isn't working.... Any ideas??? I'm about ready to throw them out the window except we're leaving early in the morning and


There is no money indication on this one. I'm speaking for free, so I hope you're asking for free.\015\012\015\012\015\012Oh yea, I already answered this question.\015\012You bought two bad timers!\015\012\015\012Sorry. ... Vacuums

Our Whirlpool microwave is 5 mo. old - it is W10182518A --- we tried to change the time because of daylight savings time going off and the clock will not hold the new time - PRESS comes up - and then different time show up - I have the manual and am doing just what it says.


... Vacuums

The problem is that the cleaner is heavy to use and does not pull itself forward as it should. It has been back to the supplier 3 times but they have not fixed the problem. The LED's on the front flicker and I think it may be a problem with the sensor. If you have any info. on how the sensor works and where it is located it would be useful as well as any other suggestions to fix the problem please.


If it heavy then do some muscle work and body building ... Vacuums

My Bissell Pro Heat Select 2X does not pull up the dirt from the carpet into the water. The water just slowly disappears. The first time I used it the water got really dirty. The very next time I used it it worked differently and the water just disappeared until it was all gone. I've only used it a couple times and I don't see where it is working. Has anyone else had this problem?


Inside the plastic suction lid is a little red plastic filter that has to be cleaned out every time you use it because it sounds like your vaccum is not picking up all the hair and debri before you clean the carpet causing the water to be injected in ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I posted my problem earlier today that I was having with my Bissell Little Green Machine not dispensing solution, but sucked up no problem. Someone said that the most common problem was a blockage. We put hot water in the reservoir for 15 minutes as advised and it still will not dispense. The fluid is now ''dribbling''so it is better. It is just not spraying. We are able to blow from the end and make bubbles in the reservoir which shows us it is not blocked. Any other suggestions?


Okay. I fixed this on mine. Undo the screws on the handle, right by the trigger. You pull the tubes off the little valve. Push on the button and see if you can blow through the valve. If not, push a pin around in the valve (with it pushed into the ... Bissell 1720-1 Little Green Wet/Dry Vacuum

I cannot find the directions for my Utilitech 1-outlet timer. It has two numbers on the back: #148297 and #TMO1DHBL. I thought that I could just put the time now arrow on the present time and pull up the sections when I wanted the timer on; the only problem is, it lights up whenever it is plugged into the outlet. I just need the directions for setting the timing. Thank you very much Lilla


... Vacuums

Hi we have a model 31075 which i did not find in the list im hoping it's similar to the 31079 The problem is that the agitator has stopped working and i can not open it to find the problem is there a manual available or a site i can go to. Can you suggest what i can do to open it to look around I am very handy with most things but this thing has got me frustrated at this point. thanks for your help. Regards Chuck


... Kenmore 31079 Upright Vacuum

I own a Hoover Steam Vac V2 deep cleaner with Auto Rinse feature. The Model Number is not available ex: was on the bottom of the machine and the sticker is completely worn off the machine. I am having a problem with the bottle you fill with detergent ex: this bottle is seperate from the main clean water tank. THE PROBLEM: The little plastic part that goes in the bottom of the bottle has an "O" ring ex: cone shaped with a spring.....it keeps falling out. Can you supply a part number for this


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=641300\015\012Generic problem for all Vacuums\015\012I own a Hoover Steam\015\012Posted by w_brennan on ... Vacuums

How can I get my DAB radio working again? I have a Sony XDRS100CD with DAB radio. The DAB radio has stopped working although I can still use the CD and get FM radio. The unit has a readout on the front that usually shows the time and this stopped working too, presumably because it got the time via the DAB radio. The unit works from mains and batteries although I have only ever used it on mains.


I have the same problem... did you ever get a fix..[email protected] ... Vacuums

I am charging Remington Shaver FS360 for the first time I have put in charge for almost 12 hrs (the instruction is to charge it for 24 hrs at the first time) but still the charge led is not glwoing. I am not sure wheather it is still charging or not. Could you please help me out to figure out the problem.


... Vacuums

Bought today a used rca rp3721a clock radio without the manual. need user manual to adjust all the settings, for example TIME, ALARM TIME, ALARM ON AND OFF, radio or "beeper" alarm on, entire unit on and off without unplugging it from shore power,and anything I haven't thought of up to here. The unit is RCA Model RP3721A clock radio, and appears to be functional. Our problem seems to be "the nut behind the wheel". e-mail: [email protected]


Hello,I advice you check the links below to search for the\015\012manual of your device, the link contain almost virtually all the manuals of all \015\012device.manualsonline.comORmanualnguide.com ... Vacuums

Arrgh! I have an upright Bissell vacuum. Everytime I use it, it smells like a cloud of dust. I have made sure countless times that all the filters are clean and the hoses are intact, so I don't know what the problem is. Is this problem normal? Or am I somehow blowing dust everywhere? Any insight it much appreciated, thanks!!


I believe you have a clogg in the suction pipe. ... Bissell 3590 CleanView Bagless Upright Vacuum

Lost Suction This is my second hoover steamvac and i am having the same problem with my new one as i did with the old one that i tossed out. I have used it about 12 times and it worked great the first 6 times... Now i'll empty a full tank of water and only half will get sucked back up. I have tried taking it apart and cleaning and also the rubber seal had some gaps so i sealed those thinking that it was leaking air from there...can anyone help? I am so close to chucking this one and buying somet


Usually when there is no suction, one cause is the lid to the recovery tank is not on all of the way in the back. Also if you have that foam filter on the underneath side of the recovery tank lid, it needs to have a 1/4 in or so gap from the top of ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

Dog hair gets caught all the time in the belt drive spool, is there a fix for this other than having to pull it out all the time by hand? I have replaced the belt and the brush but this hasnt solved the problem and the belt moves so slowly and I get the loud whining/grinding noise too.


It could be either the clutch, the beater bar or the brush housing. I have included links to each parthttp://platinumvacuum.com/dyson-dc07-dc14-clutch-assembly-900252-04.htmlhttp://platinumvacuum.com/dyson-dc07-dc14-brushbar-assembly-9041 ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0440 seconds