Having problems with your Vacuums ?

After a few minutes, vaccum emits a burnt rubber smell. Checked the V-belt and it seems fine.


Answers :

Hi there,
\015\012
\015\012It might seem fine but the burnt rubber smell means that the belt is slipping. This causes friction between the belt and the motor spindle causing the spindle to get extremely hot which melts the inner surface of the drive belt.
\015\012
\015\012Take the belt off and examine the inner side that loops over the brushbar and the motor spindle. You will find that there are sections where the belt has partially melted - they are usually smoother than the rest of the belt.
\015\012
\015\012Belts don't need to break before they need replacing. They just need to lose some tension. This is what seems to have happened in your case and you should replace your belt.
\015\012
\015\012Regards,
\015\012BElectric
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

After a few minutes, vaccum emits a burnt rubber smell. Checked the V-belt and it seems fine.


Hi there,\015\012\015\012It might seem fine but the burnt rubber smell means that the belt is slipping. This causes friction between the belt and the motor spindle causing the spindle to get extremely hot which melts the inner surface of ... Vacuums

I replaced the belts on my windtunnel vacuum u6439-900 cleaner..it works fine for a minute or so then it smells like burnt rubber and does not self propel. Does the v belt need to be taut or loose?


... Hoover Vacuums

After a few minutes of using my vacume it starts to smell like burnt rubber. like the belt is burningthe only belt I can see looks fine and is turning the brush


But how tight is the belt and how easy is the brush to turn? if the belt is slopy it will slip on the motor drive spindle,,,and it will get very hot then,,, also if the brush head is tight that makes the belt slip too, ... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

When using my hoover wind tunnel the last few times it has emitted a burnt rubber smell so my husband checked the belt and is wasn't broken or off but now when I use the vacuum the beater bar doesn't seem to be going around as well as it should be can you help


I take it the belt was put back on !! i would say hubbi forgot the tension arm a little black striker that can go in two ways but put in back wards it will not tension the arm ... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

Belt problem My belt broke. I put a new belt in, followed the instructions, seemed to be right but as I started using the vaccuum, it starting smelling like burnt rubber. The belt was extremely hot. Took it apart, tried again and the same thing happened. Please help me!!!!


Get the old lady to use a dustpan and brush instead SORTED ... Kirby Generation 3 Bagged Upright Vacuum

When I was using my Bissell ProHeat 7901, I smelled something hot (almost burnt) and turned off the vaccum. When I turned it back on, everything seemed to be working, but the vaccum part was not making the same sound. The bristles are still turning, but it isn't picking up as much and is leaving quite a bit of lint on the carpet. Could the belts be worn? How do I tell? Thanks!


Ya that is probably the issue. Here is a link to the belts you need and to the manual which has instructions:Bissell ProHeat Belts and M ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?


It may be the roller bearings? ... Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

My Kirby is brand new(Sentria). Everytime I turn it on to vacuum, it smells like burnt rubber. I've checked the belt twice, it's on fine. What am I doing wrong?


Please check out my step by step instructions.....http://reviews.ebay.com/CHANGING-THE-BELT ... Kirby G6 Bagged Upright Vacuum

Stopped working Was working fine then it smelled like burning rubber, not the belt I checked. It sounds like the motor wants to run then it just stopped but the light is on. What do you think, go by a new one?? This has been a great vacuum cleaner and I can not seem to find a Sharp anywere. Thanks for your time.


Well it could be the motor, if it is it would cost around $80 or so for a motor. May be better to buy new, thre are a number of good brands out there. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

I have a vax mach 6. There is very little suction when using the tools and it will switch itself after a few minutes. I have had it to bits and cleaned it. I can not find any blockages. The belts also seem fine.


Http://www.vax.co.uk/downloads/pdf/u90-m5_u90-m6_series_user_guide.pdf ... VAX Appliances Vacuums

Hoover Wind Tunnel 7500 Brush not Turning. I have replaced the Brush and the belt. The problem does not seem to be either to me. I believe might be a missing part. The place were the belt hooks on is a metal pole which never seems to grip the belt well. In fact it seems loose most of the time and slips on the brush, causing the belt to eventually burn up. Could there be a missing plastic or rubber piece meant to hold the belt taught  on the metal pole?


Check the Idler Pulley part Number 43241004 (Item 13 in the IPB)http://64.49.205.183/v/u6451900.pdf ... Vacuums

I checked the belt and it has not broken, but when I start to vaccum the spinning head stops, and I start to smell a rubber smell...Do you think I need to replace the belt, I did get some string caught in it the last time I vaccummed, and it did stink like rubber then also...


Yes you do need to replace the belt they stretch out. Think of a belt like a big rubber band if you were to stretch it out and hold a lighter to it the rubber band would stay stretched out. That is the same thing that happen ... Bissell Vacuums

Hello, I have a Hoover 3200 Turbo Power vaccum. while the motor appears to be working fine the vaccum no longer picks up the dirt. I turned the vaccum upside down and the belt appears to be broken. would a broken belt stop the pick up, there appears to be no suction. This vaccum is approximately 10 years old. is it worth fixing? I live in Virginia Beach Va, where would I take the vaccum for repair? my zip code is 23456- Thanks Cleta Goode


... Hoover Vacuums

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a


Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

My Hoover Wind Tunnel Bagless Pro Pet is making a very loud thudding noise when the belt rotates, belt seems to be intact and in place, what am I missing? Vacuum is less than 6 months old, belt is not worn and motor seems to be fine.


... Vacuums

My Bissell 9200 is not sucking the water into the dirty water resevoir. 1. The gasket on the clear-view seems fine. 2. The suction power just doesn't seem powerful enough (feeling with my hand). 3. The brushes turn fine and belt is fine (not sure if that even matters for this issue). Any help appreciated. Thanks, - Matt


Disassemble all lines and check to see if all O rings are installed. If cracked missing or stretched out of shape no suction will be provided ... Bissell 9200 Upright Vacuum

Bissell lift off, brush won't move smell burning rubber belt fine


OK - so your brush roller is jammed. And yes, the belt is melting! Unplug the machine, remove the belt (you will need another new one anyway) then see if you can turn the roller by hand. If it turns freely without you doing anything else, then you ma ... Bissell 6595 Lift Off Bagless Upright Vacuum

Hi, I have a Dyson DC04, (silver/lime) making ear popping screams! Does not happen all the time, and more noticeable when it is pulled back.The suctions not a problem and no funny smells or strange noises from the motor. Ive taken the base plate off and the belt and brush bar seem fine, but when I turn the belt, it seems to be the motor spindle thats squeaking, almost as if it need oiling, any help please


... Vacuums

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

Help!!!! i have an older model of the dirt devil bagless quick vac. and it has been working great, just last week i was vaccuming my bedroom and i accidentally sucked up a string belt that goes with one of my capris. and today i emtpied out the dirt cup but it seems the the string belt that was sucked up is not within my reach and whenever i start the vaccum i get this distinctive noise that i've never heard before. help.


It's likely wrapped around the brush\015\012pull out the roller and un tangle it ... Dirt Devil M084600 Dynamite Bagless Upright Vacuum

The original belt on my upright Kenmore Progressive broke and I replaced it with the spare that was in the vacuum. The vacuum and spare belt are about 10 years old. Then the spare broke after one vacuuming session and there was a burning smell coming from the vacuum. I ordered new belts and replaced it with the new belt. It seems to be working fine with no smell. I checked the belt after I vacuumed the family room and although it was in tact, the belt was very hot. Is that normal? Should t


The belt heats up due to the friction, as well as being in contact with the shaft of a hot motor. It is normal. ... Kenmore Progressive 35922 Bagged Upright Vacuum

I have two old identical 5842's that I use in the garage and around the house. The belt broke on one so I bought a bag of 2 genuine Eurika "U" belts, which is the correct belt for this vacuum. They were obviously smaller than the original belt because they were not stretched out. When I put the new belt on it lasted about 20 minutes and then came off. I put it back on and ran the vacuum with the cover off to see what was wrong. Everything looked fine except the belt rides to the outside edge of


Not 100% sure this is the remedy for that particular problem, but I would take the time to clean both of the brushes that the belts operate, one on each machine.\015\012Remove the brushes and clean as best you can. At the end of each brush there sho ... Eureka Whirlwind Litespeed 5840 Bagless Upright Cyclonic Vacuum

The belt burnt out and it seems as though the red arrown does not release the belt. Like it is backwards from the green arrow. It had a burning smell and the belt broke. Then the second belt started to burn out when the brush roller wasn't spinning. Not sure what might be wrong. Green light will not come on either.


It sounds as if there may be a piece of the broken belt in there. Look carefully with a flash light and remove any remnants you find, using a pair of pliers if you have to.\015\012\015\012Also, remove the entire brush roller assembly and ... Kirby Ultimate G Bagged Upright Vacuum

Belts breaking/melting The original belt broke at almost 1 year so I replaced it. I changed the carpet setting to shag even though my carpet is very low pile to make it easier on the vacuum. I didn't get to use it but just a couple minutes and could already start smelling the new belt getting hot. I checked the roller and it is easy to spin. Not clogged with hair or dirt. Now the inside of the new belt has small pieces of rolled rubber instead of being smooth. The metal shaft that goes into the


... Dirt Devil M088905 Vision Bagless Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0901 seconds