Having problems with your Vacuums ?

I'm trying to light a Robeson Kerosene space heater model # 03-2619-91. I am turning it on and applying flame directly to wick and it is not lighting. I just filled it with fresh fuel but nothing seems to be happening?

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I'm trying to light a Robeson Kerosene space heater model # 03-2619-91. I am turning it on and applying flame directly to wick and it is not lighting. I just filled it with fresh fuel but nothing seems to be happening?

... Vacuums

Universal Lighting and Decor company: i have one of their Halogen Three Light Torchiere and Reading Floor Lamp and the Torchiere or top light has a defective socket which works only intermittently. It seems to have some resistance and you can turn it on and nothing happens, then if you wait 5, 10, 15 minutes, it will suddenly go on. I don't think this is safe. Can I get a replacement socket system for the top lamp or what can I do?

... Vacuums

I have power at top of handle, thus start button light up. but when turn on nothing happens. I checked wiring and it all seems plugged in. The lights on the bottom of the cleaner (part of the base) don't light up. so somehow it makes since issue at base. HELP.. retired cop

Hi,\015\012Seems, the motor of vacuum has no power supply ( not connected yet). You may have a loosen/defective connection on motor cables/terminal. Please check and have it fixed. ... Oreck XL2200 Bagged Upright Vacuum

I am in ecuador and have had a local "plumber" install a lpg tankless water heater for me. After more difficulty than there should have been it's up on the wall with the water and gas lines attached but it won't light. There are 2 "c" batteries installed that seem to be the ignition system but when i turn on the gas and try to ignite the system nothing happens. No lights no sound no gas smell no hot water. Thoughts?

The system is ignited by turning on a hot water faucet causing water to flow through the unit activating the igniter.You could disconnect the gas line at the unit turn the valve on and off real quick and smell for gas.If there is air in the line you ... Vacuums

I just bought kaz model K76P (M) humidifier in Kyoto. I filled it to the right water level (a bit below) and plugged it in (nothing else is plugged in at that socket). The light comes on, but the water doesn't heat up. I can't read Japanese so can't read the instruction manual but it seems a simple procedure: fill with water, set the heating thing the water, plug in. Am I missing something or is the humidifier defect?

Take it back to the shop it should work and even though its in japanese ,they will know if your doing it wrong ,but i think it may have a damaged heater or a wire off where its been in transit ... Vacuums

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat

It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

I have a Brookstone Wet/Dry handheld vacuum. When I toggle the switch on or off, nothing happens. If I leave it on the charger and do this, nothing happens (so I don't think it's the battery). It seems like it's a few years old, but I can't be sure as I got it for free from someone's yard sale leftovers. They didn't have an option for "Brookstone" in the product selection, so I just chose the first one.

I realize this is an old post, but I also picked up the same item & \012have the same problem. Anyone know the fix? It's a Brookstone \012SKU#411884. I purchased it in an auction, brand new in the box. The \012filter is clean and shows no sign of ... AEG Vacuums

Karcher sc1402 bought july 2010 the water will not auto fill and red light keeps coming on because water not reaching tank machine works for a brief time when manually filled by unscrewing plug at top and filling it that way, once water level reduces machine wants more water and this doesn't happen i have descaled

... Karcher DE4002 Steam Vacuum

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden

Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

Hooked everything up per directions. I plugged it in to the closest electrical outlet and nothing happened. The lights did not light up, the connected wall control and sensors leds do not light up. It appears the unit doesn't have power. The electrical outlet socket is fine as everything else I plug into it works fine. I have tried every other electrical outlet available. The unit won't power on from any outlet, and all of those outlets run other things, like power tools an refrigerators

Dear Davehibshman,Firstly; dismantle the plug and replace the fuse with the same rating as the one you have just taken out. Replace the plug cover, put the plug into the socket and try again. If this doesnt work, there may be a problem wi ... Vacuums

The unit is charged, the charge indicator light is green, and the three lights on the top are lighted and steady but nothing happens. What am I doing wrong?

Press each cycle button and see if it starts up. I don't know if this is new and you just got it, but if so, you may need to remove any straps and retainers blocking the brushes etc. ... iRobot 4150 Roomba Vacuum

Karcher sc1402 bought july 2010 the water will not auto fill and red light keeps coming on because water not reaching tank machine works for a brief time when manually filled by unscrewing plug at top and filling it that way, once water level reduces machine wants more water and this doesn't happen i have descaled

... Karcher DE4002 Steam Vacuum

My Roomba will not charge, the light on the charger is on and when you plug in the roomba the light goes out and nothing happens. Can anyone help. It is a Discovery Model 4210

Are you using the home base or are you plugging the charger directly into the Roomba? If you are using the base, give plugging directly into the unit a try.You might also try resetting the battery. With the battery out of the unit, pres ... iRobot Roomba 4210 Bagless Robotic Vacuum

My kenwood steam mop makes for very wet mopping is this supposed to be? My floors are a lot wetter than when I use a traditional mop. When I fill the tank and turn it on the water seems to just leak from the bottom so I have only been half filling it and then the water light comes on within 2 mins of when steam starts to appear. What am I doing wrong??

... Vacuums

Hoover Savvy The red light for the dirt finder is on when pushing forward and the green light is on when pulling it back. This happens all the time. It's like the dirt finder sensor isn't working right. It seems to be picking up good and we keep the filter clean.

Does this happen at both Dirt Finder Sensitivity settings? ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

I recently bought a chefmate racket bug zapper from target, but can't seem to get it going. I pressed the buttons over and over so it would make it's high pitch sound and then i would know it was charged. never happened. what do i do next? I don't hear anything happening but do see the green light on. can you help?

... Vacuums

Producing steam i just got the shark assembled the mv2010, then it is not doing anything, it vacuumed just fine, but when i put the steam pad on it wouldnt ever produce steam or do anything,it felt like the water was heating up but even after it sat for 20-30 minutes when i pull handle back towards me nothing happens, no lights no steam no nothing, so why wont it work

This link is for the manualhttp://www.sharkclean.com/manual/MV2010_11_IB_ENG_110103.pdf ... Shark MV2010 Vac-Then-Steam 2-in-1 Vacuum and Steam Mop Purple

Delonghi Citiz Milk frother not working. After pressing button, red light comes on and heat starts, then after a few seconds red light starts to blink and nothing happens.

Please visit the link provided below :http://www.delonghi.com.au/support/instruction_manuals/EN265BAE_im.pdf ... DeLonghi Vacuums

The electricity in the apt attached to my house lost power in two of the walls. It happened when the cleaning ladies I think were using a vacuum, they don't speak english very well so I'm not sure. I have looked at the circuit breaker a # of times and nothing seems to have been tripped. I have also inspected the outlets and they seem to be fine. Can you help me?

Even know the breaker doesn't look tripped it might be. You have to flip it all the way off and then back on again. That is most likely what has happened. If that doesn't work check to make sure a GFI hasn't tripped. They are usually loc ... Vacuums

I plug my Polti in and absolutely nothing happens, no lights come on nothing, I've changed the fuse but still noting

There maybe a broken switch or the motor may be burnt out. Take it to a used vacuum store and they will give you sound advice. ... Polti Eco Pro 3000 Canister Steam Vacuum

I cannot charge my two year old electrolux pronto. I purchased a brand new hand held vacuum for it, but even the new one does not charge. When I plug in the cord nothing happens. If I turn on either the long handle or the portable unit within the long unit, the blue charging light comes on for a few seconds, then out. This tells me that the circuit is intact without a broken wire somewhere. I took it all apart carefully and could see nothing broken or out of place. On re-constructing it, it

It must be the charging transformer. We have already ruled out the vacuum unit. Unfortunately the transformer is not a serviceable part, and will need to be replaced. ... Electrolux Pronto 2-In-1 Stick/Hand Vacuum - Cayenne

I have a genie screw type garage-door opener. the fuse blew on the moter drive board , now the door only opens when you push the light button on the wall console ,will not go closed.green light blinks continually. when I power it up it jumps closed then nothing. It seems like the motor is not reversing.

... Genie Company Vacuums

Hoover U8311 WindTunnel2 vacuum cleaner will not run. When I press the start button, the Red dity light comes on but nothing else happens.

... Hoover U8311900 WindTunnel 2 Vacuum

I have a kenmore vacuum and the head of the vacuum is not turning as it should..what do i do? Everything else seems to be working...I tried to reset it but nothing happened. One more thing what is the head of the vacuum properly called?

Replace the belt on the vaccum. ... Vacuums

My Braun tootbrush has never charges-i have a 240 & 11v shaver socket but nothing seems to happen when i plug it in?

When charging a device on some type of charging block you need to plug it into a regular 110 socket as the block has the correct modifications in it for the device that it charges. This 11volt shaver socket is for older shavers that dont charge up yo ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0628 seconds