Having problems with your Vacuums ?

My Lasko fan is a year old type wta, TP120 volt AC 60 Hz 0.38 amps... the tower turns on but it wont blow any air out... what could be the problem i already checked and made sure all the wires are still connected.

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My Lasko fan is a year old type wta, TP120 volt AC 60 Hz 0.38 amps... the tower turns on but it wont blow any air out... what could be the problem i already checked and made sure all the wires are still connected.

... Vacuums

Roomba 550 I have a similar problem with my 550. It gives me 9 beeps and oh-oh. Took it apart, lots of junk got inside where the modules are underneath the gears. Don't know why. Blew it out with compressed air. Still no luck. Someone on YouTube made a video. Check it out if you have time. http://www.youtube.com/watch?v=s2Ts9oMs7J0&feature=related

Nice video on how to clean the CHM\015\012\015\0129 beeps suggest a bumper fault\015\012You are probably facing a bumper sensor issue.Try to clean the bumper first and if this goes on, either call iRo ... Roomba Robotic Floor Bagless Vacuum

Low suction I have a Hoover central vacuum system. I've reset the fuse box, checked the fuses, all of the lines are clear and there are no holes for escaped air to travel out. The filter has been cleaned as well. The vac works well with high suction when hooked directly to the unit, however when using any of the indoor connections there is extremely low suction. The machine still turns on so I do not believe it is an electronic issue. I have troubleshooted the issue as best I could and would

... Hoover L2310 GUV Central System Vacuum

Miele vacuum Sometimes when I hit the auto roll up cord button or even move the cord, the power vacuum goes off. I move the cord again and it comes back on. I took it apart and looked at the connection from the cord to the auto roller. These are the electrical slip on type connections and are still in good shape. There are no bends in the cord. I air dusted everthing inside, put it together (with no extra parts!). Good news..it powered up so I did not break it, but it still has the same problem.

... Vacuums

I have a Kenmore canister vacuum - model 25614506. Some time ago, I was not able to turn the vacuum off with the on/off switch, but could still use the vacuum. Turned if off/on by pulling the plug. The other day when I went to plug it in, I heard a pop. Now the sweeper runs but the vacuum cleaner does not **** - no air flow. What could be the problem. The cleaner is only 4 years old.

The motor has an inline fuse ... Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.

Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

I have a modelF5914-900 steamvac cleaner.serial #0704 0011 4711 I cleaned the carpets in my house and then started to do the stairs with the stair attachment. I got down to the last four stairs and the solution would no longer come out. I checked the tank and hose connection and tried priming the pump per the instruction manual. nothing worked. Could you make a suggestion as to what the problem could be? Thank You

Check fuses goin to the pump, is the pump working? if so you may have an air pocket or a air leak in the intake. ... Vacuums

Shark Euro-pro EP621 Bagless Upright Vacuum. Q regarding the brush not spinning / after troubleshooting and taking actions listed below, it now spinning for a few secs, but then stopping. Already removed hair, strings, etc. Checked that belt is aligned properly, checked that small wheel that turns belt is working (spins fine when belt removed. Oiled the turning parts a bit, that made it spin better, but still stops. It turns about 3-4 seconds then stops. If I switch it off and on again, I get ag

... Euro-Pro EP621 Bagless Upright Vacuum

My Shark Steam Mop quit steaming & light went out half way through mopping my kitchen floor. It still had water in it. Checked that plugged in properly and checked receptical. Could not find a problem.

Hi,Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head...Euro-Pro Shark Steam Mop Problem ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

** suction The best way to describe it is that when I was vacuuming I could see dust clouds at the front of the vacuum where the light is swirling around in the air. It was like it was blowing dust around instead of picking it up. I checked the tubing and found that it was clogged with some paper and hair ***** etc.... So I cleaned it out and tried it again and it still was not picking up properly. I had my husband take all the tubing apart to check for other clogging and there was none. When I

You have an airflow problem. You may still have a blocked intake or tube, also check the filter. The air is supposed to go in the bottom (of course) and I'm sure you k**w where it goes out. You probably can **te a reduction in exhaust. If this is ... Oreck XL Ultra Bagged Upright Vacuum

My central vaccum cleaner has no suction at all outlets even at the canister. The motor is still working and blowing air out the air release tube. What could be the problem

Check the filter in the tank. If this is dirty, the motor will still run, but there will be little to no suction. Rinse thoroughly under warm water, then allow to thoroughly air dry before replacing into vacuum. \015\012I recommend having tw ... Electrolux Central Vacuum

Hi, my name is Nicole. I have a dirt devil d1. I have been having problems with the empty space that surrounds the air director. It is filling up and I'm having to unscrew it to empty it out. I have already checked the air director, and it is not clogged or anything. When I vacuum, the bottom part of the canister fills up, but so does this space at the top. Can you help?

... Dirt Devil Vacuums

Burned smell hi, I have used my hoover 4 times and is starting to smell as something burned, I checked the troobleshouting part of the owner manual and it says that check the belt, I already did that and everything is ok I used the hoover again and still smelling bad and start to work very slow I better shut off it.. what could I do??

If the motor slowed down this would indicate a bad motor. not cost effective on this model to replace unless under warranty. it is not uncommon these days to see a motor go bad every now and then.\015\012\015\012What are the first 4 digit ... Hoover U5507900 Elite Rewind Bagless Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I had plugged it in to use it, turned it on and instantly it made a pop sound, smelled of electrical, and would not turn on after. i even waited for a while let the smell go away and tried a different plug in the house and still no operation of any kind. Is there an internal fuse that i could check on this? where is it located?

Sorry there is no fuse in the vacuum. It sounds like there is a short somewhere when they manufactured it. There is no way to fix yourself you will need to take to a repair shop\015\012\015\012Good luck ... Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto

Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

Bissell 7700 series, pro heat all rounder. Won't spray water. Have checked the line from the unit to the spray nozzel and all seems clear. Water doesn't seem to be flowing from the tank to the end of the unit where the hose connects into. What could be the problem? Any assistance would be greatly appreciated. Thank You. Steve

HelloGrasp the cleaning solution tank, and remove it from the machine. Reinsert the tank into the machine, making sure it fits snugly in the machine. If the tank is even slightly dislodged, water cannot get into the machine. Visually insp ... Vacuums

My kenmore progressive canister vacuum won't start,any ideas, is there a fuse? it was on then just quit. I've checked all connections and made sure they are snug, and that it's still plugged in (!) model 116.

Wire broken in several place along suction tubing. Replaced tubing and works fine ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated

1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

I replaced the belt on my Dirt Devil Featherlite Bagless Vacuum and the brush roller rubs and makes a very loud noise when turned on. I have gone exactly by the manual instructions and made sure the belt and end caps were on correctly, but the bristles still rub the back and it makes a very loud noise. Without the brush roller in the vacuum, it sounds and runs normal. What could the problem be?

Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=561283\015\012Generic problem for all Vacuums\015\012I replaced the belt on\015\012Posted by piggyt ... Vacuums

We have a black & decker bottom load water cooler. It has been continually running then stops and starts beeping. We have checked the connections, made sure the bottle is loaded properly. That the seal is tight and it still cointues to run and beep. Can you helpe me?

... Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

I've recently bought a hitachi HDR505 & haven't had a problem using it with an indoor ariel other than the fact in bad weather conditions there have been problems with the signals. So I tried to attach the ariel wire that connects from a box in the corner of my living room which connects to the outdoor ariel but cannot connect it into the 'ariel in' compartment on the box as it does not fit into that hole but does fit into the 'ariel out' hole. Please could I get help with a solution asap as I w

... Hitachi Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

The roller on my Dyson vacuum has stopped rotating (I still have suction) I have checked the belt (not Broken) and have checked and cleaned the roller and spindle and also checked the "auto" button setting on the vacuum but to no avail ... Anybody have any clue as to the problem Many thanks

... Dyson DC07 Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 1.9650 seconds