Having problems with your Vacuums ?

I bought a Hoover Wind Tunnel in January 2008. At first it worked great though very noisy. Now it will not pick up small fuzz on medium shag carpeting. I have checked the bag, the filter, the belt, and obstructions and there are none. Plus the noise level has increased. What is wrong? I am very dissatisfied.

Answers :

Generic problem for all Vacuums
I bought a Hoover Wind
posted by smithcarolj1 on May 01, 2008
I bought a Hoover Wind Tunnel in January 2008. At first it worked great though very noisy. Now it will not pick up small fuzz on medium shag carpeting. I have checked the bag, the filter, the belt, and obstructions and there are none. Plus the noise level has increased. What is wrong?
I am very dissatisfied.

I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Sorry you are having a problem, using the Hoover Windtunnel is a very good vacuum. Reading youre description, the belt is one of the main reasons you are not picking up the small fuzz on a medium shag carpeting. The belt change on the average , if you have one or 2 belts should be changed every 4 to 6 months as a rule, and the brushes need to be in good shape as well, if those two are working well you may have a bad seal on the motor or a broken fan blade(s) and that would decrease suction and you would need to replace the fan. Also check the gaskets if they are broken or damaged or pinched and letting air through the suction will leak out. These are some of the items to check for, so feel free to contact your local vac dealer. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST
Thanks, Don The Vac Man
Go Ahead. Use Us.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I bought a Hoover Wind Tunnel in January 2008. At first it worked great though very noisy. Now it will not pick up small fuzz on medium shag carpeting. I have checked the bag, the filter, the belt, and obstructions and there are none. Plus the noise level has increased. What is wrong? I am very dissatisfied.

Http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=563001 Generic problem for all Vacuums I bought a Hoover Wind posted by smithcarolj1 on May 01, 2008 I bought a Hoover Wind Tunnel in January 2008. At first it wo ... Vacuums

Oreck XL21 just will not work at all any more. Beater is clean - belt is fine. Fresh bag - inflates. Took the thing apart - checked for blockages at intake, bag entry, and the tube. It just doesn't vacuum anything. No suction at all for anything stronger than air. I'd say it doesn't ****, but that would be ironic. Are these known for just "quitting" after a while? We take it in for maintenance as recommended to replace filters, etc. Is there some miracle trick to make it work or sho

Did you make sure the brush turns freely? Even though it is clean, if it does not turn freely with the belt, it will not beat the carpet and pull debris up into the unit.\015\012\015\012Another (drastic?) thing to try would be to take the unit ... Vacuums

My Kenmore Progressive keeps burning up belts even after I have changed the bag, cleaned the filters and checked to make sure the agitator was clean and free turning

On the left hand side, just above the handle release, is a lever to adjust if you are doing hard wood or carpet cleaning. When adjusted for hard wood, that lever releases the belt and just uses the "vacuum" function. When set for carpet it engages ... Kenmore Vacuums

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?

There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

OUR DYSON 07 SWEEPER HAS VERY LITTLE Vacuum, have cleaned all filters and hoses, on line troubleshooting has said to check soleplate being on correctly, we have done this, still does not have good vacuum, belts are covered by a housing, the video that shows the changing of the belt is not the same, I need to know how to remove the cover to check both belts and any help in gaining the vacuum

This video shows you everything you need to know ... Vacuums

I have 2 Hoover Wind Tunnel-self propelled bagged vacuums-U6433-900 model.The roller bar does not agitate, the self propelled feature does not work and, in general, the vacuum is not performing well. I have replaced the roller bar, the v belt and the wide belt. The filters have been replaced and it has a new bag. I have had both of these since 2004 and they were fairly expensive $200 each) but if the repairs are prohibitive, I might as well get new vacuums. Suggestions? I just spent $100 for bel

The Hoover WindTunnel self propelled is a machine that we see in our retail stores (Vacuums Unlimited) constantly. The benefit of having a supposed "self-propelled" machine wears of quickly after the numerous time you will need to take this machine ... Hoover Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.

... Windsor SR12 Sensor Bagged Upright Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Weird noise i have a eureka the boss and i am getting a weird noise figured bag was full needed to change it so i did. Noise persisted so i checked make sure nothing was caught in the brushes. I even checked the belt it was fine replaced with a new one.Still the noise is there help me I am out of what else to check.

Squealing ... Vacuums

I have a Eureka 4800 series the Boss upright with a bag and Hepa filter. I love it! I was just vacuuming with the hose part and all was well and then suddenly the lower brush came on and a "burning" smell followed. Thought it was the belt so my husband was going to put on the new belt which I had on hand! When he turned it over, the "bar" that holds the belt looks as though it "shot through" the plastic side of the housing on the vacuum. There is melted plastic on the outside of the vacuum and o

I had the same problem. Take out the old belt if possible. Remove the 4 screws inside the filter and the 3 on the front of that housing. pull out the foam around the motor. carefully pull out the suction tube that is press fit against the motor. ... Eureka 4874 Bagged Upright Vacuum

Have ultra vision and have changed filter and foam filter, checked all hoses but still will not pick up. Belt is fine and brush is clean and spinning properly. dirt stays at top of filter instead of falling into canister.

My kids get mine stuck all the time :(Take the vacuum outside then:Remove the hose at the bottom and see if there is any obstructions. Also shake the hose to make sure there is nothing in there as well or take it out side and make s ... Dirt Devil Vacuums

My Dyson DC07 brushbar is not rotating. I have checked for obstructions. The belt is intact. Is there a reset somewhere within the internals of the unit?

There are two belts on the dc07 one for the brushbar and one for the clutch this video will show you what you need to do ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Vacuum My vacuum is loosing it's suction power. I've checked the belt and it's in perfect shape...I've bought a new filter cup...I've checked for clogs and there aren't any...I've cleaned the entire machine...and I still can't find the source of the problem.

You checked the belt, but I bet it has stretched and won't drive the brush roll under load like it should. Belts only last a few months the stretch and should be replaced. Iff you have suction at the hose, then it has to be down below, either belt/ ... Eureka Whirlwind 4480 Upright Vacuum

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

I have a Panasonic MC-E3011 and it won't ****. I have checked all the pipes from the beater to the inlet at the dust bag, and they are both clear, pluss the air comming out of the vent at the bottom of the upright (above the beater) casing seems abnormally hot. I have allso checked the the belt and beater bar and they are functioning A1 OK.

... Panasonic MC-V7395 Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

My Dyson DC 14 is making the horrible "ratcheting"sound only when the brush is engaged on the carpet setting. I have cleaned the brush, so there are no obstructions, the canister is empty and properly on the unit. I checked to make sure all of the "traps" and hoses are clear of obstructions, the belt is on the brush securely and moves freely, the brush itself spins freely, but there is still the "ratcheting" noise. Any other suggestions?

Our DC33 was making the same ratcheting sound immediately upon placing the cleaner/brush head on the carpet. We carefully pulled the beater/brush bar out of the vacuum. Once removed, we pulled the black plastic end off of the center rod. We discovere ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I have a Bissell proheat 2x microban carpet cleaner. no water is dispensing . I have tried double cleaning everything, changing soulation(bissell steam clening) checking the filters checking for hot water, the brushes turn (belt?) What should I do?,

... Bissell Vacuums

Sudden loss of suction. Using a dirt devil upright. Checked the belts that were changed recently and working. Changed the half full bag. No change. Checked for blockages and as far as I can see there are none. The blower is working as much as it ever was I think but I;m stumped.

R u sure there is nothing cought in the hose? ... Dirt Devil Featherlite Bagged VacuumVacuum

My Bissell lift off pet bagless is making a higher pitched noice. It sounds like the engine is workinge extra hard. I have checked the filters, belt, revolving brush, and checked for plugs. What do I do now?

We would like to assist you with troubleshooting suggestions. Please call us at 1-800-237-7691, Monday - Friday 8 a.m. to 10 p.m., or Saturday 9 a.m. to 8 p.m., ET. A representative will assist you. There still may be a clog that is causing what you ... Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

I have a Eureka Altima vaccuum and it no longer suctions like it use to and also has a burning smell. I have cleaned all filters, brush, hoses, and filters. There are no blockages. I have also checked the belt and it's still good. Any other ideas as to what may be the problem?

This bagless model gets buildup of really fine dirt in the motor and starts to clog up the fan airducts. You will need to take the motor out and clean it. ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Sebo x1.1 fitted with new bag and filter but red bag check light still comes on and then machine shuts off. Any ideas how to remedy?

Without doubt this indicates that there's a blockage somewhere. The two easiest places to look are: 1. on the underside of the machine there's an inspection flap - check in there; 2. remove the flexible hose completely from the machine at both ends - ... Sebo Automatic X1 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0609 seconds