Having problems with your Vacuums ?

The error message on my Bernina 630 reads " main motor failed check hook system." What do I do?

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The error message on my Bernina 630 reads " main motor failed check hook system." What do I do?

... Vacuums

The pump motor in my Bissel Proheat 2x Plus seems to have failed. It was seized so I sprayed WD-40 in it and let it sit for 3 days. Now I can turn it by hand, but when plugged into the unit it still doesn't spin. Here's a picture: http://bbay.dreamhost.com/bissel_proheat_2x_plus/P1070021.JPG I wanted to take the motor out and hook it into another power source to see if I can get it going but it has 3 wires. I'm used to only 2 (+ and -). How can I hook the motor up to another power source,

... Bissell Vacuums

I replaced the motor in my Oreck vacuum and it runs much faster than it used to and is very noisy. The wiring diagram that I received with the motor was very hard to read so I don't know if I wired it correctly. I also was not able to hook up the dual head lamps. Thanks, Bob

Hello Bbrote,Please visit the link provided below and find your model and then click for schematic :http://www.hescoinc.com/vacuum_cleaner_parts/oreck.html ... Vacuums

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i

At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

My Kirby 2HD has started making an odd roaring noise but still works fine. I have taken the front assembly off and cleaned and adjusted the roller and checked the belt. The noise seems to come from the motor housing. I have tried to wiggle the main shaft at the front (bearings?) and it seems tight. Can't seem to get the other housings apart. Any ideas? Thanks, John

It is quite possible, it just needs lubed. The motor comes in direct contact with dirt so, you have to make sure the front bearing has a drop of oil on it from time to time. If it starts to scream at you within one month, after oiling, the bearing ... Kirby Heritage II Vacuum

I have a Bissell 9400 E pro heat turbo. It's only been used 4 times, today it sounded like something blew. All my house electrics went off...( blew the main trip) I did read some place that the motor can short out and blow the PCB. Hubby and I just took it apart..( what a pain that was) We can't see a thing wrong with the board...( I expected to see something black, or damaged).... because when it blew today there was a weird smell... sort of like garlic. Question... how on this spinning earth

I have the exact same problem! Just occurred today. When I switch it on it fires for a couple of seconds then takes all the electrics in the house out again.\012\012\012Did ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Passat 2000 W Reg Had the rear brakes and disks changed then a month later had a front tyre replaced and as I drove off something went tinkle tinkle on the road (like someone had left a spanner). Week later the ABS light and the brake light come on with the usual STOP Brake Fail Service Manual message. Had brakes checked but they could find no fault. I've tried the ABS under controlled conditions and it works. What could the problem be?? I've been running the car under these conditions and no pr

The ABS module has a history of wearing out on VWs. Nothing wrong with the brakes themselves, but the ABS module would need to be replaced to stop the lights coming on... but the problem is a new ABS module can be very expensive for a new one (~$900 ... Vacuums

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?

... Vacuums

My Dyson DC17 beater bar motor works intermittedly. I have to almost whack it on the floor to turn it on and then shuts off again. I have checked the belt and it is fine, also have checked for blockages. The switch to turn the beater bar on or off will not work when the beater bar motor is off. the suction is fine though.

Buy a Kenmore for less money ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Barush motor won't turn on when the vac is tipped back as it should be. checked micro cwitch that controls motor it checks ok. what next

... Dyson Ball DC24 Bagless Upright Vacuum

No power when turned on, I checked motor brushes and they are almost worn out, could this be the problem? and where do I find replacement brushes? I have checked on Dirtdevil's site but I don't see any motor brushes. I am in Montreal, Canada. Thank You.

Hi,\015\012Before that I wouild check the switch...the switches on those things go bad regularly...get a meter and check the power on either side of the main switch and I think your problem will be there...\015\012\015\012heatman101 ... Dirt Devil 12 Amp HEPA Filter Vacuum Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Replacement motor I purchase a replacement motor for a F5897-900 Hoover SteamVa Motor part # 43576197 or 27242051. The replacement motor has three electrical connectors + ground were as the orginal has two electrical connectors + ground. Do I ingnore the the thrid connector and hook up the wires to the same connectors as the orginal or do I have to do some rewiring.

The manual only show one wire from the motor going to the switch, the other going to the cord, then the ground wire. I would wire it the way your old motor was, could be that some models maybe were 2 speed and the other wire would be used for that. ... Vacuums

Shopvac 90L400 quit working (4 years old). Thought the switch was bad but not the problem. I read that there is a fuse link in the motor that frequently burns up. I tried to take motor apart but not sure of the process. I was able to get to the motor but cannot pull it out of the armature. It appears I have to take the aluminum blower unit off the shaft (it appears to be pressed on with a retaining washer). Do I have to take it off to pull the shaft and motor assembly out? Is that where the fuse

By pass the switch and take power right to the motor leads.. that should tell you if the motor is ok.. have not seen fuse link on a vac motor.. graingers has new motors, but not inexpensive ... Vacuums

Motor is sparking and smells like burning rubber. When it first happened I thought the vacuum had something jamming the beater bar. That was the smell it had, like when the belt gets burned. But when we turned it over, it wasn't jamming. Took off the base plate and turned it on. The motor area is sparking and it makes a weird noise (I assume that is because the motor fails and restarts). I looked for loose wires, can't find any. I believe I need some sort of part replaced, maybe even a n

From sound and description most possible is motor is burnt up sparks usually mean metal on metal either bearing or bushings went on motor if u can jiggle the shaft thats bearing if u rotate the shaft by hand and feel and or hear rough grinding the br ... Oreck Vacuums

Webpage error detailsrn User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; FDM; AskTbPLTV52/ Timestamp: Wed, 1 Jun 2011 21:06:26 UTC Message: HTML Parsing Error: Unable to modify the parent container element before the child element is closed (KB927917) Line: 0 Char: 0 Code: 0 URI: http://www.facebook.com/hoshmend.ali1

... Euro-Pro PT205 Leaf Blower Powerful 12 AMP Leaf Blower, provides 205MPH air speed, Detachable Vaccum... Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Motor whined loudly. Vacuum failure. Suspect motor failure. Hoover.com doesn't list a replacement motor. Drive also failed - could be secondary belt HOOVER U6323- Power Drive Bagged Upright Regards, Jeffrey

Hello, funI was trying to help you out here. Maybe this will help some? I was going back to some customers that asked questions in the recent past and even farther back. It appeared that no one answered some of them, So, I thought I ... Hoover U6311-930 Power Drive Bagged Upright Vacuum

Model # 5770 the brush motor runs and shuts down after a few seconds...Turn unit off and the brush again will run for a second or two...If I don't turn unit off brush will not start up..Could it be the printed board..the motor brushes..or the wiring that goes from the printed board to the main motor...Thank you

Seems like your unit goes into failsafe because it detects something wrong. Well you should check the brushes and replace them if they are worn out. Also check the wiring for shorts etc, becaue the unit maybe tripping due to an overload. The printed ... Bissell Vacuums

How do I access the motor to my eureka capture? It has no suction at all but turns on just fine..filters are cleaned and there are no clogs or leaks on the hose....im thinking there must be something stuck in the motor possibly but there are soo many screws that im having trouble removing them all....whats the best way to access the motor to check it??

... Eureka Capture Upright Vacuum Vacuum

Oreck model BB870-AS - I was vaccuming when the vac shut off. The motor just spooled down and nothing more since. I have opened the case. Have power at the switch, and to the motor, but can't get a voltage reading to the common lead at the motor. Is there a fusible link, or something similar in that lead that might have burned out? Thanks!

... Oreck Vacuums

Dyson DC07 Vacume cleaner trips on thermal after 10 min motor not excesive hot resets after 15 min has been doing this for the last 3 mths. Could it be faulty thermal or motor overheat how can I check without changing motor

First, check both filters on that unit. the premotor filter on the side, and the hepa filter underneath the canister. if those filters are clean move through the suction channel and look for a clog or obstruction. also make sure the canister is clean ... Dyson DC07 All Floors Bagless Upright Cyclonic Vacuum

Wiring diagram took wires off motor and do not know which goes where.There are two main from plug in one whit one black then two of same coming from light in front.On the motor ther are more terminals than wires.On diagonal corners there are black dots.Can you please help this cost 800$ and do not want to burn the motor due to crossing pos and neg.Do you have a picture or know where I can find?

... Oreck XL21 Bagged Upright Vacuum

No suction. filter and hose clear. motor high pitch. don't know how to remove cover to check motor.

Something is clogged somewhere start from bottom and foolow suction path all the way through. wht kind of vacuum? ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0831 seconds