Having problems with your Vacuums ?

The external sensor on my weather station has stopped working. is about 4 years old.changed batteries,checked connections but nothing. type- wo53-4. any ideas


Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The external sensor on my weather station has stopped working. is about 4 years old.changed batteries,checked connections but nothing. type- wo53-4. any ideas


... Vacuums

Carpet stained recently cleaned my cream coloured carpet in my entrance hall with a carpet cleaning product, wet foamy spray type, ran out of this and found a part bottle of a different brand in my cupboard, used this to finish off however must be some sort of reaction and carpet gone a greenish colour i think (colour blind sorry ) any idea's of any product that might restore my carpet, will try anything, nothing to loose. thank you Peter McGurk Goole East Yorks


Ok in the future try to have carpet cleaned only by a pro. For spot cleaning use white paper towels or dish towels and warm water. (ONLY WHITE) 99% of fabric is white and then dyed to color and if you use a color cloth you might pull the dye from the ... Bissell OxyKIC - Oxygen Activated Carpet Spot and Stain Remover Vacuum

Our kenmore progressive model #11634922 was working fine today. And then - it's not. Plugged in - nothing is working on it. We let it cool down (though it didn't seem hot). Still nothing - no light, no motor. Tried it in some other plugs that we know are functioning well - and still nothing. Any idea what might be wrong with it? It's six years old but doesn't get heavy use. Thanks so much ~ Susan Golden


Hi, it could be a number of things, cord may be bad as well as a problem with the motor. There also is a fuse that could have blown. If you go to sears.com, click on parts, put in your model number, when the page loads, click on the first link ... Kenmore Vacuums

Torn Hose The hose on my Dyson is torn right at the top where the the accessories connect. I was able to take the connection apart and shorten the hose, but I don't know what to use to reattach the hose to the black fitting. It looks like it was glued...not sure what kind. Any ideas?


Duct tape ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

When connecting the wand into the brush component. sporatic power (sometimes runs sometime nothing) the power is on again off again. when hold pressure down on the wand the power stays on. do you think the coupling connection is bad on the wand? would the wand replacement likely be the culprit?


There is is switch or sensor in the connection. Likely that piece is worn or shorted out. You may be better off getting a new wand piece ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

I have a Bissell 7920 ProHeat and only used it 4 times and the brush on the bottom has stopped spinning and when attempting to spray solution the flow indicator doesn't spin and nothing comes out. I have looked at all of the belts and they seem fine. I have also removed and cleaned the heating unit. Still nothing. Any other ideas?


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

Ive got a dc07 dyson just changed the belt on it as i had to since then it isnt picking anything up at all nothings clogged up had it to bits and put it all back together again properly. The hose is working when i take it off its got plenty suction but when i run it along the floor it picks absolutely nothing up any ideas that i havent thought off. Thanks


Sounds like the hose underneath has become detached. Have a look and if its not that come back to me. Also can yo9u check your U Bend is still on as these can come off. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Miele vacuum Sometimes when I hit the auto roll up cord button or even move the cord, the power vacuum goes off. I move the cord again and it comes back on. I took it apart and looked at the connection from the cord to the auto roller. These are the electrical slip on type connections and are still in good shape. There are no bends in the cord. I air dusted everthing inside, put it together (with no extra parts!). Good news..it powered up so I did not break it, but it still has the same problem.


... Vacuums

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.


Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

When running the 2100 Electrolux vacuum, it is stopping and starting when pulling or pushing the floor attachment. Seems like the connection at the top of the handle is a little loose or the electric tabs are loose where the hose connects. Any ideas?


Other option is that on the hose end of the electrical connection, you can use an awl on the electrical connections to bend them in slightly so they make good contact when they are automatically plugged in when you connect the wands. HOWEVER, ONLY D ... Electrolux UltraLux 2000 Bagged Canister Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor


On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Emerson Microwave Model #8126 W/S/D doesn't produce any heat. No matter how many times I run it or for how long, nothing gets remotely warm. Nothing in the manual about this. Any ideas or suggestions? Thanks! Lestat


... Vacuums

Connecting to charge station


Hi,If you can't find proper service from your country, please send your Trilobite to Finland So have done some other people around europe too! :) I am a professional with Trilobite robot's.Mostly error's will be repaid f ... Electrolux Trilobite Vacuum

They dyson Dc25 I have was working and shut down. I found a rope type item on the roller, removed it and now it doesn't turn on. There is nothing in the bagless container. What might be wrong?


Hello,Thanks for the follow up. I let the Dyson sit unplugged for an hour, I then replugged it in and it was working. I'm assuming the rope item shutdown was an overheat and it needed to cool down.All is well.Tha ... Dyson DC25 All Floors Bagless Upright Vacuum

I have a Beam Rugmaster Plus power head Model BM1 393 Type AB and the connection were the metal pipe meets the plastic swivel broke close to the unit. It appears like a manufacture defect in that is broke in two small places and not the entire unit. Can this piece be replaced or glued??


This is most likely repairable. Lots of the Beam parts are available. I would recommend checking out any local vacuum shop or searching online for a central vacuum store that sells beam products. ... Beam Industries 750 Classic Bagless Central System Cyclonic Vacuum

I HAVE A FANTOM VACUUM CLEANER MOD.#F1205400. I PURCHASED IT ABOUT 6 OR SO YEARS AGO.IT WORKS PERFECT,AS FAR AS SUCTION, THE ONLY PROBLEM IS ABOUT 2 MONTHS AGO,SOMETHING HAPPENED TO IT AND IT GOT VERY LOUD, KIND OF LIKE A CAR WITHOUT MUFFLER. I TOOK IT APART,AND FOUND NOTHING OBVIOUS. CAN YOU GIVE ME SOME IDEA OF WHAT I CAN CHECK TO RESOLVE THIS PROBLEM. AS I SAID BEFORE IT STILL VACUUMS GREAT. THANK YOU, VINCE


You probably have a bad motor bearing. I don't know if the motor is available now or, these older Fantom's are obsolete along with most of their parts. ... Vacuums

I have an Ambassador canister model Electrolux. The powerhead shut off and the brush doesn't turn. There is nothing wrapped around the brush and the connection from the handle to the power head is fine. Any suggestions? Thanks AG


CHECK TUBE-SUMO ACTIVE ( PART NO: 1131402-02 ) CONNECTION AND NOZZLE-SUMO ACTIVE OR REPLACED (PART NO: 1131400-02) ... Electrolux Lux 7000 Bagged Canister Vacuum

NOTHING WORKS Used the unit 3 1/2 weeks ago, now it will not do anything except turn on. The water and shampoo will not dispense and the brushes will not turn. Is there some type of reset button that can be utilized????????? Have had unit for several years with only one other problem, the soap dispenser had to be replaced because it leaked. Teresa


Check the foam filter on the underside of the recovery tank lid, make sure that it has at least a 1/4 in. gap from the top. There also is a filter, from the bottom, it has a red frame, pull out far enough to clean it.\015\012On the bottom of t ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

My Oreck XL has worked very well until the power cord was pulled out of it. I figured how to hook up the hot but can not figure out the neutral connection. any ideas?


If there are two wires it doesnt matter normally white 2 white and black 2 black if its 3 wire than green is ground and the other 2 dont matter thanks Don ... Oreck XL Ultra Bagged Upright Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Search for bissell pro heat pump. bissell.com will not have it ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

No spray My Bissell Pro Heat 7901 will not put out any spray. I Took the pump out so I could get at it and disconnected the hoses. I put the one on the input side and the other in a bottle of water. Put the belt on the pump and turned on the machine .Nothing at all coming out of the pump. Where can I get a new pump? Also the lever that goes to the little flapper at the top under the clear plastic piece on the front that connects to the knob that changes from tools to floor broke off. Where can I


Pump part number is 2107181, the diverter valve # 2136988. You can Bissell and they can tell you who may have parts near you, or you maybe able to order thru Bissell.com. Before you took it apart, were you getting water to spray out of the hose. I ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

My SEBO vacuum cleaner keeps cutting out which seems to suggest an dodgy electrical connection...any ideas ?


If it just cuts out then comes back on after a while, it might be overheating. ... Sebo Vacuums

The vaccum has been cleaned and checked but the brush is not rotating and no suction at the bottom, but through the hose. In reading the instructions to remove the brush cover it says to lift tab one and release 2-4. Where is the tab for tab 1 can not find anything for tab one to be able to lift, nothing there any ideas for help would be greatlly appreciated/


3 on the front and one on the back. where the belt runs ... Bissell 6594 PowerForce Bagless Upright Vacuum

The brushes will not rotate on my hoover vacuum. the belts are in good shape, the motor is turning the vacuum motor, but the belt on the brushes seems loose. I ordered a replacement belt but still nothing. Their is a small "idler" but their dosent seem to be enough tension on the belt. Any ideas?


Did you order the correct size of belt? These are the belts you should have:Hoover Windtunnel Belts ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Contour Flexihead, I have a loose connection around about the cable entry. How do I open it. 3 Svrews removed but nothing comes apart


There is a solutioln on your web ... Electrolux Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0412 seconds