Having problems with your Vacuums ?

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Answers :

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more if I knew the make and model. Chris
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

My Windsor Sensor XP12 says the bag is full when it's not. I have removed the hose, brush, and filter and cleaned everything. I can put a bag on without the cover and it works great. However, when I add the bag to the front cover and close the latch the right way, it does not work. I'm thinking that the cover is not seating the bag correctly over the hole, but I can't figure out how to fix it. Any suggestions?

... Windsor SR12 Sensor Bagged Upright Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom

Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Bosch canister vac BSG81313. Took cover off to remove lots of hair, dirt etc from running without bag in place. Everything went back together OK, but cord reel spring went zip when cover was removed. How do I rewind the spring so there is tension when the cord is pulled out ? Wound cord back onto reel, but reel just clicks ever revolution etc...no tension when cord is pulled out of vac. Bob

The spring inside the hub of the cord wheel has escaped from the locking tab. You must completely dismantle the vacuum to access the cord wheel - take it out, reattach the spring and reassemble the unit. All you need is a phillips screwdriver, a pai ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

I have an old Miele canister vacuum and I do not know how to disassemble the hose to check for a clog. I think it sucked up a nerf ball the size of a ping pong ball. I changed the bag but it did isn't appear to be in the bag. The vacuum powers on but I do not have suction with the hose, and since the hose has hard plastic elbow joints I do not want to pry them apart and break it

Hi Emily: If you have the model number for your machine you may be able to find your manual on the Miele website. Check ... Miele Vacuums

No suction. filter and hose clear. motor high pitch. don't know how to remove cover to check motor.

Something is clogged somewhere start from bottom and foolow suction path all the way through. wht kind of vacuum? ... Vacuums

How do you get to the 2 screws under the cord retraction pedal? I can not find any way to remove the pedal. I am trying toi remove the canopy cover in order to get to the motor>

What model is this for? ... Kenmore Vacuums

Hi: We ahve a Tornado CV30 vacuum. The suction does not seems to be working properly. There is no suction at the tool hose and the bag does not seem to have air moving into it. Do you think there is a clog somewhere? The roller is moving. Thank you for youre help :) Kelly Branson, Mo.

To clear the clog, remove the hose and wand from the unit and separate them. The hose is\015\012released by pressing the white plastic ring in the housing. The two are\015\012separated by simply unscrewing them. Remember this threaded connection\015\ ... Tornado 93030 Wide Area Carpetkeeper Upright Vacuum

Where do you hook the clear hose that is in the compartment with the motor ? Second where the vacuum hose connects to the bag it keeps cutting in and out of power. I replaced the female cord to motor and still cuts out."no suction "

Would you care to tell us the make and model of the vacuum you're asking about? ... Vacuums

No suction hello, there was a rubber smell then no suction. i'm thinking it needs a new belt but don't know how to remove the cover to replace. is it a complicated procedure. is there a diagram available? don't have any info here. thanks, leslie

Flip the machine upside down and remove the four screws from the baseplate. Replacement should be fairly self-explanatory from there. If it's a self-propel model, note that the v-belt in the front WILL look loose normally, so it does not usually requ ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Eureka 4470 The suction works from the hose, but not from the base. I do not know how to remove the cover to check the inside.

Take apart botem 1st cheak the hoses for sumthign in there ok stick a hanger in it poke it out from bottem side under ... Eureka Smartvac 7975 Vacuum

My shop vac is plugged. The hose is clear. The filter is removed. The filter bag is not installed. It still won't draw a suction. It sounds like it is plugged. The motor whines at a higher-than-usual pitch. What can I do?

Turn off the vac, take the head off of it and remove the filter paper. Inside, there's a white ball (bigger than golf ball, smaller than baseball) that's inside a cage. This is designed to keep water out of the blower when the vac tips over, and sh ... Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu

Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

How do I access the motor to my eureka capture? It has no suction at all but turns on just fine..filters are cleaned and there are no clogs or leaks on the hose....im thinking there must be something stuck in the motor possibly but there are soo many screws that im having trouble removing them all....whats the best way to access the motor to check it??

... Eureka Capture Upright Vacuum Vacuum

How to open 116.23512301 vacuum canister AC section to wire in replacement 4370608 cable assy. This assembly contains the receptacle that powers the hose. I found the two screws below the bag cover, but can't figure out how to release the end near the retractor lever.

... Kenmore Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

I have a Kenmore central vacuum cleaner model number c107 34601. We have emptied the bucket and shaken the filter out to clean it. There is a filter that is filthy so we shook it out into a bag but the cleaner still seems to not have great suction. I notice there is a similar cap to the outlets I plug the central vac hose into on the unit itself that doesn't power the nozzle when used. 1 - what is this for? 2 - Should I somehow remove the entire filter and if so - can you tell me step by step ho

... Electrolux Vacuums

The vaccum has been cleaned and checked but the brush is not rotating and no suction at the bottom, but through the hose. In reading the instructions to remove the brush cover it says to lift tab one and release 2-4. Where is the tab for tab 1 can not find anything for tab one to be able to lift, nothing there any ideas for help would be greatlly appreciated/

3 on the front and one on the back. where the belt runs ... Bissell 6594 PowerForce Bagless Upright Vacuum

Kenmore canister model 116.25513506 wont turn on. when handle switch is turned to floor. vac motor does not turn on. When switch is turned to carpet, floor nozzle works but vac motor does not. I checked fuse, all o.k. checked continuity for plug, o.k. removed wires for bag full switch...motor wont run. I wired motor directly power cord...motor runs. Thinking it must be the circuit board, how do I bypass it or test it?

... Vacuums

I have a Sears Upright vacuum cleaner, model 116.35922500. The vacuum wasn't picking up. I discovered a clog in the nozzle hose. I attempted to remove the cover of the brush unit to clear the clog. I was unable to remove the cover completely, but was able to clear the clog. My problem now is that I cannot replace the cover correctly. Is there a way to remove this cover? Thanks, Elizabeth

When you tried to remove the cover did you have to put a little force on it to get to the clog ... Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

Lost suction my DCO7 lost suction in the hose I started taking it apart and cleaning it and looking for clogs (probably more than I should have) and when I put it back together it has awesome suction in the hose but no suction in the base. It just pulls the pine needles up (christmas tree) but they never appear in the "bag" compartment and when I look they are just all gathered in a clump in the bottom by the brush.

Hi.\015\012\015\012Remove the sole plate turn the 3 plastic screws to unlock & lift off.\015\012\015\012Now remove the blockages that have accumilated from the oppening of short clear hose.\015\012Check you can turn ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1166 seconds