Having problems with your Vacuums ?

I have a burning smell coming from my kenmore elite vacum, otherwise it seems to be operating fine


Answers :

Sounds like a belt. Isthe smell kind of like rubber then its time for a new belt. chris
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a burning smell coming from my kenmore elite vacum, otherwise it seems to be operating fine


Sounds like a belt. Isthe smell kind of like rubber then its time for a new belt. chris ... Vacuums

The original belt on my upright Kenmore Progressive broke and I replaced it with the spare that was in the vacuum. The vacuum and spare belt are about 10 years old. Then the spare broke after one vacuuming session and there was a burning smell coming from the vacuum. I ordered new belts and replaced it with the new belt. It seems to be working fine with no smell. I checked the belt after I vacuumed the family room and although it was in tact, the belt was very hot. Is that normal? Should t


The belt heats up due to the friction, as well as being in contact with the shaft of a hot motor. It is normal. ... Kenmore Progressive 35922 Bagged Upright Vacuum

Burning smell There is a burning smell when I run my Kirby Ultimate G.  The smell seems to be coming from the belt.  I looked at the brushes and they are spinning so the belt is working.  the Post on the vacuum is getting very hot not sure if that is normal.  What is causing this?


Unlock the sweeper brushes and take them out. on each end is a cup bearing and should be free of debris.then check around and under the belt and likely there is debris wrapped around it.the post is getting hot as your pulling too much of ... Kirby Ultimate G Bagged Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Not picking up at all...burning smell..belt seems fine.


Its one of 2 things, either your hose is blocked or you need a new belt,they do stretch over time. possibly the brushbar needs replacing too. Iain ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

Kenmore vacuum model 116.3592250 works fine, burn smell


Is that the one with the direct drive brushroll? those brushroll motors inside the brushroll always go bad. that is one of the worst designs from kenmore. is the brushroll turning? ... Vacuums

Burning Smell coming from the moter


This could be a motor problem. There is always a slight blue arcing that occurs when an electrical motor runs and can be visible through the exhaust vent, but any excessive arcing indicates a problem. If the carbon brushes are sticking, this will cau ... Hoover U5262-900 / U5260-900 / U5266-900 / U5268-900 EmPower Bagless Upright Vacuum

My Kenmore canister vacuum smells bad while in operation. Replacing the bag does no good. I removed the HEPA filter and it smelled fine. How do I correct this problem??


... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

The belt burnt out and it seems as though the red arrown does not release the belt. Like it is backwards from the green arrow. It had a burning smell and the belt broke. Then the second belt started to burn out when the brush roller wasn't spinning. Not sure what might be wrong. Green light will not come on either.


It sounds as if there may be a piece of the broken belt in there. Look carefully with a flash light and remove any remnants you find, using a pair of pliers if you have to.\015\012\015\012Also, remove the entire brush roller assembly and ... Kirby Ultimate G Bagged Upright Vacuum

I shut my vacume off to change its bag out. Now it won't come on. Oreck xl2. There were no noises before turning it off or any smells of rubber burning. Just won't come back on. Is there a reset button. What can I do?


An access panel mounted atop a vacuum nozzle base via finger operated latches. When the latches are undone the access panel is removed from the top surface of the nozzle base allowing access to the parts of the brush assembly. The panel also has a ... Oreck XL Ultra Bagged Upright Vacuum

I have a Napoleon Pellet stove insert Model NPI40. When the fire burn rate is extremely low it seems to operate normally. However, when I turn the heat up even a little I eventually get a high pitched noise that seems to be coming from the convection blower. Changing the speed of the blower has no effect on the noise level. I cleaned the blower but did not remove it. There was very little dust on it. Cleaning had no effect on the volum or pitch of the noise.


My theory is based upon 1st hand knowledge with a newer EPA compliant freestanding wood burner, with the air-tight and high efficiency ratings.its possible that its just the high rate of air moving through the air chambers , similar to a o ... Kenmore Whispertone 23312 Bagged Canister Vacuum

I have a Nutone CV-450. When the unit is turned on the motor makes a high pitched whining sound. The suction seems like it is reduced and there is a burning rubber smell coming from the unit. Suction at the unit itself is also reduced. Any ideas about the cause of the problem and the solution?


... Broan-NuTone CV450 Central Bagged Central System Vacuum

Electrical smell, before drop in suction that comes and goes. Working fine till then, happened after I changed from a full bag to empty one. It seems that the motor might have packed up, but why so suddenly? Can it be repaired, as suctionwas v. good till now. Thankyou.


As above, most likely the motor brushes. They cost around 14 plus vat and take 30 mins to fit ... Numatic Henry Bagged Canister Vacuum

Stopped working Was working fine then it smelled like burning rubber, not the belt I checked. It sounds like the motor wants to run then it just stopped but the light is on. What do you think, go by a new one?? This has been a great vacuum cleaner and I can not seem to find a Sharp anywere. Thanks for your time.


Well it could be the motor, if it is it would cost around $80 or so for a motor. May be better to buy new, thre are a number of good brands out there. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

Bissell lift off, brush won't move smell burning rubber belt fine


OK - so your brush roller is jammed. And yes, the belt is melting! Unplug the machine, remove the belt (you will need another new one anyway) then see if you can turn the roller by hand. If it turns freely without you doing anything else, then you ma ... Bissell 6595 Lift Off Bagless Upright Vacuum

Burning smell When i start up my vaccuum it gives off a burning smell, it still picks up & operates like it should just leaves the house smelling like ive had a fire. Any advice on how to fix will be greatly appreciated.


Replace the belt. It is probably stretched and is slipping. This will produce the smell your describing. These belts should be changed at least once a year. ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?


It may be the roller bearings? ... Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or anything. The only thing that seemed weird was that the smaller belt that actually attaches and turns the roller is a bit loose. The larger belt is tight but looks like its the one that is burning and causing the smell.


Better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the belts.it will cause the new belts to run unevevly and go bad before their time ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I just bought the LG200R vacuum. It is working wonderfully but i have only had it a week. I have already had to clean the agitator but this is due to my extremely long hair and apparently i shed a lot. I was wondering if i should be alarmed by the funny smell it leaves in the air. Its not like a burning rubber smell but more like a fresh plastic smell or sorta chemical like smell (hard to describe) and it doesn't need to be on to make this smell it seems to be permeating off the vacuum itself


... LG LUV200R Bagless Upright Vacuum

Kenmore progressive model 38812790 smelled like rubber burning then the brushes stopped turning. Does it have a belt, if so, how do I get to broken belt to replace?


... Kenmore Vacuums

Sewing machine Guru needed ;) Elna Grasshopper (new to me) circa 1950 The light works, but there was no hummm when knee pedal engaged. I have the motor out, and it is very stiff to turn. I'm at a total loss when it comes to motors and electricity. It doesn't smell burned, doesn't smell at all beyond normal machine smells. (Yes, I made detailed notes and diagrams as I took said motor out!) One other note. The long thing which my husband said might be a capacitor -- it looks like


I just purchased a fairly tidy Elna 'Grasshopper' sewing machine (1951) with the same leaking capacitor problem. I carefully removed the capacitor for examination. It is actually three capacitors in one - no chance of a direct modern replacement, but ... Vacuums

I heard that a class action lawsuit against Oreck Vacuum is being started because of all the problems customers are having with their vacuums. Does anyone know about this? My Oreck is only a couple of years old and keeps burning up belts. I took it in after only one week of usage when I started to notice white smoke coming out of it and the smell of burning rubber. I feel like I got the old run-around, when the service tech told me he couldn't find anything wrong (but replaced the burned up belt


You are correct about the fact that legal action has been taken. Go to this link to read more\015\012\015\012 ... Oreck XL2200 Bagged Upright Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

I've got a Kenmore canister vacuum, Progressive 236123, and there's a burning smell from the belt side of the head--smells a lot like hot rubber. I've cleaned the agitator and changed the belt, but I still get the smell. It's stronger when I'm using "carpet" mode than when I'm using "bare floor" mode. Any ideas what the problem is?


... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0655 seconds