Having problems with your Vacuums ?

Strong smell frommachine, some smoke which has now stopped.removed filters, found them greasy. cleaned the filters & dust container. NO LONGER ANY SMOKE.MACHINE GIVES OFF STRONG ODOR AS WHEN NEW.IN USE 15 M0NTHS. USED ONCE WEEKLY.


Answers :

If it is a rubber smell, replace the belt and/or brush roll. If it is an electrical smell, then probably the motor has gone bad.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Strong smell frommachine, some smoke which has now stopped.removed filters, found them greasy. cleaned the filters & dust container. NO LONGER ANY SMOKE.MACHINE GIVES OFF STRONG ODOR AS WHEN NEW.IN USE 15 M0NTHS. USED ONCE WEEKLY.


If it is a rubber smell, replace the belt and/or brush roll. If it is an electrical smell, then probably the motor has gone bad. ... Vacuums

It starting to put out a hot type smell. I have tried cleaning the filters real well and even tried to see if there was problem with the ozone filter. We have checked and could not find a jam. I know the hose has excellent suction. The vacumn works but the intelliclean sensors will not. It only takes about 15 seconds or so for the odor to start. Then it gets real strong and it makes my eyes water


Hi,The hot smell could be from the belt or the motor. Turn it on for a moment, turn it off, then flip it on its side and smell the belt that drives the brush. If that is where the smell is coming from, then your belt is burning up. ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

Craftsman wet dry vac no longer sucking enough to use, cleaned the filter, sounds strong but barely works??


Buy a new filter. Make sure hose is cleaned out. Sometimes if the filter is wet and not allowed to dry it will do that. Also make sure hose is on the right outlet ... Craftsman 17762 Wet/Dry Vacuum

My kenmore hida filter vacuum cleaner no longer has the sucking ability it used to have. It is only 4 years old and has worked extremely well up until this week. The motor is functioning well, as is the carpet brush function.... it just has a very weak suction... Is there any easy way to tell if it is blocked? An ideas of what is going on? thanks


Well i've hade one come in a while ago and it didn't have good suction so I looked at the bag it was buljing w/ dirt so I put a new bag in it and it had better sucktion but still not good enough so I cheched the fabrick filter and it was dirty too so ... Kenmore Whispertone 23312 Bagged Canister Vacuum

My vax won't **** dirt up but suction feels strong when I put my hand on the end of the pipe. I've checked it's empty,cleaned the parts including the filter and there aren't any blockages. What else could it be? What can I do to fix it? It's a model 121 (orange) and about 17 years old (worked fine until this week) Thanks in advance!


... VAX Appliances Vax X5 Bagless Upright Cyclonic Vacuum

Nilfisk Family Vacuum - Strong Awful Odor


Not sure what a bacteria smell is perhaps you mean a mildew type smell. If you have picked up something wet, start at the front of the vac and work your way to the exhaust.Change the front most filter first. Baking soda may help to eliminate so ... Nilfisk Family Vac Bagged Canister Vacuum

I had a gasoline spill in the car and after a week or so, it was still strong. I set the purifier in the car and set the sanitizer on high for about 2 - 3 hours. Now the sanitizer smell is very strong and it has been a good week since I did that. Can this be harmful for me and my passengers?


It might make you high. this is dangerous when driving because you can become dizzy. See if you can get a steamer off of a friend and try steaming the carpet/seats, or where it spilled. in the water add a cup of vinegar. ... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Vacuum emitting strong odors when it's on.


Hi there SmartAlec from NelsonVacuums.com.au here. I am a nilfisk vacuum agent and although i havent actually worked on one exactly the same as yours there are no Nilfisk w ... Nilfisk Family Vac Bagged Canister Vacuum

I have a Dyson Animal DC 28. It vacuums fine on floor mode, but, when locked in the upright position it releases pressure though the little valve behind filter a. I have only had it for 2 weeks so I'm hoping the filters don't need to be cleaned this often! I would like to finish vacuuming without waiting 24hrs for the filters to dry.


Unfortunately with any bagless vacuum the filters do need to be cleaned or replaced very frequently for the vacuum to perform. But the good news is it sounds like you have a clog in the hose. remove the attachment hose as you would be using it and un ... Vacuums

My filter is always full of dog hair on my animal. What is causing this. I have to clean the filter each week . Dirt seems to always be trapped in the filter also.


I have same cyclonic as you.  I also have a Miele Pull-along.  I use the cyclonic for fine dust after picking up the hairs with the Miele.  Much quicker in the long run.  Otherwise I would waste a lot of ti ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I'm not really a technician, but I used to sell Filter Queens and was taught how to maintain them, and have tackled "fixing" some problems. I am a 71 year old great-grandmother of 8, but have good health and am very active. The Filter Queen I have is r, usedeally old, and I have kept it up. Just this week, however, I turned it on and it had a noise which sounds like something might be loose in the motor. I have always been very careful to have a clean hepa filter to protect the motor, so I know


It's tricky to hold screws with one hand and screwdriver with other hand; however, I am 65-yr-old female and do it yearly with 100% perfection! Take a break, relax, and try again! I sit on floor, put attachment between legs for supporting vacuum, h ... Filter Queen Majestic Canister Vacuum

I recently bought an upright MC-E4061 and have a problem with the paper filter clogging prematurely, it needs weekly cleaning. The filter clogs too easily with the main plastic bowl having very little debris! Our older panasonic, used daily, is not problematic. Please could you advise as the paper filter is time consuming to clear.


... Panasonic Vacuums

I need to replace the hepa filter on my Typhoon vacuum cleaner model T4505, however I cannot find a supplier of spare filters. Vacuum no longer picks up efficiently


... Typhoon Vacuums

Miele cat and dog filter problem. Miele told me when it pops up this means it needs changing. It was changed two weeks ago and has popped up again. This can't be right.


... Miele Vacuums

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

My kenmore cannister vac (model 116.27514) has a slight burning odor after operating for a few minutes. We have removed the hepa filter and it looks like there is a strip of foam curled up behind the hepa filter compartment. Could that be the problem? How do we access that area? Thank you.


... Kenmore 22822 Canister Vacuum

The roller turns strong and the belt is new,but the dirt accu-mulates and doesnt get sucked up! there no observable clogs and the filter side vent blows strong.......ive removed beater,belt and am assuming there may be a problem inside the motor housing as all else appears normal..i was an aviation mech in the military and the above is my assessment........


Are you sure you have the belt on correctly?\015\012If it is not, the beater brush will push the dirt, etc, in front of itself and not back to the suction port. ... Hoover Tempo Widepath Upright Vacuum - Blue

The filter gives red light.Does this mean the filter must be washed or changed. How should it be washed, what does ''washable'' mean here?


Red light normally denoted filter is blocked. If it is a washable filter then wash it. If it liiks like a paper type filter, replace it. Washing it will make it clog up even more. ... Electrolux Oxygen Z5540 Pet Lover Vacuum

I have a Neotec XJ-2000 ionic air purifier. On the bottom of the device, it says I should open the casing and take out and clean the dust filter every month. I haven't done it in years and no longer have the manual. How do I open it up to get the dust filter out?


... Vacuums

Hepa filter does not turn on hoover wind tunnel vacuum model U6630900. It was working (turning) and I cleaned the filter and canister and now it no longer spins when the vacuum is running.


The part you refer to is not the HEPA filter. It's a very common misconception that that part spins - it looks like it when there's dust whirling around it. In fact, it does not spin - there are no visible moving parts. ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

I have a Eureka Altima vaccuum and it no longer suctions like it use to and also has a burning smell. I have cleaned all filters, brush, hoses, and filters. There are no blockages. I have also checked the belt and it's still good. Any other ideas as to what may be the problem?


This bagless model gets buildup of really fine dirt in the motor and starts to clog up the fan airducts. You will need to take the motor out and clean it. ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I HAD MY DC17 VAC FOR 3 YRS NOW NO PROBLEMS AT ALL, I REGULARLY CLEAN THE FILTER LIKE IT SAYS BUT LATELY I'VE NOTICE THAT THERE SEEMS TO BE A LOT MORE COLLECTION ON THE TOP OF THE FILTER WHEN I'M DONE VACUUMING. IT HAS ALSO STARTED THIS WEEK TO MAKE A VERY LOUD HUMMING TYPE NOISE WHILE RUNNING, I HAVE CHECKED FOR ALL POINTS FOR ANY BLOCK AND NOTHING AND NOW TODAY IT RUN A FEW MINUTES AND STOPS AUTOMATICALLY,IT WILL RESTART AFTER I LET IT SIT UNPLUGGED.WHATS UP WITH THIS THING, IT HAS BEEN GR


The vac is over heating. First, you should try a new filter. Also, keep in mind that after cleaning the filter, make sure that it fully dries. Using a wet or damp filter clogs it quickly. Second, turn the vac upside down and make sure that the roller ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I purchased a hoover windtunnel 2 model#u8361900 in Dec 2007.I am very disappointed because the self cleaning filter is not turning and particles keep clogging in that area. I have manually removed the particles but the filter will not turn.I also haven't been able to use the pet brush for some time.The cleaner has not been used hard about once a week since it was purchased.I am not happy that this product has stopped working effiently since purchased 6 months ago. Thank you Marcia Long Pottstow


The filter stands up right.the bottom goes in first then snap in the top.turn it by hand and you should hear it click if you have it in right ... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I bought an Electrolux Accelerator vacuum cleaner with a HEPA washable filter last year, and now it won't **** strongly. I think its the hose pipe. I clean the filter every time we use it. I am really frustrated! Any ideas?


Check the suction port it is probably stopped up or take the filter out and crank it up see what happens ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0431 seconds