Having problems with your Vacuums ?

I have a Kenmore upright vacuum cleaner Model No 116.35922500 and the orange and red lights stay on all of the time. I have cleaned out the round tube where the bag fits like the manual said but it still happens

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Kenmore upright vacuum cleaner Model No 116.35922500 and the orange and red lights stay on all of the time. I have cleaned out the round tube where the bag fits like the manual said but it still happens

... Vacuums

I have bought new Hoover bags on two occasions. The first spares I bought were the Xxxl variety and I didn't think they fitted that well. The next spares I bought were the type g megafilt. I still feel like they do not fit that well and the suction power on the vacuum is not as good. I'm I buying the correct replacements? I followed the guidelines on the Hoover bags the vacuum came with. These were printed as the right bags to buy. I only have the vacuum around a year and thought it was brillian

... Bosch BSG71310UC Bagged Canister Vacuum

I own a Miele S5210 vacuum cleaner which has stopped working. It looks like the dust bag wasn't fitted properly and the machine is very dirty and the filters are completely clogged. I've cleaned it up as best I can and have replaced the filters but it still won't operate. How can I get inside the casing to clean the inner motor compartment? Thanks Tom

... Vacuums

I have a Flotec shallow well FP4122-08. A burglar stood on the pump this summer to gain access to my goats building (window). There's a small black tube that came off at both ends. When I put the tube back on, it shoots right back off as soon as the pump is plugged in. I don't know the name of the part (tube) to order a new one, and I don't know if it just plugs onto the fittings of both ends, or goes into the pump at the end with the round fitting on it.

... Vacuums

I was vacuuming and noticed that the bag needed changing. the red light with the ! inside the triangle also came on. When the bag was changed, the vacuum would not restart. The red light came on. Tried the reset button but nothing happened. Tried unplugging and re-plugging in and nothing happened. Replaced all the filters and still it wouldh't start. So I brought it downstairs and tried one more time to get it to start. it worked! Is there something wrong with the vacuum cleaner? Was it overheat

It was overheated that is why it worked downstairs after cooling off. ... Miele S548 Bagged Canister Vacuum

I have a Electrolux Epic 6500 SR canister vacum cleaner. It is nine years old and for the past few weeks it has started shutting off for no apparent reason.The symbol for bag change lights up and it cuts off, but even after I have put a new bag in, it still does the same thing. Do you have any suggestions? There is a little button or switch that the top of the bag fits on. Do you think it could be the problem?

Your machine is probably clogged, look through the wands, look in the bottom attachment, to see if there is anything stuck there. You can also drop a marble through the hose itself to see if anything is stuck there as well. To unclog the hose try hol ... Electrolux Harmony Canister Vacuum - EL6985 Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?

There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

** suction The best way to describe it is that when I was vacuuming I could see dust clouds at the front of the vacuum where the light is swirling around in the air. It was like it was blowing dust around instead of picking it up. I checked the tubing and found that it was clogged with some paper and hair ***** etc.... So I cleaned it out and tried it again and it still was not picking up properly. I had my husband take all the tubing apart to check for other clogging and there was none. When I

You have an airflow problem. You may still have a blocked intake or tube, also check the filter. The air is supposed to go in the bottom (of course) and I'm sure you k**w where it goes out. You probably can **te a reduction in exhaust. If this is ... Oreck XL Ultra Bagged Upright Vacuum

Sebo x1.1 fitted with new bag and filter but red bag check light still comes on and then machine shuts off. Any ideas how to remedy?

Without doubt this indicates that there's a blockage somewhere. The two easiest places to look are: 1. on the underside of the machine there's an inspection flap - check in there; 2. remove the flexible hose completely from the machine at both ends - ... Sebo Automatic X1 Bagged Upright Vacuum

I just purchased a deni 3500 to processe my deer meat. i stuff the 1 lb. game bags with sausage. to my supprize this machine is a #5 grinding head. where can i find a 2 in. stuffing tube to fit this grinder so that i will be able to stuff these bags ??

Hello. Here is the link to the parts you seek. http://www.thegourmetdepotco.com/store/store_manufacturer.asp?manufacturer=93 ... Vacuums

Clogged vacuum Rather stupidly, my boyfriend 1) were vacuuming without a bag and 2) vacuumed up a big piece of cotton from a sofa cushion. And now it's making a horrible noise and I see it vibrating where the tube connects to the machine. When you look inside there's a white thing sticking out but it looks like it's part of the vacuum. If it's a clog, how do you fix it? I tried unscrewing the tray the bag sits in but it won't budge.

You can start by taking off the bottom plate or top cover, which ever comes off, that is where the inlet starts going in and hopefully the clog is there. Could be in the hose also. But without the complete model number I can't look it up to see a p ... Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

My vacuum turns on for a second and shuts off. I have replaced the bag and filter, and it still happens. The replace bag light turns on after I do this.

1. Detach the hose and turn on. If it runs, place hand over opening. If it shuts off, the control valve assembly is dirty or worn out and needs cleaned/replaced. This is a job that should be done by an authorized Aerus Electrolux service tech. I ... Electrolux Epic 6500 Vacuum

We have an MC-3003 vacuum cleaner which keeps cutting out. We've changed the bag, but the problem still occurs with a new bag fitted. Could it be an electrical fault and is the machine repairable?

... Panasonic Vacuums

My nilfisk action sucks for a few minutes then over heats and sometimes blows dust out and the bag explodes. The pipe is not blocked and I have cleaned filters and put a new bag in but still thesame thing is happening

Their has to be an obstruction in the system causing this issue ... Vacuums

I replaced the belt in our Eureka Boss Smart Vac, it still seems loose, it uses a type R belt. The beater belt still doesn't seem to turn properly and seems that it doesn't pick up very well when I use it on my berber carpet. We have 2 dogs and I like to use it frequently. I have changed the bags and belt......

Check to see that the beater brush is not frozen up. Pull the brush and clean it, spraying some WD40 on each end piece that holds the brush in place.\015\012Also be sure the belt is properly installed so that the brush turns in the correct direction ... Eureka Vacuums

Hello, we have a Miele cat and dog turbo 5000 vacuum cleaner which we bought in December. It has just started blowing air out of the grid on the top of the cleaner instead of sucking from the tube. The whole top section which is opened to change the bags doesn't seem to want to clip down properly either. Do you have any ideas> I'm gutted as it was so good until this happened. Thanks Michelle.

The lid not closing properly is almost certainly the cause of your problem. Without that lid sealed tight to the body you will get no suction through the hose. So, the question is: why isn't the lid clipping down properly? Did you just change the bag ... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Vacuum motor overheating. Never happened before till last nite and today. It seems to be getting hot and tripping an overload switch or something like that. Starts back up after a long cooldown. Roller brush will still come on, even though the vacuum motor will not. Any idea what may be causing that?

... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

I have a Eureka Pet Pal and it seems to have lost suction on the main part of the vacuum. It looks like it sucked something up before it happened so I'm fairly sure that the tube is clogged but I don't know how to take the vacuum apart so that I can clear it out. Is there anyone out there than can help me figure it out?

... Eureka 2991AVZ Bagless Upright Cyclonic Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

35922, sounds like there is a clog , have cleared hoses, put new bag in loss of suction, still hear loud clogged noise near rear vent hole

Try putting the vacuum hose end into vent hole while running. That may dislodge the clog. Otherwise, you will need to disassemble the machine far enough to get to the clog area. ... Vacuums

My shop vac is plugged. The hose is clear. The filter is removed. The filter bag is not installed. It still won't draw a suction. It sounds like it is plugged. The motor whines at a higher-than-usual pitch. What can I do?

Turn off the vac, take the head off of it and remove the filter paper. Inside, there's a white ball (bigger than golf ball, smaller than baseball) that's inside a cage. This is designed to keep water out of the blower when the vac tips over, and sh ... Vacuums

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.

Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums


You probably have a bad motor bearing. I don't know if the motor is available now or, these older Fantom's are obsolete along with most of their parts. ... Vacuums

I have an old hoover turbopower approx 1986 i think its a U1102, the prob is it doesnt pick up anymore and i wondered if it had some sort of filter on it, ive cleaned all the tubes put new bag on but its still got weak suction, could you make any suggestions, thanks

Theres a tube that come up and emty's into the bag that tube is clogged.take the bag out and get a coat hanger and put a bend in it so the end is round then work it down the tube to push out the clog ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0650 seconds