Having problems with your Vacuums ?

I have a Janome Model 556, purchased in 1968 in Zimbabwe. I need to know how to replace the wires of the foot pedal. There were 4 wires used to go into the small plug attached to the machine, however the wall plug only had 3 wires.

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Janome Model 556, purchased in 1968 in Zimbabwe. I need to know how to replace the wires of the foot pedal. There were 4 wires used to go into the small plug attached to the machine, however the wall plug only had 3 wires.

... Vacuums

We have inherited a Filter Queen Majestic Triple Crown Model 99C vaccum and have no owners manual stating the year it was purchased and parts available. Our power hose electic wire connection (about 6 inches long) which plugs into the main unit is split in the hose attachment end. The motor sound went instantly quieter and I wondered if this was why when I found this frayed electical wire. It has not been used since this problem was found. How much is this single replacement part? I live

... Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?

You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?

Open this manual to page 18 and clean all the filters listed to restore air flow.http://www.managemylife.com/mmh/lis_pdf/OWNM/L0908343.pdf ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Hello, I,ve just bought an Italian designed 3 bulb 70's wall lamp. It has a 2 wire lead feeding out with 2 wire lead running from one bulb socket To the other 2 inside the casing. I'm trying to wire it in my porch which has 3 wire cable coming from a 13amp plug for power. Any suggestions on making this work please ?

... Vacuums

We have a dyson dc 07 animal the machine was working fine then switched off after returning to the machine minutes later it wouldnt switch on, i removed on off switch cover and used a short piece of wire across the brown wires flicked the wall switch and it worked, aha i thought faulty switch aquired a new one to no avail and now even the short piece of wire trick doesnt work, has the motor died do you think, it wasnt over heating or making strange noises prior to refusing to work

It could be the motor. I'm having to replace the brushes on my DC 05. It appears that you can only get brushes for the YDK motors in the DYSON, not the Panasonic motor. Which might be saying something about the YDK motors. What happens is that the ca ... Dyson DC05 Cylinder Bagless Canister Cyclonic Vacuum

I have an older model F6056-900 Hoover steamvac Spin Scrub Cleaner. My first problem was that I loaned it out to a friend. Anyway she ran over the hose (used for attachments) with her car. I tried using the cleaner for carpet cleaning this morning but when I tried to put the solution tank into place...its loose...won't snap back in like it used to. When I can get it somewhat in place the solution just complete drains out through the bottom fo the tank. The leak is where the small hole on the bot

... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

My Kirby shampooer - G4 - hardly used any water from the tank and no suds at all. Pet hair did blow out of the small slotted holes in the tray as I moved the shampooer back and forth, but the carpet was basically dry. I did vacuum before shampooing, so the brush part seemed to work great during shampooing, but no water! The small screen was stuck in the crook of the hose that attached to the tank so I did get that out and put it on the small hole on the tank, but it didn't make any difference. I

Few things:Make sure the sponge and the valve under the sponge (water tank) is clean.Make sure you follow the instructions (f you do not have the manual you can find one ... Kirby Ultimate G Bagged Upright Vacuum

The power brush floor rug attachment on my Eureka 6997 A Oxygen Canister Vacuum goes on an off as I use it. I replaced the The power cord from the handle has 2 plug in connections: 1 at the handle / upper wand 1 at the lower wand top of the power brush attachment I replaced the entire wand assembly and it worked great for a year or so and now it's doing the same thing again. I was told to keep the power switch on the handle set to off when connecting the power brush attachment or it will bu

This is from the prongs not making a good connection causing an arch inside the plugg causing what looks like rust on the plugg. I would try snugging up the connection by squeezing the female section to get a better connection on the prongs when it i ... Vacuums

DC07 DYSON REPLACEMENT HOSE. HOW DO YOU REMOVE IT FROM THE HANDLE. I have a kenmore whispertone 8540 canister vaccum. The electrical wires (3) to power the beater are embedded in the hose, in a spiral fashion. The yokes that hold the hose on both ends (and attach to the beater on one end and the unit on the other) have no screws or pressure latches; i don't want to use brute force as i may damage the attachment device inside the yoke. If someone can tell me the trick to get these yokes off each

Should be a pry off dot on the underside revealing a screw ... Vacuums

Vacuum tube is obstructed at curve next to roller. I'm unable to clear it using a chop stick. vacuum functions when tube is used w/ attachment for small areas.

Do not give up... Now try wire coat hanger to clean out. Restriction of air flow will burn out your motor, eventually. ... Bissell Vacuums

Makita 440 Dust Extractor - Trying to rectify a problem, when i switch on an appliance plugged into the socket, it will not run. IS used to run with this plugged in, but the hoover motor runs no problem. Any ideas what might be amiss, or where i can get a wiring diagram? Thanks in Advance!

... Makita 440 Wet/Dry Vacuum

Hoover wiring the blue wire that is in the lead that runs from the hoover to the plug that goes in the wall has come loose at the hoover end and has come out of the actual hoover. i've unscrewed it but am unsure as to where the blue lead (bare copper) needs to be screwed... if you see what i mean?!!

Hello lukeplayer,\015\012Based on your description, ( first disconnect the plug from the wall recptacle).You will need to open up the Hoover Vacuum Body to gaion access to the internal wiring. In order to better assist you, please provide me wi ... Hoover Vacuums

My Panasonic performance plus platinum vacuum cuts off and on while using the beater bar, this doesn't happen at all using the stair cleaning attachment. It appear electrical contact is being lost where the lower plug makes contact.

The solution to my problem which is located at the lower electrical plug on the long wand was to expermint using a nickel and placing this in an area where the long wand connects with the beater bar section, here there is a gap which allows too much ... Panasonic Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto

Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

I have had my Bissell Healthy Home for just over a year. I use it once or twice a week on five area rugs and two small bedrooms with wall to wall carpet. Just recently, the motor started to sound extremely loud and it smells like it's burning. The vacuum still picks up everything and all the brushes are turning. Advice? I really like this vacuum and would really like to fix it rather than replace it!

Hi,Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...Bissell Bagless Upright Vacuum no ... Bissell 5770 Healthy Home Bagless Upright Cyclonic Vacuum

I was vacuuming with an attachment, the vacuum began to loose suction and the hose collapsed, then the vacuum stopped running. I have turned it off and continue to plug it in off and on, using different plugs. It will not turn back on.

Hi there VacuumGuru for www.vacuumspot.com.au here. You have got yourself a blockage in the hose is all. The reason it wont turn on is because that machine has a thermal cut o ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce

I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum

The last time the vacuum cleaner was used the outlet sparked causing it to smoke when turning on vacuum cleaner. I replaced the outlet and plugged it in and things seemed o.k. Today I turned on the vacuum, it stayed on for a mili second and went off. I checked the switch on the vacuum and it showed voltage coming and going, but would not turn on again. I checked all the wires in the area of the switch all seemed o.k. I thought maybe there might be a short in the cord. When I went to plug

... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum

Have a 2yr old Broan VX6000C built in vacuum. Has power when plugged in I have disconnected unit from the wall and the wires to the outlets are also disconnected and the power unit still runs as soon as it is plugged in???

... Broan-NuTone Vacuums


You can download a PDF version of the manual at the link below. I believe you can contact Hoover as well and they might mail you one.http://www.hoover.com/CustomerService/Manuals/Default.aspxGood Luck! ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

The Power carpet sweep attatchment when plugged in runs on and off intermittitly. (Cuts on and off) It has barely been used What is wrong I don't see any loose wires

Try pushing into valve just a little more. If that doesn't solve the problem, it's probably a loose wire in the hose, wands or power nozzle. Could be the circuit breaker in the power nozzle. Contact your installer or a local vacuum cleaner repair cen ... Electrolux Central Vacuum

I have a cheap stereo with a flimsy wire that plugs into the wall. Is there anything that can be done to strengthen the reception?

Hi,The only Feature you could add is to Find a Compatible Signal Amplifier. These would Improve the Performance of the Stereo.Let me know, if needed further assistance.Hope i helped you.Thanks for using ... Vacuums

Old Sanyo 1500 watt "Power Control" vacuum cleaner. I need to remove the plastic covers that are attached to the on/off switch and the power cord recoil. This will allow me to remove the retaining screws for the upper motor cowling. The motor and wiring is clogged with wood dust and I want to blow the dust out using compressed air.

... Sanyo Vacuums

The electricity in the apt attached to my house lost power in two of the walls. It happened when the cleaning ladies I think were using a vacuum, they don't speak english very well so I'm not sure. I have looked at the circuit breaker a # of times and nothing seems to have been tripped. I have also inspected the outlets and they seem to be fine. Can you help me?

Even know the breaker doesn't look tripped it might be. You have to flip it all the way off and then back on again. That is most likely what has happened. If that doesn't work check to make sure a GFI hasn't tripped. They are usually loc ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0571 seconds