Having problems with your Vacuums ?

I have a kenmore Model # 116 22100400 about 6 yrs old and I can not get any power to the machine, I was using it and it stopped and will not go anymore. I have changed the bag, checked and cleaned the filter and no power when plugging the machine in and turning the button on.


Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a kenmore Model # 116 22100400 about 6 yrs old and I can not get any power to the machine, I was using it and it stopped and will not go anymore. I have changed the bag, checked and cleaned the filter and no power when plugging the machine in and turning the button on.


... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!


... Miele Vacuums

Poor suction I have a hoover hush s5627 vacuum purchased about 4 years ago from Costco. It's suction power isn't so good anymore. I've checked all the lines & hoses and they're clear and I've changed the bag. I even disconnected the pipe from the vacuum unit and held my hand over the intake. While the machine roars like a jet engine the suction power just ain't like it used to be. What could possibly be the problem?


This vaccuum has a Fan Blade inside connected to the motor that spins to create the suction you feel. After a few years of use (and misuse) the blades on this (plastic) fan will be broken off, thus damaging the unit. These Fans are replaceable if yo ... Vacuums

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.


You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

No power to sensor SR 12. I also have cleaned rollers and filters and bags. I have reset the handle. When I hit the power the check brush and full bag lights flash once. That is the only power that is getting through.The unit was in storage for a bit and got wet but its been drying off for a couple months. Is there something I can check or replace. Its a great Vac.


... Windsor SR12 Sensor Bagged Upright Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!


... Miele S7210 Bagged Upright Vacuum

I have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.


... Hoover Company Wind Tunnel U53019 Upright Vacuum

Have a hoover windtunnel platinum. I have changed the bag ( hepa Q bag) but the bag light wont reset. so the vaccum wont turn on. I have unpluged it and let it set for a while with the new bag in and repluged it in. I have checked the brushes and it is all clean but it will not reset. This only the second bag so it is a new machine I should not be having problems. Is there some sore of reset button I can hit.


... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

My Kenmore Progressive keeps burning up belts even after I have changed the bag, cleaned the filters and checked to make sure the agitator was clean and free turning


On the left hand side, just above the handle release, is a lever to adjust if you are doing hard wood or carpet cleaning. When adjusted for hard wood, that lever releases the belt and just uses the "vacuum" function. When set for carpet it engages ... Kenmore Vacuums

When I plug in my vaccum the power light turns on, but i get no power to the machine??? I changed bags and filters and still nothing??? Can you help?


That light wire is attached to part of the wiring that is just a piece attached to the main wire coming from the switch. Your bags and filters have nothing to do with powering the machine. You may have a bad switch or there may be a ground wire off ... Vacuums

Vacuum My vacuum is loosing it's suction power. I've checked the belt and it's in perfect shape...I've bought a new filter cup...I've checked for clogs and there aren't any...I've cleaned the entire machine...and I still can't find the source of the problem.


You checked the belt, but I bet it has stretched and won't drive the brush roll under load like it should. Belts only last a few months the stretch and should be replaced. Iff you have suction at the hose, then it has to be down below, either belt/ ... Eureka Whirlwind 4480 Upright Vacuum

I have a new scoba (irobot) the battery is charged the tanks were fillied and every time i hit the power button and then clean the machines "check the tank" light came on. i have done all the proper instruction checks an i have done all the trouble shooting section. the machine will only work (and that is for 5 minutes drying its head) when i hit power and the clean button twice. so obviously the machine is somewhat working


We had to prime the sensor. irobot suggested a turkey baster, but we didn't have oneso we used an empty visine bottle with the end snipped off and rinsed completely. this worked after the first try. thank you for your interest ... iRobot 5800 Scooba Vacuum

Poor suction...I have checked hoses...have changed bag. Is there a filter that needs to be cleaned?


... Panasonic MC-V5217 Vacuum

I have a mile tt2000 that works fine up to 1300W but if I crank it up higher the motor decreases and increases speed every couple of seconds. I have changed the bag and filters and done the usual cheCks for blockages but can find nothing amiss. Unusually when it is running and I block the intake it will run at full power but as soon as I clear it the motor "hunts" again. Any ideas.


... Miele Cat & Dog 326i Bagged Canister Vacuum

Very little suction power - red light for poor performance is on, I have changed the bag, cleaned the filters, confirmed nothing is stuck in the hose


Make sure there are no clog ups in the hose ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Lost suction after I changed the bag and cleaned the air filter


The bag has a cardboard collar with latex. It must seal over the inlet. Make sure not to tear the bag when replacing.\015\012\015\012Is the cover closing properly? The cover seals against a gasket. The same with the filter. ... Riccar 8955 Upright Vacuum

Was using my Miele Champagne vacuum, powered down, changed the bag, and now I have no power. I checked to make sure all lids were securely closed, still no power. Checked to make sure outlet was working, still no power...help.


Most likely the cord went bad, one side of it opened up, you will have to replace the cord reel asm. if this is the problem, Could also be a switch, electronic control or the motor. ... Miele Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?


Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Hello, I have the same model. And though it is three years old, starting from the last month, it does not clean anything anymore. Cannot even pick up one single thing from the floor. Every dirt gets stuck in the hose. I cleaned the hose and cleaned the filters but it still does not pick anything up. Is three years its normal lifetime or do I have the change the filters, instead of cleaning them? Thanks.


I know bissell vacuums are very cheap but they should last more than 3 years. there should be two parts to the dirt cup. remove the dirt cup and above it there should be a round plastic part. unscrew it and check that filter. ... Bissell 6594 PowerForce Bagless Upright Vacuum

My electrolux 7000 shuts off red filter light goes on i have changed the bag, changed the filter. the slightest amount of interruption in suction (including reconnecting the hose) makes the red light go off and turns off the vac. Whats a clean freak to do?


... Electrolux Lux 7000 Bagged Canister Vacuum

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i


At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

We understand that your problem is: I currently own and use on a regular basis the Kenmore Progressive upright bagged vacuum. Model number 116.35923500. The headlight flickers and the intelliclean light stays red. Ive tried cleaning the intelliclean sensors, changed the bag, and cleaned off the agitator. Is this a power issue? Should I take it to the store? Any suggestions would be greatly appreciated


Welcome to fixya\012\012Hello\012\012 \012\012I have a solution for this ... Kenmore Progressive 35922 Bagged Upright Vacuum

I own a Miele S5210 vacuum cleaner which has stopped working. It looks like the dust bag wasn't fitted properly and the machine is very dirty and the filters are completely clogged. I've cleaned it up as best I can and have replaced the filters but it still won't operate. How can I get inside the casing to clean the inner motor compartment? Thanks Tom


... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1149 seconds