Having problems with your Vacuums ?

I have the Eureka The Boss Power PLus Model # 4703 Type A. When using the detached hose and wand it works OK; however, when using the Vacuum with the hose attached it doesn't work well at all.

\015 There is no debris stuck in the hose or around the brushes. It is an auto height adjustment model but the wheels do not go all the way down to the where the adjustment is located. I think it is missing a piece.\015

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have the Eureka The Boss Power PLus Model # 4703 Type A. When using the detached hose and wand it works OK; however, when using the Vacuum with the hose attached it doesn't work well at all.


... Vacuums

This vacuum is not picking up anymore when used as an upright, however it does still work very well when using the hose and attachments, I have looked at the vacuum but I cannot figure out where the clog could be.


Is the brush rotating?Have you turned it over, taken off the bottom plate and cleaned it out?Is the belt in good shape or does it no longer rotate the brush? Is it on the proper floor/carpet setting for the surface you are cleaning? ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

When using hose with attachments little or now suction; also is making a funny sound when machine is on and left idle; seems to be working fine when using on carpeting (picking up the cat hair and dust well ---- had to empty it twice in 20 minutes of vacuuming.


Try this link.http://www.youtube.com/watch?v=mwcLnjpn9Tg&feature=related ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

The power brush floor rug attachment on my Eureka 6997 A Oxygen Canister Vacuum goes on an off as I use it. I replaced the The power cord from the handle has 2 plug in connections: 1 at the handle / upper wand 1 at the lower wand top of the power brush attachment I replaced the entire wand assembly and it worked great for a year or so and now it's doing the same thing again. I was told to keep the power switch on the handle set to off when connecting the power brush attachment or it will bu


This is from the prongs not making a good connection causing an arch inside the plugg causing what looks like rust on the plugg. I would try snugging up the connection by squeezing the female section to get a better connection on the prongs when it i ... Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a Craftsman wet dry vac with blower capability (22 L). While I was using it to **** up water, the water came out of the blower hose. Now I can't get it to work as a vacuum. What can I do to fix this problem? Is there a toggle switch somewhere that allows me to choose vacuum or blower? Also, will the vacuum still work without the filter nut attached to the plate? Please let me know at your earliest convenience. Thank you.


... Craftsman Vacuums

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?


Open this manual to page 18 and clean all the filters listed to restore air flow.http://www.managemylife.com/mmh/lis_pdf/OWNM/L0908343.pdf ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Recently purchase SC-N500 vacuum cleaner. Worked well only the first 2 times I used it to clean up plaster dust from floor after sanding. Since then it has not worked at all well wiht very poor suction. Fluff gets stuck in the hose and has to be manually removed. Suction power is very poor. I have washed the filter to remove the dust with no difference. Who do I contact in Brisbane to service or assess the problem further.


... Sanyo Vacuums

I have a kenmore vacuum cleaner model # 116.23612. When the hose is attached to the canister it runs, but if you remove the head to just use the hose the unit stops working. Is the motor dead or is there some type of reset or fuse. Could you please tell me how to test this. If so could you please send me instructions on how to replace the motor. Thank you in advance for your help, Tony


... Kenmore Vacuums

I have a rainbow e series vacuum cleaner that quit working while vacuuming and will not come back on. I know there is a reset button on the wand sweeper but I was not using that attachment when it sh


<p>If you have the <a rel='nofollow' href="http://www.rainvac.com/rainbow-vacuum-parts">eSERIES</a> single speed model, then it could be the <a rel='nofollow' href="http://www.rainvac.com/motor-rainbow-120v-e">motor</a> ... Rainbow E series Canister Wet/Dry Vacuum

Hi I’ve got a Panasonic vacuum cleaner MC E468 1600W a few years old now but works well up to recent problem. Not picking up I checked the obvious things and found excessive air being sucked in around the hose housing at the back of the vacuum (as it enters the waste bag) On inspection it appears to me as if there should be some sort of gasket that may have perished and been sucked in, however I can’t identify any such part. Any thoughts on what the problem/solution may be will be appreciate


The hose on the back might be loose - check to see that the hose is not obstructing anything where it screws in at the back - or indeed the screws may be loose themselves; some of the MCE 468 models had an additional ring washer that sits between the ... Panasonic Vacuums

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head. Is there anything else I can try? Model Callisto


Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor. ... Miele Vacuums

I have a hoover 3000 i have not used in awhile, and since I removed a large rug, I would like to use it again on my slate floor. HOWEVER, I cannot get it to pick up ANY water in the water recovery unit......it is dry, dry, dry. I have put in a new filter, cleaned the nozzle unit, the scrubber , and reconnected both the recovery unit and the water unit several times, but to no avail. I would like to get a graut attachment a well as replacement part, but since I can't get the basic unit to work, I


Have you made sure the plastic filter cover with the round hole in it that covers the filter is in place ( part # 59177096 ). This piece seems to get lost, and without it there is no pick-up. The other common problem is that the wheel assembly has be ... Hoover Floormate H3000 Upright Wet/Dry Vacuum

Low suction I have a Hoover central vacuum system. I've reset the fuse box, checked the fuses, all of the lines are clear and there are no holes for escaped air to travel out. The filter has been cleaned as well. The vac works well with high suction when hooked directly to the unit, however when using any of the indoor connections there is extremely low suction. The machine still turns on so I do not believe it is an electronic issue. I have troubleshooted the issue as best I could and would


... Hoover L2310 GUV Central System Vacuum

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou


Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

Poor suction absolutely loved the machine when I first got it. I have dogs so it is getting a work out. however, the suction isn't as great as when I first got it. I have cleaned the washable filter and empty the cylinder after every vacuum. When I use the hose, the suction just isn't there. anything else I can do?


OK- I had the same problem and I took it to sears for service, It still wasn't great. So I proceeded to pull out all of the filters, including the internal filter that is not easy to get get to. I washed it and air dried it, put it all back together ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Hi, having problems with my Dyson DC27. It's worked very well for the last few years but recently i can't get the handle to stay attached to the base after using the wand causing the handle to


Hi there, it's Jack at Dyson.I'm surprised to hear that your wand isn't staying attached in use - it's engineered to lock securely to the machine when you replace it after use. Like all of our upright and cylinder vacuums, DC27 has a ... Dyson DC27 Bagless Upright Vacuum

I need to know how you attach the upholstery cleaner brush to the vacuum. I don't have instructions and I an use the shampoo but need upholstery brushes to work as well!


Hello, ckrsI was trying to help you out here. Maybe this will help some? I was going backto some customers that asked questions in the recent past and even fartherback. It appeared that no one answeredsome of them, So, I thought I would ta ... Kirby G4 Bagged Upright Vacuum

My Kirby shampooer - G4 - hardly used any water from the tank and no suds at all. Pet hair did blow out of the small slotted holes in the tray as I moved the shampooer back and forth, but the carpet was basically dry. I did vacuum before shampooing, so the brush part seemed to work great during shampooing, but no water! The small screen was stuck in the crook of the hose that attached to the tank so I did get that out and put it on the small hole on the tank, but it didn't make any difference. I


Few things:Make sure the sponge and the valve under the sponge (water tank) is clean.Make sure you follow the instructions (f you do not have the manual you can find one ... Kirby Ultimate G Bagged Upright Vacuum

My 8 yr old kenmore vacuum works well - however the hose has worn under the handle where there is a hole (resulting in decreased suction power). I'd like instructions on opening the handle and bypassing the worn piece of tubing rather than replacing it for $129. Some of the handle screws remove easily but the last one doesn't loosen easily.


Hi,Have you tried spraying the stubborn screw with WD40 and let it soaked for a while? Other than these screws holding the handle together, there would no other way of opening it up. Hope this be of initial help/idea. ... Kenmore Vacuums

Does the Hoover Elite 350 top-fill bag vacuum use hose attachments?


... Hoover Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after


... Vacuums

Carpet vacuum attachment quit working after sucking up a bedskirt. Bedskirt has been removed but carpet attachment will not work. My old vacuum had a reset button on the carpet attachment for use when the carpet attachment sucked up something and turned off. Does the Hoover have such a feature, and, if so, where is it? If not, how do I fix the problem and how do I keep it from recurring? Model # S3765-040. Serial # 100700081298. Purchased 2/08.


I have a Hoover Conquest approx. 4 yrs old. The turbo head is not working Model No. PB4 230-240V AC 50Hz 200w CS4901N (N127) I have been trying to locate another one or another one similiar to fit my machine ... Hoover Vacuums

Hose attachment not working well.


You don't say what model of Dyson you've got. It's listed on FixYa under DC14 Animal, but sometimes things get listed incorrectly. If it is a DC14, there are several places to check for blockages: 1. remove the wand and check it; 2. remove the hose a ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

On my DC17, the wand is not working right. The upright part works fine, but when I go to use the wand, the hose sucks in on itself. I get suction for a few seconds, then the hose collapses in on itself and no more suction.


... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1293 seconds