Having problems with your Vacuums ?

Vax 2400 performance pet. Suction too low/weak. changed both filters, but made no difference. hose clear although suction seems better without hose!

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vax 2400 performance pet. Suction too low/weak. changed both filters, but made no difference. hose clear although suction seems better without hose!

... Vacuums

My Bissell BS3920F upright (similar to the 10N6F) has been working wonderfully for the past 3 years but suddenly seems to not pick up dog hair as well as it used to. It has been pulled apart by my husband to ensure nothing is blocking the hoses etc and when running the suction seems to be there. It seems to grab the dog hair and leave it in a straight line directly under the unit without picking it up. I then disconnect the hose and use to hose to pick up the dog hair. This works well but obviou

Check to see if your brush is not worn down, they do wear with age - compare the length of the bristles with a new one. Replace the brush ir there is a significant difference in bristle lengths. Also check the flexible ben ... Bissell Vacuums

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom

Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I cleaned out the hose and removed brush to clean and checked belt. Everything seems to work but will not pick up or suction on carpet. The hose is totally clear from clogs. I can see the floor from one end to the other. What am I missing that might be causing lack of suction?

Hi troupdavid,I see that your Vacuum is having issues with it suction, you mentioned that you took it a part to clean it, see steps below.\015\012\015\012Check if everything is inserted prope ... Hoover Tempo Widepath Upright Vacuum - Blue

No suction I've only had my vacuum for a couple of months and it seem I have a similar problem but there is no clear blockage. It seems like I don't have adequate suction that reaches the accessory hoses nor the main one. I'm not sure where to start. I've taken the darn thing apart but I can't see any obvious malfunction. Any suggestions?

If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?

As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Dyson DC 14 hose has no suction, with or without brush attachments. Hot air shoots out from the base of the canister when I try to use the hose. I cleaned the top filter, but can't figure out how to remove the hepa filter to clean it without destroying the case. It looks like it might take three hands to insert pennies and "flip" the case open as is suggested on a youtube video for a different model. Would this even help, assuming I could get the thing open?

... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My dyson DC24 has very poor suction - all filters clean and hoses seem to be clear. had it for just over a year

Hi there,I'm sorry to hear your DC24 doesn't seem to be picking up as well as it should be. From your description of the issue, it sounds as if there may be a blockage in the machine - to locate and remove this, please follow the steps shown ... Dyson Ball DC24 Bagless Upright Vacuum

Vaccum does not seem to have good suction replaced bag & hose is clear

... Kenmore 23812 Progressive PowerMate Bagged Canister Vacuum

I have a eureka endeavor nls that does not have floor suction anymore although the hose is clear and the roller is working when on. what is going on...i am very frustraited because it is over heating

... Vacuums

We have a Russell hobbs power cyclonic pets 2000w vacum cleaner that seems to have lost quite a bit of suction, we have cleaned the filter and made sure there are no obstructions in the hose. We have only had the item for 2 months so would like some help with the problem. Regards Mrs D.Cook

... Vacuums

I have a eureka endeavor nls that does not have floor suction anymore although the hose is clear and the roller is working when on. what is going on...i am very frustraited because it is over heating

... Eureka Vacuums

We have two of these vacuums and both of them have experienced the same problems. First the floor heighth adjustment doesn't work and now neither one will pick up on either carpet or floor when in the brush/floor mode. They both seem to work with the suction hose function. We have removed the back panel to see if there was an obstruction but it was clear. We have changed the bag and the small filter (not the HEPA filter) all to no avail. What else can we do? We are desperate to use our vacu

Did you check the powerhead for obstructions? With a bend in the tube just below where the hose connects, this is a common spot for clogs. To check, detach hose and drop a coin in the hole. If it doesn't drop through, a blockage is present. Use t ... Electrolux Oxygen 3 Upright Vacuum Cleaner - EL5035 Vacuum

I have Bissell ProHeat 2X 9300-M that I tried to use again today. Is does not dispense solution when turned to Floor Cleaning, when switched to Hose it seems to be working fine. Brushes and suction are working as well. Soap and water containers are full. I took off and replaced tanks, waited to prime the pump multiple times without success. Not sure what is going on.

Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell ProHeat Turbo Deep Cleaner Upright Steam Vacuum

When I use the hose, it makes a hissing sound that wasn't being made before. The suction power seems to be not as strong.

Either you have a hole in your hose or there is a knob on the top of the hand that is open. ... Eureka Whirlwind 4496 Bagless Upright Cyclonic Vacuum

Kirby shampooer The suds are not coming out of the shampooer. I made sure it was connected right. The sponge filter and the cap are attached. i have a g4 vacuum and the screen in in properly.. if i move at a snails pace i can get spots of suds about every 6 inches or so but not a lot. i have adjusted the on and off, if verified the video its put together correctly but it acts like no suction .. i thought of a small hole in the hose for the suds and cut off about 1 inch it act better but not by

On the shampooer tank, remove the screen cap from the little hole that the shampooer hose plugs onto. Clean the screen and make sure that it is not plugged up with debris. Make sure that the screen is securely glued to the cap all the way around the ... Kirby G4 Bagged Upright Vacuum

My versatility electrolux vacuum is 2 years old and it has lost its suction, i have replaced the filters and checked every hosing area i have access to, it seems to all be clear. I dont know what else to do, it has a higher pitched whinnig sound when it is on

It sounds like the fan blades have worn away until there's basically no air resistance, thus no air flow/suction. The whine is created by the motor turning at a higher speed due to lack of resistance. \015\012The fan wasn't covered by the wa ... Electrolux Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

No Suction I get great suction in the hose, but when I plug the hose back into the unit, there is no suction and the air flow indicator line goes completely red. I've changed the bag and filters. I took the small panel off the back and made sure there is no clog, and took the hose off to make sure there was no clog there. Still no suction. Please help.

I about to say that's always a clog of some sort that causes that ... Miele S7210 Bagged Upright Vacuum

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?

There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

My dyson vacuum cleaner doesn't seem to have the same suction power it used to. I have cleaned out the canister and have taken apart the vacuum head (for cleaning carpets) and it doesn't seem to be blocked but it seems to lose suction by the time it reaches the head. The suction is strong at the end of the hose (where you attach the telescopic attachment with vacuum head) Any ideas? Thanks, Irene

... Vacuums

My Eureka/The Boss doesn't seem to have the suction power it had. However, when I place my hand under the hose, it has good suction, then when I try to pull in a small particle, it doesn't, unless I have the hose nozzle completely over the particle. The vac is 10 yrs. old. I cleaned everything. Someone said the belt. Would the belt matter if the hose doesn't **** well? It is just old and worn out? It did shut off recently do to overheating. Help. Thanks. Lorraine

Doesn't "The Boss" Vacuum have a filter? Perhaps your filter is clogged and not allowing it to work properly. ... Vacuums

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!

First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

No Suction I have the Eureka Upright Vacuum. I have no suction when doing regular vacuuming but it seems to have function with just the hose. Also, the height adjustment doesn't seem to work at all. The vacuum has only be usede 3 times. Thanks

Is your brush roller turning? unplug the vacuum and see if you can turn the brushroller by hand.if it turns real freely the the belt is broke ,if its real hard to turn then something is caught up around the bearings on the ends of the roller.my sugge ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0802 seconds