Having problems with your Vacuums ?

Old (60's /70's??) commercial type hoover guardsman upright: connection between bag or bag cover and the main 'vaccuum' became disconnected. Can't seem to reattach.

Answers :

\015\012Generic problem for all Vacuums
\015\012Old (60's /70's??) commercial type
\015\012Posted by jaqueshardge on Jul 07, 2008
\015\012Old (60's /70's??) commercial type Hoover guardsman upright: connection between bag or bag cover and the main 'vacuum' became disconnected. Can't seem to reattach.
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. Most of the older Hoover Comm’l type vacuums have a shake our bag with a slide on clamp – so you would keep the clamp & then either the bag usually is wired on @ the bottom of the fill area & would need to re-attach if the outer bag is still in good shape. If not then I suggest that you replace the bag and clamp if needed. include the brand name & model # with your request to either company. Questions? Contact the Hoover website or Hoover cust service @ the info listed below. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

\015\012http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

\015\012Thanks, Don the Vac Man
Go Ahead. Use Us.

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Old (60's /70's??) commercial type hoover guardsman upright: connection between bag or bag cover and the main 'vaccuum' became disconnected. Can't seem to reattach.

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=754094\015\012Generic problem for all Vacuums\015\012Old (60's /70's??) commercial type\015\012Posted b ... Vacuums

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?

Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

I cannot keep the bag attached to the handle inside the cover on my Oreck XL Vaccuum. When it comes off dust blows out into the cover instead of the bag which makes it very hard to unzip the cover.

There should be a spring ring that slides up over the bag on the handle if thats missing try and use a couple of heavy duty rubber bands. however i do suggest you order the correct part. ... Oreck XL Ultra Bagged Upright Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!

... Miele S7210 Bagged Upright Vacuum

Burning smell took everything apart suction is working throughout hose and bag, replaced bag and belt, roller is turning seems to be missing the suction from the main floor section into the roller?

I had burning smell and some visible smoke which I tracked down to the handle area. The mains socket at the bottom of the handle had burned out. When I pulled the plug out I noticed that the prongs were blackened and scorched. I will replace the sock ... Oreck XL Ultra Bagged Upright Vacuum

My Oreck XL upright is blowing out instead of sucking in. I changed the bag and cleaned the brushes; I also cleaned out the main "pipe." I looked for a place to change settings and couldn't find any, so I know I didn't inadvertently switch something. The brushes seem to be spinning at the correct speed. Thank you, Julia Byrem

... Oreck XL2200 Bagged Upright Vacuum

My sanitaire 9100 commercial upright seems have rubbing internally. Doe not pick up well at all. I've taken it apart - cleared all obstructions. The bag is fairly new. I'm stumped

When you take it apart, check the end play and lateral travel of the shaft in the motor that the fan connects to. ... Vacuums

Faithful Sebo X1 upright, about 12 years old, stopped working today. I replaced old with new dust bag, checked all dust paths were clear, checked main brush was clear/clean, and drive spindle rotated OK with fingers. When power switched on, the two red indicators briefly flash on then off, but nothing more happens, motor does not start - even with power reaching machine. Tried removing all consumables, refitting and turning on a few times to reset, no joy. Removed base cover, both belts were i

At 12 years, this vacuum has had a good long life. I suspect the motor is shot, but it could be due to faulty wiring and connections. A bad switch, break in the power cord, and worn brushes in the motor are other causes.\015\012I recommend ta ... Sebo Automatic X1 Bagged Upright Vacuum

We have Nilfisk Tempest 1500W bagged cleaner. It just stopped working and I have taken off top cover and all wires/contacts look OK. But power still not getting through I assume. The retractable lead goes into base and cant get to this area. How do I check main lead or perhaps you provide details of serviceman. On North Shore, Auckland, NZ.

... Vacuums

Cleaner stopped working, changed bag still not working. Have checked mains fuse and liittle fuse on printed circuit board. When cleaner is on moving slider to the off positon the LED's glow red for a fraction of a second. Reset button does not feel as though it clicks when pressed, it does not seem to move. Many thanks, Hugh

... Panasonic MC-E583 Bagged Upright Vacuum

I just purchased an Electrolux Epic 6500 SR, Model #C102G. I found that inside the cover over the bag. But where is the Serial number? I can't seem to locate that anywhere. Also, in case it breaks, I will need a light gray color on/off switch button located near the front of the canister.rnThanks.

The serial number is on the bottom of the machine. I believe near the front wheels, but can't remember for sure.\015\012Parts can be purchased at any authorized Aerus Electrolux store. You can locate the one nearest you using the below link. ... Electrolux Vacuums

I have an L shaped piece of metal with a hole at one end that fell out of my hoover elite bagged upright vaccuum cleaner. I repaired the belt but don't know where this metal piece goes. I think it has something to do with the wheel assembly which is replaced and it seems to want to stay there. any thoughts

This metal clip was for the wheel assembly, but not always needed. you can diregard the part if your vac is working correctly with the front wheels. ... Hoover Elite U5061-900 Bagged Upright Vacuum

I have a lindhaus ch pro commercial vaccuum where can i get bags and filters for it thanks

... Lindhaus CH pro Hepa Bagged Upright Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?

As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Havent used for about two years. I had to put the belt on it. It doesnt seem to be sucking up very well and after about 15 minutes of vaccuuming the bag was empty. My house got really dusty. I know the rollers were spinning because i looked. I could hear some dirt going in but could definatly tell it wasnt working properly. Is it in reverse or something?

After two years you need to make sure the bag is connected properly and inspect it for tears and that the hoses are connected correctly and not deteriorated. Make sure the hose is clear. You should be able to feel the suction at the end of the hose. ... Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

Hoover U6445-900 bagged self propelled Mach 6.9 brush will not turn, replaced belts, not the problem....housing cover seems loose & when manifulated the belt brush will turn. Any ideas on what the problem could be? Thanks!

... Hoover U6446-900 WindTunnel Bagged Upright Vacuum

My Windsor Sensor XP12 says the bag is full when it's not. I have removed the hose, brush, and filter and cleaned everything. I can put a bag on without the cover and it works great. However, when I add the bag to the front cover and close the latch the right way, it does not work. I'm thinking that the cover is not seating the bag correctly over the hole, but I can't figure out how to fix it. Any suggestions?

... Windsor SR12 Sensor Bagged Upright Vacuum

My Oreck is 10+ years old. The bag will not remain on the opening of the handle inside the bag. Dust goes into the cover rather than in the bag getting in the zipper which makes it very difficult to unzip the cover. Any suggestions?

Check and make sure bag collar is behind the two lips. if it isn't it will leak dust and make it hard to open. ... Oreck XL Ultra Bagged Upright Vacuum

My old bissell 3510 upright vacuum seems to have no suction into the bag...I replaced a broken belt several days ago, and now the vacuum picks up debris, but seems to just collect it behind a wheel..The bag does not "puff out" like it used to...How can I fix this??

... Bissell 3510 PowerPartner Upright Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

Bag is empty but it vaccuum still says bag needs to be checked?

You need to blow out the insides some how like with an air compresser ... Hoover U5227-930 Elite Upright Vacuum

My vaccuum has lost suction. I changed the bag and cleaned everything out. The vaccuum is only 6 years old. I even replaced the belt around the brush. When I turn the vaccuum on it smells like burning rubber. My vaccuum is an upright 12 amp model #33000300C serial #Y347012385

... Kenmore Vacuums

Dyson vacuum I have a DC07 vaccuum. The problem I am having is that the front does not want to stay down as I vaccuum and I continuously have to keep stepping on the front to make it go back down to the floor. It seems as though there is either not enough weight in the front or possibly the unit just has to be broken in so that there is not so much resistance between the handle and the front of the vaccuum. Could there be something I did not remove or is this typical on these vaccuums?

There is some thing broken it is two plastic cogs they help the front go down and stay up you will have to get a star screw driver and there should be two screws on top and two at the b ... Dyson DC07 Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0821 seconds