Having problems with your Vacuums ?

Kirby heritage 2 will not operate with hose on but with hose off it runs fine

\015 The vacuum runs fine with hose off but when I attach the hose it will not run. The power light will come on though\015

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Kirby heritage 2 will not operate with hose on but with hose off it runs fine

... Vacuums

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Kirby g6 My kirby is running louder than usual. Kind of like its screaming instead of running now. Its working fine, but the noise is really unbearable. What could it be?

Could be the bearings, especially if the machine is old or the dust filters have not been replaced regularly.\015\012Check to see if the noise is still present after the machine winds down when the power is turned off. A rattling sounds means b ... Kirby G6 Bagged Upright Vacuum

Motor runs fine and hose not clogged will not pickup dirt

This may sound silly, but have you checked the belt? A lot of Eureka vacuums use the vac motor to run the brush, and if the brush is not running the vacuum won't pick up. Another thing to check is the condition of the fan blades.. if they get worn th ... Eureka Vacuums

Electrolux 5000 light is on where it normally says chande out bag. vacuum still will not run with hose on. with hose off works fine.

Clear solution here - the hose is blocked.\015\012\015\012\015\012\015\012Using a blunt stick with blunt ends, remove the entire hose assembly and compact up with the stick. Wriggle the stick a couple of times and this should dislodge whatever ... Electrolux Lux 5500 Canister Vacuum

Lux 5000 Vacuum will start and then shut off with hose installed. W/O hose it runs fine

Some times that happens when the full bag indactor is broken call and ask electrolux or the guy that left his number what he thinks :) ... Electrolux Lux 5500 Canister Vacuum

Vacum runs fine with hose disconnected and soon as any pressure is put to hose recepticle including your hand it shuts off

These machines have a "Suction" sensor this has become blocked or gone faulty, or the microprocessor has... yes there is one in here too. Probably going to have to get it looked at? ... Electrolux Epic 6500 Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad? My Kenmore Progressive won't turn on today either -but was fine last week. I cleaned the filters checked for blocked air, tried a different outlet and no luck. I'll check the pins on the connections and see if one of them is not matching up or appears worn.

Give the prongs a wiggle and see if there is any play in them.Might just be a plug end. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Motor runs fine and hosed not clogged will not pickup dirt

Check your fan for damaged or worn blades, then following the flow towards the bag check for blockage. Does your bag inflate when the vacuum is on? If so, it is less likely that you have blockage, than it is that there is an issue with the fan. ... Eureka Vacuums

Vacuum shuts off, bag light on, runs fine without hose connected

I'm not sure if I understand your problem completely, but if it is your full bag indicator that is coming on, even with a new bag, it's probably your control valve. These can be replaced by your dealer. When working correctly, the control valve shoul ... Electrolux Epic 6500 Vacuum

For the first time, I tried using my Kirby Sentria shampoo attachment. I've lost the manual but found instructions online for making the swap from regular vac to shampoo-er and got it all assembled. The foam laid down just fine, however, when I run the vac back over the foam to pick it up, there is not a stitch of water showing up in the tray. First I thought maybe it was bc I hadn't put that much of the foam/water onto the carpet, but 12 hours later, the carpet is still wet in spots. Clearly

Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=638285\015\012Generic problem for all Vacuums\015\012For the first time, I\015\012Posted by MHicks on J ... Vacuums

Sebo upright barged hoover- good suction using hose, brush wont turn, sounds fine when running, nasty wineing noise when stopping?? help!! i love my hoover, have checked for bolckages....

The real clue seems to be the brush is not turning, a bad belt is possible or a blockage at that head, if you cannot get the brush moving the rest does not matter. ... Sebo Felix Classic Bagged Upright Vacuum

My Kenmore canaster vacuum Mod# 116.25513506 runs continously when plugged in regardless of the on/off hand controlled switch.. Disconnecting the switch located on the hose assembly has no affect of the continous vacuum operation. What component in the electric motor circuit is at fault and what would be the cost of repair?

... Kenmore Vacuums

Lately, my Kirby Ultimate G has been acting funny. When I push it forward, it's fine, but when I pull it backward on the carpet, the light on the front flickers and the power flutters off an on. I thought it might be the rollers, so tonight I turned the machine over and pulled out the hair that was wrapped around the roller. However, that did not fix the problem. I should probably backtrack a little bit. In the past, I have had problems with the vacuum running over its own power cord.

The cord will need to be replaced with a cord made for the machine, as it has a non-standard plug. The cord cover is held in place with a # 20 Torx screw. Remove the screw and push the cover gently from behind to unlatch it. The handle must also be r ... Kirby Ultimate G Bagged Upright Vacuum

I cant get my kirby to blow out...bag is removed from seating...its plugged in...i attach the hose to the place where the bag goes, but it wont run

I did get it to work! It was a struggle, but It finally hit that hidden switch just right. The hose attaches to where the bag goes, and it just wouldnt seat properly. I suppose there might be some wear there on the hose end that twists in . ... Kirby Vacuums

There is no foam in the hose as I run the kirby shampooer. What could the problem be?

Check out the manual HERE.It may be clogged valve on the solution tank. Very dirty or clogged sponge (shampooer tank)Very dirty or clogged scre ... Kirby Ultimate G Bagged Upright Vacuum

Kenmore 21875 One day it's working fine. Next day, it won't turn on. When I attach the hose to another vacuum cleaner, it runs. Is there a reset button on the canister? Could it be the receptacle is bad?

My first recomendation would be to try pluging into a diffrent wall outlet as well as something that is on a diffrent circut . It is a known problem that the pins inside that make the connection could be worn out . There are several pins from the one ... Kenmore 21513 Vacuum

II have the kirby sentria, i have it in canister mode with blower attachment on the hose is on with the hand sprayer attachment the problem is the foam is not coming out the sprayer used it just fine all day went to refill w/ water and cleaner now the foam wont come out whats wrong with it?

Make sure the "straw" is in.See if dust coming out of the hose did not clog the air passages. ... Kirby Heritage II Vacuum

My Riccar 8850 stopped running. Changed the bag and cleared all hoses. Light comes on but the motor doesn't operate. I can turn the brush freely by hand.

Greetings from GoVacuum,\015\012\015\012If the light on your Riccar 8850 is coming on, but the motor is not coming on, this indicates that your motor has gone bad. There is a reset switch on the back of the vacuum cleaner that sometimes ... Riccar 8850 Vacuum

Kirby heritage 2 motor runs slow then speeds up with burning smell.

Replace your belt and clean your roller brush. ... Kirby Vacuums

I was using my Heritage 11 vacumn with the hose attachment and the motor shut down like the power went off .When you push the switch on the housing the light comes on but the motor does not run.

Hi, the motor could be overheating. Most vacuums have a heat sensor that shuts the vac. off if there is a clog. Let it sit, feel if it's hot. If so you may have a blockage of dirt etc. Try to clear it, let it cool and tart it up. I hope this helps, i ... Kirby Heritage II Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

I have an electrolux epic 6500 sr. The change bag light came on, I changed the bag, now it won't run properly. If the bag is out and the hose attached it will run or if the bag is in and the hose is off it will run, but not if the bag is in and the hose is attached. Any suggestions?

First, if it runs without a bag, there's a problem with the bag lock-out switch or wiring. This needs to be replaced/repaired by an authorized Aerus Electrolux technician.\015\012\015\012First, turn dial on top of vacuum counter-clockwis ... Electrolux Epic 6500 Vacuum

Old Kirby Heritage 2 (Model 2Hd ) won't power on

The power light is a 2 stepswitch make sure when u put yhe power head back on it is locking all the way back if so and not working the switch may have failed ... Kirby Vacuums

Kirby turns on with hose attachement but not with head attachment

Front of the unit, black switch that is pressed by this plastic protrusion from hose coupling has two parts. It is because ANY generation Kirby has speeds - HIGH for vacuuming with hose and LOW for using it with nozzle.Looks like the switch we ... Kirby Ultimate G Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 1.6522 seconds