Having problems with your Vacuums ?

My nilfisk action sucks for a few minutes then over heats and sometimes blows dust out and the bag explodes. The pipe is not blocked and I have cleaned filters and put a new bag in but still thesame thing is happening

Answers :

Their has to be an obstruction in the system causing this issue
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My nilfisk action sucks for a few minutes then over heats and sometimes blows dust out and the bag explodes. The pipe is not blocked and I have cleaned filters and put a new bag in but still thesame thing is happening

Their has to be an obstruction in the system causing this issue ... Vacuums

No suction--blocked hose was cleaned out, but there is no suction now. I put in a new bag and air filter, also.

You may have a broken belt that turns the brush.Jim ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

My upright kenmore progressive vacuum will not suction up when using the sweeper. It will suction things when I use one of the tools. I have put in a new bag and have tried to see if anything is blocking the bottom. It sometimes makes a very loud noise when I try to vacuum. If I press the intell clean on and off yellow button the noise may go away but it still does not work.

Double check hose placement, making sure you have the hose inserted into the correct slot. The long attachment nozzle stores in the front hole on the right, and the sucking hose inserts into the rear hole on the right. I know this is too simple of a ... Vacuums

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened up the front to replace the bag, tons of dirt and dust came pouring out. I thoroughly cleaned the vacuum, put in a new bag, but still no sucking power. Just dust coming from the rear vents where one of the filters is. Is the vacuum ruined, or is it a simple solution of buying a new filter?

Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.\015\012This is where a vacuum that won't run without a bag would have been nice. (Aerus for one) ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

I have a hoover windtunnel 2. The filter was filthy so I dismantled the whole thing to try and clean the filter. Now I can't put it together again. Also, where can I find a new filter to buy in Orlando, Florida? Has there been a recall on these vacuums? The filter definately is NOT self cleaning?

... Hoover WindTunnel Cyclonic HEPA Bagless Upright Vacuum - Plum

Kenmore Elite 721.66463500 Microwave died. Didn't even notice until I went to use it. Changed fuse and screen asked to enter the time of day. Entered the time and hit start. The microwave buzzed for 0.5sec and it blew the new fuse I installed.. put in another fuse and the same thing happened.. I measured the resistance in the noise filter. Results: L1-L2 < 1ohm N1-N2 < 1ohm L1 or L2 - N1 or N2 = 0ohms I'm thinking I need a new filter but I also was unable to measure any resistance o

... Vacuums

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga

I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

The vacuum stopped working when i was vacuuming. The bag had a hole in it so all the dirt and stuff where clogging the filters. I cleaned them and put a new bag in but it will not turn back on. So I want to take it apart to see if there is more dirt on the inside,

... Fuller Brush FB-PT2 Vacuum

My HAAN Garment steamer was only intermittently releasing steam. I cleaned it out since there was some mineral deposits in there. After cleaning it out, I let it run for a while with distilled water and the same thing was happening. So, I called HAAN and they told me to troubleshoot. This entailed taking all the water out of the system and "shaking it out." Then to put new water in and turn it on. I was to do this three times and call them if it didn't work. After the third time, I realiz

... Vacuums

I recently purchased a Hoover SteamVac to replace an old one because the brushes would not turn. I used it last week and then tried to use it last night and the same thing happened w/ the brand new model - the brushes won't. I've cleaned the brushed, the filter and everything else I can see. Can you help?

Those things are a waste of money you better off renting one. but the only thing i could think of is that something is stuck or your belt came off track ... Hoover Steam Vac Dual V w/ SpinScrub Vacuum

I have an old hoover turbopower approx 1986 i think its a U1102, the prob is it doesnt pick up anymore and i wondered if it had some sort of filter on it, ive cleaned all the tubes put new bag on but its still got weak suction, could you make any suggestions, thanks

Theres a tube that come up and emty's into the bag that tube is clogged.take the bag out and get a coat hanger and put a bend in it so the end is round then work it down the tube to push out the clog ... Vacuums

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

Vacuum has new bag but won't pick up dirt. Cleaned flat filter and it made it worse. Do I need to replace rectangular filter or can I clean it. If so , how? If not, do I need to take it in for repair, ir should I get new parts? Thanks!

It's clogged somewhere. Disconnect the hoses where you can and check for obstructions. Run a coat hanger down the hose if you need to to clear the obstruction. ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

Our problem with our Rainbow E Series is that it has sucked water up and blown it out through the lower part of the hepa filter, making the filter wet and dirty. This had happened before and the repair shop did not see any problems with the machine, so we replaced the filter and were very carful not to overfill the tank and to change the water often. Now it has happened again and ruined another filter. Do you know what could be causing this issue? Can the filter be cleaned or will a new one be

Thank you for allowing\012us to help, please respond with further questions and concerns\012\012Spanish speaking\012available for all problems\012\012 ... Rainbow E series Canister Wet/Dry Vacuum

My electrolux oxygen cannister has the "bag change" light on when there is a new bag. The light stays on when the suction power is high (to pick up small particles) and it won't pick up, but the ight goes off when the suction power is low (to pick up big objects). I changed the hepa filter, cleaned the motor filter and changed bags, but all that didn't help.

You may have a clog in the hose, and/or the inlet by the brush roll. A clog will turn on that light as well as a full bag. ... Vacuums

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.

Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

When removing the canister bag, the plate and spring that it slides into popped out. When I put them back in, the bag full indicator is completely red. It is a new bag and filters. I think I am not getting the plate and spring back in the canister correctly. Any instructions or pictures showing proper insertion and configuration of these? I looked in the manual and the part is only shown while bag being inserted.

... Miele S514 Solaris Bagged Canister Vacuum

My Windsor Sensor XP12 says the bag is full when it's not. I have removed the hose, brush, and filter and cleaned everything. I can put a bag on without the cover and it works great. However, when I add the bag to the front cover and close the latch the right way, it does not work. I'm thinking that the cover is not seating the bag correctly over the hole, but I can't figure out how to fix it. Any suggestions?

... Windsor SR12 Sensor Bagged Upright Vacuum

Poor suction (new bag, clean filter, clear hose)

Check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?) ... Vacuums

What causes these things to become unbearably loud? We've cleaned evey filter on the machine, pulled every speck of hair and lint off the brushes, changed the belt, no clogs anywhere. I've totally (and I mean totally, down to the brushes on the motor!) torn this thing down and put it back together with no difference. Also have a Eureka bagless, and after minimal use, and almost anal retentive maintance, it does the same thing,to stinkin loud. Wish one would **** up the other to save a trip to th

A clog in the hose or dirt inlet by the brush roll will cause the motor to sound loud. But so will a bad motor bearing, or motor fan, in which case you would have to replace the motor. ... Bissell Vacuums

I have an Ecectrolux Epic canister vacuum. As soon as it starts sucking, the vacuum cuts off. I put a new filter and bag in, but it doesn't seem to help. If I open the front where the bag goes, take the bag out and depress the safety button the vacuum will run. Need some help or direction. Thank you

Try this.\015\012Disconnect hose. Turn machine on and place hand over intake. If it shuts off immediately, first try turning dial on top of machine so largest dot matches up with arrow. Turn on and place hand over intake again. If it still ... Electrolux Vacuums

I have a Electrolux Epic 6500 SR canister vacum cleaner. It is nine years old and for the past few weeks it has started shutting off for no apparent reason.The symbol for bag change lights up and it cuts off, but even after I have put a new bag in, it still does the same thing. Do you have any suggestions? There is a little button or switch that the top of the bag fits on. Do you think it could be the problem?

Your machine is probably clogged, look through the wands, look in the bottom attachment, to see if there is anything stuck there. You can also drop a marble through the hose itself to see if anything is stuck there as well. To unclog the hose try hol ... Electrolux Harmony Canister Vacuum - EL6985 Vacuum

HOOVER 6430-900 Runs for about a minute or two and shuts off. Wait a while and it will run again. Changed the belts, new bag, new filter. Seems to put out a lot of heat when running.

Hoover Fined for Failing to Report Vacuum Cleaner Fire Hazard\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\015\012\01 ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Electrolux Oxygen Z5530 stopped working and the Filter light and face light are flashing, but both the filter and the bag are new and clean?

... Electrolux Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0936 seconds