Having problems with your Vacuums ?

Hi, I bought a used Miele silvermoon vacuum on ebay and the motor just doesnt seem as powerful as my Miele red star

\015 The motor on my Miele Silver Moon just doesnt seem as powerful as my Miele Red Star. Please give suggestions.\015

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hi, I bought a used Miele silvermoon vacuum on ebay and the motor just doesnt seem as powerful as my Miele red star

... Vacuums

Miele s314 red star-motor stopped working-on/off switch broken?

Most likely the problem is with the cord winder. This is the most common problem with Mieles. It is actually the most common problem with any vacuum with a cord winder. A Miele repair center should not change you to look at the vacuum and tell you ... Miele Vacuums

The pump motor in my Bissel Proheat 2x Plus seems to have failed. It was seized so I sprayed WD-40 in it and let it sit for 3 days. Now I can turn it by hand, but when plugged into the unit it still doesn't spin. Here's a picture: http://bbay.dreamhost.com/bissel_proheat_2x_plus/P1070021.JPG I wanted to take the motor out and hook it into another power source to see if I can get it going but it has 3 wires. I'm used to only 2 (+ and -). How can I hook the motor up to another power source,

... Bissell Vacuums

Motor dying? recently my herritage has been sounding sick, i tried to use it the other morning and it barely could blow up the bag, there is also a hot smell to it when it is running, the motor doesnt sound as powerful as it use to. Any suggestions?

Replace the carbon brushes in the motor. ... Kirby Heritage II Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?

... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I bought a new power head for my older Rainbow. The power head had a red button to push to engage the drive motor if it stops. Well, it stops often except if I'm using the tallest setting for carp

... Rainbow Vacuums

My Miele capricorn has started making an odd noise. It seems like something is blocking the engine. I've turned if off and on, and reset it and it still have the odd, almost loud barking noise. The power nozzle also does not seem to be working. I've checked the connections. Right before this happened I was using the vacuum. I didn't notice anything out of the ordinary until this.

Greetings,\015\012\015\012This is a major problem. The Miele vacuums motor should never make a loud noise, period. The way the motor is designed, it's quiet and should be quiet for the life of the motor. There are two motors on your ... Vacuums

Power nozzle on E-series won't start when cold unless the red 'reset' button is pressed multiple times while also holding the trigger to 'warm it up'...this is w/the power nozzle off the floor - no restriction on it turning. Once it's been running and then turned off the button must be pressed w/the trigger to get it to run - again w/the nozzle off the floor. It also seems to shut off too easily while vacuuming. I replaced the motor,which didn't fix it. Is the reset switch next on my list? T

... Rainbow E series Canister Wet/Dry Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v

Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a miele S4210 vacuum. It has a SAB100 accu nova battery brush which will not work. After charging the battery, light comes on saying not charged and now the power head brush won't turn. I had problems with my first powerhead so I purchased another and it worked for a short time and now I have the same problem again. I have four batteries I use interchangeably but nothing seems to work. I spent a fortune on this vacuum and to tell you the truth I hate it! Contacted Miele after 1st year of

... Miele S300 Bagged Canister Vacuum

I have the Miele S7280...the one without the clog hatch on the back. I took the bag cover off, then continued the remove the screws and cover underneath it to detatch the top from the bottom. Found the clog and cleaned it out. Heres the problem...now the power nozzle light comes on and the vacuum "on" is lite up red, but it will not come on. Checked the filters and the bag. It certaintly seems like the top and bottom are meeting up to latch into each other, but I have no power. Help!!

... Miele S7210 Bagged Upright Vacuum

I bought a Miele White Star from Craigslist. Tested it seemed fine the only thing I noticed was it made a long wining sound when turned off. Took it home used it for an hour all of the sudden it wou

... Miele Vacuums

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(

... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Press the power button on - good got a green light (new battery) press the clean button - got a green light iRobot runs for a couple of seconds and stops, then starts, then stops. After two or three times I now have a red light on for the Status. All of the wheels seem to be clean. I used compressed air to clean the underside. But still have the start stop problem.

How many times does the red light blink before it pauses? ... iRobot Roomba Discovery SE Bagless Robotic Vacuum

I have an Oreck canister vacuum, it says fc1000 on the bottom sticker, it's red. My problem is that the suction in it works perfectly, the belt is ok, and the roller can turn, but the motor doesnt turn it when I turn on the power.

... Vacuums

After not using my binatone f430 for approx 2 months doesnt seem to want to charge up? red light not coming on (shud be on showing charging) any ideas

Hello,the problem is either from the charger or the battery of your Binatone f430. But most likely, the problem should be from the charger. The charger might be defective and maybe that's why its not charging the unit.You can ... Vacuums

Miele Red Star Power switch not working when depress.

... Miele Vacuums

Our miele red star(s314i) vacuum was running great and quit suddenly. It had not been running for a very long time and just quit. Newish bag, no clogs in hose and doesn't seem overly hot. the over heated warning light did not come on. I've waited 30 plus minutes to try to restart and no luck. Any ideas

Ok, so if the cord test didn't fix the problem, then it sounds like either the plug has gone bad, or the switch. The plug is a very common problem to go bad, and can be caused by just simply yanking the plug out of the wall, or putting too much tens ... Miele Red Star Bagged Canister Vacuum

Replace power cord - Miele Red Star Bagged Canister Vacuum

Go to www.repairclinic.com and buy the power cord.God bless you ... Miele Red Star Bagged Canister Vacuum

When taking the handle/wand back to use it seems to lose the suction power regardless of what setting I use. Upon several times of standing it back up it seems to engage the suction power correctly is there a button or something that does not always engage to get power? can I fix it

When you say taking handle back I assume you mean the action to start rotation of brushes. Had simular problem and found by removing brush from tube and then cleaning "baked on rubbish" in plastic tube (so you can see clearly through tube) Clean with ... Dyson DC28 Animal Bagless Upright Vacuum

New Miele Red Star - Powerbrush not working

Wish you had listed the model number of the vac and of the powerhead. The plug going into the cannister, is it pushed all of the way in, also same for the plug going into the hose end? You can hook up the powerhead plug to a/c and see if it runs, i ... Miele Red Star Bagged Canister Vacuum

Miele Blue moon vacuum motor surging on and off and power light flashing. After many surges of the motor (on->off->on-> off etc), the motor no longer attempting to start as ferquently ie. now off for many seconds and may turn on for 1 second.. sometimes stops turming on and just power light flashes. There is also no voltage at the plug for the hose for the power head. I noticed that the vacuum first started having probs when hair was caught in the power head and the ovetrheating light went on

... Miele Blue Moon Bagged Canister Vacuum

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce

I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti

You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.2775 seconds