Having problems with your Vacuums ?

No suction put new motor and no suction in hoses

Answers :

I hate to ask the potentially obvious here, but is the engine running...? What year/make/model? What in particular is not working? If the hoses don't have any vacuum I would venture to guess that the main vacuum assembly is not connected to the intake manifold. Provide some more info any I might be able to be more helpful.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

No suction put new motor and no suction in hoses

I hate to ask the potentially obvious here, but is the engine running...? What year/make/model? What in particular is not working? If the hoses don't have any vacuum I would venture to guess that the main vacuum assembly is not connected to the intak ... Vacuums

My vax power 8, 2200 watts 300 air watts 4L capacity upright Hoover is brand new, I emptied out the dust/dirt collecter and cleaned the motor filter yesterday for the first time, i switched it on and all fine, the brush is spinning and the hose is sucking, put the Hoover to work it's fine for about 30 seconds then then suction stops and its dead it won't collect no more, so switched off taken apart again and the motor filter is blocked and full of dust, so I unblocked it, do the same process aga

I had the same problem. It looks like the seal on the lid on the bottom of the cylinder has fallen out when it was emptied. There is no longer a proper vacuum being created so you don't get the cyclone effect and the dirt doesn't collect where its su ... Vacuums

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!

First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

I have a new bag in, checked the hoses for clogs have the motor cover off showing motor runs. Problem is vacuum has no suction in hose area, cover off where bag is and the air blows out of filter. hoses are clean no blockage.

Have you checked the filter? Many vacuums have a filter under or behind the bag to keep dust and dirt out of the motor. If this gets clogged the motor can't get any suction. Also look for holes in the hose or in the small segment between hose and bag ... Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative

Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

My vac has lost suction. When I vacuum it picks up very little, but when I remove the wand hose it has good suction. We have cleaned both filters, checked for blockage in all hoses & cleaned the beater bar brush. All to no avail. Is it the motor? Or is there a blockage deep in the vac somewhere? We're debating repair versus buying a new one. Hope you can help. Thanks.

Hi there,Sorry to hear you're having a problem with your DC14. Since you say you've already washed the filters and checked for blockages, it's probably best if you get in touch with us so we can run through some simple troubleshooting ste ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged

Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch ... Electrolux Epic 6500 Vacuum

No suction--blocked hose was cleaned out, but there is no suction now. I put in a new bag and air filter, also.

You may have a broken belt that turns the brush.Jim ... Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

35922, sounds like there is a clog , have cleared hoses, put new bag in loss of suction, still hear loud clogged noise near rear vent hole

Try putting the vacuum hose end into vent hole while running. That may dislodge the clog. Otherwise, you will need to disassemble the machine far enough to get to the clog area. ... Vacuums

My Dyson DC02 is acting strangely. The motor sounds louder, the suction is still brilliant, but for some reason lumps of dust are sticking to the filter. I put some new filters and the first time I used it was covered in lumps of fluff and dust. Any ideas?? Kind regards Annette

... Vacuums

My 4 yr old Nilfisk vacuum cleaner has been working fine up until now. But suddenly, it has hardly any suction power and also, hot air seems to be coming out thru the vents on top and also thru the space that's normally used for blowing air OUT....the outlet with the retractable cover located close to the part where the power cable comes out of and retracts into. I've checked the filter and the hose and they are not clogged...I have also put in a new bag. Not keen to buy another vacuum cleaner u

Hi there SmartAlec from Nelsonvacuums.com.au here.It sounds like a blockage of some kind. The best way to find it is to set the machine up for normal vacuuming and remove o ... Vacuums

We have a series e rainbow cleaner. my wife had been using it i turned off and turned the canister up sie down to get the serial number. it would not turn back on.we need a new hose and thats why i was looking for the serial num. it has a rocker switch and the motor will work on low but will not run on the suction side. i have checked the wiring harnesses out as best i could without taken it all apart. im wondering if it may be the switch. it started once and then stopped.

There is one way to verify if it is the switch.It's kind of dangerous though,but not too bad.You need an extra piece of wire,fairly thick.I would use 4 guage myself.Hold it with pliers,just in case it gets hot.Turn the switch on and hold the wire to ... Rainbow Vacuums

Little green machine pro heat pet the collection tank wasn't collection and dirty water was coming out of the bottom. i took it apart, cleaned it up and put a new "duckbill" gasket in. then it quit spraying, but i think i got that working again. now after i spray and get a good foam on the carpet, i switch to suction and it seems very weak. i can see the water moving (trickling) from the head into the hose but it is not reaching the collection tank -- actually, i am not sure where its goin


My filter queen just had the motor rebuilt last year and was basically a brand new unit when I got it back. It is not picking anything up now when I vacuum. The beater bar on the carpet attachment is turning fine and when I take all the attachments off the hose I can feel the suction being created like it should be picking up debris just fine. I have emptied the canister even when it did not have much in it; however, it still will not pick anything up off the carpet. It picks up debris tempo

It sounds as if you have a clog inside the "Power Nozzel". They mention that there are "no user serviceable parts within the Majestic® Power Nozzle" My advice would be to see if you can see a clog with in reachable distance and try to remove the ... Filter Queen Vacuums

Fantom vpw46h,house pressure washer.the motor runs,it was setting for sometime started,using it,but never had any pressure besides the house hose pressure, with the motor running,then the pressure startes to work great,while using it the wand hose came out of the pressure washer,i put it back in,now the motor will only run when i try to adjust the wand head but will not produce any pressure and will shut the motor off,it seem like as soon as the wand hose came out of the presure washer and after

... Vacuums

No suction Hello - any help with this would be much appreciated! I just changed the bag and filters. The machine runs, seems normal, but there is no suction. There is no blockage of the hose, as indicated by the fact that that little viewer window above where the hose connects to the unit is not showing the red portion that it shows when there is something blocking the hose (god, this is hard to describe!). If I disconnect the hose and put my hand over the hole, I feel some suction. But

Well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (mayb ... Miele S514 Solaris Electro Plus Vacuum

I have the electrolux guardian-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi,\015\012Check your hose you have something stuck in the hose...stretch it out straight and run something through it to push out whatever is stuck in there...\015\012\015\012heatman101 ... Electrolux Guardian Bagged Canister Vacuum

I have the Aerus Lux7000-My full bag light indicater is coming on even with a new bag. It gets worst-the machine will cut off when I insert the hose or put my hand over the hole where the hose goes. I changed the filter on the back and put in a new bag. Help please :)

Hi, you very likely have a defective control valve under the dial on top of\015\012the vac , or a kink or blockage in the tiny pressure hose that feeds\015\012the air from the throat of the vac or the back of the bag chamber\015\012against the two si ... Electrolux Guardian Bagged Canister Vacuum

Lost suction my DCO7 lost suction in the hose I started taking it apart and cleaning it and looking for clogs (probably more than I should have) and when I put it back together it has awesome suction in the hose but no suction in the base. It just pulls the pine needles up (christmas tree) but they never appear in the "bag" compartment and when I look they are just all gathered in a clump in the bottom by the brush.

Hi.\015\012\015\012Remove the sole plate turn the 3 plastic screws to unlock & lift off.\015\012\015\012Now remove the blockages that have accumilated from the oppening of short clear hose.\015\012Check you can turn ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Miele SES125 electeic hose kinked/collapsed. Can I buy just a hose with a wire in it and put fittings from collapsed hose on new piece of hose?

... Miele SES125 Electric Hose

Hi...there is no suction in my upright's hose...there is suction when regular carpet cleaning but when I put it in an upright position and take the hose out there is extemely light suction.

... Miele S7210 Bagged Upright Vacuum

No suction how goes it.. my hoover windtunner v2 has no suction through the hose.. it does however have suction from the body, but once i put the canister in, it has very little through the hose.. no blockage in any of the parts.. whats up

Check again for obstructions in the hose. Also underneath where the debri goes when it is being sucked up. Also make sure all your hoses are connected as this could effect the suction. ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

I have a DC07 and the brush wasn't rotating and I had no suction at the brush but perfect suction through the hose. I noticed a large build up of dog hair around the brush so I took off the cover plate and removed all the hair, cleaned inside the floor/brush housing and cleaned out the hose. I also cleaned the filter and removed the other air access cover and made sure that they were clear. I put everything back and the brush still doesn't turn and there is still no suction through the bottom

Hi and welcome to FixYa. I am Kelly. \015\012\015\012Here is a link that can assist you in your quest for the missing suction: \015\012\015\012 ... Dyson DC07 Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0751 seconds