Having problems with your Vacuums ?

Where do you hook the clear hose that is in the compartment with the motor ? Second where the vacuum hose connects to the bag it keeps cutting in and out of power. I replaced the female cord to motor and still cuts out."no suction "

Answers :

Would you care to tell us the make and model of the vacuum you're asking about?
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Where do you hook the clear hose that is in the compartment with the motor ? Second where the vacuum hose connects to the bag it keeps cutting in and out of power. I replaced the female cord to motor and still cuts out."no suction "

Would you care to tell us the make and model of the vacuum you're asking about? ... Vacuums

I have a power drive baggless vacuum cleaner...it runs well, but suddenly it seems to have lost most of the suction coming through the hose and floor area. When I remove the dirt container, the suction below it seems strong. I have had it to repair twice--they have tuned it up and replaced all filters and belt. It still does not pick up well when I vacuum or use the hose. Can you help ?

There is something stopping it up,you will have to dissasemble the unit to find the blockage,this is the most likely problem. ... Hoover U6660-900 WindTunnel Bagless Upright Vacuum

I have a CT600 power brush that would not power up. Thinking the motor was bad in it, I replaced it with a new CT700 power brush, I am still experiencing the same problem the power brush itself does not seem to be getting electic power, but the Vacuum unit does come on with suction.

First try connecting the power nozzle directly to the hose. If it works, the problem is due to a broken wire or faulty connection in the wands. At least one wand will need to be replaced.\015\012My guess is it's probably due to a broken or di ... Broan-NuTone VX550 Bagged Central System Vacuum

The powerhead cuts in and out on power as you vacuum with the brushes. Works ok with suction only. Have replaced both wands and still cuts out, Can it be the powerhead connections? Help? TJZ

Had the same problem with mine check all the prongs on the 2 wands and on the power nozzle and on the handle itself you will probably see that one of them is discolored or burned looking you will need to replace that section, I had to replace one of ... Eureka 6984A Bagged Canister Vacuum

Our unit is 7024A Electrolux Oxygen 3 - it seems to work great but suddenly, the head or 'power brush' or whatever it is called - has died. I checked by removing the hose and plugging it directly into the body, but it is still dead. Without that motorized head working, the vacuum is useless. Is it worth replacing? The unit is only about 1 year old and has seen light use only. Very frustrating, since it was the most expensive unit in the store:(

... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

Electrolux Centralux I have a Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor. If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times. Any suggestions?? Thanks, Bruce

I dont know if you had your unit looked at yet but it sounds like the Power module is going. I repair the machines so I know some of the work. ... Electrolux Centralux Vacuum

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?

Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?

Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor

On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

The vacuum i've had for 6 months has very liittle suction power. checked that the belt is on. cleaned filter. checked to see if hoses were clogged. I used a super vac to suction any debris out of vacuum. still little suction power

As this unit has 3 filters on it, a lot of people forget about the one filter that will cause all of your trouble here. \012\012There is the exhaust hepa filter, no problem, your unit is pretty new, it shouldn't be a problem. \012Th ... Bissell Upright Vacuum - The Pet Hair Eraser 1 ea Vacuum

I also have a Hoover upright and I need to replace the electrical cord. I have dimantled the back, where the tools are stored, and the hose. I still cannot find the screws or whatever, to get to the area behind the cord, so I can replace it. I think I will have to take off the bottom too. Has anyone out there tried to do this? It seems crazy. This machine works great so I hope I can also put it back together. Thanks for the help.

Since I do not know your specific model I can only supply you with general instructions. Be aware that most of the time you only need to gain access to the on/off switch to replace the power cord. Also Make sure that you are replacing the existing co ... Vacuums

The power head of my DC 21 keeps cutting off as soon as I start moving the hose around. The only way to get it going again is to step on the main switch on the canister, then the whole cycle of off and on starts again. I have replaced the entire power head and tested the continuity of all the wires in the hose and they are good. The repair shop says the PCB is bad but can not get one. What can I do ?

Not much. my only suggestion is to dig through the internet and try and find that pcb it may take awhile but it would be worth a shot. if you dont think you can make the repair take it to repair shop with new pcb and let them do it. ... Dyson Genuine DC-21 "Stowaway" Spare HEPA Filter, Dyson

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.

Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated

1, Does the blower (discharge) side blow bunches of air??Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.Or: The bag is not properly seated. Make sure that the plastic piece is ... Kenmore 23313 Whispertone Bagged Canister Vacuum

I have any easy-flo built-in vacuum. I recently had the bearings on the motor, top and bottom replaced. I put the vacuum back together and it mow has low suction power. There is plenty of suction on the side of the canister where the rigid tubing meets the canister body but little suction at the wall plates. Any ideas? Roger

There is either a blockage or a pipe is open somewhere. You should check the system at the wall valve without the hose to determine if the pipes are blocked or if perhaps the hose is plugged. If one of the wall valves is damaged or open, this will af ... Vacuums

Power cord Cord is just all knotted a twisted, i bought a rubber cord and just want to replace the original. I have removed all the screws from the rear of the machine and it still doesn't want to come apart and i dont want to force it. any help is appreciated.

If the cord goes in at the top, take the handle off, then remove the tool holder, then you can get to the cord. If it goes in at the bottom, You have to take off the motor cover to get to the connecting end. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Have a rainbow e series with 2 speed motor replaced motor with another now after 5 minutes on the vacuum the motor cuts off intermitently like a power surge. all the connections and wires have continuity any ideas???

... Vacuums

I have a Miele Vacuum cleaner MedicAir 5000 Plus. Recently the Dust Bag Indicator bar is full during normal cleaning and consequently the suction power is much less. I replaced the dust bag, engine pre-filter and Hepa filter but no change. When i remove the hose, the Indicator is normal, but when i attach the hose, wand, head, the indicator is full. I checked the hose, wand, head but can't see any blockage and when i blow with my mouth it seems fine. Can anybody help? thanks!

... Miele Vacuums

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

I just got the majestic and it doesn't seem to have a lot of suction power- I ran water thru the hose and it drained out fine I also put the hose on top and blew it out. Could it still be the hose?-or does it sound like a bigger problem?

Did you change the filter cone? Clogged pores can and do inhibit airflow. Bent fan blades can be another problem. Holes, slits, and cracks, no matter how small, in the hose can result in reduced suction.\015\012And you should NEVER run water ... Filter Queen Majestic Canister Vacuum

Replaced power cord on hoover u6470 but loss suction

... Hoover U6476-900 WindTunnel Vacuum

Vacuum shrinks, power is still on but no suction

Perhaps there is something stuck in the vacuum. Look where the hose fits in. There is obvioulsy no blockage in the hose because you have suction. Do the power brushes spin on the vacuum?? Take the bag off, and inspect the area the bag fits in for ... Kenmore Magic Blue 24195 Bagged Canister Vacuum

My electrolux ambassador power wand quit working. I replaced the switch that shuts it off when the roller stops, but it wasn't the problem. The on/off switch is fine, the motor is fine. We have traced the problem to the wires inside the canister by opening the inside cover to the bag container. We see the power cords going into the canister but we're not able to get to anything. We can't find any screws to undo that would open it up in order to follow the wires deep into the canister. We've bypa

... Electrolux Vacuums

Where do I find a replacement hose for the Hoover U5432-900. The hose is crimped in 2 places, so the suction power is not very strong. Thanks! Fran Reisner

Fran,\015\012Please call Hoover Service at \015\0121-330-499-9499 (U.S.) and 1-800-263-6376 (Canada) ... Hoover U5432-900 WindTunnel Plus Bagged Upright Vacuum

We have lost suction power from our dc07 but only from the base the hose still has decent suction

It sounds like a clog. I have had vacuum cleaners that i had to take almost all the way apart just to get the clog totally cleaned. Vacuums do need some maintenance due to the fact the amount of dust and hair they collect can easily clog them. You ca ... Dyson DC07 Allergy Blue/Turquoise Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0926 seconds