Having problems with your Vacuums ?

My sanitaire 9100 commercial upright seems have rubbing internally. Doe not pick up well at all. I've taken it apart - cleared all obstructions. The bag is fairly new. I'm stumped


Answers :

When you take it apart, check the end play and lateral travel of the shaft in the motor that the fan connects to.
Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My sanitaire 9100 commercial upright seems have rubbing internally. Doe not pick up well at all. I've taken it apart - cleared all obstructions. The bag is fairly new. I'm stumped


When you take it apart, check the end play and lateral travel of the shaft in the motor that the fan connects to. ... Vacuums

I have 2 Hoover Wind Tunnel-self propelled bagged vacuums-U6433-900 model.The roller bar does not agitate, the self propelled feature does not work and, in general, the vacuum is not performing well. I have replaced the roller bar, the v belt and the wide belt. The filters have been replaced and it has a new bag. I have had both of these since 2004 and they were fairly expensive $200 each) but if the repairs are prohibitive, I might as well get new vacuums. Suggestions? I just spent $100 for bel


The Hoover WindTunnel self propelled is a machine that we see in our retail stores (Vacuums Unlimited) constantly. The benefit of having a supposed "self-propelled" machine wears of quickly after the numerous time you will need to take this machine ... Hoover Vacuums

My electrolux lux 2000 kkeeps shuting down as though the bag is full(bag light) even with new bag , hose is clear but shuts down as soon as air flow is interupted an any rate


... Electrolux Vacuums

I just received My brand new hoover platinum lightweight upright UH30010 (with canister) which I ordered through ebay and today is just the SECOND time I used it but the check bag light indicator is already flashing. My husband and I live in a 1 bedroom (695 sq t) apartment (no kids or pets). I checked the bag and the dirt is just maybe two inches - far from the limit line showing on the bag..and I remembered the advertisement on TV that it can even last upto to six months depending on the usage


I have the same problem. If it was just an indicator light I could live with it, but mine actually shuts the vacuum off. I can only run the vacuum for 3-5 seconds before it turns itself off. Any ideas? ... Hoover Platinum Collection Upright Vacuum

Poor suction (new bag, clean filter, clear hose)


Check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?) ... Vacuums

Sebo upright vacuum cleaner - Bag full or clog light on constantly when using as an upright but not when using detachment pipe. Bag changed and no sign of blockage. Is this a common fault or does it need to be taken apart by an authorised repairer?


Hello,\015\012\015\012I have actually written an in depth trouble shooting guide on how to find the clog in your Sebo. Since this light is coming on only when you have the wand inserted into the vacuum and are vacuuming the floor, this i ... Vacuums

I have a Kirby Heritage II which normally works amazingly well, but it's not playing at all nicely today - and of course we have apartment inspections tomorrow. *dies* The belt broke today (as did the replacement belt, which I'd bought at the same time, so apparently the rubber was old), so I went over to Stark's to get some new ones - but it still won't cooperate. I've taken the head apart and put it back together several times, to be sure that everything is properly seated, but it's just not


... Kirby Heritage II Vacuum

The hose is disconnected, new bag in unit, new filter, unit runs when hose is detached but immediately turns off when hose is attached but hose has no obstruction, etc.. i was told i need some sort of valve. HELP! I have birds, a cat and 2 large dogs and no vacuum :)


There is a vacuum hose that attaches inside the unit to a round clear plactic piece. In most cases you can simply cut the small vacuum hose and it will fix the problem. ... Electrolux Epic 3500 Vacuum

I have a Eureka Contour model 2900 type A upright vacuum, the roller works fine nothing clogged, took it apart motor blade is free of debris, no suction from tube and blasts OUT air from the front HEPA filter location. New bag, New belt, nothing in hose.any clues as to why this can be happenning? Air should not be blasting out of the HEPA filter.


Even with your explanation,it seems the hose is clogged.Try taking the hose off,then blow through it or pour water through it.If this doesn't do it,make sure the suction canals are going to the proper areas. ... Eureka 2900A / 2901A Contour Bagged Upright Vacuum

Not sucking i have a KIRBY G3 that was working great. One day there was a strong smell and the brush roller belt broke so I replaced it. The fan looks good. Now the vacuum does not **** up dirt but instead seems to very gently blow air forward. I took the (new) bag off and it is blowing hard int the bag. I am stumped!


Belt is not connect to the drive pulley, see manual for fitting or see utube for video ... Kirby Generation 3 Bagged Upright Vacuum

My hoover vacuum runs for about 10-15 minutes then the saftey feature shuts it off(overheat?). i have taking it apart a cleaned it with no results, added new bag also. after an hour it cools down and works again. do i just need a new vacuum?


Do you have suction through the tools? Does it look like it picks up when it runs? The machine could be clogged and that would cause the problem, but unfortunately the sensor that shuts the machine off could be bad if the machine isnt clogged. Its no ... Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

My new Kenmoore Powermate 116 canister has poor suction. I have no pets and light dust. Its not picking up small particles on the wood floor with the floor attachment. When I put my hand to the suction it feels weak. Cleared hose and changed bag. Using again, same issues. This should not be happening with a new vacuum. Is it a bad design in the elbow joint of the hose? I want to return this!!!!


First of all disassemble the handle and hose as much as possible and examine the inside. Make sure there is not any significant debris lodged in the hose somewhere like a plastic bag or something.\015\012\015\012Also check at the top of t ... Kenmore 23912 Progressive PowerMate Bagged Canister Vacuum

The vacuum stopped working when i was vacuuming. The bag had a hole in it so all the dirt and stuff where clogging the filters. I cleaned them and put a new bag in but it will not turn back on. So I want to take it apart to see if there is more dirt on the inside,


... Fuller Brush FB-PT2 Vacuum

Hoover tempo upright is clogged. I can only vac for a few minutes, then I have to unplug it and turn it over and clean out the under part under the roller. It is totally stuffed with dirt and dust and carpet fibers. I have a new bag in. It is like it is clogged up inbetween the bag and the roller. Also gets clogged when using the hose. It is maybe a year old. How can I take it apart and unclog it?


Disconnect the hose and head and wands. Drop a quarter thru the hose, the handle sometimes clogs. peer thru the wands and inspect the elbow on the head for blockage as well ... Vacuums

I am getting very little suction from the motor. The hose is clear, the bag new. When I open the bag cover, plug the hose in and turn the vacuum on, there is next to no suction from the motor. What do you think is wrong? How do I remove the cord retractor to get to the two screws that hold the back of the canopy cover?


Your problem is probably is you don't have a proper seal in your chasis. A vacuum has to be sealed tight or the air will leak out and the seal broken. Check around the whole body after the bag is in and check for any airflow noise. I could help more ... Vacuums

When I flip the switch on my sebo x1 upright, a red light comes to the brush and bag icons. However, I cleaned out the hose and checked to make sure there is no obstruction from the brush to the hose also, or from the hose to the bag. It is clear that juice is coming to the vacuum, but there is no sign of life except the two red lights.


Thanks for contacting fixya. You should pull out the bag and reset the machine. You should take all the user replaceable items. And turn it on. You will get lot of errors. Then turn the machine off. Put back all the accessor ... Sebo Automatic X1 Bagged Upright Vacuum

Help hi there. i have a hoover savvy u8172-900 vaccum. the hose has great suction, but there is limited suction on the main unit and the brush does not spin when i try to use the product. we have cleared the brush of any debris and have also installed a new bag. a few days ago, we disconnected the hose to make sure there was not any foreign bodies stuck in the unit...nothing seems to help. any advise?


As the hose fits into the base (if i am correct) the power at the base should be fine, make sure the base is clean and free from blockage,\015\012you say the brush doesn't spin, has the belt broken, if so replace it, (very cheap) and only a couple of ... Hoover U8171-900 / U8172-900 / U8173-900 / U8174-900 Savvy Bagless Upright Vacuum

Morphy Richards Pets vacuum cleaner, less than one year old. Not sucking, overheating, claims bag is full when it is new. I have looked for blockages but the hose is clear. Can't find anywhere in Aberdeen to repair it


Discovered I had a 3 year warranty on it so got a replacement. Thanks for your helpful advice! ;) ... Morphy Richards Vacuums

35922, sounds like there is a clog , have cleared hoses, put new bag in loss of suction, still hear loud clogged noise near rear vent hole


Try putting the vacuum hose end into vent hole while running. That may dislodge the clog. Otherwise, you will need to disassemble the machine far enough to get to the clog area. ... Vacuums

Over heats and shuts off, wont start again untill it cools off. can maybe vacuum one room before overheating. cyclone tubes are all clean, all hoses & lines are clear. this vacuum is fairly new, not used much. cant find a reset button. is the moter dirty of something?


The electric motor has a thermal switch and is self-resetting so there is no re-set switch. Make sure the air filter for the exhaust is clean. Also make sure that the height adjustment is not too low causing strain on the motor. Always bring the heig ... Dirt Devil Reaction Twin Cyclone Upright Vacuum

Vac has no suction,hose clear and tried new bags


Make sure lid is all the way down, detach hose from canister and drop penny through to make sure is clear.. ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Bought a Kenmore Progressive canister vacuum at a garage sale that looked in better than average condition, filters clean, new bag, all accessories intact, some debris in roller brush. problem is no suction when turned on. There does not appear to be any obstruction in hose. did not have manual


Hello,Carnister vacuum cleaners are all built with the same principle in mind. A motor \015\012generates power which powers a vacuum which, in turn, creates suction to\015\012 lift debris. The most common areas of suction loss are within ... Kenmore 25512/ 25513 Progressive Canister Vacuum

Sharp 8.5 amp, 900 w upright vacuum, new bag, cleared out clog from all intakes, no suction at all...heeeelp


... Sharp Twin Energy EC-T5980 Bagged Upright Vacuum

Hi I have an Electrolux Envirosteamer and it has stopped steaming. I have made sure the water cap is on tight and also taken the head apart (where the hose finishes up and the attachments fit on) and the hose is intact there. I have no steam and wonder if I have a valve problem? if so can anyone tell me if it's worth trying to order the part and fix myself. I'm fairly handy! Thanks Sue


If the water is boiling and element is ok then it could be the outlet valve it is poss to diy but is a 2 person job as very fiddley ... Eureka Deluxe Enviro Steamer Vacuum

Blowing out? I have checked all hoses for clogs, I have even taken it all apart, but it seems to be blowing out? The bag inside the canister is sucked in? Can the motor reverse on itself, I'm baffled!!


Did you check the inlet down by the brush roll? ... Bissell 3522 PowerForce Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0705 seconds