Having problems with your Vacuums ?

Hi, I have a whirlpool 7700 Power Clean vacuum cleaner - the built in kind. It's not sucking very well. The motor still runs and I've cleaned out the collector. Any suggestions?

Answers :

Repair Help & Product Troubleshooting for Vacuums

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My bissell model 18Z6 has developed a loud noise and vibration when the brush is running. I have removed the brush assy and cleaned all the hair, etc but still the noise. I ran the brush motor with the belt disconnected and all seemed ok, but of course there was no load on the motor. I suspect a problem with the brush assy bearings or axle or both but I hate to just throw parts at the problem. any suggestions would be greatly appreciated.

... Bissell Vacuums

Hi, I have a whirlpool 7700 Power Clean vacuum cleaner - the built in kind. It's not sucking very well. The motor still runs and I've cleaned out the collector. Any suggestions?

... Vacuums

I was just using my Bosch 1450W bagged vacuum and all of a sudden, the motor just shut down. No warning, no problems. The light still turns on, but the motor is unresponsive. There is a clean bag and filter, and nothing caught in the front roller. The motor sounded fine - no shaking, or weird frequency variations. There were no weird smells, just a little bit of heat, but nothing beyond normal. I've had this thing for several years, and never had a bit of trouble with it. Any suggestions

Many vacuums have internal thermal switches that need to cool to allow the vac to operate. After 30 minutes, check all 3 air filters and try again.\012Gary ... Bosch BSG71310UC Bagged Canister Vacuum

On an old upright prolux plus, I just replaced the belt and cleaned out the brush motor, ran the vacuum for a bit, then the vacuum motor died...it's always run great. any suggestions of what to check?

... Electrolux Vacuums

When trying to use my Hayden Model 3600 central vac when trying to turn on the unit runs for 1 or 2 seconds and shuts off and continues to do so while switched on. I have thoroughly cleaned the filter and dirk canister but the intermittent running still occurs. Any suggestions?

... Hayden Industries SuperVac 3600 Central System Vacuum

My kenmore vacuum model 116.36933502. It has no suction. I have cleaned out every spot,taken off the back and still nothing. The motor runs but doesnt seem to be at full power. The agitator brush works. When it broke i seemed to smell something and since it has no belt. Does this possibly have to motors?

... Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

I have a Electrolux , EL6988 Canister Vacum, howeveer the brushes and motor will not run when turned on. I have take the plates and cleaned around the brushes, but it will not come one. The vacum comes on but the motorized bushes do not activate. Thanks I have lost my owners manual, and have looked for the reset button and can't find or know where it is located. Any suggestions.

I need the molded wire harness inside the plastic wand ( one of the prongs is broke off) What is the part # or where can I buy it? Model EL6988 ... Electrolux UltraLux 2000 Bagged Canister Vacuum

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is still there and lights work but the power head motor turns off and the suction stops. I will turn it off and on, check the outlet, flick the on off buttons...nothing. I will turn it off for a couple minutes and it turns back on and runs like normal. I've check the bags, filters, cleaned the hos

It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!! ... Kenmore 34612 Bagged Upright Vacuum

While vaccuming it just stopped. Tried another outlet and checked power cord. Did find tube clogged with a dirt clog but no motor strain heard. Cleaned it out, Still not running

On the back of most vac's , u will find a red butten,use that to reset the vac. but even if that works u can avoid this usely buy ajusying the vac to a higher set . that helps reduse strian that the belt gets.\015\012 thanks\015\012 ... Bissell 68001 Canister Vacuum

My Bissell Powertrak Cyclonic Vacuum has started running REALLY loud! I have cleaned the filters, checked for any clogs in the hoses and replaced the belt, but it stull sounds like a jet plane! Could it be the motor? Any suggestions!?

... Bissell 6594 PowerForce Bagless Upright Vacuum

Stopped running. Filter was clogged. Cleaned filter and changed bag, but still won't start. Motor was warm when it stopped.

Hi There,This sounds like the Thermal Switch in your motor tripped. All Riccar vacuum cleaners have a motor reset switch, that will shut the motor down when it gets hot. Usually it's caused by a full bag, clog, or dirty filter. ... Riccar 8850 Vacuum

Burning Smell Hi, I have a Rainbow E series that when I run the vacuum there is a burning smell. I have cleaned the entire unit and filter but still have the smell? I am afraid that the motor will burn out?

Check the carbon motor brushes, there might be arcing on the armature. New brushes may help if the armature is ok. ... Rainbow E series Canister Wet/Dry Vacuum

My Optima Eureka model 431BX suddenly slows down motor still running while vacuuming and after a minute speeds up again. Everything is clean and no obstructions. .??

... Vacuums

I have an old hoover turbopower approx 1986 i think its a U1102, the prob is it doesnt pick up anymore and i wondered if it had some sort of filter on it, ive cleaned all the tubes put new bag on but its still got weak suction, could you make any suggestions, thanks

Theres a tube that come up and emty's into the bag that tube is clogged.take the bag out and get a coat hanger and put a bend in it so the end is round then work it down the tube to push out the clog ... Vacuums

Kenmore 116.23513301 Motor runs, but the brush will not rotate. Every time I hit the overload reset button, it will rotate for about a second then stop. I replaced the belt and cleaned around the brush, but the brush still will not rotate. Any help you can give me would be greatly appreciated.

If the motor on the power brush is running the belt is bad, if the motor on the power brush only runs when you push the overload, the overload is bad. ... Kenmore 22812 Bagged Canister Vacuum

The motor sounds quite rough but still runs and cleans fairly well

How old is it?\012If it is bagless, are all three filters clean?\012Have all filters been in place at all times?\012If the motor is rough, there could be something making it off balance: some of the impellar broke off, for instance. ... Electrolux Epic 6500 Vacuum

I have a nearly 9 year old Electrolux Excellio Z5228 vacuum cleaner. It has recently started cutting out during operation. I cleaned the micro filter (between bag & motor) via brush & hitting against wall & seems / looks quite clean. I washed the gore filter (output from motor to clean the exhaust air) as per instructions, then let to dry. It was very clogged but now very clean. The vacuum clearner still cuts out often. Even after a long rest (say overnight) it still won't start, then ano

... Electrolux Vacuums

Same problem as voirjs 12/29/09 - runs a while & needs brushes cleaned w/same repeat scenario. have been doing all of the cleaning as felix80 said on 1/8/10; but it still continues the run awhile & need cleaning behavior. a more indepth solution is required.

I called iRobot Customer Support, and they are sending me a new cleaning head module. ... iRobot Roomba 560 Robotic Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.

It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Nutone model cv-350 vacuum motor will not shut off. I have to unplug system in garage. I disconnected wire to house vacuum inlets and motor is still running. There must be a reset on the motor. I have turned the external switch on and off and still no help.

Mine is the same, and it is the relay welding itself closed. The relay is switched by the low-voltage wiring that connects to the vacuum outlets, and it switches the motor on and off. Mine was welded in the energized position. I have cleaned and file ... Vacuums

My irobot scooba does not spray cleaning solution out after about the first 30 seconds it is running. I have tried all the suggestions in this post with the suction bulb to charge with air, and then with water to clean it out. water does come out of both valves when forced with the bulb or immediately after using the bulb to charge it. then after it runs for about 30 seconds the floor is dry.

... iRobot 5800 Scooba Vacuum

My vacuum sounds like it is screaming the entire time it is on. We have cleaned out every possible area, but it is still extremely load. Any suggestions?

Is it cleaning as good as it used to? 1) If not there may be an air leak. A crack or a hole will allow air to rush in. The motor will make a louder noise when not under load. 2) Have you changed house locations, ie Country? Diffferent house vol ... Bissell 87B4 Bagless Upright Cyclonic Vacuum

Power head motor is good,runs great from test cord switch seems to work. brush roll cleaned but power head motor will not run

If you have checked the power delivery down to the powerhead and you have current running to the powerhead, then you likely have a burned fuse. There is a fuse built into the powerhead motor and is usually located on the field winding. This is not ea ... Eureka 6831A Bagged Canister Vacuum

I have Nutone VX550C. Motor runs intermittently (cycles on and off rapidly--the light on the handle is blinking furiously) when I use the on/off switch on the hose. This happens at all of the wall connectors, so suggests a hose contact problem. Motor runs continuously when I turn it on at the switch on the wall unit.

The unit does have a switchs the PVC outlets, and it sounds like the hose mech to operate the switches is broken, and intermittently making contact. A replacement hose would likely fix the problem. Looked them up on the net, and they're not che ... Broan-NuTone VX550 Bagged Central System Vacuum

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see

... Oreck XL Ultra Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1016 seconds