Having problems with your Bissell 1698 PowerSteamer ProHeat Upright Wet/Dry Vacuum ?

The unit isn't pumping water or solution when the trigger is depressed. I've replaced all belts and the motor works fine. Any help?


Answers :

You might have a blockage in the heater its very common 
Repair Help & Product Troubleshooting for Bissell 1698 PowerSteamer ProHeat Upright Wet/Dry Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

The unit isn't pumping water or solution when the trigger is depressed. I've replaced all belts and the motor works fine. Any help?


You might have a blockage in the heater its very common  ... Bissell 1698 PowerSteamer ProHeat Upright Wet/Dry Vacuum

The motor on my Epic 6500 works, the hose is sucking, but the power head isn;t working... I tried the sidestep power head and that one works. Ive opened and replaced the belt and that is fine. The bulb was already burned out and wasn't replaced so I cant tell if theres power to the head. What else could it be?


Connect the power nozzle directly to the hose and try.\015\012Check the terminals where the wand connects to the PN. If any are discolored or cracked, that may be the problem.\015\012Open the PN and check for loose or broken wires and co ... Electrolux Epic 6500 Vacuum

I can't find replacement belt for little lux (original model bought in 1991). Stamped on back "Model 1673BA". Motor works fine but belt doesn't turn roller any more.


... Electrolux Little Lux Bagged Handheld Vacuum

Hi, I have a Dyson DC04, (silver/lime) making ear popping screams! Does not happen all the time, and more noticeable when it is pulled back.The suctions not a problem and no funny smells or strange noises from the motor. Ive taken the base plate off and the belt and brush bar seem fine, but when I turn the belt, it seems to be the motor spindle thats squeaking, almost as if it need oiling, any help please


... Vacuums

Have a Centralux Aerus about 5 years old. Don't see a model number. There is suction but beater brush quit working. Was using for a few minutes, shut it off for a few minutes, turned it back on and suction only. Tried the reset button also. Tried the sidekick attachment and it works fine. There was no smell like something was hot. Belt is fine. Are there any fuses or anything else to try? This vacuum cleaner has not really been used that much, it is hard to believe the motor would need replaced


There probably is a loose wire in the handle near the switch or a wire off near the swivel elbow near the vac power head. With the right fastener tool to remove some screws you can fix it yourself ... Electrolux Centralux Vacuum

Hello i own the bissle proheat steamer it turns on but no water or soap or suction from floor or the utensiles ive taken the take off the back to scope out anything that could be in the way but dont see anything the motor is making that clogged vacume noise witch makes me believe something could be stuck somewhere in it but it could also be no water is getting to the pump or despencer but the brissels still work belt for that is good where would i be best to check and where is the location of th


... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Have a rexair model D series vacuum cleaner that worked fine until recently. Started making noise and then started smoking/overheating. I took apart the machine cover and am unsure how to get it tore down to see the motor or belt in there. Please help!


Below I have listed a link to the manual that has instructions on how to change your belt and a link for the replacement belt you need. ... Vacuums

Schematics I went to replace the belt, and when I put it back on I noticed the silver pulley that the brush belt goes on has came unattached from the red piece by the motor belt. It is one peice. I can order a new pump, but I need the schematics so I can replace the pump. http://www.vacuums24x7.com/bistclpa.html How can I enlarge this so i can read it?


Well you can right click the picture and save it to your desktop, I did it, but it was alittle blurry. But if this doesn't work for you, post me your email addy and I can send you a better picture. But take the top off, there are 6 screws, 3 on ea ... Bissell 8910 ProHeat Clear View Upright Vacuum

Hi my proheat bissell 7901 stopped pumping water to the floor, but it pumps water from the hand hose. I read the manual and followed how to check belt and the flat belt on right side of shampooer is fine and I turned on and it turns and so do the brushes at the bottom of the machine. I was reading online and I guess there's two belts on this machine? where can I find the other belt to see if it needs replacing. I guess it's a ribbed belt? that is the water pump belt?


Just taken ours apart with the same problem... found it was caused by the 2 halves of the main casing coming apart in the area where the upright pedal release is. I found this to be due to the upper casing having broken in 2 places - the bottom of th ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the


Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

My Dyson DC17 beater bar motor works intermittedly. I have to almost whack it on the floor to turn it on and then shuts off again. I have checked the belt and it is fine, also have checked for blockages. The switch to turn the beater bar on or off will not work when the beater bar motor is off. the suction is fine though.


Buy a Kenmore for less money ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

The original belt on my upright Kenmore Progressive broke and I replaced it with the spare that was in the vacuum. The vacuum and spare belt are about 10 years old. Then the spare broke after one vacuuming session and there was a burning smell coming from the vacuum. I ordered new belts and replaced it with the new belt. It seems to be working fine with no smell. I checked the belt after I vacuumed the family room and although it was in tact, the belt was very hot. Is that normal? Should t


The belt heats up due to the friction, as well as being in contact with the shaft of a hot motor. It is normal. ... Kenmore Progressive 35922 Bagged Upright Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

My Bissell Model 3760-4 is not working properly. The belt has been replaced (and checked 3 times), but the brush bar does not move when the brush motor button is on. The little metal turning piece that turns the belt is turnable with one's finger when the belt is off, but when we put it all back together and turn on the vacuum, the brush bar does not go around and the burning belt smell returns. The portable part of the machine works properly. It's the brush bar. It has been cleared of hair, etc


... Bissell Lift-Off(R) Revolution(R) Turbo Upright Vacuum

My older Dyson DC14 (the purple one) early model with a clutch on the beater bar belt needs a clutch replacement. The bar has been cleaned and there are no worn or damaged parts so I conclude that the clutch at the motor end of the belt needs to be replaced. I can find the part online but no instructions on how to disassemble the vacuum to get to and replace it. Dysons only advice is to give me the address and phone of the nearest service center. Can you help me?


Have a look at www.dysonmedic.com which has some very useful info on dismantling and repairing Dysons.\015\012\015\012Although this site doesnt actually cover the DC1 ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

Brush Roll belt stops turning durring vacuuming on WindTunnel self-propelled, v belt is a little loose with handle down. Tensioning roll is engaged OK, but fully at the end of its travel. Replaced belts flat and v, but still stops turning even on high carpet setting when vacuuming. Carpet setting and height adjustment appears to be working OK, roll is clean and turns easily when out. Also turns easily until it engages the carpet. Self propel function works just fine.


... Hoover U6485900 Bagged Upright Vacuum

I have a carpet magic steam machine. The pump worked fine yesterday. Today, I cannot get the pump to prime. (The solution resevoir is full.) Is there anything I can do to help prime the pump? Thanks for any help!


... Vacuums

I have a Dyson all-floor model (not the ball). I recently replaced my carpet to a Frieze. Since replacing the carpet, the Dyson is extremely hard to push. It almost forms a "seal" with the carpet. Seems to work fine on Berber carpet and laminate floor. My husband has checked to make sure the brushes are working, hoses are not clogged and belts are OK. I've had it for about a year. It is virutally impossible to push on the new carpet. Any ideas?


Have you adjusted the brush control system. If you look at the link below page 6 will tell you how to adjust. If this is not you vacuum please give the model # of the one you have so I can help you more.\015\012\015\012 ... Dyson DC14 All floors Bagless Upright Cyclonic Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

I have a Hoover Windtunnel Farrington upright model U6431-900 It has worked flawlessly until last week. The roller brush has stopped turning and I believe it is the belt that has broken but I am not sure how to remove the cover to inspect it and replace the belt if that is the problem. Please inform me how to perform the operation and what I should I look for? Is there a site with a diagram on how to replace said parts? Thanks for any and all helpful info that you can supply me with. Larry


Http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=783264\015\012Generic problem for all Vacuums\015\012I have a Hoover WindTunnel\015\012Posted by ... Vacuums

I have a Eureka 5902AVZ and the brushroll does not work. when i remove the belt, which is not torn nor worn out, the motor spins perfectly fine. Though when i put the brushroll back into place, it shows that the motor is trying to spin, but with resistance. it seems the brushroll will not spin if locked into place, because there is no attachment on the left side of the brushroll that will allow it to spin freely with the belt. am I missing some parts or is there something else wrong?


Hi and welcome to Fixya. I am Kelly. \015\012\015\012You have correctly identified the problem as the brush roll itself. \015\012\015\012There is a bearing under each end cap of the brush roll. You can gain access to the ... Eureka 5902AVZ Bagless Upright Vacuum

My Bissell 3760-1 has stopped sucking in the roller portion. The grab n go part are working fine. Checked the belt and it looks fine. Did I burn up the motor or a microchip?


Hey Lisa! Sorry you're having difficulty with your Lift-Off vacuum. Here's a link to troubleshooting steps to assist you with the suction.\015\012http: ... Vacuums

I have a Necchi LYdia 3 machine type 544 The motor was overheating and I removed the bottom cover and examined the motor .It looked fine and ran well. It worked OK for a time and then got hot.I was able to partially remove the motor for inspection.I found that the cooling impeller was not secured to the shaft,I tightened the set screws and reinstalled the motor. In process of getting the drive belt back on I turned the wheel that extends out of the case to index the screw that attaches the bobb


Good day!Please try to re align the motor position.You have to do is repeat the procedure that you take to remove the motor and double check the alignment because all motor in misalignment is very hard to turn.And ... Vacuums

My bissell brush band has come off and wont stay on thus the brush will not turn, there is also a black arm type thing on a spring inside (on both sides) on the pump belt side it has broken - the side where the brush belt is, help im searching for parts and a way to fix it but im getting no joy, incidentley the brush belt thickness looks way to thick for the small thickness for the brush belt cog (?) to stay on........am i missing something? so i need to get the arm thing replaced plus find a


... Bissell ProHeat Deep Cleaner Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0941 seconds