Having problems with your Bissell 1699 ProHeat Clear View Upright Steam Vacuum ?

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


Answers :

The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear from the carbons that should make contact with the rotor, now they are almost out.\012\012\012
The motor is destroyed, the damage is too great to be fixed and it would have to be replaced, at an very high price. Using in in this condition is out of the question, it could short so strongly that it could set the power cable on fire and fry the entire electrical system in your house in the process.
This vacuum is dead, time for a new one.
Repair Help & Product Troubleshooting for Bissell 1699 ProHeat Clear View Upright Steam Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

When I turn on the Hoover U5780-900 it seems the motor just starts to rev up and stays that way until I shut it off. I have replaced all the belts, made sure there were not any blockages, and checked the filters. It still does it. Any other ideas.


... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

Hi, There is a high pitched whirring sound coming from lower part of the vacuum. When I tilt it toward me (while standing in the normal vacuuming stance) the sound sometimes lessens for a minute or so. I have tried the following things: -cleaned the two sponge filters -emptied the dirt receptacle -removed the roller and cleaned it -cleaned the brushes -the belt is not ragged and does not seem floppy -checked all of the airways for clogs (including removing the wheel base) Can you help?


Your looking for some dirt stuck in some thing you didn't check yet. with the roller out and the belt out of the way run it to see if it still makes the noise. if it does then you looking at the impeller or the motor bearing themselfs those bearin ... Bissell 3750 Lift Off Bagless Upright Vacuum

My model 4870 Eureka type K Vacuum Cleaner won't turn back on after it started smoking. I turned it off, checked the belt and filters, and they seemed to be fine. The brush will turn so I don't think the motor is seized up. where do I go from here? Thanks for you help, David Andrews


... Eureka Smartvac 4870 Bagged Upright Vacuum

Shark/cordless /sweeper - over four years old. Started - but seemed like it was caught and shut off almost immediately. Not used year around - tried to start after absence. I have removed some hair and perhaps dental floss. Checked belt - it seems O.K. Do I need a new battery or is it just worn out.


Check the brush,is there any dirt got stuck in between brush rolls.If there is then it needs to be cleaned.Your cordless sweeper will automatically shut off if an obstruction is caught in the brush roll. the other thing to checks is dust contai ... Vacuums

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or anything. The only thing that seemed weird was that the smaller belt that actually attaches and turns the roller is a bit loose. The larger belt is tight but looks like its the one that is burning and causing the smell.


Better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the belts.it will cause the new belts to run unevevly and go bad before their time ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My Kirby 2HD has started making an odd roaring noise but still works fine. I have taken the front assembly off and cleaned and adjusted the roller and checked the belt. The noise seems to come from the motor housing. I have tried to wiggle the main shaft at the front (bearings?) and it seems tight. Can't seem to get the other housings apart. Any ideas? Thanks, John


It is quite possible, it just needs lubed. The motor comes in direct contact with dirt so, you have to make sure the front bearing has a drop of oil on it from time to time. If it starts to scream at you within one month, after oiling, the bearing ... Kirby Heritage II Vacuum

It leaves dirt and fluff in the rollers not in the filter. So is not cleaning properly. There is never anf fluff at all in the filter. Also the lid does not close properly and we constantly get the 'check tank' light coming on. It leaves streaky marks across the floor and seems to leave the floor too wet (hence the streaks). Look forward to hearing from you.


Is there something stuck in the air passage between the tank and inlet ... iRobot 5800 Scooba Vacuum

My Bissel Proheat smartmix bottle is emptying really fast and it doesn't seem like the carpet is even getting wet. I am just trying to do a rug in the kitchen and have filled the smartmix bottle 3x now and the rug is barely wet yet. I have cleaned out the flow indicator filter and it does not spin when I push the button like it used to. I have also checked the belt and it seems fine. It is actually a Bissel Proheat 7901/8910 (Pet) but they could not find my product. Any suggestions, I am


... Bissell Carpet Cleaner Powerbrush Deep Cleaner Vacuum

Nothing spraying out of Bissell Powersteamer Proheat. I've check filter under flow indicator, pump belt is fine, cleaner in proper tank, bladder of water tank is full. We've had it for a very long time but it's barely been used. Can anyone help?


... Bissell 1698-1 PowerSteamer ProHeat Plus Upright Vacuum

I have a Model U57809RM Hoover Cyclonic which started making a very loud noise. Changed both belts on it but the noise persists. It seems to happen when I put the handle in the 'engage to vacuum' mode. The minute I start to lower it the noise begins. Help!


Hello,You could have a broken fan in the motor and need to replace the fan. If the noise is coming from the brush area of the vacuum, you probably have a broken bearing in your brush roller and would need to replace the brush itself. ... Hoover Vacuums

How to disassemble the brush to empty anything that might be stuck inside of the brush? The motor seems to be overheating, all belts have been checked, all airways are clear and the filter is clean. The vacuum is vibrating and releasing a burning smell, but still sucking up dirt. There is nothing stuck on the outside of the brush, but is there a way to check inside of it to see if that is where a clog is occuring?


If there's a burning smell and the belts are fine, the problem is going to be hot wires causing the insulation to melt, or the motor going bad. Discontinue use and have it checked at a repair shop. ... Bissell 6594 PowerForce Bagless Upright Vacuum

I HAD MY DC17 VAC FOR 3 YRS NOW NO PROBLEMS AT ALL, I REGULARLY CLEAN THE FILTER LIKE IT SAYS BUT LATELY I'VE NOTICE THAT THERE SEEMS TO BE A LOT MORE COLLECTION ON THE TOP OF THE FILTER WHEN I'M DONE VACUUMING. IT HAS ALSO STARTED THIS WEEK TO MAKE A VERY LOUD HUMMING TYPE NOISE WHILE RUNNING, I HAVE CHECKED FOR ALL POINTS FOR ANY BLOCK AND NOTHING AND NOW TODAY IT RUN A FEW MINUTES AND STOPS AUTOMATICALLY,IT WILL RESTART AFTER I LET IT SIT UNPLUGGED.WHATS UP WITH THIS THING, IT HAS BEEN GR


The vac is over heating. First, you should try a new filter. Also, keep in mind that after cleaning the filter, make sure that it fully dries. Using a wet or damp filter clogs it quickly. Second, turn the vac upside down and make sure that the roller ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Bisssil cleaner will not pick up the water from the floor. I checked all the trouble shooter helps and evewrything is OK Checked all belts they are OK. It also will not pick up water with the hand held tools, seems as though the vacuum is not working


Hi,Here is a tip that will give you all the information you need to fix your Bissell Proheat Vacuum Problem. ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have 2 Kenmore whispertone #116.20512 vac's that have been working perfectly. Within 2 mos of each other both refused to start after being used the day before. No clogs or belt probs, etc. I have read the manual, checked filters but there is no other troublshooting advice.


... Kenmore 25914 / 25915 Progressive Bagged Canister Vacuum

[email protected] Hello My name is Marta Getman and I am having trouble with my dyson. The brush under the beeter bar is not spinning. I have checked the belt and cleaned the filter. What else can I do? Thanks Marta.


... Vacuums

My Bissell Powertrak Cyclonic Vacuum has started running REALLY loud! I have cleaned the filters, checked for any clogs in the hoses and replaced the belt, but it stull sounds like a jet plane! Could it be the motor? Any suggestions!?


... Bissell 6594 PowerForce Bagless Upright Vacuum

I have a bissell power steamer That is not spraying soap, only water. I have checked all the filters and belts that I know of I also tried to reprime the pump as indicated in the trouble shooting section. Is there anything else I can try? Thanks


If it spraying water, then the pump is ok. The valve at the bottom of the soap bottle may be bad. Also when you turn the smart mix vavle, does it turn easily or hard, if hard, try spraying some furniture polish around the knob and turn it to work i ... Vacuums

Why does my dyson slim dc18 keep shutting down, even though i keep it clean. Filters area is clean and all others have been properly blown out with air from a air compressor. It will work for about 5-10 minutes and then shuts down. Smells like ****, check the belt and a bit later it restarts again. It's seems to be almost over heating.


Maybe your motor is going. Here's a link to a site that talks about motor failure and replacement in a DC07 (not DC18). I don't know exactly what the odor smells like but maybe you can see if you have any of the other symptoms. Good luck! ... Dyson Slim DC18 All Floors HEPA Bagless Upright Vacuum - Iron/Titanium/Yellow

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Belt problem My belt broke. I put a new belt in, followed the instructions, seemed to be right but as I started using the vaccuum, it starting smelling like burnt rubber. The belt was extremely hot. Took it apart, tried again and the same thing happened. Please help me!!!!


Get the old lady to use a dustpan and brush instead SORTED ... Kirby Generation 3 Bagged Upright Vacuum

OUR DYSON 07 SWEEPER HAS VERY LITTLE Vacuum, have cleaned all filters and hoses, on line troubleshooting has said to check soleplate being on correctly, we have done this, still does not have good vacuum, belts are covered by a housing, the video that shows the changing of the belt is not the same, I need to know how to remove the cover to check both belts and any help in gaining the vacuum


This video shows you everything you need to know ... Vacuums

Roller not turning, belt not working no water . The belt on my Bissell Proheat is not getting water (although there is plenty in the holding tank). It seems the belt is not turning and there fore the water is prevented from leaving the holding tank.


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell ProHeat Turbo Deep Cleaner Upright Steam Vacuum

Bissell Pro-Heat 7901-1 no cleaning solution is pumped out. The flow indicator is spinning and the belt is spinning the beater bar. Have cleaned the flow indicator, checked vavles in the solution tank and water tank and they are working properly. Also checked the trigger to make sure it works okay. Any ideas?? Moody Fan


Bissell Pro Heat shampooer - Fill the soap dispenser with extremely hot water and shampoo with only water for a few minutes. There is often dried soap in the lines. Make sure that all filters are clean. Press the soap container and the water conta ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

I have a Tetratec IN600 Plus aquarium filter which does not seem to be pumping air bubbles through the water. I have checked inside and everything looks as if it should work. The pump system seems to be working as the filter is vibrating when on, but no bubbles! Please help!


... Tetra Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0928 seconds