Having problems with your Bissell 1950-3 Quicksteamer Plus Vacuum ?

It's brand new - just out of the box! Noticed the dirty water tank is bone dry. There is no suction! The front removable nozzle seems to be loosely attached.. The metal clip doesn't seem to hold it tight. Not sure if that is the problem. But I have a very wet rug! Suggestion?


Answers :

It sounds as if it wasn't assembled correctly. Was it already put together when you purchased it? It sounds like the Brush Bar Belt never got put on.

Let me know if you need more help.

Jim
Repair Help & Product Troubleshooting for Bissell 1950-3 Quicksteamer Plus Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

It's brand new - just out of the box! Noticed the dirty water tank is bone dry. There is no suction! The front removable nozzle seems to be loosely attached.. The metal clip doesn't seem to hold it tight. Not sure if that is the problem. But I have a very wet rug! Suggestion?


It sounds as if it wasn't assembled correctly. Was it already put together when you purchased it? It sounds like the Brush Bar Belt never got put on.Let me know if you need more help.Jim ... Bissell 1950-3 Quicksteamer Plus Vacuum

When we turn on the vacuum, the canister falls open. The clips holding the canister in place do not seem to hold the canister tightly which I'm sure that it did in the past. The clips do not look bent, but every time we turn on the vacuum the intense pressure blows the canister open only remaining attached the the rest of the vacuum by one clip


Check filter and make sure it is kept clean at regular intervals. Possibly worn out clip retainers on cannister side due to excessive pressure build up. Do not force closure unless pressure is back to normal. May crack cannister or damage unit beyond ... Hayden Industries SuperVac 6000 Central System Vacuum

Hoover Wind Tunnel 7500 Brush not Turning. I have replaced the Brush and the belt. The problem does not seem to be either to me. I believe might be a missing part. The place were the belt hooks on is a metal pole which never seems to grip the belt well. In fact it seems loose most of the time and slips on the brush, causing the belt to eventually burn up. Could there be a missing plastic or rubber piece meant to hold the belt taught  on the metal pole?


Check the Idler Pulley part Number 43241004 (Item 13 in the IPB)http://64.49.205.183/v/u6451900.pdf ... Vacuums

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??


... Kirby Vacuums

Vorwerk VK121 vacuum cleaner - smell of burning from housing enclosing motor. How do I get into the housing to inspect the motor? After tilting the bag sideways, there are two screws holding the housing visible, but there seems to be a thrid fixing inside the point where the handle shaft is attached - is the handle simply clipped in place? Thanks


Yes the handle is clipped in place and should come out when the button in front is pushed. Remove the screws you wrote about. After that the puzzle begins. At the bottom of the vacuum where the head is attached, remove the head by pressing the but ... Vacuums

Hoover windtunnel t series belt is loose- roller brush doesnt turn. Its brand new belt is slipping. we bough new belts and putthem on same problem. Can not find solutio in manual. Is the belt supposed to go around the "metal pulley". I know it goes around the little metal motor thing, then thru the guide and around the brush. What is the metal pulley??? Is is the larger round silver thing between the guide and roller?


I also have a loose belt and have bought additional belts but have the same problem. I put the it around the metal rotor and around the brush roller a shown by he Hoover video, and it is loose. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

I want to brush the pile up on my carpet do I need a special attachment to do this??. I have shampood it and it still seems a bit flat. When I shampood no water/foam filled up in the front tray???I am sure I had attached everything correctly. The only thing I can think of is when I attach the brush and tray to the front of the machine, do I turn the handle back to the right way up, or do I leave it upside down, this is the one that picks up the belt.


Here's my online guide for using the Kirby shampooer....\015\012\015\012 ... Kirby Ultimate G Bagged Upright Vacuum

Kenmore 23613 The vacuum when turned on has a burnt smell. My husband has taken the vacuum apart, still can't seem to get to the belt. The belt in the rug part is not the problem, it is something in the canister part. Can you tell me what you think might be our problem? Thanks!


If it smells like burnt plastic it is something wrong with the motor part, but if it is a wet dog,burnt hair gross kinda smell it cool change the bag and buy deoderizer tablet to put under bag kinda like a airfreshener. if it dont work like it used ... Kenmore 22085 Bagged Canister Vacuum

Dyson dc17 My dc17 has great suction with the attachment but when i try to vacuum my carpet it hardly has any suction. I just bought this on ebay and the seller told me to pull the pole all the way out but it doesn't seem to completely come out. am i doing something wrong? Is the metal pole suppose to come all the way out unless you are using the attachment?


... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

My Dyson is not picking up on the carpet as good as it use to. The brush doesn't seem to engage on the carpet unless I hold the angle upright. It's very uncomfortable to hold it at that angle. What would correct this problem?


Brushes do wear out. Compare the length of the bristles on you brush with a new one. ... Dyson DC07 Bagless Upright Cyclonic Vacuum

Saeco Odea Giro pumps the water but the internal spline or gear is not turning moving the ground coffee grinds to the point where the water can pump to the front exit lines so the water is pumped into the over flow resevoir. How do I replace the gear or check to make sure this is the problem. I want to replace this myself.. Also how do I get the unit apart it seems to be bullet proof. Is this a common problem.


It is a common problem if it is what I think it is. However your description is a little confusing. So the coffee does get ground up, but then has a hard time getting to the next stage of the process? Please clarify... And no water gets pumped th ... Vacuums

No suction I've only had my vacuum for a couple of months and it seem I have a similar problem but there is no clear blockage. It seems like I don't have adequate suction that reaches the accessory hoses nor the main one. I'm not sure where to start. I've taken the darn thing apart but I can't see any obvious malfunction. Any suggestions?


If you have low suction at the end of the hose, then you either have a clog in the hose or a clogged filter. Take the hose off and drop something in it to see if it comes out the other end. If you have suction at the end of the hose, then the dirt ... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

The electricity in the apt attached to my house lost power in two of the walls. It happened when the cleaning ladies I think were using a vacuum, they don't speak english very well so I'm not sure. I have looked at the circuit breaker a # of times and nothing seems to have been tripped. I have also inspected the outlets and they seem to be fine. Can you help me?


Even know the breaker doesn't look tripped it might be. You have to flip it all the way off and then back on again. That is most likely what has happened. If that doesn't work check to make sure a GFI hasn't tripped. They are usually loc ... Vacuums

Hi, I have a Kenmore vacuum cleaner model number 20712008. There seems to be a problem with power getting to the suction base. There may be an electrical problem with the connector between the metal tube and the base.


... Kenmore Vacuums

On-off switch My problem is finding a source for an on-off switch for an electrolux vacuum sweeper model 2100. I have replaced the broken toggle and now the sweeper turns on but only as long as the outside button is depressed. It appears that the on-off switch itself is broken as the switch does not ''hold'' when the toggle is activated. It seems to return to it's ''off'' setting as soon as the toggle is released. What ''holds'' the switch in its ''on'' position? Does it depend only on the on-


Hi Hugh. The 2100 has a rocker switch under neath the button. it is probably broken, or the button has a worn detent spring. If you would like, I could send you a switch kit with the rocker, button, and detent spring enclosed for around 20 dollars ... Vacuums

HI, I have a Kenmore 25813 and it seems like there is an intermittent short. When I have the extension wand on and the power floor attachment on, when it rotate the wand the light cuts out and so does the power floor attachment, when I twist it back it comes on again. I don't have this problem if I remove the wand and just use the crevice tool with the hose. Any idea where the short might be and can I fix it myself? Thanks. Gary


This is common you may have a short in the contacts from the handle to the wand or a break in the cord that goes into the powerhead ... Kenmore 25812 / 25813 Progressive Bagged Canister Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My wind tunnel keeps breaking its belt. The big one. The little one is properly attached. This is a recent problem so it has nothing to do with the rug height settings. I just broke two in the course of 15 minutes. The bag is NOT full, the brush/beater has been cleaned and properly attached Help.


Well will the brushes turn freely as they run in bearings if its got wool of cotton raped around the side of the brushs that will make them tight to turn and will brake every belt you put on it, in a flash,,,\015\012the other thing that causes ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My model F5906-900 --- problem is the brushes have stoped working... I pulled the brush assembly out by holding the two tabs, and all seems clean and the brush assembly rotates easly... onced the brush assembly is removed. What I did notice is the female driver slot (found in the main assembly unit) that drives the brushes seems stuck..Is that normal when the machine is not hooked up to power? How can I get the brushed going??? it is a good machine, but the brush options is important too it's ab


(1) Assure the Brush Control on the hood is NOT set to the OFF position.\015\012(2) Remove the brush assembly by pulling/unlatching it from base on each side.\015\012(3) Does one of the brushes ... Hoover F5906-900 Upright Steam Vacuum

The self propell does not work... i turned it over and took off th bottom plate and can see where the cable is suppose to be attached to the drive system, but it is no longer atteached, so it came out or a piece of the vaccum broke as it seems to be alot of plastic.. i see a screw and the end of the cable is still there... But where does it attach and how do i do it.. i havent taken the complete houseing apart yet as i have never done that before and wasnt sure about all the scres and what not..


... Hoover Self-Propelled WindTunnel Bagless Upright VacuumVacuum

Shampoo-er This seems to be a common problem, the shampooer is putting out alot of water and hardly any suds. I read through the posts about the little filter that sometimes gets out of place and I think I found it in the box - is it about 1" diameter hard plastic ring around very fine mesh? If so where exactly does it go? Some posts say in the hose, and others say in the opening of the tank. Or does it go in the place where the hose attaches to the tray? I also found a round sponge in the box o


It goes on the small hole on the tank where the hose attaches to it. The sponge goes in the hole directly under the on/off valve. Here is a link to my online shampooer instructions.\015\012 \015\012 ... Kirby Ultimate G Bagged Upright Vacuum

Hi I have an Electrolux Envirosteamer and it has stopped steaming. I have made sure the water cap is on tight and also taken the head apart (where the hose finishes up and the attachments fit on) and the hose is intact there. I have no steam and wonder if I have a valve problem? if so can anyone tell me if it's worth trying to order the part and fix myself. I'm fairly handy! Thanks Sue


If the water is boiling and element is ok then it could be the outlet valve it is poss to diy but is a 2 person job as very fiddley ... Eureka Deluxe Enviro Steamer Vacuum

Bisell Healthy home vacuum stopped working. The troubleshooting guide said there could be a problem in the connection at the handle. None of the phillips screwdrivers we have seem to work in removing the screw that holds the handle to the vacuum. What size phillips screw driver should we be using? If the screw is stripped, how can we get it out to replace it since it is not easily accessible in the handle?


You should use a p2 size phillips. there is only one screw right in the center that holds the handle assy on. frequently that screw backs out and allows the handle to slide back and loose connection. make sure the handle is tightly pressed in and the ... Vacuums

The problem has been getting worse. It works, then cuts off. Then works and cuts off. Making sure the canister is not full. Time b/w it working is getting longer and longer. Almost seems this time when I change the outlet it is plugged into it works. But then shuts off quicker than it was doing before. I'm getting very frustrated.


We had exactly the same problem with our Animal. After the motor was replaced under warranty a different engineer came out and diagnosed it as the cyclone chamber itself being clogged.(the bit with the purple cylinders on it). This is completely unse ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0622 seconds