Having problems with your Bissell 1960-3 QuickSteamer Plus Upright Vacuum ?

PROBLEM WITH MOTOR

\015 I have my quick steamer for about 2 yeahrs,Only cleaned my carpet twice,It worked great,then I try it again a few months later,and it did not even start.My questions is should I have it fixed or it is cheaper to pay a new one.It should not happening so quick.\015

Answers :

Sorry but the motor from Bissell is no longer available, they have obsoleted alot of the older cleaners & parts for them, and this model is one of them. I would buy new, even if the motor was available, it would cost around $60+, then also labor if you take it to a shop.
Repair Help & Product Troubleshooting for Bissell 1960-3 QuickSteamer Plus Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Motor smells I have the same problem. Did you get this fixed? Was the problem the motor or the brushes. I don't want to spend $80 for the motor KC92FCJNZ000 is there another way to repair this?


... Kenmore Vacuums

My bissell model 18Z6 has developed a loud noise and vibration when the brush is running. I have removed the brush assy and cleaned all the hair, etc but still the noise. I ran the brush motor with the belt disconnected and all seemed ok, but of course there was no load on the motor. I suspect a problem with the brush assy bearings or axle or both but I hate to just throw parts at the problem. any suggestions would be greatly appreciated.


... Bissell Vacuums

Hi I need help because I have a problem with my Electrolux Centralux Central Vac system in my house. When I plug the vac hose in the central vac socket at first I heard the motor running very gently with NO suction then after a minute or so it went completely dead and they is NO motor sound, suction, or anything happening what so ever. Can anyone tell me what this problem is???


Have you checked for a clog in the lines or in the hose? If there is no clog in the system anywhere, then your motor could be dying. ... Electrolux Centralux Vacuum

We own a dirt devil model 088600, and are experiencing a problem with the belt wearing away a section between where the belt connects to the brushes and the motor. There is a lot of plastic/rubber residue coming out from the vacuum. We have tried new belts only to find the same problem occurs. I noticed that the source of the dust is coming from the section between the brushes and motor, where there appears to be a section that is misshapen and melted. I looked up the schematic online and can't


If you are certain that the belt is seated correctly and the beater bar is nested in its holder and the cover of the assembly has been properly installed and you still see a contact area between the belt and cover, you should either: return the vac ... Dirt Devil Vacuums

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

Motor wiring My Vax VS19TL motor died and I have managed to get hold of a new Vax 006 Turboforce motor which is the same size . My problem is that the original motor had two wires (black and white) which ran to the PCB switch. The new motor has three wires (black, white and yellow). I have ordered the PCB wiring loom for the 006 motor but I can't find any documentation that tells me where each wire goes. Can anyone help?


... VAX Appliances Vax X5 Bagless Upright Cyclonic Vacuum

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti


You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

I have a Kirby Dual Sanitronic '50' Vacuum Cleaner I bought in 1966. The motor does not start when I attach the belt lifter of the rug nozzle. When I remove the rug nozzle and detach the belt from the motor fan shaft the motor starts when I depress the nozzle switch and the power switch . Seems like the brushes in the motor are worn out. I do not have a manual for this unit. Can you assist me as to what newer unit is this compatible to and the problem I'm having at present??


... Kirby Vacuums

Motor problem I just picked up a screw. It appears to be stuck in motor. The sound of the motor changed to a whirring noise and it started to smoke. How can i access the motor?


First six pictures HERE will let you know how to remove shell to see the motor. I would not recommend starting it before you get the screw out (you will need to ... Kirby Generation 3 Bagged Upright Vacuum

Shopvac 90L400 quit working (4 years old). Thought the switch was bad but not the problem. I read that there is a fuse link in the motor that frequently burns up. I tried to take motor apart but not sure of the process. I was able to get to the motor but cannot pull it out of the armature. It appears I have to take the aluminum blower unit off the shaft (it appears to be pressed on with a retaining washer). Do I have to take it off to pull the shaft and motor assembly out? Is that where the fuse


By pass the switch and take power right to the motor leads.. that should tell you if the motor is ok.. have not seen fuse link on a vac motor.. graingers has new motors, but not inexpensive ... Vacuums

Motor problem When i plug my steam vac in the motor sparks and smokes. It smells as if the motor is burning out. I've tried different outlets through out the house and get the same outcome, what can i do to solve this?


Nothing you can do im affraid its the motor armature so unless it can be stripped down then you will need to replace the motor i would get a price for the motor to decide if it is worth doin sorry. ... Vacuums

There is no power...seems like a motor problem. The bag is clean...the mouth is clean the plug us in...NOTHING! I took mouth off and manipulated/pushed in that power press area that engages the motor on the front (not the switch on the back) and NOTHING! Not sure if motor died and/or what to do now. Help. I have had this baby for 15 years.


The front safety switch must be pushed in by either the hose or head (or manually), before the on/off switch will operate. The most common reason for no power is a bad cord. Second most common is worn carbons in the motor, and third is a bad switch. ... Kirby G4 Bagged Upright Vacuum

Miele Cat & Dog vacuum gets VERY hot and is VERY loud. Hose has no restrictions and I have changed the dust compartment (motor) filter and the exhaust filter. It still gets hot when I run it with the top open and all filters removed, so I'm guessing the problem is with the motor. Should I be going into the motor compartment? If so, what am I looking for?


Hi\015\012\015\012The fact that it gets very hot could be due to a number of issues.,but the fact that it started making a very loud noise at the same time suggests that there might be more problems maybe brushes etc.\015\012\ ... Miele S514 Solaris Bagged Canister Vacuum

Our Hoover U8172-900 brush motor is not working. Do you have a wiring diagram so I can determine if the motor circuit board is the problem or the motor?


No diagrram is necessary unless you have dismandled.\012Check if the brushes are touching the mtor commutator. If not you can easily remove both the brushes and polish the surface evenly .Insert only after cleaning the motor commutator till the ... Hoover Vacuums

I was just using my Bosch 1450W bagged vacuum and all of a sudden, the motor just shut down. No warning, no problems. The light still turns on, but the motor is unresponsive. There is a clean bag and filter, and nothing caught in the front roller. The motor sounded fine - no shaking, or weird frequency variations. There were no weird smells, just a little bit of heat, but nothing beyond normal. I've had this thing for several years, and never had a bit of trouble with it. Any suggestions


Many vacuums have internal thermal switches that need to cool to allow the vac to operate. After 30 minutes, check all 3 air filters and try again.\012Gary ... Bosch BSG71310UC Bagged Canister Vacuum

Recently my central vac system started making a louder than usual and laboured sound when in uise, enough so that I took note and inspected the canister and motor while running. The motor was trowing off blue sparks and looked like it could 'POP' at any moment. I will not risk using it until I know what the problem is and how to repair it. My assumption is the motor needs to be replaced. The system came with the resale house I bought 3 yrs ago but I do not know the age of the system itself.


... Vacuums

Nilfisk GM 90 motor bearing Hi I have replaced the motor bearing on the GM 90 model but having problem with re fitting the turbyne I forgot the sequence it has 2 turbines and 4 2 inch washers Can you please tell me the sequence it is fitted Thanks,,,Ps the motor is 100% ok now Peter


... Nilfisk Vacuums

Dead motor? My 8 year old Miele S251i has worked fine, until I was recently vacuuming and moved the plug from one outlet to another. When I restarted the vacuum, it made rrrrr.....rrrrrr....rrrrr noises and smelled like something was burning. I turned it off, and it's shown no signs of life since. Sound like a motor problem? I've taken the cover off and looked at the cord and seen the motor, nothing looks obviously wrong, but I'm also not mechanical.


... Miele S251 Flamenco II Bagged Canister Vacuum

Problem with motor; need to open the motor compartment


This may help. My Kenmore is ten years old. I found two screws under the hinges of the cover to the tool accessory compartment. Remove cover screws are in the corners. The other two I found are under the cord return foot pad. Pad pops off by pry ... Kenmore 23612 Progressive PowerMate Bagged Canister Vacuum

Motor problem machine is smoking/burning smell coming from the bottom of the machine. Motor still turns but doesn't make much sound; and soulution won't squirt. The model # is 1970


I had to throw the machine away before it burned my house down. There is no way to fix it; had to replace it. ... Bissell 1770 Quicksteamer II Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

Ihave a Hoover Windtunnel self-propel model U6445-920. The belt from the drive motor to the big wheel will not run in the center of the wheel. The belt runs about 1/3 off the wheel. I have tried several new belts and still the same problem. What do I need to do to repair this problem.


The large wheel may be worn off center. If the belt stays on and is not thrown, you can run the vac. if there is wobble in the wheel causing a genuine belt to slide off replace the wheel mechanism. ... Vacuums

I have an older Oreck XL vacuum that sounds like it is running twice as fast as it should. I disassembled the entire vacuum, including disconnecting the motor wires, to clean out the hair, string, and other things. When I put everything back and connected all the wires, everything appears to work, including the light. The only problem is, it sounds extremely loud like the motor is running too fast. The model number is: XL3610HH Ser. No. 3610HHXA039740-6 I do not have as electrical diagram to see


... Oreck XL Ultra Bagged Upright Vacuum

Electrical problem The light comes on but the motor will not come on when the on button is pressed. Is there a reset button? I thought it was because the bag was full but I just changed the bag and the motor still will not come on.


The light is separate from motor. No reset switch. Check for a fuse but i suspect it may be brushes are worn out and not making contact.Sometimes that starts as an intermittent.Hopefully one of the coils isn't open circuited. ... Sharp Twin Energy EC-12TWT4 Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0476 seconds