Having problems with your Bissell 6594 PowerForce Bagless Upright Vacuum ?

My Bissel powerforce 6596 has suction but the dirt is not making it into the dirt cup. If I shut it off, the dirt drops to the floor. Also the motor seems to be over heating. All filters are clean. I can't find any obstruction.


Answers :

Just because you cant see the obstruction doesnt mean theres not one. The hose could be stopped up somewhere not visible to your eyes. I have one and I have to take hose off and apart to clean it out. check the roller. Is it rolling?
Repair Help & Product Troubleshooting for Bissell 6594 PowerForce Bagless Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My Bissel powerforce 6596 has suction but the dirt is not making it into the dirt cup. If I shut it off, the dirt drops to the floor. Also the motor seems to be over heating. All filters are clean. I can't find any obstruction.


Just because you cant see the obstruction doesnt mean theres not one. The hose could be stopped up somewhere not visible to your eyes. I have one and I have to take hose off and apart to clean it out. check the roller. Is it rolling? ... Bissell 6594 PowerForce Bagless Upright Vacuum

Filter I bought this Hoover a few years ago-- just now about to use it first time. I cannot find my user's manual and don't know how to change the filter-- or to clean it or whatever I am supposed to do with it. Also, there is a handle on one side of the unit that seems to be attached to an empty chamber or canister kind of thing. It looks like it should pull out, but it does not budge. I really would like to have a manual, but can't seem to find one. Is there a similar model that is still


This is not for the exact same model, but should help you out:\015\012http://edge.maytag.com/epipubs/56511B47.PDF ... Hoover U8143-900 Upright Vacuum

Hello- my motor filter is becoming clogged every time i use it. i have removed and washed it--I thought maybe i didn't have the lid closed tight enough but for some reason dirt is pouring into the filter, it seems that some of the dirt suctioned is actually being pulled into the filter intead of the canister


One way or another, dirty air is by-passing the cyclone. My best guess is that when you emptied the clear bin, a seal has dropped out (or become displaced) and the base of the clear bin is no longer sealing properly against the bottom of the cy ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Motor sounds loud and high pitched. Suction seem ok, can't find any blockages. Cleaned filter at top of removable canister. Exhaust seems hot and low. Can there be a blockage within the motor housing?


Most likely your bearings are shot. it will need a new motor ... Kenmore Vacuums

No suction I have the central vac type. It has no suction at the can. I pulled the hose going to the walls and tested there...and nothing. I removed the dirt can and checked the motor ...it is spinning but does not feel like any suction. I checked the exhaust and it is pushing strong air out. I also cleaned the filter and still nothing. Is there a relay or something that would cause only exhaust air. I emptied the can of dirt and put it back together and have absolutely no air.....hear the motor


On some units there is a screen that protects the impeller of the motor. If this gets sealed off with debris then it is like putting a potato in the tail pipe of a car. Taking the top off the unit reveals the motor. DO UN-PLUG the unit first from th ... Electrolux Central Vacuum

My filter is always full of dog hair on my animal. What is causing this. I have to clean the filter each week . Dirt seems to always be trapped in the filter also.


I have same cyclonic as you.  I also have a Miele Pull-along.  I use the cyclonic for fine dust after picking up the hairs with the Miele.  Much quicker in the long run.  Otherwise I would waste a lot of ti ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door ... Hoover U6630-900 WindTunnel Bagless Upright Vacuum

My Bissel Proheat smartmix bottle is emptying really fast and it doesn't seem like the carpet is even getting wet. I am just trying to do a rug in the kitchen and have filled the smartmix bottle 3x now and the rug is barely wet yet. I have cleaned out the flow indicator filter and it does not spin when I push the button like it used to. I have also checked the belt and it seems fine. It is actually a Bissel Proheat 7901/8910 (Pet) but they could not find my product. Any suggestions, I am


... Bissell Carpet Cleaner Powerbrush Deep Cleaner Vacuum

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is ... Vacuums

It leaves dirt and fluff in the rollers not in the filter. So is not cleaning properly. There is never anf fluff at all in the filter. Also the lid does not close properly and we constantly get the 'check tank' light coming on. It leaves streaky marks across the floor and seems to leave the floor too wet (hence the streaks). Look forward to hearing from you.


Is there something stuck in the air passage between the tank and inlet ... iRobot 5800 Scooba Vacuum

I have a Dirt Devil Vision and when I put a clean canister back in place the suction at the bottom of the filter clogs up and very rarely go into the canister. Also where the air blows out of the motor, I will get particals that will blow out. I have checked where the belt is and also the suction tube. Do you have any ideas how to fix this problem?


Yes your intake hose is clogged thats the clear hose you can see it on the bottom from the back.disconnect the upper hose from your intake hose and try to push a coat hanger through with the end of the coat hangers end bent till its rounded so you do ... Dirt Devil M086700 Vision Bagless Upright Vacuum

I have an older Wega 2 group espresso machine. Looks like a date of 1992 on the group head, but not sure. This has no model name that I can find. Anyway, when I turn it on I get all lights flashing after it heats up 5 minutes or so. I do get nice steam from the wands. I drained teh tank and found a little scale, but not much. I took apart the group heads and cleaned them thinking it may be a clog there, but that doesn't seem to have worked. Also fwiw the water level float is not visible and whe


For a new fridge, need more time to maintain the required temperature of the fridge abut mainly the goods in it? So everything seems normal. The time will be reduced day by day since the goods will stay for longer time in and door opening will bec ... Vacuums

Brush spins, motor heats up, container doesn't spin anymore, not sure if it is "sucking up" anything ..had it for less than a year. Why won't it vacuum? dirt devil 12 amp HEPA filter vacuum


Probably clogged, or filters are very dirty ... Dirt Devil 12 Amp HEPA Filter Vacuum Vacuum

Hi, I have a cleanview bagless model# 3576-2 and my belt keeps breaking (it seems like one of the rings it should wrap around is missing) right now I have been wrapping it around the brush and a metal rod. Also, the dirt collected is going directly into the hose and not the bagless filter. What is going on?


... Bissell 3576 CleanView II Bagless Upright Vacuum

How to disassemble the brush to empty anything that might be stuck inside of the brush? The motor seems to be overheating, all belts have been checked, all airways are clear and the filter is clean. The vacuum is vibrating and releasing a burning smell, but still sucking up dirt. There is nothing stuck on the outside of the brush, but is there a way to check inside of it to see if that is where a clog is occuring?


If there's a burning smell and the belts are fine, the problem is going to be hot wires causing the insulation to melt, or the motor going bad. Discontinue use and have it checked at a repair shop. ... Bissell 6594 PowerForce Bagless Upright Vacuum

I have an old silver king cannister vaccum (R2-D2 star wars) Im looking for filters. When you take machine apart there is a donut looking filter under motor(top of vaccum) that protects motor. I cant find them anywhere. I found the other filter the model uses (disc filters) HELP!!!


I'LL DO A SEARCH ON LONE BUT THE MODEL NUMBER WOULD HELP ... Vacuums

Our Bissell Cleanview II 3576M does a great job except that the filter cup below the dirt cup gets full very fast and the dirt cup barely has anything in it. To clean the whole house, I have to empty the dirt cup and clean the filter several times. It didn't use to work this way. It seems like something is missing, a gasket or seal maybe? I don't think dirt, hair and debris should be going straight to the lower cup and bypassing the upper. I looked at the user guide but can't see why it's happen


Contact Bissell Direct for a parts diagram and support at \015\012\015\012http://uk.bissell.com/EmailUs.aspx\015\012 ... Bissell 3576 CleanView II Bagless Upright Vacuum

Bad Motor I have purchased two of the Kenmore direct drive beltless systems with Progressive systems. The first died after a year, the vacuum motor start making a grinding noies. I pulled the side HEPA filter and could see a fine coating of graphite like dust. Took it to a vacuum repair shop. They said the brushes were going and thus the motor was shot. I liked the vacuum and bought a second, 1 year later the motor is making a slight noise that and removing the HEPA filter I find a slight metall


That dust is from the carbon brushes on the motor. You may need to check them, and also clean out the motor compartment. A slight noise could be a motor bearing starting to go. Does the smell like rubber or electrical. If rubber, then the belt h ... Vacuums

I have a Hoover, Steam spin scrub, Model F5897-900. Only used it a couple times and the motor gave out. First started being noisy then a bad smell. It did seem noisier that what I would expect from the start but I didn't realize it was a problem with the shaft of the motor. I took it apart and found the motor shaft wasn't true and causing sparks. The motor looks like it can not be taken apart and repaired. This seems like a default from the beginning but it is past warranty. Also noti


You will have to replace the motor and the hose asm. thehooverstore.com may be able to help, or you should be able to find a repair shop that can order them for you. ... Vacuums

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

Took my miele canister vacuum cleaner in for repair because the cord had a break in it creating a short. He said it also needed an inter filter ($12.29) and the carbon brushes were worn out ($21.95). Is that possible? Also wanted to service the motor and put in a new seal ($49.95) Shouldn't that include the inter filter and carbon brushes?


Depending on the age of the vacuum and how much use it gets, the first two are possible. I would question the brushes as they should last for several years.\015\012The servicing is generally for labor only and doesn't include parts. I do reco ... Miele Vacuums

Hi, i try to find bags and filters and also some canister for my elecrtolux epic 6500 sr which i bought about 10 years ago. i also would like to find a store in my area, i live in nj,please help,thanks,Sonya


You can use multi filter 4 ply bags from your local vac specialtyshop or look up AERUS Electrolux ... Electrolux Epic 6500 Vacuum

Fantom Twister Our Fantom Twister is not picking up dirt. There does not seem to be any blockage in the hoses and I replaced the hepa filter and the second filter that sits just below the canister where the dirt is collected. It is still not working. Any suggestions yuo have will be appreciated. William Moran


When cleaning everything change the main filter which it's the filter inside the yellow mesh holder. the filter number is 1010fs. One filter is 26.90 with s&h. This needs changing every 2 years.\015\012call customer service number above. ... Fantom Vacums FM741 Twister Bagless Upright Vacuum

Kenmore Progressive canister model 116.27514700 Problem: Vacuum motor won't turn on. The power head operates, but nothing from the vacuum. Have checked all areas of airflow: hose, bag, motor filter and hepa filter. All are fine. Have checked and rechecked all electrical connections, all seem to be in working order. Vacuum hasn't run for a week or so, so it's not the thermal protector, unless it's defective. Vacuum was running fine last week. Didn't stop operating when using. Went to v


Hello! The culprit is the PCB Assembly; Part # KC86WBZR3000...Cost is $6.99. I would remove and inspect for burnt components, or broken wires...Then clean connections both male/female using an eraser, toothbrush and alcohol...Using a bright ... Vacuums

I have a nearly 9 year old Electrolux Excellio Z5228 vacuum cleaner. It has recently started cutting out during operation. I cleaned the micro filter (between bag & motor) via brush & hitting against wall & seems / looks quite clean. I washed the gore filter (output from motor to clean the exhaust air) as per instructions, then let to dry. It was very clogged but now very clean. The vacuum clearner still cuts out often. Even after a long rest (say overnight) it still won't start, then ano


... Electrolux Vacuums
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0742 seconds