Having problems with your Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum ?

I lent it out (NEVER AGAIN!) got it back and no water squirts out of it in front I looked at it with the cover off but it doesn't come all the way off anyhow nothing looks clogged the belt is all fine too. Clean all the grime is seen and still doesnt work. What's wrong?


Answers :

It might be pet hair caught in its hose. You might have to disassemble everything just to be sure.
Repair Help & Product Troubleshooting for Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I lent it out (NEVER AGAIN!) got it back and no water squirts out of it in front I looked at it with the cover off but it doesn't come all the way off anyhow nothing looks clogged the belt is all fine too. Clean all the grime is seen and still doesnt work. What's wrong?


It might be pet hair caught in its hose. You might have to disassemble everything just to be sure. ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Bissell 8920 proheat x2 brushes not turning i only noticed this after i finished cleaning.. or kinda cleaning because of the brushes ntot turning.. water comes out fine suction is fine but its not scrubbing so its not as clean as it could be. manual part works well water coming out hot. I did take it apart and cleaned off all the hairs in hopes maybe that was it.. put it together still nothing.. No idea how the belts should look onit and i cant find a picture or a video showing how belts look o


Hello,\015\012\015\012Here's a link to a very helpful video that shows you step by step on how to access and replace the belt on your machine. When the brushes stop spinning, but the rest of the machine works fine, this is a tell-tale ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

Brush will not spin. filters are clean, no clogs, belt is fine. remove canister, it works fine plenty of suction.


Probably a good idea to remove the brush and clean as best you can.\015\012Add some WD40 at each end by the plastic clips and turn by hand until they move freely.\015\012Reassemble being sure the belt is on properly. ... Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?


It may be the roller bearings? ... Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

Clean machine All the belts are fine but the machine does not pick up the water. I think it is clogged with pet hair but don't know where to clean it out. I have taken off the roller, etc. but nothing seems to work.


This is what was wrong with mine....very simple solution to fix:\015\012\015\012Check the bottom of the water reservoir. It should have a black rubber washer attached to the lip that goes down into the main system. If that part is inside the main s ... Bissell 1697-7 Powersteamer Pro Deluxe Vacuum

My Eureka pet expert seems to be clogged. It apart and keep finding stuff right at the beginning of the hose. Belt looks fine. Any ideas?


... Eureka 3276AZ Pet Lover Bagless Upright Vacuum

I have a hoover tempo and it no longer has suction. I have cleaned the brush, replaced the belt and looked for possible clogs. Any other ideas?


Try this troubleshooting procedure. \015\012\015\012Remove the bag on top and the plate on the bottom. Clean out the air passages, top and bottom, looking for a clog. When it seems clear, turn on the vacuum to see if air is moving through ... Vacuums

My eureka vacuum was fine but then suddenly got loud. We cleaned the filters and replaced the belts, but it is still loud. We have not seen any clogs in the tubing or in the vacuum. What other problems could the vacuum have to make it loud?


The noise could be coming from the Beater Bar's ball bearings. ... Vacuums

Hello! I have a Kenmore Progressive bagless vacuum with the Easy Clean extended life filter. The model number on my vacuum is 34728401. I was vacuuming the carpet when it just stopped running. The dirt sensor light will come on, but nothing else. The belt looks fine, and I don't see anything keeping the beaters from rotating. Help Please!!!


You can have power to the dirt light sensor, but it seems like the motor itself is not using the power supplied. ... Vacuums

I have a Bissell 7920 ProHeat and only used it 4 times and the brush on the bottom has stopped spinning and when attempting to spray solution the flow indicator doesn't spin and nothing comes out. I have looked at all of the belts and they seem fine. I have also removed and cleaned the heating unit. Still nothing. Any other ideas?


Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

I have a Bissell pet hair eraser model #3920. It's been working great until last night. I went to use it and the brush won't spin. It also smells like it's burning. I checked the belt and it looks fine, and the brush spins by hand easily. It's not clogged anywhere that I can see. Anyone have any other ideas? This vacuum is only 8 months old.


- Remove the access panel, which is on the bottom of the machine. There are 4 tabs to lift on the access panel to remove. Start with tab 1 then 2-4 tabs.- Check the brush, and belt for any damage. Clean off any debris on the brush. ... Bissell 3920 Bagless Upright Vacuum

My Dyson vacuum works fine for cleaning the rug but the hose doesnt get any suction at all. I removed the hose and all the parts around it that I could and dont see any clogs or broken pieces. I lost my manual so I dont know if this is addressed, or if there is a switch Im not flipping. Gave it a thorough look but found nothing.


Hi there,Sorry to hear you're having a problem with your DC07. If you have suction through the cleaner head but not through the wand, it sounds as though you have a blockage. Although you say you've already checked for these, you may find ... Dyson DC07 Bagless Upright Cyclonic Vacuum

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the


Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

My Dyson Animal has good suction and works fine for actually picking up dirt, but when I use the vacuum with the roller, I hear a grinding/rumbling noise. Its only when I use the vacuum with the brush rotating. It does not happen hen I shut the roller brush off. The belt is fine. I cannot figure out what is wrong as there are no clogs, debris, or foreign objects stuck in the brush or in the belt. The noise seems to be the only issue. The vacuum picks up fine. It just doesn't sound right a


Trace the path of the suction into the tank and see if there is anything loose or ingested.\015\012Also, remove the brush and clean as best you can. Perhaps there is something caught in it. Lubricate where it makes sense with some WD40. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have a kenmore grab n go bagless and I need to know the exact size of the belt, I lost the manual, and I have burn several belts at the bigining of the problem the motor stops and burn the belts I open it and I think it was a little piece of plastic, that cause the problem, but when I put the new belt it looks like the motor works fine,but still burn the belt, I'm using UB-1 #5275 belt am I using the wrong one?


... Kenmore 34722 Grab-N-Go Upright Vacuum

I have two old identical 5842's that I use in the garage and around the house. The belt broke on one so I bought a bag of 2 genuine Eurika "U" belts, which is the correct belt for this vacuum. They were obviously smaller than the original belt because they were not stretched out. When I put the new belt on it lasted about 20 minutes and then came off. I put it back on and ran the vacuum with the cover off to see what was wrong. Everything looked fine except the belt rides to the outside edge of


Not 100% sure this is the remedy for that particular problem, but I would take the time to clean both of the brushes that the belts operate, one on each machine.\015\012Remove the brushes and clean as best you can. At the end of each brush there sho ... Eureka Whirlwind Litespeed 5840 Bagless Upright Cyclonic Vacuum

I have a nearly 9 year old Electrolux Excellio Z5228 vacuum cleaner. It has recently started cutting out during operation. I cleaned the micro filter (between bag & motor) via brush & hitting against wall & seems / looks quite clean. I washed the gore filter (output from motor to clean the exhaust air) as per instructions, then let to dry. It was very clogged but now very clean. The vacuum clearner still cuts out often. Even after a long rest (say overnight) it still won't start, then ano


... Electrolux Vacuums

My Bissell 3760-1 has stopped sucking in the roller portion. The grab n go part are working fine. Checked the belt and it looks fine. Did I burn up the motor or a microchip?


Hey Lisa! Sorry you're having difficulty with your Lift-Off vacuum. Here's a link to troubleshooting steps to assist you with the suction.\015\012http: ... Vacuums

There is a shaft that comes out of the pump of my Bissell 1623-1 Power Steamer with gears on it. The belt to the brush attaches to it. When I went to change the belt, the belt was fine but the gear itself with the small shaft on it was no longer attached and just dropped out. It looks like there might have been a bushing there, but no more. Any ideas?


... Bissell Vacuums

Brush Roll belt stops turning durring vacuuming on WindTunnel self-propelled, v belt is a little loose with handle down. Tensioning roll is engaged OK, but fully at the end of its travel. Replaced belts flat and v, but still stops turning even on high carpet setting when vacuuming. Carpet setting and height adjustment appears to be working OK, roll is clean and turns easily when out. Also turns easily until it engages the carpet. Self propel function works just fine.


... Hoover U6485900 Bagged Upright Vacuum

Hi, There is a high pitched whirring sound coming from lower part of the vacuum. When I tilt it toward me (while standing in the normal vacuuming stance) the sound sometimes lessens for a minute or so. I have tried the following things: -cleaned the two sponge filters -emptied the dirt receptacle -removed the roller and cleaned it -cleaned the brushes -the belt is not ragged and does not seem floppy -checked all of the airways for clogs (including removing the wheel base) Can you help?


Your looking for some dirt stuck in some thing you didn't check yet. with the roller out and the belt out of the way run it to see if it still makes the noise. if it does then you looking at the impeller or the motor bearing themselfs those bearin ... Bissell 3750 Lift Off Bagless Upright Vacuum

My steam pocket mop seems clogged. Steam does not come out of the mop head. The clog appears to be in the rectangular mop head. The triangular head still works fine. I've tried soaking it in hot water and soaking it with cleaning solutions. They have not worked. If I blow into the connection piece, no air goes through. That's what leads me to believe there is a clog. If you can help, please do. I like the product and haven't been able to use it for awhile because of this. Thanks.


I had the same issue with the rectangular mop and corrected it by disassembling the tube from the rectangular piece. There are two screws that will need to be removed in order to get access to the connector. Once the connector is removed from the rec ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

Dc07 problem I have a dc07 cyclonic vaccum and like this model,however, for some reason,it has been very dificult to push and pull for the past month or so. i have completely cleaned the brush assembly,cleared any obstructions in the hoses,and, cleaned the filter.I also checked the belt tension,wich i thought was fine but to no avail.Be advised that the brush assembly is spinning and suction is excellent. It just feels like the brush drags along the carpeting. this is a great vacuum cleaner and


The dyson uses two belts, one from the motor to a clutch and then from the clutch to the brush roller, the belts that they use are not much better then any other belt ( those you should change yearly ) but you cant just change the belts you have to c ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

Model number f 5912-900 hoover steam vav with clean surge.This is not the f5914 model........my new machine has 10 min. on it...in mid use it has stopped sucking and now is blowing more than anything, I took the front clear piece off as well as the black cowling/shroud and can find no obvious hoses to un-clog nor anything else to un-clog for that matter...I am looking for advise to fix this thing now, myself


Here is a list to go by for no suction problems that you can follow along with they are common proble\015\012Problem #1 Steamvac is not Sucking!If your Hoover Steamvac was working properly and suddenly it is not sucking any ... Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

Lost suction my DCO7 lost suction in the hose I started taking it apart and cleaning it and looking for clogs (probably more than I should have) and when I put it back together it has awesome suction in the hose but no suction in the base. It just pulls the pine needles up (christmas tree) but they never appear in the "bag" compartment and when I look they are just all gathered in a clump in the bottom by the brush.


Hi.\015\012\015\012Remove the sole plate turn the 3 plastic screws to unlock & lift off.\015\012\015\012Now remove the blockages that have accumilated from the oppening of short clear hose.\015\012Check you can turn ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0636 seconds