Having problems with your Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum ?

I have a Bissell 7920 ProHeat and only used it 4 times and the brush on the bottom has stopped spinning and when attempting to spray solution the flow indicator doesn't spin and nothing comes out. I have looked at all of the belts and they seem fine. I have also removed and cleaned the heating unit. Still nothing. Any other ideas?

Answers :


Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101 \012
Repair Help & Product Troubleshooting for Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a Bissell 7920 ProHeat and only used it 4 times and the brush on the bottom has stopped spinning and when attempting to spray solution the flow indicator doesn't spin and nothing comes out. I have looked at all of the belts and they seem fine. I have also removed and cleaned the heating unit. Still nothing. Any other ideas?

Hi,Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.Bissell Proheat Upright Wet/ ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

Bissell 8920 proheat x2 brushes not turning i only noticed this after i finished cleaning.. or kinda cleaning because of the brushes ntot turning.. water comes out fine suction is fine but its not scrubbing so its not as clean as it could be. manual part works well water coming out hot. I did take it apart and cleaned off all the hairs in hopes maybe that was it.. put it together still nothing.. No idea how the belts should look onit and i cant find a picture or a video showing how belts look o

Hello,\015\012\015\012Here's a link to a very helpful video that shows you step by step on how to access and replace the belt on your machine. When the brushes stop spinning, but the rest of the machine works fine, this is a tell-tale ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I lent it out (NEVER AGAIN!) got it back and no water squirts out of it in front I looked at it with the cover off but it doesn't come all the way off anyhow nothing looks clogged the belt is all fine too. Clean all the grime is seen and still doesnt work. What's wrong?

It might be pet hair caught in its hose. You might have to disassemble everything just to be sure. ... Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

Hello! I have a Kenmore Progressive bagless vacuum with the Easy Clean extended life filter. The model number on my vacuum is 34728401. I was vacuuming the carpet when it just stopped running. The dirt sensor light will come on, but nothing else. The belt looks fine, and I don't see anything keeping the beaters from rotating. Help Please!!!

You can have power to the dirt light sensor, but it seems like the motor itself is not using the power supplied. ... Vacuums

When I vacuum w/ the brush control in the on position it make a really loud noise, almost like a grinding sound. I have looked at it and nothing seems to be wrong, but I notice that the pin that engages the belt seems to vibrate a bit, possibly creating the noise. It started when I accidentally got part of a plastic grocery bag caught in the brush. Could it have stretched a belt? Nothing is caught any other place and it only makes the noise when the brush in in the on position.

Yes, the belt could have been stretched and is now vibrating and hitting other parts and creating a noise if much of the bag got caught under the belt. If you have another belt for this vacuum, please put it on and see if the noise stops. If it does ... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

The original belt on my upright Kenmore Progressive broke and I replaced it with the spare that was in the vacuum. The vacuum and spare belt are about 10 years old. Then the spare broke after one vacuuming session and there was a burning smell coming from the vacuum. I ordered new belts and replaced it with the new belt. It seems to be working fine with no smell. I checked the belt after I vacuumed the family room and although it was in tact, the belt was very hot. Is that normal? Should t

The belt heats up due to the friction, as well as being in contact with the shaft of a hot motor. It is normal. ... Kenmore Progressive 35922 Bagged Upright Vacuum

My Kirby 2HD has started making an odd roaring noise but still works fine. I have taken the front assembly off and cleaned and adjusted the roller and checked the belt. The noise seems to come from the motor housing. I have tried to wiggle the main shaft at the front (bearings?) and it seems tight. Can't seem to get the other housings apart. Any ideas? Thanks, John

It is quite possible, it just needs lubed. The motor comes in direct contact with dirt so, you have to make sure the front bearing has a drop of oil on it from time to time. If it starts to scream at you within one month, after oiling, the bearing ... Kirby Heritage II Vacuum

There is a shaft that comes out of the pump of my Bissell 1623-1 Power Steamer with gears on it. The belt to the brush attaches to it. When I went to change the belt, the belt was fine but the gear itself with the small shaft on it was no longer attached and just dropped out. It looks like there might have been a bushing there, but no more. Any ideas?

... Bissell Vacuums

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?

It may be the roller bearings? ... Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

My bissell powersteamer model 1695 does not spray enough water out. Hardly anything will come out of the handheld attachment either, just a few drips. With the floor unit, it appears the only water coming out is a result of gravity when the control is squeezed. Nothing appears to be plugged up with debrie or deposits. There does not appear to be any kind of drive belt for the pump as it seems to operate off the main vacuum motor. Any ideas?

Hi, my name is John I will do my best to assist you.\015\012\015\012Referring to this ... Bissell 1695 PowerSteamer Vacuum

Burning smell There is a burning smell when I run my Kirby Ultimate G.  The smell seems to be coming from the belt.  I looked at the brushes and they are spinning so the belt is working.  the Post on the vacuum is getting very hot not sure if that is normal.  What is causing this?

Unlock the sweeper brushes and take them out. on each end is a cup bearing and should be free of debris.then check around and under the belt and likely there is debris wrapped around it.the post is getting hot as your pulling too much of ... Kirby Ultimate G Bagged Upright Vacuum

The electricity in the apt attached to my house lost power in two of the walls. It happened when the cleaning ladies I think were using a vacuum, they don't speak english very well so I'm not sure. I have looked at the circuit breaker a # of times and nothing seems to have been tripped. I have also inspected the outlets and they seem to be fine. Can you help me?

Even know the breaker doesn't look tripped it might be. You have to flip it all the way off and then back on again. That is most likely what has happened. If that doesn't work check to make sure a GFI hasn't tripped. They are usually loc ... Vacuums

My vacuum's rug brush will not spin. the belts are fine and in place, but when i engage the carpet brush nothing happens. i looked under the bottom and there are no obstructions preventing the brush from opporating/

Have your clutch checked out by a local vacuum repair shop. That's a common problem with dyson brush rollers ... Dyson DC07 All Floors Bagless Upright Cyclonic Vacuum

My Eureka pet expert seems to be clogged. It apart and keep finding stuff right at the beginning of the hose. Belt looks fine. Any ideas?

... Eureka 3276AZ Pet Lover Bagless Upright Vacuum

My beater bar on my Kenmore 116.25615506 canister vacuum keeps turning on and off when I vacuum rugs. The suction continues, but the beater bar seems to be shorting or whatever. I checked the belts and they look like new. Any suggestions? The rest of the vacuum works fine!

... Kenmore 25512/ 25513 Progressive Canister Vacuum

Clean machine All the belts are fine but the machine does not pick up the water. I think it is clogged with pet hair but don't know where to clean it out. I have taken off the roller, etc. but nothing seems to work.

This is what was wrong with mine....very simple solution to fix:\015\012\015\012Check the bottom of the water reservoir. It should have a black rubber washer attached to the lip that goes down into the main system. If that part is inside the main s ... Bissell 1697-7 Powersteamer Pro Deluxe Vacuum

The agitator stopped working. It is clear of all debris, and the belt looks fine. The "reset" button doesn't seem too do anything. What is wrong with it?

... LG Electronics Kompressor Pet Care Upright Vacuum Cleaner LUV200R

The brushes and the belt are not rotating. The power seems fine and there is suction. I have no other history on this problem since I was given this almost new unit over Thanksgiving. Where should I be looking for a problem/solution.

If you've got suction, but the brushes and belt are not rotating, then either the belt has come off the motor shaft, or the belt is broken and just looks OK.Remove the bottom cover off the floor head and check that the brush roller turns ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

My Kenmore canister model (116) 26212601 works in hard-surface mode (basic suction), but the brush won't spin for carpets, and when I try to turn it on, it makes a whiny sound and then turns off as it does when I need to press the overload button. I looked inside a bit, and the belt isn't broken--it seems fine. So not sure what the problem is. Thanks for any help.

... Kenmore 27815 Bagged Canister Vacuum

The motor that turns the rollbrush does not seem to be turning. How can i check to see if the motor is still working? the belt looks fine.

Have u tried getting access to the motor 2 check that the spindle the belt goes onto is turning or has the belt strectched marting ... Eureka Uno 2998AZ Bagless Upright Vacuum

My Bissell 3760-1 has stopped sucking in the roller portion. The grab n go part are working fine. Checked the belt and it looks fine. Did I burn up the motor or a microchip?

Hey Lisa! Sorry you're having difficulty with your Lift-Off vacuum. Here's a link to troubleshooting steps to assist you with the suction.\015\012http: ... Vacuums

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or anything. The only thing that seemed weird was that the smaller belt that actually attaches and turns the roller is a bit loose. The larger belt is tight but looks like its the one that is burning and causing the smell.

Better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the belts.it will cause the new belts to run unevevly and go bad before their time ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Windtunnel belt I have a new Hoover Windtunnel canister. The belt keeps coming off. It happened a couple weeks ago (several times after putting the belt back on) so I assumed I might need a new belt as it might have dried out at the store. I ordered new belts and today I used it for about an hour and the belt came off again, twice. There doesn't seem to be anything to hold the belt on the stem as it seems to slip off. I have tried it centered, to the left and to the right....can you help. I am v

I've successfully used a compatible belt - Royal 104425001 .It's still new, but for the time being at least - it works. ... Hoover S3765-040 WindTunnel Bagless Canister Vacuum

I have a Eureka 4870GZ. It turns on, but the brush roller doesn't move. The belt looks fine. I do have an extra belt and would try replacing the old belt, but I can't get the old one off the motor shaft or the new one on. I called Eureka customer service. The lady said there's supposed to be a small space between the motor shaft and the outside edge of the vacuum where I can slip the old belt off and the new one on. I don't see it. It looks like the motor shaft goes into a recessed place in the

Remove the top cover so that you can access to belt, You'll find 2 rows of 4 decorative holes on the top cover, In two of the holes you'll find the screws, Please use a flash light to see in that., Once the screws are removed, you'll be able to ... Eureka Vacuums

The brushes will not rotate on my hoover vacuum. the belts are in good shape, the motor is turning the vacuum motor, but the belt on the brushes seems loose. I ordered a replacement belt but still nothing. Their is a small "idler" but their dosent seem to be enough tension on the belt. Any ideas?

Did you order the correct size of belt? These are the belts you should have:Hoover Windtunnel Belts ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0818 seconds