Having problems with your Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum ?

Hmmm Hi there, I actually had tried everything you mentioned except for the vinegar idea which I'll do when I get back up to my home in Oregon. I checked for pinches, the heater, etc. Water does NOT come out of the accessory tool and only will dispense out of the main area for a second or two..any liquid actually starts filling up the area right behind the nozzles and around the pump instead of OUT of the machine. I checked gaskets, made sure there was a tight seal, and even made sure the little


Answers :

Check the nozzles to make sure they aren't clogged. Sometimes there is a problem with the flow indicator cap, maybe too tight or not tight enough. Try squeezing the trigger while turning the can one way or the other. If at a certain point it starts to spray, leave the cap at that point. ( Pump may be bad).
Repair Help & Product Troubleshooting for Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Hmmm Hi there, I actually had tried everything you mentioned except for the vinegar idea which I'll do when I get back up to my home in Oregon. I checked for pinches, the heater, etc. Water does NOT come out of the accessory tool and only will dispense out of the main area for a second or two..any liquid actually starts filling up the area right behind the nozzles and around the pump instead of OUT of the machine. I checked gaskets, made sure there was a tight seal, and even made sure the little


Check the nozzles to make sure they aren't clogged. Sometimes there is a problem with the flow indicator cap, maybe too tight or not tight enough. Try squeezing the trigger while turning the can one way or the other. If at a certain point it starts ... Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

I just used my Bissell Proheat, when I heard the vacuum sound get lower and lower then suddenly something "gave" and it got very loud and started emitting a burnt rubber smell. It still worked to put liquid into the carpet; seemed to have trouble getting it out. I checked the tank, filters, belt, and roller and all seemed OK - but when I started up again and looked down I saw sparks in the motor/belt area and shut it down immediately. Any thoughts?


The bearing that is located at the top of the vacuum motor has failed . Because of that the shaft of the motor's rotor is out of position and the pulley attached to it has started rubbing on the other pulleys, giving you that smell. the spark appear ... Bissell 1699 ProHeat Clear View Upright Steam Vacuum

We have a black & decker bottom load water cooler. It has been continually running then stops and starts beeping. We have checked the connections, made sure the bottle is loaded properly. That the seal is tight and it still cointues to run and beep. Can you helpe me?


... Vacuums

When I turn on the Hoover U5780-900 it seems the motor just starts to rev up and stays that way until I shut it off. I have replaced all the belts, made sure there were not any blockages, and checked the filters. It still does it. Any other ideas.


... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

The machine backs out of the dock, then proceeds to turn in circles, stop and then start turning in circles again. I have cleaned all of the sensor areas and made sure the bumpers were not stuck against the machine. Any ideas


... iRobot Roomba 560 Robotic Vacuum

My kenmore progressive canister vacuum won't start,any ideas, is there a fuse? it was on then just quit. I've checked all connections and made sure they are snug, and that it's still plugged in (!) model 116.


Wire broken in several place along suction tubing. Replaced tubing and works fine ... Kenmore 23913 Progressive PowerMate Bagged Canister Vacuum

Won't start. My son was using the vacuum & Didn't change the bag. The vacuum was making the full bag smell, but the light was't on & it didn't stop. I stopped him, changed the bag, checked the filter, closed the compartments & turned on the vacuum. Nothing happened. I checked to be sure that it was plugged in, that wasn't the problem. I've let the vacuum "rest" for several days, It still won't start. Any suggestions?


There is a reset button at the back of the powerhead. The user manual can be downloaded from the electrolux website, although I didn't find it very useful. There was some info on how to change the powerhead drive belt. ... Electrolux EL7020A Oxygen 3 Ultra Canister Vacuum Cleaner Bagged Vacuum

I have a Kenmore 116.36932 (upright-bagless vacuum) that the motor protector by-pass valve has opened. I've clean out the area between the agitator brush where the flexible extension hose starts. There was some blockage there. I checked the rest of the system (extenstion hose, back filter area, pipe area to canister and area to side filter. I took the 2 filters out and the by-pass valve is still open. Where else could there be a blockage that I can take apart to clean and put back together


... Vacuums

Vacuum smell I have a new bagless Hoover Empower Widepath. When I start to vacuum, after only about 2 minutes, it starts to smell really bad, like rubber I would say. Is it band slipping, and how do I check that out to make sure??


Your belt is slipping, it is probably stretched and slips trying to drive the brush roll. Take the bottom plate off, check the brush also, make sure the ends turn freely. The belt runs from the brush roll to the motor shaft. If you can't get to th ... Vacuums

My Hoover Whisper Cyclonic is collecting the dirt but not taking it into the cylinder. The brushes were at one point starting and stoping due to the belt periodically turning,now the brushes are turning and the dirt just collects and I'm starting to smell a an oder like rubber burning.I've taken it apart and tried to make sure the is no clog. The one hose that I can't check is in the back right base, above and left of the right back wheel.


... Hoover U5753-900 WindTunnel Bagless Upright Vacuum

I have two older Filter Queen (brown vacuum cleaners). Besides unclogging the hose area and making sure it is not filled with dirt, what else would cause the machine to run hot and have a high pitched sound? Is there another area where I might have clogs?


There is a secondary filter under the paper cone that gets filled with fine dust. It can choke off the airflow. The noise motor sounds like a bearing going dry. That should be replaced ... Filter Queen Majestic Canister Vacuum

We have the GE sensor microwave WES1358DN1WW. It was made in 5/2009 & bought in July of 2010 brand new. it worked perfect til last week. i put something in it & it started to make a loud humming/vibrating noise. i assumed it was just something ontop of the microwaved & ignored it. 1 min later my food was still ice cold. we tried unplugging & plugging back in & made sure that it was clear of anything but it still makes noise & doesn't heat. GE charges $79 to look at it, & since the microwa


... Vacuums

Does the trivac 1100 have a fuse? My machine has suddenly stopped.I have checked the fuses in the plugs and also made sure that power is at the wall socket. I can see what loks like a fuse holder in the top of the machine near to the on/off switch but it is very tight so I want to be sure that it is a fuse before unscewing it. Thank you Jim


... Philips Vacuums

I HAVE A BISSELL PROHEAT 2X HEALTY HOME, IT WORKED JUST FINE THE LAST TIME I PUT IT UP. YESTERDAY, I NOTICED THE FLOW GAUGE WAS NOT SPINNING, SO I CHECKED AND SURE ENOUGH NO WATER WAS COME OUT. I CHECKED AND ALL THE TUBS AND EVERYTHING ARE IN THE RIGHT PLACE AND HAVE LIQUID IN THEM. HAVE TRIED PRIMING CLEANING THE BRUSHES RUNNING HOT WATER THROUGH IT... HELP


Have you made sure that the tanks are seated properly and the red \012(or black) auto-load gaskets are in place. \012Check the bottom of the Water Tank and the Formula Bottle to make \012sure each has a red auto-load gasket attache ... Bissell 9500 ProHeat 2X CleanShot Upright Deep Cleaner, Red Berends Vacuum

I have a bissell bagless easy vac. When I vacuum the debris keeps getting stuck in the hose (also going into the filter area and the apparatus above the cannister with none of it going into the cannister. I have made sure the cannister is properly placed and the lock is pushed in all the way.


... Bissell 3102-0 EasyVac Upright Vacuum

My dyson DC17 will not turn on unless the handle is pulled back.(into the vacuuming position) The attachment hose will not work at all (0 suction thru it). I've checked the hose and made sure there is no obstruction. Any ideas?


Not sure if I can help, but I'll try. The DC17 has two motors: the vacuum motor and a separate motor for the brush bar. It is normal that the brush motor works only when the handle is pulled back in the vacuuming position - that's the way it's made. ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Hello. My scooba 5800 had a check tank light on. I used a straw on the valve and that fixed the problem. Now the scooba runs like nothing is wrong, but there is no actual cleaning going on! It goes the full cycle, but no liquid comes out. The vac part seems to be working b/c there is fluff in the vac when it's done. Please help!


Hello, Take the battery out and hold the switch down for 30 seconds, to reset the curcuit board, then charge back up for 12 hours. this should take care of it. If I can help future please call @ 1561-848-3387 Thank you, Teresa. Clean Sweep Vacuums ... iRobot 5800 Scooba Vacuum

Chassis hook broken to rod which controls release of liquid shampoo in Hoover steam cleaner. It is the back of the handle area that is snapped off, not the actual rod with "push on / release"


If it is part of the handle, it breaks inside alot, part number 39458006. #2 in the picture.\015\012 \015\012 ... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

My McCulloch whipper snipper was working just fine after finding cracked fuel lines,. Replaced wiht home made lines and worked fine until Sunday and now wont start at all . Checked everything , now think its electrical Would like to kow if there is anyone in Perth who can sort this out


Your local lawn mower repair shop will be able to fix it for you. ... Vacuums

I have Hoover Floormate Model H3004. The machine will no longer dispense the cleaning fluid due to the trigger assembly not engaging properly with the inlet/outlet on the Clean Water Solution Tank. I have checked and made sure the tank was seated properly.


... Hoover Floormate H3000 Upright Wet/Dry Vacuum

Loud noise I have a brand new Dyson and it is great on all my floors except one of my area rugs when it starts making this really loud vibrating noise. I am not sure why - nothing is stuck in the roller or vacuum and it doesn't make it on any of my other rugs. Also it is really hard to push whereas all the other floors it just glides. I don't want to return it but I also don't want to hear this sound every time I vacuum.


This is the clutch as it jams up in the brush. Usually happens with rugs that are not secured to the floor. ... Dyson DC14 Animal Bagless Upright Cyclonic Vacuum

My Bissell started to **** up my daughter's stuffed animal. I quickly turned it off and pulled the stuffed animal out. Now my vacuum won't pickup. Not sure what to do. I have unplugged the vacuum and checked for clogs. Please Help!


Did you check the hose. The vacuum won't **** if there is a clog in the hose. ... Bissell 6594 PowerForce Bagless Upright Vacuum

It sounds as though a belt is rubbing or slightly off-track. The sound is extremely loud. We've removed the plate around the brush bar, made sure the brushes are free of dog hair, and found that the belt appears to be on track. What should we try now? We haven't tried to use it to check for suction for fear of doing real damage! Thank you. Marcia VanDyne


Is the sound coming from the head unit where the belt is attached? When you power up the vac, can you watch the belt to see if it is frayed or running off track. I have the same Dyson and had this same issue, cleaning the head cured it, but your issu ... Dyson DC17 Animal Bagless Upright Cyclonic Vacuum

Won't start orange canister type,has change ba light hepa &motor filter,and power hose and beaterhead,put new filters in checkedthe hose,made sure it wasnt clogged


Take an AC VOLT Meter and place the leads of the meter where the power cord terminates,one on the white lead and one on the black. There should be 110-120 volts AC. If that is good then move one of your meter leads to the other side of the on switch ... Electrolux Epic 6500 Vacuum

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or anything. The only thing that seemed weird was that the smaller belt that actually attaches and turns the roller is a bit loose. The larger belt is tight but looks like its the one that is burning and causing the smell.


Better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the belts.it will cause the new belts to run unevevly and go bad before their time ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0509 seconds