Having problems with your Bissell 8910 ProHeat Clear View Upright Vacuum ?

I HAVE A BRISSELL MODEL 8910 THE BEATER BAR IS NOT TRUNING THE BELT IS ON BUT DOESNOT SEEM TO HAVE ANYTHING WRONG WITH IT SO WHAT COULD THE PROBLEM BE


Answers :

Repair Help & Product Troubleshooting for Bissell 8910 ProHeat Clear View Upright Vacuum

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I HAVE A BRISSELL MODEL 8910 THE BEATER BAR IS NOT TRUNING THE BELT IS ON BUT DOESNOT SEEM TO HAVE ANYTHING WRONG WITH IT SO WHAT COULD THE PROBLEM BE


... Bissell 8910 ProHeat Clear View Upright Vacuum

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor seemed to slow down all of the sudden and then began smelling like burning rubber. I shut the vacuum off to check for blockages but could not find anything blocked. When I then turned it on again it runs but seems to only be running at 1/2 the motor speed and still has the rubber buring smell.


It sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the moto ... Vacuums

I have had my RCA microwave model # RMW1108 for about 8 months now. It was working fine until yesturday evening. I went to warm up some food for 2 minutes, the microwave itself was on and everything appeared to be working except my food did not get warmed up. I plugged it out and checked all over it for any damage but i could not find anything wrong. What would cause it to just stop heating up the food? Is this type of problem covered in the 1 year manufacturer's warranty.


... Vacuums

My filter queen majestic quit working. I opened up the unit to see what was wrong and I did not immediately notice anything wrong. Upon furter examination I noticed one of the traces on the printed circuit card was burnt. I used a soldering iron to "bridge the trace and it appeared to fix the problem for a while. Now it has stopped working again, and when I jumper the trace to run the motor it seems to work. Should I just replace the card? Or is there a more serious problem with too much current


I recommend replacing the card. Soldering involves the risk of further damaging the card, so it would be useless anyway. Why waste valuable time?\015\012There is a possibility of the motor overheating, generally due to a blockage in the airfl ... Filter Queen Majestic Canister Vacuum

My FIL purchased an Electrolux bagless canister vacuum model EL5 76501 last year. When I tried to use it today, the hose keeps pulling out of the power brush whenever I pull it towards me. it doesn't seem like anything has broken off. The only thing I noticed was that the rubber ring washer seems to be flattened. Could it be something that simple or do you think some part has fallen off and gone missing? Regards, Craig Somersett


I believe I've just had the same problem and after searching for a small gray horsehoe clip that needs to first be found and then inserted into the slot for it on the tube section that comes out of the beater bar. Insert this clip from the outside af ... Electrolux Vacuums

Model#F5858-910 hoover steam vac,silver ,spin and scrub. It doesnt seem to spray cleaner it seems to stream it now. what could be wrong? I cant get to end of where it sprays to see if something is blocking it . otherwise it works great. I have it about 8 yrs. always worked good until recently


... Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

Hoover Wind Tunnel U6458-900 Self Propel doesn't work - via other expert advice here for other models of Hoover - I'm thinking it is the actuator that needs to be replaced as I can see the cable does not connect to anything on the bottom. My problem is - I can't get the cover off. Been trying for a couple of hours. I removed every screw I can seem to find but something is hold it down. I also am wondering if/when I do eventually get the cover off, would I need to replace the cable when I replac


On some models there are hook/springs that hold the cover of the base snug. ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Bought today a used rca rp3721a clock radio without the manual. need user manual to adjust all the settings, for example TIME, ALARM TIME, ALARM ON AND OFF, radio or "beeper" alarm on, entire unit on and off without unplugging it from shore power,and anything I haven't thought of up to here. The unit is RCA Model RP3721A clock radio, and appears to be functional. Our problem seems to be "the nut behind the wheel". e-mail: [email protected]


Hello,I advice you check the links below to search for the\015\012manual of your device, the link contain almost virtually all the manuals of all \015\012device.manualsonline.comORmanualnguide.com ... Vacuums

I have a Hoover Steamvac model F5808. It no longer sucks up the water and seems to only blow air. I already removed all the hair and fuzz buildup... what could be wrong? I no longer have the manual to look at.


... Vacuums

I have a vax cylinder model V-094. Working fine then started to play up. Switch it on and the motor seems to struggle to power up. Kind of wurrs up and down. Was thinking it could be the brushes have worn. Tokk to bits and cleaned her up, took a look at motot and brushes, cleaned them too, back together and still them same problem. Help please, hoover is not old but has done some work really don't want to through away something that can be fixed.


Hi.\015\012\015\012after all you have done I would be pretty confident its the motor thats faulty they are expensive to buy so machine is going to be scrap,\015\012\015\012Sorry.\015\012\015\012 ... Vacuums

My Euro Pro model s3101 doesn't seem to have the steam content that it did when brand new. What could the problem be?


Hi,Change the water you are using... Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head... ... Euro-Pro Shark Steam Mop - Gray/ Purple Vacuum

Hoover Wind Tunnel 7500 Brush not Turning. I have replaced the Brush and the belt. The problem does not seem to be either to me. I believe might be a missing part. The place were the belt hooks on is a metal pole which never seems to grip the belt well. In fact it seems loose most of the time and slips on the brush, causing the belt to eventually burn up. Could there be a missing plastic or rubber piece meant to hold the belt taught  on the metal pole?


Check the Idler Pulley part Number 43241004 (Item 13 in the IPB)http://64.49.205.183/v/u6451900.pdf ... Vacuums

Dyson animal won't start. Never had any problem with this vacuum. No apparent problem. No electrical problem with house or outlet. If there are some common things I could check/fix, things that might go wrong, I would like to check them out and get this machine going again.


Hi there, if the machine was running and cut out in use, this could be due to the motor overheating. The cause of this would be a blockage or a dirty filter. These checks can be found in the Support section on our website at www.dyson.com. ... Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

I have the yellow altima vac. for a while now I can not get the darn thing to pick up properly. Or should i say keep it up.. The vac does seem to be getting everything picked up but as soon as you turn it off, you have a mess under the vac.. I have checked for clogks and can't seem to find any.. I have removed the hose, Nothing there.. And yep have removed the yellow thing inside the trash cup.. Is there anything else you could suggest??


If it smells hot, then there's a strain on the motor no doubt about it. Check the suction channel behind the sole plate and remove all of the hoses to check for a clog. It could well be that there is a clog inside the machine after the dust channel f ... Eureka Altima Upright Vacuum Model 2996AVS Vacuum

I have a bissell pro heat carpet shampooer model # 8910 and it will not spray any solution out what could the problem be its only been used twice without any problems


Hi,Here is a tip that will give you all the information you need to fix your Bissell Proheat Vacuum Problem.B ... Bissell 8910 ProHeat Clear View Upright Vacuum

Hello, I just bought a Bissell Powergroom (model 92L3-W) vacuum and a Bissell Proheat Pet (model 8910-3) deep cleaner and I love them both. My problem is, when we unpacked them we somehow lost the manuals; I think I had too many helpers that night – they may have gone out to the trash with the boxes. I need replacement manuals if you would be so kind as to help me out. Could you email me a manual for each of these two machines, or tell me exactly where to find them online? I’ve been looking, but


Follow the link below and enter the model numbers to access the User's Guides.\015\012http://www.bissell.com/customer-support/ ... Bissell 8910 ProHeat Clear View Upright Vacuum

Hi, I have a Kenmore vacuum cleaner model number 20712008. There seems to be a problem with power getting to the suction base. There may be an electrical problem with the connector between the metal tube and the base.


... Kenmore Vacuums

Sunbeam water cooler YLR2-5-87 H3 I find a part inside is distorted I guess from the heater is sunbeam doing anything for this problem which seems to be a problem and can you get parts to fix it


... Sunbeam Vacuums

Helping out someone that has a ECV 1590A model 117A Electrolux central Vacuum. There seems to be a problem with the brushes. I'm looking for a manual or what brushes to get or a new motor. It seems to run fine what it starts.


... Electrolux Vacuums

Low suction Have a Powr-Flite PF 18, suction is good at motor, but low at where hose comes out of top of vacuum. Could new lid seals help the problem? Where can I get new seals for this model. Also my zip is 98801 and my shop is not listed, could you add it please? Sew Creative 1139 N. Princeton Wenatchee, Wa 98801 509-663-5516 Thanks, Lauren-Sew Creative


Replacing the motor cover solved the problem, it must have been warped and was letting suction out thru it. ... Vacuums

When I vacuum w/ the brush control in the on position it make a really loud noise, almost like a grinding sound. I have looked at it and nothing seems to be wrong, but I notice that the pin that engages the belt seems to vibrate a bit, possibly creating the noise. It started when I accidentally got part of a plastic grocery bag caught in the brush. Could it have stretched a belt? Nothing is caught any other place and it only makes the noise when the brush in in the on position.


Yes, the belt could have been stretched and is now vibrating and hitting other parts and creating a noise if much of the bag got caught under the belt. If you have another belt for this vacuum, please put it on and see if the noise stops. If it does ... Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

The hose works great, but the head of the vaccuum does not pick up anything !!! I checked every opening that may have been clogged, but nothing came up. When I hold my hand under the brush/roller, it seems to be putting out more air than intaking air. Particles "dance" on the carpet, but don't get "sucked up" into the vaccuum ? I have had the vaccuum only 1 year, so the brushes should not be a problem. I changed the bag, and checked the belt. The belt and brushes seem to be OK. ?


Hi there,Uprights are notorious for debris forming clogs when changing direction. The 90 degree turn where the base suction goes up. Have a closer look . You may need to pull the base plate off to access the blockage.Best reg ... Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Poor suction The actual sweeper seems to work ok, but the hose attachment has some suction but not enough to pick up things I think it should and not enough to make the power brush spin. I've checked everywhere I can for clogs, but I can't see anything. And there doesn't seem to be any way to check to hose itself for clogs. I've cleaned out the container and the filters, but there's still a problem.


Check the inlet down by the brush roll, make sure it is open, if it is then the hose itself must have a clog. If the hose comes off, drop something like a marble in one end and see it it comes out the other end, if it doesn't then you have a clog. ... Dirt Devil M1100009 Reaction Soft Touch Cyclonic Upright Vacuum Cleaner Vacuum

My model F5906-900 --- problem is the brushes have stoped working... I pulled the brush assembly out by holding the two tabs, and all seems clean and the brush assembly rotates easly... onced the brush assembly is removed. What I did notice is the female driver slot (found in the main assembly unit) that drives the brushes seems stuck..Is that normal when the machine is not hooked up to power? How can I get the brushed going??? it is a good machine, but the brush options is important too it's ab


(1) Assure the Brush Control on the hood is NOT set to the OFF position.\015\012(2) Remove the brush assembly by pulling/unlatching it from base on each side.\015\012(3) Does one of the brushes ... Hoover F5906-900 Upright Steam Vacuum

I have a similar problem as many do with this model, "clean Roomba's brushes".. We took it apart last night, cleaned out all of the dust we saw. we removed the cover, the housing for the brushes and everything else we could. Still has the same problem. What now?


Mine did the same thing and no mater how much I cleaned the brush or pulled fibers of the ends it did not stop until I:Removed the little yellow tabs on the ends of both brushes and used a tooth pic to remove the built up inside the bearing ass ... iRobot Roomba 530 Robotic Vacuum
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mictaservice.com || Terms of Use || Contact || Privacy Policy
Load time: 0.1132 seconds